python-virtualenv-vl.spec 6.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184
  1. %global oname virtualenv
  2. Summary: Tool to create isolated Python environments
  3. Summary(ja): 隔離されたPython環境を構築するためのツール
  4. Name: python-%{oname}
  5. Version: 20.16.5
  6. Release: 1%{?_dist_release}
  7. Group: programming
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. Packager: yasumichi
  11. License: MIT
  12. URL: https://pypi.python.org/pypi/%{oname}
  13. Source0: https://pypi.python.org/packages/source/v/%{oname}/%{oname}-%{version}.tar.gz
  14. # Add /usr/share/python-wheels to extra_search_dir
  15. BuildArch: noarch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  17. BuildRequires: python-rpm-macros
  18. BuildRequires: python3-rpm-macros
  19. BuildRequires: python3-setuptools
  20. BuildRequires: python3-devel
  21. %description
  22. virtualenv is a tool to create isolated Python environments. virtualenv
  23. is a successor to workingenv, and an extension of virtual-python. It is
  24. written by Ian Bicking, and sponsored by the Open Planning Project. It is
  25. licensed under an MIT-style permissive license.
  26. %package -n python3-virtualenv
  27. Summary: Tool to create isolated Python environments
  28. Summary(ja): 隔離されたPython環境を構築するためのツール
  29. Group: programming
  30. Requires: python3-setuptools
  31. Requires: python3-devel
  32. %description -n python3-virtualenv
  33. virtualenv is a tool to create isolated Python environments. virtualenv
  34. is a successor to workingenv, and an extension of virtual-python. It is
  35. written by Ian Bicking, and sponsored by the Open Planning Project. It is
  36. licensed under an MIT-style permissive license
  37. %prep
  38. %setup -q -n %{oname}-%{version}
  39. %{__sed} -i -e "1s|#!/usr/bin/env python||" tasks/update_embedded.py
  40. # Remove the wheels provided by RPM packages
  41. rm src/virtualenv/seed/wheels/embed/pip-*
  42. rm src/virtualenv/seed/wheels/embed/setuptools-*
  43. rm src/virtualenv/seed/wheels/embed/wheel-*
  44. test ! -f src/virtualenv/seed/embed/wheels/*.whl
  45. %build
  46. # Build code
  47. %{py3_build}
  48. %install
  49. rm -rf %{buildroot}
  50. %{py3_install}
  51. # The versioned 3.x script was removed from upstream. Add it back.
  52. cp %{buildroot}/%{_bindir}/virtualenv %{buildroot}/%{_bindir}/virtualenv-%{python3_version}
  53. cp %{buildroot}/%{_bindir}/virtualenv %{buildroot}/%{_bindir}/virtualenv-3
  54. %clean
  55. rm -rf %{buildroot}
  56. %files -n python3-virtualenv
  57. %license LICENSE
  58. %doc docs/*rst README*
  59. %{_bindir}/virtualenv
  60. %{_bindir}/virtualenv-3
  61. %{_bindir}/virtualenv-%{python3_version}
  62. %{python3_sitelib}/virtualenv
  63. %{python3_sitelib}/virtualenv-*.egg-info/
  64. %changelog
  65. * Tue Oct 25 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 20.16.5-1
  66. - new upstream release.
  67. - dropped python2 support.
  68. * Sat Aug 22 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 20.0.31-1
  69. - new upstream release.
  70. - made python3 primary (/usr/bin/virtualenv).
  71. - dropped Patch0.
  72. * Mon Dec 18 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 15.1.0-1
  73. - new upstream release.
  74. - added Patch0.
  75. - made to use python{,3}-rpm-macros.
  76. - added a sub-package for python3.
  77. * Sat Aug 02 2014 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.11.6-1
  78. - new upstream release
  79. - add Vendor, Distribution and Packager
  80. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5.1-2
  81. - rebuild with python-2.7.2
  82. * Mon Nov 22 2010 Shu KONNO <owa@bg.wakwak.com> 1.5.1-1
  83. - updated virtualenv to 1.5.1
  84. * Sat Sep 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.8-1
  85. - initial build for Vine Linux
  86. * Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1.4.8-4
  87. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  88. * Wed Jul 7 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.8-3
  89. - Fixed EPEL installation issue from BZ#611536
  90. * Tue Jun 8 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.8-2
  91. - Only replace the python shebang on the first line (Robert Buchholz)
  92. * Wed Apr 28 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.8-1
  93. - update pip to 0.7
  94. - move regen-docs into bin/
  95. - Fix #31, make activate_this.py work on Windows (use Lib/site-packages)
  96. unset PYTHONHOME envioronment variable -- first step towards fixing the PYTHONHOME issue; see e.g. https://bugs.launchpad.net/virtualenv/+bug/290844
  97. - unset PYTHONHOME in the (Unix) activate script (and reset it in deactivate())
  98. - use the activate.sh in virtualenv.py via running bin/rebuild-script.py
  99. - add warning message if PYTHONHOME is set
  100. * Fri Apr 2 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.6-1
  101. - allow script creation without setuptools
  102. - fix problem with --relocate when bin/ has subdirs (fixes #12)
  103. - Allow more flexible .pth file fixup
  104. - make nt a required module, along with posix. it may not be a builtin module on jython
  105. - don't mess with PEP 302-supplied __file__, from CPython, and merge in a small startup optimization for Jython, from Jython
  106. * Tue Dec 22 2009 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.3-1
  107. - Updated for upstream release.
  108. * Thu Nov 12 2009 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.2-1
  109. - Updated for upstream release.
  110. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.3-2
  111. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  112. * Tue Apr 28 2009 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.3-1
  113. - Updated for upstream release.
  114. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.2-2
  115. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  116. * Thu Dec 25 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.2-1
  117. - Updated for upstream release.
  118. * Thu Dec 04 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.3.1-4
  119. - Rebuild for Python 2.6
  120. * Mon Dec 1 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.1-3
  121. - Added missing dependencies.
  122. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.3.1-2
  123. - Rebuild for Python 2.6
  124. * Fri Nov 28 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.1-1
  125. - Updated for upstream release
  126. * Sun Sep 28 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3-1
  127. - Updated for upstream release
  128. * Sat Aug 30 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.2-1
  129. - Updated for upstream release
  130. * Fri Aug 29 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.1-3
  131. - Updated from review notes
  132. * Thu Aug 28 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.1-2
  133. - Updated from review notes
  134. * Tue Aug 26 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.1-1
  135. - Initial Version