python-pyudev-vl.spec 9.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244
  1. %bcond_with systemd
  2. %global srcname pyudev
  3. Summary: A libudev binding
  4. Name: python-%{srcname}
  5. Version: 0.24.0
  6. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  7. Group: programming
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: LGPLv2+
  11. URL: https://pypi.org/project/pyudev/
  12. Source0: https://pypi.io/packages/source/p/%{srcname}/%{srcname}-%{version}.tar.gz
  13. BuildArch: noarch
  14. %description
  15. pyudev is a LGPL licensed, pure Python binding for libudev, the device
  16. and hardware management and information library for Linux. It supports
  17. almost all libudev functionality, you can enumerate devices, query device
  18. properties and attributes or monitor devices, including asynchronous
  19. monitoring with threads, or within the event loops of Qt, Glib or wxPython.
  20. The binding supports CPython 2 (2.6 or newer) and 3 (3.1 or newer), and
  21. PyPy 1.5 or newer. It is tested against udev 151 or newer, earlier
  22. versions of udev as found on dated Linux systems may work, but are not
  23. officially supported.
  24. %package -n python3-%{srcname}
  25. Summary: A libudev binding
  26. Group: programming
  27. %{?python_provide:%python_provide python3-%{srcname}}
  28. BuildRequires: python3-devel
  29. BuildRequires: python3-setuptools
  30. BuildRequires: python3-rpm-macros
  31. # Needed for libudev, loaded through ctypes
  32. %if %{with systemd}
  33. Requires: systemd-libs
  34. %endif
  35. # Used for python2/3 compatibility
  36. Requires: python3-six
  37. %description -n python3-%{srcname}
  38. pyudev is a LGPL licensed, pure Python binding for libudev, the device
  39. and hardware management and information library for Linux. It supports
  40. almost all libudev functionality, you can enumerate devices, query device
  41. properties and attributes or monitor devices, including asynchronous
  42. monitoring with threads, or within the event loops of Qt, Glib or wxPython.
  43. The binding supports CPython 2 (2.6 or newer) and 3 (3.1 or newer), and
  44. PyPy 1.5 or newer. It is tested against udev 151 or newer, earlier
  45. versions of udev as found on dated Linux systems may work, but are not
  46. officially supported.
  47. %prep
  48. %autosetup -n %{srcname}-%{version}
  49. rm -rf pyudev.egg-info
  50. %build
  51. %pip3_build_wheel
  52. %install
  53. %pip3_install_wheel
  54. %files -n python3-%{srcname}
  55. %license COPYING
  56. %doc README.rst CHANGES.rst
  57. %{python3_sitelib}/pyudev
  58. %{python3_sitelib}/pyudev-*-info
  59. %exclude %{python3_sitelib}/pyudev/glib.py
  60. %exclude %{python3_sitelib}/pyudev/__pycache__/glib.*
  61. %exclude %{python3_sitelib}/pyudev/pyside.py
  62. %exclude %{python3_sitelib}/pyudev/__pycache__/pyside.*
  63. %exclude %{python3_sitelib}/pyudev/wx.py
  64. %exclude %{python3_sitelib}/pyudev/__pycache__/wx.*
  65. %changelog
  66. * Sat Nov 05 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.24.0-1
  67. - new upstream release.
  68. * Thu Apr 08 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.22.0-2
  69. - added systemd support (disabled as default).
  70. * Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.22.0-1
  71. - new upstream release.
  72. * Mon Sep 16 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.21.0-13
  73. - initial build for Vine Linux.
  74. - dropped qt4/qt5 stuff.
  75. * Fri Aug 16 2019 Miro Hrončok <mhroncok@redhat.com> - 0.21.0-12
  76. - Rebuilt for Python 3.8
  77. * Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.21.0-11
  78. - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
  79. * Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.21.0-10
  80. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  81. * Thu Oct 11 2018 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 0.21.0-9
  82. - Python2 binary package has been removed
  83. See https://fedoraproject.org/wiki/Changes/Mass_Python_2_Package_Removal
  84. * Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.21.0-8
  85. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  86. * Fri Jun 15 2018 Miro Hrončok <mhroncok@redhat.com> - 0.21.0-7
  87. - Rebuilt for Python 3.7
  88. * Fri Mar 23 2018 Iryna Shcherbina <ishcherb@redhat.com> - 0.21.0-6
  89. - Update Python 2 dependency declarations to new packaging standards
  90. (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
  91. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.21.0-5
  92. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  93. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.21.0-4
  94. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  95. * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.21.0-3
  96. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  97. * Wed Dec 21 2016 Kevin Fenzi <kevin@scrye.com> - 0.21.0-2
  98. - Rebuild for Python 3.6
  99. * Fri Jul 29 2016 mulhern <amulhern@redhat.com> - 0.21.1
  100. - Deprecate use of Device object as mapping from udev property names to values
  101. - Add a Properties class and a Device.properties() method for udev properties
  102. - Fix places where Device object was incorrectly used in a boolean context
  103. - Return an empty string, not None, if the property value is an empty string
  104. - Exceptions re-raised from libudev calls now have a message string
  105. - Insert a warning about using a Device in a boolean context in docs
  106. - Infrastructure for vagrant tests is removed
  107. - Various internal refactorings
  108. - Extensive test improvements
  109. - Numerous documentation fixes
  110. * Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.20.0-3
  111. - https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
  112. * Mon May 2 2016 mulhern <amulhern@redhat.com> - 0.20.0
  113. - Remove parsing code added in previous release
  114. - No longer do CI for Python 2.6
  115. - Eliminate all wildcard imports and __all__ statements
  116. - No longer use deprecated Device.from_sys_path() method
  117. - Minor pylint induced changes
  118. - Documentation fixes
  119. * Mon Feb 08 2016 mulhern <amulhern@redhat.com> - 0.19.0
  120. - Never raise a DeviceNotFoundError when iterating over a device enumeration
  121. - Device.subsystem() now returns None if device has no subsystem
  122. - Add DeprecationWarnings to deprecated Device methods
  123. - Replace "/" with "!" in Device.from_name() sys_name parameter
  124. - Add some unstable classes for parsing some kinds of values
  125. - Make version info more like Python's including micro numbers and levels
  126. - Refactor some internal modules into subdirectories
  127. - Work on tests and reproducers
  128. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.18.1-5
  129. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  130. * Mon Dec 21 2015 mulhern <amulhern@redhat.com> - 0.18.1
  131. - Restore raising KeyError in astring, asint, asbool methods in Attributes
  132. - Add dependency on six package
  133. - pyudev sources now in src directory
  134. - Added support for pyqt5 monitor observer
  135. - Added discover module, which looks up a device on limited information
  136. - DeviceNotFoundError is no longer a subtype of LookupError
  137. - Attributes class no longer extends Mapping class
  138. - Attributes class no longer inherits [] operator and other Mapping methods
  139. - Attributes class object are no longer iterable or indexable and have no length
  140. - Attributes.available_attributes property added
  141. - Attributes.get() method, with usual semantics explicitly defined
  142. - Device.from_* methods are deprecated, use Devices.from_* methods instead
  143. - Device.from_device_number() now raises DeviceNotFoundByNumberError
  144. - Devices.from_interface_index() method added
  145. - Devices.from_kernel_device() method added
  146. * Thu Dec 3 2015 David Shea <dshea@redhat.com> - 0.17-4
  147. - Add requires for things that are required
  148. - Split the main-loop integration modules into separate packages
  149. * Wed Nov 04 2015 Robert Kuska <rkuska@redhat.com> - 0.17-3
  150. - Rebuilt for Python3.5 rebuild
  151. * Tue Sep 15 2015 David Shea <dshea@redhat.com> - 0.17.1-2
  152. - Fix a typo in the python3-pyudev Provides
  153. * Mon Sep 14 2015 David Shea <dshea@redhat.com> - 0.17.1-1
  154. - Really start the monitor on pyudev.Monitor.poll()
  155. - Force non-blocking IO in pyudev.Monitor to avoid blocking on receiving the device
  156. - Set proper flags on pipe fs
  157. - Handle irregular polling events properly
  158. - Rename MonitorObserver GUI classes and deprecate the old ones
  159. - Remove patches for #1170337 and #1230773 that are now part of upstream
  160. - Switch to new packaging guidelines which renames python-pyudev to python2-pyudev
  161. * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.16.1-4
  162. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  163. * Fri Jun 12 2015 David Shea <dshea@redhat.com> - 0.16.1-3
  164. - Retry interrupted system calls (#1230773)
  165. - Rearrange the build process to match current packaging recommendations
  166. * Wed Jan 28 2015 David Shea <dshea@redhat.com> - 0.16.1-2
  167. - Use %%license for the license file
  168. * Wed Dec 10 2014 David Shea <dshea@redhat.com> - 0.16.1-1
  169. - Update to pyudev-0.16.1 (#880644)
  170. - Apply a patch from upstream to remove a global reference to libudev (#1170337)
  171. * Wed Dec 10 2014 David Shea <dshea@redhat.com> - 0.15-7
  172. - Fix license tag (LGPL -> LGPLv2+) (#990579)
  173. - Remove rst tags from description
  174. - Remove unnecessary requires and buildrequires (#1095459)
  175. - Avoid packaging upstream egg-info files
  176. - Add a python3 package
  177. - Drop the Group tag which wasn't even the right group
  178. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.15-6
  179. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  180. * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.15-5
  181. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  182. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.15-4
  183. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  184. * Mon Jul 23 2012 Chris Lockfort <clockfort@redhat.com> 0.15-3
  185. - Reflect rawhide merging udev into systemd
  186. * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.15-2
  187. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  188. * Mon Jun 18 2012 Chris Lockfort <clockfort@redhat.com> 0.15-1
  189. - initial package