python-cryptography-vl.spec 9.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286
  1. %global with_python3 1
  2. %{!?python3_pkgversion:%global python3_pkgversion 3}
  3. %global srcname cryptography
  4. Summary: PyCA's cryptography library
  5. Name: python-%{srcname}
  6. Version: 38.0.1
  7. Release: 1%{?_dist_release}
  8. Group: programming
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. License: ASL 2.0 or BSD
  12. URL: https://cryptography.io/en/latest/
  13. Source0: https://pypi.io/packages/source/c/%{srcname}/%{srcname}-%{version}.tar.gz
  14. Source1: cryptography-%{version}-vendor.tar.bz2
  15. Source2: conftest-skipper.py
  16. Source3: vendor_rust.py
  17. BuildRequires: openssl-devel
  18. BuildRequires: gcc
  19. BuildRequires: python-rpm-macros
  20. %if 0%{?with_python3}
  21. BuildRequires: python%{python3_pkgversion}-rpm-macros
  22. BuildRequires: python%{python3_pkgversion}-devel
  23. BuildRequires: python%{python3_pkgversion}-setuptools
  24. BuildRequires: python%{python3_pkgversion}-setuptools-rust
  25. BuildRequires: python%{python3_pkgversion}-pip
  26. BuildRequires: python%{python3_pkgversion}-asn1crypto >= 0.21
  27. BuildRequires: python%{python3_pkgversion}-idna >= 2.1
  28. BuildRequires: python%{python3_pkgversion}-six >= 1.4.1
  29. BuildRequires: python%{python3_pkgversion}-cffi >= 1.7
  30. %endif
  31. %description
  32. cryptography is a package designed to expose cryptographic primitives and
  33. recipes to Python developers.
  34. %if 0%{?with_python3}
  35. %{?python_provide:%python_provide python2-%{srcname}}
  36. %else
  37. Provides: python-%{srcname}
  38. %endif
  39. %if 0%{?with_python3}
  40. %package -n python%{python3_pkgversion}-%{srcname}
  41. Group: programming
  42. Summary: PyCA's cryptography library
  43. %{?python_provide:%python_provide python%{python3_pkgversion}-%{srcname}}
  44. Requires: openssl
  45. Requires: python%{python3_pkgversion}-idna >= 2.1
  46. Requires: python%{python3_pkgversion}-asn1crypto >= 0.21
  47. Requires: python%{python3_pkgversion}-six >= 1.4.1
  48. Requires: python%{python3_pkgversion}-cffi >= 1.7
  49. %description -n python%{python3_pkgversion}-%{srcname}
  50. cryptography is a package designed to expose cryptographic primitives and
  51. recipes to Python developers.
  52. %endif
  53. %debug_package
  54. %prep
  55. %autosetup -p1 -n %{srcname}-%{version}
  56. %if 0%{?with_python3}
  57. rm -rf %{py3dir}
  58. cp -a . %{py3dir}
  59. find %{py3dir} -name '*.py' | xargs sed -i '1s|^#!/usr/bin/python|#!%{__python3}|'
  60. %endif
  61. %build
  62. %if 0%{?with_python3}
  63. pushd %{py3dir}
  64. %pip3_build_wheel
  65. %endif # with_python3
  66. %install
  67. # Actually other *.c and *.h are appropriate
  68. # see https://github.com/pyca/cryptography/issues/1463
  69. find . -name .keep -print -delete
  70. %if 0%{?with_python3}
  71. pushd %{py3dir}
  72. %pip3_install_wheel
  73. popd
  74. %endif # with_python3
  75. %check
  76. %if 0%{?with_python3}
  77. pushd %{py3dir}
  78. # workaround for pytest 3.2.0 bug https://github.com/pytest-dev/pytest/issues/2644
  79. rm -f tests/hazmat/primitives/test_padding.py
  80. #%{__python3} setup.py test
  81. popd
  82. %endif
  83. %if 0%{?with_python3}
  84. %files -n python%{python3_pkgversion}-%{srcname}
  85. %license LICENSE*
  86. %doc README.rst docs
  87. %{python3_sitearch}/*
  88. %{python3_sitearch}/%{srcname}-*-info
  89. %endif
  90. %changelog
  91. * Fri Oct 28 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 38.0.1-1
  92. - new upstream release.
  93. * Tue Jan 25 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 36.0.1-1
  94. - new upstream release.
  95. - dropped python2 support.
  96. * Sat Aug 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.0-1
  97. - new upstream release.
  98. * Mon Nov 19 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.4.1-1
  99. - initial build for Vine Linux.
  100. - new upstream release.
  101. * Mon Aug 13 2018 Christian Heimes <cheimes@redhat.com> - 2.3-2
  102. - Use TLSv1.2 in test as workaround for RHBZ#1615143
  103. * Wed Jul 18 2018 Christian Heimes <cheimes@redhat.com> - 2.3-1
  104. - New upstream release 2.3
  105. - Fix AEAD tag truncation bug, RHBZ#1602752
  106. * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.1-3
  107. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  108. * Fri Jun 15 2018 Miro Hrončok <mhroncok@redhat.com> - 2.2.1-2
  109. - Rebuilt for Python 3.7
  110. * Wed Mar 21 2018 Christian Heimes <cheimes@redhat.com> - 2.2.1-1
  111. - New upstream release 2.2.1
  112. * Sun Feb 18 2018 Christian Heimes <cheimes@redhat.com> - 2.1.4-1
  113. - New upstream release 2.1.4
  114. * Sun Feb 18 2018 Christian Heimes <cheimes@redhat.com> - 2.1.3-4
  115. - Build requires gcc
  116. * Mon Feb 12 2018 Iryna Shcherbina <ishcherb@redhat.com> - 2.1.3-3
  117. - Update Python 2 dependency declarations to new packaging standards
  118. (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
  119. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.3-2
  120. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  121. * Thu Nov 23 2017 Haïkel Guémar <hguemar@fedoraproject.org> - 2.1.3-1
  122. - Upstream 2.1.3
  123. * Tue Oct 24 2017 Christian Heimes <cheimes@redhat.com> - 2.1-2
  124. - Change Requires to openssl-libs
  125. * Thu Oct 12 2017 Christian Heimes <cheimes@redhat.com> - 2.1-1
  126. - New upstream release 2.1
  127. * Wed Sep 27 2017 Troy Dawson <tdawson@redhat.com> - 2.0.2-3
  128. - Cleanup spec file conditionals
  129. * Thu Aug 03 2017 Christian Heimes <cheimes@redhat.com> - 2.0.2-2
  130. - Add workaround for pytest bug
  131. * Thu Aug 03 2017 Christian Heimes <cheimes@redhat.com> - 2.0.2-1
  132. - New upstream release 2.0.2
  133. - Modernize spec
  134. * Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.9-3
  135. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
  136. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.9-2
  137. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  138. * Tue Jun 27 2017 Christian Heimes <cheimes@redhat.com> - 1.9-1
  139. - Upstream release 1.9
  140. * Wed Feb 15 2017 Christian Heimes <cheimes@redhat.com> - 1.7.2-1
  141. - Update to latest upstream
  142. * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.1-2
  143. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  144. * Thu Jan 05 2017 Matěj Cepl <mcepl@redhat.com> - 1.7.1-1
  145. - Update to the latest upstream.
  146. - Add a patch from https://github.com/pyca/cryptography/pull/3328
  147. * Tue Dec 13 2016 Charalampos Stratakis <cstratak@redhat.com> - 1.5.3-5
  148. - Enable tests
  149. * Mon Dec 12 2016 Charalampos Stratakis <cstratak@redhat.com> - 1.5.3-4
  150. - Rebuild for Python 3.6
  151. - Disable python3 tests for now
  152. * Thu Nov 10 2016 Nathaniel McCallum <npmccallum@redhat.com> - 1.5.3-3
  153. - Revert previous change
  154. * Thu Nov 10 2016 Nathaniel McCallum <npmccallum@redhat.com> - 1.5.3-2
  155. - Disable tests on releases earlier than 24
  156. * Mon Nov 07 2016 Nathaniel McCallum <npmccallum@redhat.com> - 1.5.3-1
  157. - Update to v1.5.3
  158. - Update source URL
  159. - Add BR for pytz
  160. * Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.1-4
  161. - https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
  162. * Tue May 10 2016 Nathaniel McCallum <npmccallum@redhat.com> - 1.3.1-3
  163. - Remove versioned setuptools dependency
  164. * Tue May 10 2016 Nathaniel McCallum <npmccallum@redhat.com> - 1.3.1-2
  165. - Make it easier to build on EL7
  166. * Tue May 03 2016 Nathaniel McCallum <npmccallum@redhat.com> - 1.3.1-1
  167. - Update to v1.3.1
  168. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.1-3
  169. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  170. * Mon Jan 11 2016 Nathaniel McCallum <npmccallum@redhat.com> - 1.2.1-2
  171. - Move python-cryptograph => python2-cryptography
  172. * Sat Jan 09 2016 Nathaniel McCallum <npmccallum@redhat.com> - 1.2.1-1
  173. - Update to v1.2.1
  174. * Wed Nov 11 2015 Robert Kuska <rkuska@redhat.com> - 1.1-1
  175. - Update to v1.1
  176. * Wed Nov 04 2015 Robert Kuska <rkuska@redhat.com> - 1.0.2-2
  177. - Rebuilt for Python3.5 rebuild
  178. * Wed Sep 30 2015 Matěj Cepl <mcepl@redhat.com> - 1.0.2-1
  179. - New upstream release (fix #1267548)
  180. * Wed Aug 12 2015 Nathaniel McCallum <npmccallum@redhat.com> - 1.0-1
  181. - New upstream release
  182. * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9-2
  183. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  184. * Thu May 14 2015 Nathaniel McCallum <npmccallum@redhat.com> - 0.9-1
  185. - New upstream release
  186. - Run tests on RHEL
  187. - New deps: python-idna, python-ipaddress
  188. * Fri Apr 17 2015 Nathaniel McCallum <npmccallum@redhat.com> - 0.8.2-1
  189. - New upstream release
  190. - Add python3-pyasn1 Requires (#1211073)
  191. * Tue Apr 14 2015 Matej Cepl <mcepl@redhat.com> - 0.8-2
  192. - Add python-pyasn1 Requires (#1211073)
  193. * Fri Mar 13 2015 Nathaniel McCallum <npmccallum@redhat.com> - 0.8-1
  194. - New upstream release
  195. - Remove upstreamed patch
  196. * Wed Mar 04 2015 Nathaniel McCallum <npmccallum@redhat.com> - 0.7.2-2
  197. - Add python3-cryptography-vectors build requires
  198. - Add python-enum34 requires
  199. * Tue Feb 03 2015 Nathaniel McCallum <npmccallum@redhat.com> - 0.7.2-1
  200. - New upstream release. BSD is now an optional license.
  201. - Fix test running on python3
  202. - Add upstream patch to fix test paths
  203. * Fri Nov 07 2014 Matej Cepl <mcepl@redhat.com> - 0.6.1-2
  204. - Fix requires, for reasons why other development files were not
  205. eliminated see https://github.com/pyca/cryptography/issues/1463.
  206. * Wed Nov 05 2014 Matej Cepl <mcepl@redhat.com> - 0.6.1-1
  207. - New upstream release.
  208. * Sun Jun 29 2014 Terry Chia <terrycwk1994@gmail.com> 0.4-1
  209. - initial version