file-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441
  1. %define __libtoolize :
  2. Summary: A utility for determining file types.
  3. Summary(ja): ファイルの種類を判別するユーティリティー
  4. Name: file
  5. Version: 5.43
  6. Release: 1%{?_dist_release}
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. Packager: daisuke
  11. License: BSD
  12. URL: http://www.darwinsys.com/file/
  13. # master site is toooooooooooooooooo slow
  14. Source0: http://ftp.astron.com/pub/file/%{name}-%{version}.tar.gz
  15. # Addtional magic file for Vine
  16. Source10: magic.printer-j
  17. # Upstream says it's up to distributions to add a way to support local-magic.
  18. Patch0: file-localmagic.patch
  19. # not yet upstream
  20. Patch1: file-4.17-rpm-name.patch
  21. Patch2: file-5.04-volume_key.patch
  22. # Vine
  23. Patch1000: file-5.14-magicbuild-fix.patch
  24. Buildroot: %{_tmppath}/%{name}-%{version}-root
  25. #BuildRequires: automake
  26. #BuildRequires: autoconf
  27. BuildRequires: zlib-devel
  28. Obsoletes: file-static
  29. %description
  30. The file command is used to identify a particular file according to the
  31. type of data contained by the file. File can identify many different
  32. file types, including ELF binaries, system libraries, RPM packages, and
  33. different graphics formats.
  34. You should install the file package, since the file command is such a
  35. useful utility.
  36. %description -l ja
  37. file コマンドは、ファイルに含まれるデータの種類によって各ファイルが
  38. どのようなファイルかを判定するために使います。file は ELF バイナリ、シ
  39. ステムライブラリ、RPM パッケージ、そして様々なグラフィックフォーマット
  40. を含む、多くの異なるファイルの種類を見分けることができます。
  41. %package devel
  42. Summary: Libraries and header files for file development
  43. Summary(ja): libmagic の開発用ファイル
  44. Group: programming
  45. Requires: %{name} = %{version}-%{release}
  46. %description devel
  47. The file-devel package contains the header files and libmagic library
  48. necessary for developing programs using libmagic.
  49. %package -n python-magic
  50. Summary: Python bindings for the libmagic API
  51. Group: programming
  52. BuildRequires: python-devel
  53. BuildRequires: python-setuptools
  54. BuildRequires: python-rpm-macros
  55. Requires: %{name} = %{version}-%{release}
  56. %description -n python-magic
  57. This package contains the Python bindings to allow access to the
  58. libmagic API. The libmagic library is also used by the familiar
  59. file(1) command.
  60. %package -n python3-magic
  61. Summary: Python bindings for the libmagic API
  62. Group: programming
  63. BuildRequires: python3-devel
  64. BuildRequires: python3-setuptools
  65. BuildRequires: python3-rpm-macros
  66. Requires: %{name} = %{version}-%{release}
  67. %description -n python3-magic
  68. This package contains the Python bindings to allow access to the
  69. libmagic API. The libmagic library is also used by the familiar
  70. file(1) command.
  71. %debug_package
  72. %prep
  73. %setup -q
  74. %autopatch -p1
  75. cat %{SOURCE10} >> ./magic/Localstuff
  76. iconv -f iso-8859-1 -t utf-8 < doc/libmagic.man > doc/libmagic.man_
  77. touch -r doc/libmagic.man doc/libmagic.man_
  78. mv doc/libmagic.man_ doc/libmagic.man
  79. %build
  80. autoreconf -fiv
  81. CFLAGS="%{optflags} -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE" \
  82. %configure --enable-fsect-man5 --disable-rpath
  83. # remove hardcoded library paths from local libtool
  84. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  85. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  86. export LD_LIBRARY_PATH=$RPM_BUILD_ROOT/%{name}-%{version}/src/.libs
  87. make
  88. cd python
  89. %py_build
  90. %py3_build
  91. %install
  92. rm -rf $RPM_BUILD_ROOT
  93. mkdir -p $RPM_BUILD_ROOT%{_bindir}
  94. mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
  95. mkdir -p $RPM_BUILD_ROOT%{_mandir}/man3
  96. mkdir -p $RPM_BUILD_ROOT%{_mandir}/man5
  97. mkdir -p $RPM_BUILD_ROOT%{_datadir}/misc
  98. mkdir -p $RPM_BUILD_ROOT%{_datadir}/file
  99. make install DESTDIR=$RPM_BUILD_ROOT
  100. cat magic/Magdir/* > ${RPM_BUILD_ROOT}%{_datadir}/misc/magic
  101. ln -s misc/magic ${RPM_BUILD_ROOT}%{_datadir}/magic
  102. ##ln -s file/magic.mime ${RPM_BUILD_ROOT}%{_datadir}/magic.mime
  103. ln -s ../magic ${RPM_BUILD_ROOT}%{_datadir}/file/magic
  104. cd python
  105. %py_install
  106. %py3_install
  107. %{__install} -d ${RPM_BUILD_ROOT}%{_datadir}/%{name}
  108. # LIBTOOL=/usr/bin/libtool
  109. #ln -s file/magic ${RPM_BUILD_ROOT}%{_datadir}/magic
  110. #ln -s file/magic.mime ${RPM_BUILD_ROOT}%{_datadir}/magic.mime
  111. #ln -s ../magic ${RPM_BUILD_ROOT}%{_datadir}/misc/magic
  112. #{ cd ${RPM_BUILD_ROOT}
  113. # strip .%{_bindir}/file
  114. # cp %SOURCE1 .%{_datadir}/magic.mime
  115. #}
  116. # remove unused files
  117. rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
  118. %ifarch x86_64
  119. %check
  120. export LD_LIBRARY_PATH=$PWD/src/.libs
  121. make -C tests check
  122. %endif
  123. %clean
  124. rm -rf $RPM_BUILD_ROOT
  125. %files
  126. %defattr(-,root,root)
  127. %license COPYING
  128. %doc ChangeLog README
  129. %{_bindir}/*
  130. %{_libdir}/libmagic.so.*
  131. %{_datadir}/file/*
  132. %{_datadir}/magic*
  133. %{_datadir}/misc/*
  134. %{_mandir}/man[15]/*
  135. %files devel
  136. %defattr(-,root,root,-)
  137. %{_libdir}/*.so
  138. %{_libdir}/pkgconfig/*
  139. %{_includedir}/magic.h
  140. %{_mandir}/man3/*
  141. %files -n python-magic
  142. %defattr(-, root, root, -)
  143. %license python/LICENSE
  144. %doc python/README* python/example.py
  145. %{python_sitelib}/magic.py
  146. %{python_sitelib}/magic.pyc
  147. %{python_sitelib}/magic.pyo
  148. %{python_sitelib}/*egg-info
  149. %files -n python3-magic
  150. %defattr(-, root, root, -)
  151. %license python/LICENSE
  152. %doc python/README* python/example.py
  153. %{python3_sitelib}/*
  154. %changelog
  155. * Sun Oct 02 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.43-1
  156. - new upstream release.
  157. * Thu Aug 12 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.40-2
  158. - renumbered patches.
  159. - imported Patch3-5 from upstream.
  160. * Wed Apr 21 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.40-1
  161. - new upstream release.
  162. - dropped ldconfig scriptlets.
  163. * Wed Feb 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.39-1
  164. - new upstream release.
  165. - dropped Patch14 and 9000: fixed in upstream.
  166. * Sun Oct 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.37-2
  167. - added Patch9000.
  168. * Sat Oct 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.37-1
  169. - new upstream release.
  170. - added python3 support.
  171. - updated Patch0.
  172. - dropped Patch1, 5-17 and 100: fixed in upstream.
  173. - imported Patch14 from rawhide.
  174. * Thu Jul 28 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.28-1
  175. - new upstream release.
  176. - dropped Patch200: fixed in upstream.
  177. - updated patches.
  178. - imported Patch15,17 and 100.
  179. * Sat Nov 15 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.20-1
  180. - new upstream release
  181. - update/drop patches based on fc22
  182. * Fri Oct 24 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 5.14-7
  183. - reflected 6.0 updates and bumped release
  184. * Thu Sep 11 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-6
  185. - drop patch230 (moved to patch320)
  186. - add Patch240 for fix CVE-2014-0207
  187. - add Patch250 for fix CVE-2014-0237
  188. - add Patch260 for fix CVE-2014-0238
  189. - add Patch270 for fix CVE-2014-3478
  190. - add Patch280 for fix CVE-2014-3479
  191. - add Patch290 for fix CVE-2014-3480
  192. - add Patch300 for fix CVE-2014-3487
  193. - add Patch310 for fix CVE-2014-3538
  194. - add Patch320 for fix CVE-2014-3587
  195. These patches are from debian/ubuntu, thanks.
  196. * Thu Aug 28 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-5
  197. - add patch230 for fix CVE-2014-3587 (cdf_read_property_info)
  198. * Thu Mar 27 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-4
  199. - add patch110,220 for fix regression of CVE-2014-2270
  200. * Wed Mar 12 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-3
  201. - add patch210 for fix CVE-2014-2270
  202. * Thu Feb 20 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-2
  203. - add patch200 for fix CVE-2014-1943
  204. * Sun Jul 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.14-2
  205. - rebuild with VineSeed environment
  206. * Sun Sep 22 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-1
  207. - new upstream reelase
  208. - add patch100 to fix build error
  209. - remove -static subpackage and add Obs: file-static
  210. - fix old changelog date...
  211. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 5.11-1
  212. - new upstream reelase
  213. - drop all local patches
  214. - import fedora patches
  215. * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.05-3
  216. - rebuild with python-2.7.2
  217. * Sun Feb 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.05-2
  218. - rebuild package
  219. - fix Patch100
  220. * Sat Feb 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.05-1
  221. - new upstream release
  222. - updated Vine patches (but Patch100 has not been ported yet...)
  223. - split to devel and static subpackcages
  224. * Mon Sep 27 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.21-3
  225. - rebuilt with rpm-4.8.1
  226. - add environment variable LIBTOOL for make command
  227. * Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 4.21-2
  228. - spec in utf-8
  229. - removed *.la
  230. * Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.21-1
  231. - applied new versioning policy
  232. * Tue Dec 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.21-0vl1
  233. - new upstream release
  234. - import debian/fedora patches
  235. - drop obsolete vine magic.
  236. * Thu Jun 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.09-0vl3
  237. - rebuild for VineSeed with new tool chain
  238. * Thu May 31 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.09-0vl2.2
  239. - add patch110 for fix CVE-2007-2799
  240. - add zlib-devel to BuildPreReq tag
  241. * Mon Mar 26 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.09-0vl2.1
  242. - add patch100 for fix CVE-2007-1536
  243. * Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.09-0vl2
  244. - changed Group to Applications/System
  245. * Sun Apr 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4.09-0vl1
  246. - new upstream release
  247. - update vine patches
  248. * Wed Sep 10 2003 Tomoya TAKA <taka@vinelinux.org> 4.03-0vl2
  249. - update Patch10, use 'size_t' in src/jcode.[ch]
  250. * Tue Sep 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.03-0vl1
  251. - update to 4.03
  252. - update Patch0, 1, 10 for 4.03
  253. - s/Copyright/License/
  254. * Mon May 12 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.02-1vl1
  255. - update to 4.02
  256. - update Vine patches for 4.02
  257. * Sun Mar 9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.41-0vl1
  258. - new upstream release
  259. - fixed security bug (http://www.idefense.com/advisory/03.04.03.txt)
  260. - remove unneeded patches.
  261. - update Vine patches for 3.41
  262. * Mon Apr 1 2002 Jun Nishii <jun@vinelinux.org> 3.37-0vl2
  263. - added NPDL2 data [Vine:02348]
  264. * Fri Feb 08 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.37-0vl1
  265. - update to 3.37
  266. * Sun Jul 15 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  267. - 3.35-0vl3
  268. - disable some entries in elf for problems on big-endian archs
  269. * Wed Jun 6 2001 Jun Nishii <jun@vinelinux.org>
  270. - file-3.35-0vl1
  271. - ver.up
  272. - added %doc
  273. * Thu Jan 11 2001 Jun Nishii <jun@vinelinux.org>
  274. - file-3.33-1vl4
  275. - more fix and clean up jtext patch (file-3.33-vinejtext.patch)
  276. * Thu Jan 11 2001 Jun Nishii <jun@vinelinux.org>
  277. - file-3.33-1vl3
  278. - fix again jtext patch (file-3.33-vinejtext.patch)
  279. - added file-3.33-vinenames.patch to avoid miss-judgement
  280. * Wed Jan 10 2001 Jun Nishii <jun@vinelinux.org>
  281. - file-3.33-1vl2
  282. - update jtext patch (file-3.33-vinejtext.patch)
  283. * Mon Jan 8 2001 Jun Nishii <jun@vinelinux.org>
  284. - file-3.33-1vl1
  285. - modify description-ja and spec
  286. * Sun Jul 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  287. - file-3.28-2vl2
  288. - fixed %files section to handle compressed man pages
  289. * Tue Jun 13 2000 Lisa Sagami <czs14350@nifty.ne.jp>
  290. - marged RH 3.28-2 and Vine 3.27-3vl3
  291. * Wed Feb 16 2000 Cristian Gafton <gafton@redhat.com>
  292. - add ia64 patch from rth
  293. * Mon Feb 7 2000 Bill Nottingham <notting@redhat.com>
  294. - handle compressed manpages
  295. - update to 3.28
  296. * Mon Sep 6 1999 Norihito Ohmori <ohmori@flatout.org>
  297. - Japanese Text detection bug fix. (by Toru Hoshina <hoshina@best.com>)
  298. * Fri Aug 27 1999 Norihito Ohmori <ohmori@flatout.org>
  299. - patch dues not apply bug.
  300. * Thu Aug 26 1999 Norihito Ohmori <ohmori@flatout.org>
  301. - not need kcc (Thanks for Toru Hoshina <hoshina@best.com>)
  302. - ASCII data and Shift JIS data detected in Japanese Text Detection bug fix.
  303. * Mon Aug 23 1999 Jeff Johnson <jbj@redhat.com>
  304. - identify ELF stripped files correctly (#4665).
  305. - use SPARC (not sparc) consistently throughout (#4665).
  306. - add entries for MS Office files (#4665).
  307. * Thu Aug 12 1999 Jeff Johnson <jbj@redhat.com>
  308. - diddle magic so that *.tfm files are identified correctly.
  309. * Tue Jul 6 1999 Jeff Johnson <jbj@redhat.com>
  310. - update to 3.27.
  311. * Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
  312. - experimental support for realmedia files added
  313. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  314. - auto rebuild in the new build environment (release 5)
  315. * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
  316. - strip binary.
  317. * Fri Nov 27 1998 Jakub Jelinek <jj@ultra.linux.cz>
  318. - add SPARC V9 magic.
  319. * Tue Nov 10 1998 Jeff Johnson <jbj@redhat.com>
  320. - update to 3.26.
  321. * Mon Aug 24 1998 Jeff Johnson <jbj@redhat.com>
  322. - update to 3.25.
  323. - detect gimp XCF versions.
  324. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  325. - translations modified for de, fr, tr
  326. * Wed Apr 08 1998 Erik Troan <ewt@redhat.com>
  327. - updated to 3.24
  328. - buildrooted
  329. * Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
  330. - built against glibc
  331. * Mon Mar 31 1997 Erik Troan <ewt@redhat.com>
  332. - Fixed problems caused by 64 bit time_t.
  333. * Thu Mar 06 1997 Michael K. Johnson <johnsonm@redhat.com>
  334. - Improved recognition of Linux kernel images.