libev-vl.spec 5.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207
  1. %global source_dir %{_datadir}/%{name}-source
  2. %global inst_srcdir %{buildroot}/%{source_dir}
  3. Name: libev
  4. Version: 4.19
  5. Release: 1%{?_dist_release}
  6. Summary: High-performance event loop/event model with lots of features
  7. Summary(ja): 高機能・高性能のイベントループ・イベントモデル
  8. Group: System Environment/Libraries
  9. License: BSD or GPLv2+
  10. URL: http://software.schmorp.de/pkg/libev.html
  11. Source0: http://dist.schmorp.de/libev/Attic/%{name}-%{version}.tar.gz
  12. Source1: %{name}.pc.in
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  14. BuildRequires: automake libtool
  15. %description
  16. Libev is modeled (very loosely) after libevent and the Event Perl
  17. module, but is faster, scales better and is more correct, and also more
  18. featureful. And also smaller.
  19. %description -l ja
  20. libev は libevent および Perl の Event を大まかに参考にして作られましたが、
  21. それらより高速に動作し、よりスケールし、より正確で、より高機能で、
  22. 同時によりコンパクトです。
  23. %package devel
  24. Summary: Development files for %{name}
  25. Summary(ja): %{name} の開発用ファイル
  26. Group: Development/Libraries
  27. Requires: %{name}%{?_isa} = %{version}-%{release}
  28. Requires: pkgconfig
  29. %description devel
  30. Libev is modeled (very loosely) after libevent and the Event Perl
  31. module, but is faster, scales better and is more correct, and also more
  32. featureful. And also smaller. Development libraries.
  33. %description devel -l ja
  34. このパッケージには libev 用開発ライブラリとヘッダが収録されています。
  35. %package source
  36. Summary: Source code for libev
  37. Summary(ja): libev のソースコード
  38. Group: Development/Libraries
  39. BuildArch: noarch
  40. %description source
  41. This package contains the source code for libev.
  42. Libev is modeled (very loosely) after libevent and the Event Perl
  43. module, but is faster, scales better and is more correct, and also more
  44. featureful. And also smaller. Development libraries.
  45. %description source -l ja
  46. このパッケージには libev のソースコードが収録されています。
  47. %prep
  48. %setup -q
  49. # Add pkgconfig support
  50. cp -p %{SOURCE1} .
  51. sed -i.pkgconfig -e 's|Makefile|Makefile libev.pc|' configure.ac configure
  52. sed -i.pkgconfig -e 's|lib_LTLIBRARIES|pkgconfigdir = $(libdir)/pkgconfig\n\npkgconfig_DATA = libev.pc\n\nlib_LTLIBRARIES|' Makefile.am Makefile.in
  53. aclocal
  54. automake
  55. %build
  56. %configure --disable-static --with-pic --includedir=%{_includedir}/%{name}
  57. make %{?_smp_mflags}
  58. %check
  59. make check
  60. %install
  61. rm -rf %{buildroot}
  62. make install DESTDIR=%{buildroot} INSTALL="install -p"
  63. rm -rf %{buildroot}%{_libdir}/%{name}.la
  64. # Make the source package
  65. mkdir -p %{inst_srcdir}
  66. find . -type f | grep -E '.*\.(c|h|am|ac|inc|m4|h.in|pc.in|man.pre|pl|txt)$' | xargs tar cf - | (cd %{inst_srcdir} && tar xf -)
  67. install -p -m 0644 Changes ev.pod LICENSE README %{inst_srcdir}
  68. %clean
  69. rm -rf %{buildroot}
  70. %post -p /sbin/ldconfig
  71. %postun -p /sbin/ldconfig
  72. %files
  73. %doc Changes LICENSE README
  74. %{_libdir}/%{name}.so.4
  75. %{_libdir}/%{name}.so.4.0.0
  76. %files devel
  77. %{_libdir}/%{name}.so
  78. %{_includedir}/libev/
  79. %{_libdir}/pkgconfig/%{name}.pc
  80. %{_mandir}/man?/*
  81. %files source
  82. %{source_dir}
  83. %changelog
  84. * Sat Nov 01 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 4.19-1
  85. - updated to 4.19
  86. - spec in UTF-8
  87. - moved devel and source packages to Development/Libraries Group
  88. * Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.04-1
  89. - initial build for Vine Linux
  90. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.04-2
  91. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  92. * Tue Aug 9 2011 Tom Callaway <spot@fedoraproject.org> - 4.04-1
  93. - move man page
  94. - cleanup spec
  95. - update to 4.04
  96. * Mon Jun 13 2011 Matト嬲 Cepl <mcepl@redhat.com> - 4.03-2
  97. - EL5 cannot have noarch subpackages.
  98. * Sat Feb 5 2011 Michal Nowak <mnowak@redhat.com> - 4.03-1
  99. - 4.03; RHBZ#674022
  100. - add a -source subpackage (Mathieu Bridon); RHBZ#672153
  101. * Mon Jan 10 2011 Michal Nowak <mnowak@redhat.com> - 4.01-1
  102. - 4.01
  103. - fix grammar in %%description
  104. * Sat Jan 2 2010 Michal Nowak <mnowak@redhat.com> - 3.90-1
  105. - 3.9
  106. * Fri Aug 10 2009 Michal Nowak <mnowak@redhat.com> - 3.80-1
  107. - 3.8
  108. - always use the most recent automake
  109. - BuildRequires now libtool
  110. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.70-3
  111. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  112. * Fri Jul 17 2009 Michal Nowak <mnowak@redhat.com> - 3.70-2
  113. - spec file change, which prevented uploading most recent tarball
  114. so the RPM was "3.70" but tarball was from 3.60
  115. * Fri Jul 17 2009 Michal Nowak <mnowak@redhat.com> - 3.70-1
  116. - v3.7
  117. - list libev soname explicitly
  118. * Mon Jun 29 2009 Michal Nowak <mnowak@redhat.com> - 3.60-1
  119. - previous version was called "3.6" but this is broken update
  120. path wrt version "3.53" -- thus bumping to "3.60"
  121. * Thu Apr 30 2009 Michal Nowak <mnowak@redhat.com> - 3.6-1
  122. - 3.60
  123. - fixed few mixed-use-of-spaces-and-tabs warnings in spec file
  124. * Thu Mar 19 2009 Michal Nowak <mnowak@redhat.com> - 3.53-1
  125. - 3.53
  126. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.52-2
  127. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  128. * Wed Jan 07 2009 Michal Nowak <mnowak@redhat.com> - 3.52-1
  129. - 3.52
  130. * Wed Dec 24 2008 Michal Nowak <mnowak@redhat.com> - 3.51-1
  131. - 3.51
  132. * Thu Nov 20 2008 Michal Nowak <mnowak@redhat.com> - 3.49-1
  133. - version bump: 3.49
  134. * Sun Nov 9 2008 Michal Nowak <mnowak@redhat.com> - 3.48-1
  135. - version bump: 3.48
  136. * Mon Oct 6 2008 kwizart <kwizart at gmail.com> - 3.44-1
  137. - bump to 3.44
  138. * Tue Sep 2 2008 kwizart <kwizart at gmail.com> - 3.43-4
  139. - Fix pkgconfig support
  140. * Mon Aug 12 2008 Michal Nowak <mnowak@redhat.com> - 3.43-2
  141. - removed libev.a
  142. - installing with "-p"
  143. - event.h is removed intentionaly, because is there only for
  144. backward compatibility with libevent
  145. * Mon Aug 04 2008 Michal Nowak <mnowak@redhat.com> - 3.43-1
  146. - initial package