akonadi-vl.spec 9.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335
  1. %define _qt4_ver 4.8.0
  2. %define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
  3. %define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
  4. %define _qt4_plugindir %(pkg-config --variable plugindir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/plugins)
  5. ## Can be either MYSQL(uptsream default), SQLITE, or POSTGRES(untested)
  6. %global database_backend SQLITE
  7. Name: akonadi
  8. Summary: PIM Storage Service
  9. Summary(ja): PIM ストレージサービス
  10. Version: 1.13.0
  11. Release: 1%{?_dist_release}
  12. Group: System Environment/Libraries
  13. License: LGPLv2+
  14. URL: http://download.akonadi-project.org/
  15. Source0: http://download.akonadi-project.org/akonadi-%{version}.tar.bz2
  16. %define mysql_conf_timestamp 20110629
  17. # shrink default initial db size a bit (approx 140mb->28mb)
  18. Patch1: akonadi-mysql_conf.patch
  19. ## upstream patches
  20. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  21. BuildRequires: cmake >= 2.6.0
  22. BuildRequires: qt4-devel >= 4.4
  23. BuildRequires: automoc4
  24. BuildRequires: MySQL-server
  25. # for xsltproc
  26. BuildRequires: libxslt
  27. BuildRequires: shared-mime-info
  28. BuildRequires: libboost-devel libboost-program-options
  29. BuildRequires: soprano-devel >= 2.5.0
  30. BuildRequires: sqlite3-devel
  31. BuildRequires: libICE-devel libXext-devel
  32. Requires: qt4 >= %{_qt4_version}
  33. %if "%{?database_backend}" == "MYSQL"
  34. Requires: qt4-MySQL
  35. # not *strictly* required, but we need a functional default configuration
  36. Requires: MySQL-server
  37. %endif
  38. Obsoletes: akonadi-sqlite < %{version}-%{release}
  39. Requires(post): /sbin/ldconfig
  40. Requires(postun): /sbin/ldconfig
  41. %description
  42. %{summary}.
  43. %if "%{?database_backend}" == "MYSQL"
  44. Requires an available instance of mysql server at runtime.
  45. Akonadi can spawn a per-user one automatically if the mysql-server
  46. package is installed on the machine.
  47. See also: %{_sysconfdir}/akonadi/mysql-global.conf
  48. %endif
  49. %package devel
  50. Summary: Developer files for %{name}
  51. Summary(ja): %{name} の開発用ファイル
  52. Group: Development/Libraries
  53. Requires: %{name} = %{version}-%{release}
  54. Requires: qt4-devel
  55. %description devel
  56. %{summary}.
  57. %prep
  58. %setup -q
  59. #%patch1 -p1 -b .mysql_conf
  60. #touch -d %{mysql_conf_timestamp} server/src/storage/mysql-global.conf
  61. %build
  62. %ifarch x86_64
  63. PATH="$PATH:`/usr/bin/pkg-config --variable=bindir Qt`"
  64. %endif
  65. mkdir -p %{_target_platform}
  66. pushd %{_target_platform}
  67. %cmake \
  68. -DCONFIG_INSTALL_DIR=%{_sysconfdir} \
  69. -DINSTALL_QSQLITE_IN_QT_PREFIX:PATH=%{_qt4_plugindir} \
  70. %{?database_backend:-DDATABASE_BACKEND=%{database_backend}} \
  71. ..
  72. popd
  73. make %{?_smp_mflags} -C %{_target_platform}
  74. %install
  75. rm -rf $RPM_BUILD_ROOT
  76. make install DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
  77. mkdir -p $RPM_BUILD_ROOT%{_datadir}/akonadi/agents
  78. # create "big" config (analog to -mobile.conf)
  79. install -p \
  80. $RPM_BUILD_ROOT%{_sysconfdir}/akonadi/mysql-global.conf \
  81. $RPM_BUILD_ROOT%{_sysconfdir}/akonadi/mysql-global-big.conf
  82. # default to small/mobile config
  83. install -p \
  84. $RPM_BUILD_ROOT%{_sysconfdir}/akonadi/mysql-global-mobile.conf \
  85. $RPM_BUILD_ROOT%{_sysconfdir}/akonadi/mysql-global.conf
  86. touch -d %{mysql_conf_timestamp} \
  87. $RPM_BUILD_ROOT%{_sysconfdir}/akonadi/mysql-global*.conf \
  88. $RPM_BUILD_ROOT%{_sysconfdir}/akonadi/mysql-local.conf
  89. # create/own %{_libdir}/akondi
  90. mkdir -p $RPM_BUILD_ROOT%{_libdir}/akonadi
  91. #%check
  92. #make test -C %{_target_platform}
  93. #export PKG_CONFIG_PATH=$RPM_BUILD_ROOT%{_datadir}/pkgconfig:$RPM_BUILD_ROOT%{_libdir}/pkgconfig
  94. #test "$(pkg-config --modversion akonadi)" = "%{version}"
  95. %clean
  96. rm -rf $RPM_BUILD_ROOT
  97. %post -p /sbin/ldconfig
  98. %posttrans
  99. update-mime-database %{_datadir}/mime &> /dev/null || :
  100. %postun
  101. /sbin/ldconfig ||:
  102. if [ $1 -eq 0 ] ; then
  103. update-mime-database %{_datadir}/mime &> /dev/null ||:
  104. fi
  105. %files
  106. %defattr(-,root,root,-)
  107. %doc AUTHORS lgpl-license
  108. %dir %{_sysconfdir}/akonadi
  109. # example conf's
  110. %{_sysconfdir}/akonadi/mysql-global-big.conf
  111. %{_sysconfdir}/akonadi/mysql-global-mobile.conf
  112. %config(noreplace) %{_sysconfdir}/akonadi/mysql-global.conf
  113. %config(noreplace) %{_sysconfdir}/akonadi/mysql-local.conf
  114. %{_bindir}/akonadi_agent_launcher
  115. %{_bindir}/akonadi_agent_server
  116. %{_bindir}/akonadi_control
  117. %{_bindir}/akonadi_rds
  118. %{_bindir}/akonadictl
  119. %{_bindir}/akonadiserver
  120. %{_bindir}/asapcat
  121. %{_libdir}/libakonadi*.so.1*
  122. %{_datadir}/dbus-1/interfaces/org.freedesktop.Akonadi.*.xml
  123. %{_datadir}/dbus-1/services/org.freedesktop.Akonadi.*.service
  124. %{_datadir}/mime/packages/akonadi-mime.xml
  125. %{_datadir}/akonadi
  126. %{_qt4_plugindir}/sqldrivers/libqsqlite3.so
  127. %files devel
  128. %defattr(-,root,root,-)
  129. %{_includedir}/akonadi
  130. %{_libdir}/pkgconfig/akonadi.pc
  131. %{_libdir}/libakonadi*.so
  132. %{_libdir}/cmake/Akonadi
  133. %changelog
  134. * Wed Dec 31 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.13.0-1
  135. - new upstream release
  136. * Mon May 05 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.12.1-1
  137. - new upstream release
  138. * Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.11.0-1
  139. - new upstream release
  140. * Sat Sep 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.2-1
  141. - new upstream release
  142. * Wed Jun 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.9.2-1
  143. - new upstream release
  144. * Sun Nov 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.1-1
  145. - new upstream release
  146. * Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.0-1
  147. - new upstream release
  148. * Mon Jan 9 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.6.2-2
  149. - rebuilt with qt-4.8.0
  150. * Sun Oct 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.6.2-1
  151. - new upstream release
  152. * Sun Sep 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.6.1-1
  153. - new upstream release
  154. * Sat Aug 20 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.6.0-2
  155. - rebuilt with soprano-2.7.0-2
  156. * Sat Jul 30 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.6.0-1
  157. - new upstream release
  158. * Thu Mar 10 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.5.0-2
  159. - rebuilt with qt4-4.7.2
  160. * Mon Jan 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.5.0-1
  161. - new upstream release
  162. * Mon Sep 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4.0-2
  163. - rebuilt with rpm-4.8.1
  164. * Sun Aug 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4.0-1
  165. - new upstream release
  166. - added BR: sqlite3-devel
  167. - added sqlite subpackage
  168. * Sun Apr 11 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.3.1-3
  169. - new upstream release
  170. * Sun Apr 11 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.3.1-3
  171. - updated Patch1
  172. - added BR: MySQL-server
  173. * Sun Feb 14 2010 Shu KONNO <owa@bg.wakwak.com> - 1.3.1-2
  174. - added qmake path to PATH (if x86_64)
  175. * Sat Feb 13 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.3.1-1
  176. - new upstream release
  177. - built with new toolchain
  178. * Thu Sep 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.1-1
  179. - new upstream release
  180. * Wed Sep 02 2009 NAKAMURA Kenta <kenta@vinelinux.org> - 1.2.0-4
  181. - use %%cmake macro
  182. - removed MySQL-server from BuildRequires:
  183. * Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.0-3
  184. - fixed Requires
  185. * Sat Aug 15 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.0-2
  186. - Initial build for Vine
  187. * Thu Jul 30 2009 Lukáš Tinkl <ltinkl@redhat.com> - 1.2.0-1
  188. - Akonadi 1.2.0
  189. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.95-2
  190. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  191. * Thu Jun 25 2009 Than Ngo <than@redhat.com> - 1.1.95-1
  192. - 1.1.95
  193. * Wed Jun 03 2009 Rex Dieter <rdieter@fedoraproject.org> 1.1.90-1
  194. - akonadi-1.1.90
  195. * Tue May 26 2009 Rex Dieter <rdieter@fedoraproject.org> 1.1.85-3
  196. - akonadi.pc.cmake: s/AKONADI_LIB_VERSION_STRING/AKONADI_VERSION_STRING/
  197. * Tue May 12 2009 Than Ngo <than@redhat.com> 1.1.85-2
  198. - fix rpm file list
  199. * Wed May 06 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.85-1
  200. - akonadi-1.1.85
  201. * Thu Apr 30 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.2-1
  202. - akonadi-1.1.2
  203. - optimize scriptlets a bit
  204. * Wed Feb 25 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.1-6
  205. - rev startup patch
  206. - BR: cmake >= 2.6.0
  207. - preserve timestamp's on mysql*.conf's
  208. * Tue Feb 24 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.1-5
  209. - own %%_sysconfig/akonadi/mysql-local.conf
  210. - startup patch: reset conf only when needed, and clear mysql log file on update
  211. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.1-4
  212. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  213. * Fri Feb 20 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.1-3
  214. - shrink default db initial size a bit (approx 140mb->28mb)
  215. - drop extraneous RPATH-cmake baggage
  216. * Wed Jan 21 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.1-1
  217. - 1.1.1
  218. * Sun Jan 04 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.0-1
  219. - 1.1.0
  220. * Tue Dec 16 2008 Rex Dieter <rdieter@fedoraproject.org> - 1.0.81-1
  221. - 1.0.81
  222. * Mon Dec 08 2008 Rex Dieter <rdieter@fedoraproject.org> - 1.0.80-3
  223. - restore Requires: mysql-server
  224. * Mon Dec 01 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1.0.80-2
  225. - own /usr/share/akonadi and /usr/share/akonadi/agents (#473595)
  226. * Wed Nov 26 2008 Than Ngo <than@redhat.com> - 1.0.80-1
  227. - 1.0.80
  228. * Wed Oct 22 2008 Rex Dieter <rdieter@fedoraproject.org> 1.0.0-4
  229. - drop Requires: mysql-server (for now), mention in %%description
  230. * Wed Jul 30 2008 Rex Dieter <rdieter@fedoraproject.org> 1.0.0-3
  231. - Requires: mysql-server
  232. * Wed Jul 30 2008 Rex Dieter <rdieter@fedoraproject.org> 1.0.0-2
  233. - BR: mysql-server
  234. - Requires: qt4-mysql
  235. - cleanup spec
  236. * Wed Jul 23 2008 Than Ngo <than@redhat.com> - 1.0.0-1
  237. - 1.0.0
  238. * Wed Jun 18 2008 Rex Dieter <rdieter@fedoraproject.org> 0.82.0-1
  239. - akonadi-0.82.0
  240. * Tue Jun 3 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.81.0-0.2.20080526svn812787
  241. - BR automoc, drop automoc hack
  242. * Mon May 26 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.81.0-0.1.20080526svn812787
  243. - update to revision 812787 from KDE SVN (to match KDE 4.1 Beta 1)
  244. - restore builtin automoc4 for now
  245. - update file list, require pkgconfig in -devel (.pc file now included)
  246. * Mon May 5 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.80.0-2
  247. - -devel: remove bogus Requires: pkgconfig
  248. * Sat May 3 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.80.0-1
  249. - first Fedora package