cairo-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390
  1. Summary: Cairo - multi-platform 2D graphics library.
  2. Summary(ja): Cairo - マルチプラットフォーム 2D グラフィックスライブラリ
  3. Name: cairo
  4. Version: 1.12.14
  5. Release: 1%{?_dist_release}
  6. License: LGPL/MPL
  7. Group: System Environment/Libraries
  8. Source0: http://cairographics.org/releases/%{name}-%{version}.tar.xz
  9. # don't use serverside gradients, most drivers don't handle those and are
  10. # really slow, should workaround performances issues for ati, nouveau and nvidia
  11. # https://launchpad.net/ubuntu/maverick/+source/cairo/1.10.0-1ubuntu1
  12. Patch1: cairo-1.10.0-dont_use_server_side_gradients.patch
  13. URL: http://cairographics.org/
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: pkgconfig
  16. BuildRequires: pixman-devel
  17. BuildRequires: glib2-devel
  18. BuildRequires: libpng-devel
  19. BuildRequires: freetype2-devel
  20. BuildRequires: fontconfig-devel
  21. BuildRequires: libX11-devel
  22. BuildRequires: libXrender-devel
  23. BuildRequires: gtk-doc
  24. BuildRequires: librsvg2-devel
  25. BuildRequires: mesa-libGL-devel
  26. BuildRequires: mesa-libEGL-devel
  27. BuildConflicts: XOrg-compat70-devel
  28. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  29. %description
  30. Cairo provides anti-aliased vector-based rendering for X. Paths
  31. consist of line segments and cubic splines and can be rendered at any
  32. width with various join and cap styles. All colors may be specified
  33. with optional translucence (opacity/alpha) and combined using the
  34. extended Porter/Duff compositing algebra as found in the X Render
  35. Extension.
  36. Cairo exports a stateful rendering API similar in spirit to the path
  37. construction, text, and painting operators of PostScript, (with the
  38. significant addition of translucence in the imaging model). When
  39. complete, the API is intended to support the complete imaging model of
  40. PDF 1.4.
  41. Cairo relies on the Xc library for backend rendering. Xc provides an
  42. abstract interface for rendering to multiple target types. As of this
  43. writing, Xc allows Cairo to target X drawables as well as generic
  44. image buffers. Future backends such as PostScript, PDF, and perhaps
  45. OpenGL are currently being planned.
  46. %package -n compat32-%{name}
  47. Summary: Cairo - multi-platform 2D graphics library.
  48. Summary(ja): Cairo - マルチプラットフォーム 2D グラフィックスライブラリ
  49. Group: System Environment/Libraries
  50. Requires: %{name} = %{version}
  51. %description -n compat32-%{name}
  52. Cairo provides anti-aliased vector-based rendering for X. Paths
  53. consist of line segments and cubic splines and can be rendered at any
  54. width with various join and cap styles. All colors may be specified
  55. with optional translucence (opacity/alpha) and combined using the
  56. extended Porter/Duff compositing algebra as found in the X Render
  57. Extension.
  58. Cairo exports a stateful rendering API similar in spirit to the path
  59. construction, text, and painting operators of PostScript, (with the
  60. significant addition of translucence in the imaging model). When
  61. complete, the API is intended to support the complete imaging model of
  62. PDF 1.4.
  63. Cairo relies on the Xc library for backend rendering. Xc provides an
  64. abstract interface for rendering to multiple target types. As of this
  65. writing, Xc allows Cairo to target X drawables as well as generic
  66. image buffers. Future backends such as PostScript, PDF, and perhaps
  67. OpenGL are currently being planned.
  68. %package devel
  69. Summary: Development files for Cairo library.
  70. Summary(ja): Cairo ライブラリの開発用ファイル
  71. Group: Development/Libraries
  72. Provides: lib%{name}-devel = %{version}-%{release}
  73. Requires: %{name} = %{version}
  74. Requires: libpng-devel
  75. Requires: freetype2-devel
  76. Requires: fontconfig-devel
  77. Requires: libX11-devel
  78. Requires: libXrender-devel
  79. Requires: pixman-devel
  80. Requires: glib2-devel
  81. Requires: mesa-libEGL-devel
  82. %description devel
  83. Development files for Cairo library.
  84. %package tools
  85. Summary: Development tools for cairo
  86. Group: Development/Tools
  87. %description tools
  88. Cairo is a 2D graphics library designed to provide high-quality display
  89. and print output.
  90. This package contains tools for working with the cairo graphics library.
  91. * cairo-trace: Record cairo library calls for later playback
  92. %prep
  93. %setup -q
  94. %patch1 -p1 -b .dont-use-server-side-gradients
  95. %build
  96. %configure --disable-static \
  97. --enable-gtk-doc \
  98. --enable-xlib \
  99. --enable-freetype \
  100. --enable-ps \
  101. --enable-pdf \
  102. --enable-svg \
  103. --enable-tee \
  104. --enable-gobject \
  105. --enable-gl
  106. %ifarch x86_64
  107. cp libtool libtool.old
  108. ldpath="/lib64 /usr/lib64 /usr/lib /usr/X11R6/lib64 /usr/X11R6/lib"
  109. sed "s|^sys_lib_search_path_spec=.*|sys_lib_search_path_spec=$ldpath|" libtool.old \
  110. > libtool
  111. rm libtool.old
  112. %endif
  113. make
  114. %install
  115. rm -rf $RPM_BUILD_ROOT
  116. %makeinstall
  117. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
  118. %clean
  119. rm -rf $RPM_BUILD_ROOT
  120. %post -p /sbin/ldconfig
  121. %postun -p /sbin/ldconfig
  122. %post -n compat32-%{name} -p /sbin/ldconfig
  123. %postun -n compat32-%{name} -p /sbin/ldconfig
  124. %files
  125. %defattr(644,root,root,755)
  126. %doc AUTHORS BUGS COPYING COPYING-* ChangeLog NEWS README
  127. %{_libdir}/lib*.so.*
  128. %files devel
  129. %defattr(644,root,root,755)
  130. %{_libdir}/lib*.so
  131. #{_libdir}/lib*.la
  132. %{_includedir}/*
  133. %{_libdir}/pkgconfig/*.pc
  134. #{_libdir}/lib*.a
  135. %{_datadir}/gtk-doc/html/cairo
  136. %files tools
  137. %defattr(-,root,root,-)
  138. %{_bindir}/cairo-trace
  139. %{_bindir}/cairo-sphinx
  140. %{_libdir}/cairo
  141. %if %{build_compat32}
  142. %files -n compat32-%{name}
  143. %defattr(644,root,root,755)
  144. %{_libdir}/lib*.so.*
  145. %endif
  146. %changelog
  147. * Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.14-1
  148. - new upstream release
  149. * Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.8-1
  150. - new upstream release
  151. * Fri Nov 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.6-1
  152. - new upstream release
  153. * Sat Oct 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.4-1
  154. - new upstream release
  155. * Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-2
  156. - add Requires: mesa-libEGL-devel
  157. * Sat Jul 21 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.2-1
  158. - new upstream release
  159. - Enable OpenGL backend
  160. - add BR: librsvg2-devel, mesa-libGL-devel, mesa-libEGL-devel
  161. * Sat Mar 31 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
  162. - new upstream release
  163. * Tue Mar 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.2-2
  164. - enable tee support
  165. - add configure options specifically
  166. - disable static library
  167. * Wed Jan 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
  168. - new upstream release
  169. - add BuildRequires: glib2-devel
  170. - add Requires: glib2-devel (devel package)
  171. * Wed Oct 13 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-2
  172. - add patch1 from ubuntu to fix performance regressions
  173. - don't use serverside gradients, most drivers don't handle those and are
  174. really slow, should workaround performances issues for ati, nouveau and nvidia
  175. https://launchpad.net/ubuntu/maverick/+source/cairo/1.10.0-1ubuntu1
  176. * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
  177. - new upstream release
  178. - add tools sub package
  179. * Tue Sep 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.10-3
  180. - add BuildRequires: fontconfig-devel
  181. - add Requires: fontconfig-devel (devel package)
  182. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.8.10-2
  183. - build with rpm-4.8.1-1 for pkg-config file
  184. * Tue Mar 2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.8.10-1
  185. - new upstream release
  186. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.8-1
  187. - new upstream release
  188. * Sat May 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.8.6-2
  189. - applied cairo-1.8.6-status-return-fix.patch from Gentoo Linux
  190. - added BuildRequires: gtk-doc
  191. * Sat Jan 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6-1
  192. - new upstream release
  193. * Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.4-1
  194. - new upstream release
  195. * Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-1
  196. - new upstream release
  197. * Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-1
  198. - new upstream release
  199. * Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.4-1
  200. - new upstream release
  201. * Wed May 28 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.4-3
  202. - add Requires: pixman-devel to -devel
  203. * Sun May 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-2
  204. - rebuilt with xorg-x11 7.3
  205. - spec in UTF-8
  206. * Thu May 1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-1
  207. - new upstream release
  208. - removed lib*.la from devel package
  209. * Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.14-1vl5
  210. - used %%{?_dist_release}
  211. * Thu Feb 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.14-0vl1
  212. - new upstream release
  213. * Sun Dec 9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.12-0vl1
  214. - new upstream release
  215. * Tue Jul 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.10-0vl1
  216. - new upstream release
  217. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.6-0vl1
  218. - new upstream release
  219. - remove BuildRequires: pango-devel, gtk2-devel
  220. (these are only needed for testing)
  221. * Sat Mar 31 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.4.2-0vl1
  222. - upstream release
  223. - Patch30 and Patch40 is skipped (not working correctly)
  224. but held in src.rpm
  225. - add BUGS, ROADMAP to %%doc
  226. - add BuildRequires: pango-devel, gtk2-devel
  227. * Tue Oct 24 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-0vl2
  228. - rebuild without XOrg-compat70-devel
  229. - add BuildConflicts: XOrg-compat70-devel
  230. * Sun Oct 22 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-0vl1
  231. - new upstream release
  232. - remove unneeded Patch20 which breaks 8bpp rendering (<BTS:297>)
  233. * Tue Sep 19 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.2-0vl3
  234. - added Patch40 for 15bpp problem
  235. * Tue Sep 5 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.2-0vl2
  236. - added ad-hoc Patch30 for 16bpp problem
  237. * Thu Aug 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-0vl1
  238. - new upstream release
  239. * Sat Aug 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl1
  240. - new upstream release
  241. * Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-0vl1
  242. - new upstream release
  243. * Sat May 20 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.2-0vl4
  244. - added compat32- package for x86_64 architecture support
  245. * Sun Mar 05 2006 Shu KONNO <owa@bg.wakwak.com> 1.0.2-0vl3
  246. - added x86_64 architecture support
  247. * Sat Dec 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl2
  248. - add Patch20 to fix broken desktop rendering on xorg-x11-6.9
  249. - add X.Org 6.9.0 (6090000) to blacklist
  250. * Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl1
  251. - new upstream release
  252. * Tue Oct 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl5
  253. - update Patch10
  254. * Sun Oct 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl4
  255. - add Patch10 to use embedded bitmap font if available.
  256. (controllable by "embeddedbitmap" in fontconfig)
  257. * Thu Sep 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl3
  258. - rebuild with new fontconfig
  259. * Sun Sep 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl2
  260. - add Requires: libpng-devel, XOrg-devel, freetype2-devel
  261. to devel package instead of BuildRequires (typo)
  262. - add Japanese summaries
  263. * Sun Aug 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl1
  264. - new upstream release
  265. - remove libpixman dependency (which is now included in cairo)
  266. - obsoletes libpixman <= 0.1.6
  267. - add more BuildRequires
  268. * Sat Aug 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.2-0vl1
  269. - new upstream version
  270. * Sun Jul 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.1-0vl1
  271. - new upstream version
  272. - fixed License (http://cairographics.org/introduction)
  273. * Sun Mar 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.0-0vl1
  274. - new upstream version
  275. - include gtk-doc files
  276. * Sun Jan 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.0-0vl1
  277. - new upstream version
  278. - add Requires: libpixman
  279. * Mon Nov 01 2004 Satoshi MACHINO <machino@vinelinux.org> 0.2.0-0vl1
  280. - new upstream version (cairo-0.2.0)
  281. * Mon Oct 11 2004 Satoshi MACHINO <machino@vinelinux.org> 0.1.23-1vl1
  282. - rebuilt for VineLinux
  283. * Tue Jun 01 2004 Marcel Pol <mpol@mandrake.org> 0.1.23-1mdk
  284. - 0.1.23
  285. - reenable libtoolize
  286. * Wed May 5 2004 G魚Waschk <waschk@linux-mandrake.com> 0.1.22-1mdk
  287. - fix devel provides
  288. - drop redundant buildrequires
  289. - requires new pixman
  290. - autoconf 2.5 macro
  291. - New release 0.1.22
  292. * Fri Feb 06 2004 Marcel Pol <mpol@mandrake.org> 0.1.17-2mdk
  293. - build with X11
  294. * Sun Feb 01 2004 Marcel Pol <mpol@mandrake.org> 0.1.17-1mdk
  295. - 0.1.17
  296. - provides cairo
  297. - drop patch, use --disable-xlib
  298. - buildrequires
  299. - don't run libtoolize
  300. * Sun Dec 14 2003 Marcel Pol <mpol@mandrake.org> 0.1.13-1mdk
  301. - initial mandrake package