gdb-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438
  1. Summary: A GNU source-level debugger for C, C++ and other languages.
  2. Summary(ja): C, C++ その他の言語用 GNU ソースレベルデバッガ
  3. Name: gdb
  4. Version: 8.2.1
  5. Release: 1%{?_dist_release}
  6. License: GPL
  7. Group: Development/Debuggers
  8. Source: ftp://sources.redhat.com/pub/gdb/releases/gdb-%{version}.tar.xz
  9. Buildroot: %{_tmppath}/%{name}-%{version}-root
  10. URL: http://sources.redhat.com/gdb/
  11. BuildRequires: ncurses-devel glibc-devel gcc make gzip texinfo expat-devel
  12. BuildRequires: python3-devel python3-rpm-macros
  13. BuildRequires: zlib-devel
  14. Requires: install-info
  15. Vendor: Project Vine
  16. Distribution: Vine Linux
  17. %description
  18. GDB, the GNU debugger, allows you to debug programs written in C, C++,
  19. and other languages, by executing them in a controlled fashion and
  20. printing their data.
  21. %description -l ja
  22. GDB (GNU デバッガ) は C, C++ その他の言語で書かれたプログラムのデバッグに
  23. 使うツールです.プログラムの実行を制御し,データを出力することができます.
  24. %prep
  25. %setup -q
  26. %build
  27. export CFLAGS="$RPM_OPT_FLAGS"
  28. rm -fr dejagnu tcl expect
  29. ./configure \
  30. --prefix=%{_prefix} \
  31. --sysconfdir=%{_sysconfdir} \
  32. --mandir=%{_mandir} \
  33. --infodir=%{_infodir} \
  34. --with-python=%{__python3} \
  35. %{_target_platform}
  36. make %{?_smp_mflags}
  37. make %{?_smp_mflags} info
  38. cp gdb/NEWS .
  39. %install
  40. rm -rf $RPM_BUILD_ROOT
  41. %makeinstall infodir=$RPM_BUILD_ROOT%{_infodir} prefix=$RPM_BUILD_ROOT%{_prefix}
  42. # The above is broken, do this for now:
  43. #mkdir -p $RPM_BUILD_ROOT/%{_infodir}
  44. #cp `find -name "*.info*"` $RPM_BUILD_ROOT/%{_infodir}
  45. # These are part of binutils
  46. #rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  47. #rm -f $RPM_BUILD_ROOT%{_infodir}/dir.info*
  48. rm -f $RPM_BUILD_ROOT%{_infodir}/bfd*
  49. rm -f $RPM_BUILD_ROOT%{_infodir}/configure*
  50. rm -f $RPM_BUILD_ROOT%{_infodir}/standard*
  51. rm -r $RPM_BUILD_ROOT%{_libdir}/lib{bfd*,opcodes*}
  52. rm -f $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd.mo,opcodes.mo}
  53. rm -rf $RPM_BUILD_ROOT%{_includedir}
  54. %clean
  55. rm -rf $RPM_BUILD_ROOT
  56. %post
  57. [ -f %{_infodir}/annotate.info ] && /sbin/install-info %{_infodir}/annotate.info %{_infodir}/dir || :
  58. [ -f %{_infodir}/annotate.info.gz ] && /sbin/install-info %{_infodir}/annotate.info.gz %{_infodir}/dir || :
  59. [ -f %{_infodir}/gdb.info ] && /sbin/install-info %{_infodir}/gdb.info %{_infodir}/dir || :
  60. [ -f %{_infodir}/gdb.info.gz ] && /sbin/install-info %{_infodir}/gdb.info.gz %{_infodir}/dir || :
  61. [ -f %{_infodir}/stabs.info ] && /sbin/install-info %{_infodir}/stabs.info %{_infodir}/dir || :
  62. [ -f %{_infodir}/stabs.info.gz ] && /sbin/install-info %{_infodir}/stabs.info.gz %{_infodir}/dir || :
  63. %preun
  64. if [ $1 = 0 ]; then
  65. [ -f %{_infodir}/annotate.info ] && /sbin/install-info --delete %{_infodir}/annotate.info %{_infodir}/dir || :
  66. [ -f %{_infodir}/annotate.info.gz ] && /sbin/install-info --delete %{_infodir}/annotate.info.gz %{_infodir}/dir || :
  67. [ -f %{_infodir}/gdb.info ] && /sbin/install-info --delete %{_infodir}/gdb.info %{_infodir}/dir || :
  68. [ -f %{_infodir}/gdb.info.gz ] && /sbin/install-info --delete %{_infodir}/gdb.info.gz %{_infodir}/dir || :
  69. [ -f %{_infodir}/gdbint.info ] && /sbin/install-info --delete %{_infodir}/gdbint.info %{_infodir}/dir || :
  70. [ -f %{_infodir}/gdbint.info.gz ] && /sbin/install-info --delete %{_infodir}/gdbint.info.gz %{_infodir}/dir || :
  71. [ -f %{_infodir}/stabs.info ] && /sbin/install-info --delete %{_infodir}/stabs.info %{_infodir}/dir || :
  72. [ -f %{_infodir}/stabs.info.gz ] && /sbin/install-info --delete %{_infodir}/stabs.info.gz %{_infodir}/dir || :
  73. fi
  74. %files
  75. %defattr(-,root,root)
  76. %license COPYING COPYING.LIB
  77. %doc README NEWS
  78. %{_bindir}/*
  79. %{_mandir}/*/*
  80. %dir %{_datadir}/gdb
  81. %{_datadir}/gdb/syscalls
  82. %dir %{_datadir}/gdb/python
  83. %{_datadir}/gdb/python/gdb
  84. %dir %{_datadir}/gdb/system-gdbinit
  85. %{_datadir}/gdb/system-gdbinit/elinos.py
  86. %{_datadir}/gdb/system-gdbinit/wrs-linux.py
  87. %{_infodir}/annotate.info*
  88. %{_infodir}/gdb.info*
  89. %{_infodir}/stabs.info*
  90. %exclude %{_infodir}/dir
  91. %ifarch %{ix86} x86_64
  92. %{_libdir}/libinproctrace.so
  93. %endif
  94. ## don't include the files in include, they are part of binutils
  95. #%{_includedir}/*
  96. #%{_infodir}/bfd.info*
  97. #%{_infodir}/configure.info*
  98. #%{_infodir}/standard.info*
  99. #%{_libdir}/*
  100. #%{_datadir}/locale/*/LC_MESSAGES/bfd.mo
  101. #%{_datadir}/locale/*/LC_MESSAGES/opcode.mo
  102. %changelog
  103. * Wed Jan 23 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.2.1-1
  104. - new upstream release.
  105. * Fri Jul 22 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.11.1-1
  106. - new upstream release
  107. * Sun Apr 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.11-1
  108. - new upstream release
  109. * Sun Oct 11 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.10-1
  110. - new upstream release
  111. * Mon Jul 06 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.9.1-1
  112. - new upstream release
  113. * Sun Feb 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.9-1
  114. - new upstream release
  115. * Sun Dec 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.8.1-1
  116. - new upstream release
  117. * Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.8-1
  118. - new upstream release
  119. * Sun Nov 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6.1-1
  120. - new upstream release
  121. * Mon Oct 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-1
  122. - new upstream release
  123. * Tue May 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.4.1-1
  124. - new upstream release
  125. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.4-1
  126. - new upstream release
  127. * Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.2-2
  128. - add BuildRequires: python-devel, zlib-devel
  129. - fix %%files
  130. * Thu Apr 28 2011 Shu KONNO <owa@bg.wakwak.com> 7.2-1
  131. - updated gdb to 7.2
  132. * Wed Feb 17 2010 Shu KONNO <owa@bg.wakwak.com> 7.0.1-1
  133. - updated gdb to 7.0.1
  134. - rebuilt with new environment
  135. * Sat Sep 13 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-1vl5
  136. - applied new versioning policy, spec in utf-8
  137. * Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.7.1-0vl4
  138. - rebuild with expat-2.0.1
  139. - add BuildRequires: expat-devel
  140. * Sun Jan 27 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl3
  141. - dropt %%{_localedir}/*/LC_MESSAGES/*.mo conflicts with binutils
  142. * Fri Jan 04 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl2
  143. - dropt %%{_libdir}/lib{bfd*,iberty*,opcodes*} conflicts with binutils-devel
  144. * Mon Dec 31 2007 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl1
  145. - new upstream release
  146. * Wed Jul 12 2006 Shu KONNO <owa@bg.wakwak.com> 6.4.90-0vl1
  147. - new upstream release
  148. * Sat Dec 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0-0vl1
  149. - new upstream release
  150. * Thu Nov 28 2002 KAZUKI SHIMURA <rito@pos.to> 5.2.1-4vl2
  151. - Oops, spec was written in Shift-JIS. Fixed.
  152. * Mon Nov 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.2.1-4vl1
  153. - based on 5.2.1-4 from Rawhide and built for Vine Linux
  154. * Fri Aug 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
  155. - added mainframe patch from developerworks
  156. * Wed Aug 21 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-3
  157. - Add changelogs to the previous patch
  158. * Wed Aug 14 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-2
  159. - Add some patches from Elena Zannoni <ezannoni@redhat.com>
  160. * Tue Jul 23 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-1
  161. - 5.2.1
  162. * Mon Jul 22 2002 Florian La Roche <Florian.LaRoche@redhat.de>
  163. - compile on mainframe
  164. * Mon Jul 8 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-3
  165. - Rebuild
  166. * Tue May 7 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-2
  167. - Rebuild
  168. * Mon Apr 29 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-1
  169. - 5.2
  170. * Mon Apr 29 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.92-1
  171. - 5.1.92. Hopefully identical to 5.2 final
  172. * Mon Apr 22 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.91-1
  173. - 5.1.91. 5.2 expected in a week
  174. * Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-5
  175. - Update to current
  176. * Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-4
  177. - Update to current
  178. * Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-3
  179. - Update to current
  180. * Wed Mar 20 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-2
  181. - Update to current
  182. * Wed Mar 13 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-1
  183. - Update to current 5.2 branch
  184. * Thu Jan 24 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.1-1
  185. - 5.1.1
  186. - add URL
  187. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  188. - automated rebuild
  189. * Mon Dec 10 2001 Trond Eivind Glomsr <teg@redhat.com> 5.1-2
  190. - Fix some thread+fpu problems
  191. * Mon Nov 26 2001 Trond Eivind Glomsr <teg@redhat.com> 5.1-1
  192. - 5.1
  193. * Mon Nov 19 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.94-0.71
  194. - 5.0.94. Almost there....
  195. * Mon Nov 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.93-2
  196. - Add patch from jakub@redhat.com to improve handling of DWARF
  197. * Mon Nov 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.93-1
  198. - 5.0.93
  199. - handle missing info pages in post/pre scripts
  200. * Wed Oct 31 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.92-1
  201. - 5.0.92
  202. * Fri Oct 26 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.91rh-1
  203. - New snapshot
  204. - Use the 5.0.91 versioning from the snapshot
  205. * Wed Oct 17 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-17
  206. - New snapshot
  207. * Thu Sep 27 2001 Trond Eivind Glomsr <teg@redhat.com>
  208. - New snapshot
  209. * Wed Sep 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-16
  210. - New snapshot
  211. * Mon Aug 13 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-15
  212. - Don't buildrequire compat-glibc (#51690)
  213. * Thu Aug 9 2001 Trond Eivind Glomsr <teg@redhat.com>
  214. - New snapshot, from the stable branch eventually leading to gdb 5.1
  215. * Mon Jul 30 2001 Trond Eivind Glomsr <teg@redhat.com>
  216. - s/Copyright/License/
  217. - Add texinfo to BuildRequires
  218. * Mon Jun 25 2001 Trond Eivind Glomsr <teg@redhat.com>
  219. - New snapshot
  220. * Fri Jun 15 2001 Trond Eivind Glomsr <teg@redhat.com>
  221. - New snapshot
  222. - Add ncurses-devel to buildprereq
  223. - Remove perl from buildprereq, as gdb changed the way
  224. version strings are generated
  225. * Thu Jun 14 2001 Trond Eivind Glomsr <teg@redhat.com>
  226. - New snapshot
  227. * Wed May 16 2001 Trond Eivind Glomsr <teg@redhat.com>
  228. - New snapshot - this had thread fixes for curing #39070
  229. - New way of specifying version
  230. * Tue May 1 2001 Trond Eivind Glomsr <teg@redhat.com>
  231. - New tarball
  232. - Kevin's patch is now part of gdb
  233. * Mon Apr 9 2001 Trond Eivind Glomsr <teg@redhat.com>
  234. - Add patch from kevinb@redhat.com to fix floating point + thread
  235. problem (#24310)
  236. - remove old workarounds
  237. - new snapshot
  238. * Thu Apr 5 2001 Trond Eivind Glomsr <teg@redhat.com>
  239. - New snapshot
  240. * Sat Mar 17 2001 Bill Nottingham <notting@redhat.com>
  241. - on ia64, there are no old headers :)
  242. * Fri Mar 16 2001 Trond Eivind Glomsr <teg@redhat.com>
  243. - build with old headers, new compiler
  244. * Fri Mar 16 2001 Trond Eivind Glomsr <teg@redhat.com>
  245. - new snapshot
  246. * Mon Feb 26 2001 Trond Eivind Glomsr <teg@redhat.com>
  247. - new snapshot which should fix some more IA64 problems (#29151)
  248. - remove IA64 patch, it's now integrated
  249. * Wed Feb 21 2001 Trond Eivind Glomsr <teg@redhat.com>
  250. - add IA64 and Alpha patches from Kevin Buettner <kevinb@redhat.com>
  251. - use perl instead of patch for fixing the version string
  252. * Tue Feb 20 2001 Trond Eivind Glomsr <teg@redhat.com>
  253. - don't use kgcc anymore
  254. - mark it as our own version
  255. - new snapshot
  256. * Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  257. - Link with ncurses 5.x even though we're using kgcc.
  258. No need to drag in requirements on ncurses4 (Bug #24445)
  259. * Fri Jan 19 2001 Trond Eivind Glomsr <teg@redhat.com>
  260. - new snapshot
  261. * Wed Dec 20 2000 Trond Eivind Glomsr <teg@redhat.com>
  262. - new snapshot
  263. * Mon Dec 04 2000 Trond Eivind Glomsr <teg@redhat.com>
  264. - new snapshot
  265. - new alpha patch - it now compiles everywhere. Finally.
  266. * Fri Dec 01 2000 Trond Eivind Glomsr <teg@redhat.com>
  267. - new snapshot
  268. * Mon Nov 20 2000 Trond Eivind Glomsr <teg@redhat.com>
  269. - new CVS snapshot
  270. - disable the patches
  271. - don't use %%configure, as it confuses the autoconf script
  272. - enable SPARC, disable Alpha
  273. * Wed Aug 09 2000 Trond Eivind Glomsr <teg@redhat.com>
  274. - added patch from GDB team for C++ symbol handling
  275. * Tue Jul 25 2000 Trond Eivind Glomsr <teg@redhat.com>
  276. - upgrade to CVS snapshot
  277. - excludearch SPARC, build on IA61
  278. * Wed Jul 19 2000 Trond Eivind Glomsr <teg@redhat.com>
  279. - rebuild
  280. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  281. - automatic rebuild
  282. * Sun Jul 02 2000 Trond Eivind Glomsr <teg@redhat.com>
  283. - rebuild
  284. * Thu Jun 08 2000 Trond Eivind Glomsr <teg@redhat.com>
  285. - use %%configure, %%makeinstall, %%{_infodir}, %%{_mandir},
  286. and %%{_tmppath}
  287. - the install scripts for info are broken(they don't care about
  288. you specify in the installstep), work around that.
  289. - don't build for IA64
  290. * Mon May 22 2000 Trond Eivind Glomsr <teg@redhat.com>
  291. - upgraded to 5.0 - dump all patches. Reapply later if needed.
  292. - added the NEWS file to the %%doc files
  293. - don't delete files which doesn't get installed (readline, texinfo)
  294. - let build system handle stripping and gzipping
  295. - don't delete libmmalloc
  296. - apply patch from jakub@redhat.com to make it build on SPARC
  297. * Fri Apr 28 2000 Matt Wilson <msw@redhat.com>
  298. - rebuilt against new ncurses
  299. * Tue Mar 7 2000 Jeff Johnson <jbj@redhat.com>
  300. - rebuild for sparc baud rates > 38400.
  301. * Tue Feb 8 2000 Jakub Jelinek <jakub@redhat.com>
  302. - fix core file handling on i386 with glibc 2.1.3 headers
  303. * Fri Jan 14 2000 Jakub Jelinek <jakub@redhat.com>
  304. - fix reading registers from core on sparc.
  305. - hack around build problems on i386 with glibc 2.1.3 headers
  306. * Thu Oct 7 1999 Jim Kingdon
  307. - List files to install in /usr/info specifically (so we don't pick up
  308. things like info.info from GDB snapshots).
  309. * Thu Oct 7 1999 Jim Kingdon
  310. - Update GDB to 19991004 snapshot. This eliminates the need for the
  311. sigtramp, sparc, xref, and threads patches. Update sparcmin patch.
  312. * Mon Aug 23 1999 Jim Kingdon
  313. - Omit readline manpage.
  314. * Sat Aug 7 1999 Jim Kingdon
  315. - Remove H.J. Lu's patches (they had been commented out).
  316. - Add sigtramp patch (from gdb.cygnus.com) and threads patch (adapted
  317. from code fusion CD-ROM).
  318. * Wed Apr 14 1999 Jeff Johnson <jbj@redhat.com>
  319. - merge H.J. Lu's patches into 4.18.
  320. * Mon Apr 05 1999 Cristian Gafton <gafton@redhat.com>
  321. - updated the kern22 patch with stuff from davem
  322. * Thu Apr 1 1999 Jeff Johnson <jbj@redhat.com>
  323. - sparc with 2.2 kernels no longer uses sunos ptrace (davem)
  324. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  325. - auto rebuild in the new build environment (release 3)
  326. * Mon Mar 8 1999 Jeff Johnson <jbj@redhat.com>
  327. - Sparc fiddles for Red Hat 6.0.