graphviz-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424
  1. %define _unpackaged_files_terminate_build 1
  2. Summary: Graph Visualization Tools
  3. Summary(ja): グラフ可視化ツール
  4. Name: graphviz
  5. Version: 2.49.3
  6. Release: 2%{?_dist_release}
  7. Group: graphics
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. Packager: daisuke
  11. License: EPL
  12. URL: https://www.graphviz.org/
  13. Source0: https://gitlab.com/graphviz/graphviz/-/archive/%{version}/%{name}-%{version}.tar.bz2
  14. BuildRequires: bison
  15. BuildRequires: cairo-devel
  16. BuildRequires: expat-devel
  17. BuildRequires: flex
  18. BuildRequires: fontconfig-devel
  19. BuildRequires: freetype2-devel
  20. BuildRequires: gd-devel
  21. BuildRequires: ghostscript
  22. BuildRequires: gmp-devel
  23. BuildRequires: gtk2-devel
  24. BuildRequires: guile-devel
  25. BuildRequires: libjpeg-turbo-devel
  26. BuildRequires: libpng-devel
  27. BuildRequires: libSM-devel
  28. BuildRequires: libtool-ltdl-devel >= 2.2.6a
  29. BuildRequires: libXaw-devel
  30. BuildRequires: libXext-devel
  31. BuildRequires: librsvg2-devel
  32. BuildRequires: lua-devel
  33. BuildRequires: m4
  34. BuildRequires: perl
  35. BuildRequires: python3-devel
  36. BuildRequires: python3-rpm-macros
  37. BuildRequires: python3-setuptools
  38. BuildRequires: ruby-devel
  39. BuildRequires: swig
  40. BuildRequires: tcl-devel >= 8.4
  41. BuildRequires: tk-devel >= 8.4
  42. BuildRequires: zlib-devel
  43. Requires: urw-fonts
  44. # only for this release
  45. # BuildConflicts: graphviz-devel
  46. %description
  47. A collection of tools and tcl packages for the manipulation and layout
  48. of graphs (as in nodes and edges, not as in barcharts).
  49. %package devel
  50. Summary: Development tools for version %{version} of %{name}
  51. Group: programming
  52. Requires: %{name} = %{version}
  53. %description devel
  54. The %{name}-devel package contains the header files
  55. and man3 pages necessary for developing programs
  56. using version %{version} of the %{name} libraries.
  57. %package doc
  58. Summary: PDF and HTML documents for graphviz
  59. Group: documentation
  60. %description doc
  61. Provides some additional PDF and HTML documentation for graphviz.
  62. %package guile
  63. Summary: Guile extension for graphviz
  64. Group: programming
  65. Requires: %{name} = %{version}-%{release}, guile
  66. %description guile
  67. Guile extension for graphviz.
  68. %package lua
  69. Summary: Lua extension for graphviz
  70. Group: programming
  71. Requires: %{name} = %{version}-%{release}, lua
  72. %description lua
  73. Lua extension for graphviz.
  74. %package perl
  75. Summary: Perl extension for graphviz
  76. Group: programming
  77. Requires: %{name} = %{version}-%{release}
  78. Requires: perl >= 2:5.34.0
  79. %description perl
  80. Perl extension for graphviz.
  81. %package -n python3-graphviz
  82. Summary: Python3 extension for graphviz
  83. Group: programming
  84. Requires: %{name} = %{version}-%{release}
  85. Requires: python3
  86. Obsoletes: graphviz-python3 < 2.49.0
  87. Provides: graphviz-python3 = %{version}-%{release}
  88. %description -n python3-graphviz
  89. Python3 extension for graphviz.
  90. %package ruby
  91. Summary: Ruby extension for graphviz
  92. Group: programming
  93. Requires: %{name} = %{version}-%{release}
  94. Requires: ruby
  95. %description ruby
  96. Ruby extension for graphviz.
  97. %package tcl
  98. Summary: Tcl extension & tools for graphviz
  99. Group: programming
  100. Requires: tcl >= 8.4, tk >= 8.4
  101. Requires: %{name} = %{version}
  102. %description tcl
  103. Various tcl packages (extensions) for the graphviz tools.
  104. %debug_package
  105. %prep
  106. %setup -q -n graphviz-%{version}
  107. # Attempt to fix rpmlint warnings about executable sources
  108. find -type f -regex '.*\.\(c\|h\)$' -exec chmod a-x {} ';'
  109. %build
  110. ./autogen.sh
  111. # using archdir instead of sitearchdir for Vine
  112. sed -i -e "s|sitearchdir|archdir|g" config/config_ruby.rb
  113. # Rewrite config_ruby.rb to work with Ruby 2.1
  114. sed -i 's|expand(|expand(RbConfig::|' config/config_ruby.rb
  115. sed -i 's|sitearchdir|vendorarchdir|' config/config_ruby.rb
  116. # get the path to search for ruby/config.h to CPPFLAGS, so that configure can find it
  117. export CPPFLAGS=-I`ruby -e "puts File.join(RbConfig::CONFIG['includedir'], RbConfig::CONFIG['sitearch'])" || echo /dev/null`
  118. # XXX ix86 only used to have -ffast-math, let's use everywhere
  119. %{expand: %%define optflags %{optflags} -ffast-math}
  120. %configure \
  121. --with-x \
  122. --disable-static \
  123. --with-mylibgd \
  124. --with-ipsepcola \
  125. --with-pangocairo \
  126. --with-gdk-pixbuf \
  127. --without-mylibgd \
  128. --without-ming \
  129. --without-qt \
  130. --disable-sharp \
  131. --enable-guile \
  132. --disable-java \
  133. --enable-lua \
  134. --disable-ocaml \
  135. --enable-perl \
  136. --disable-php \
  137. --enable-python3 \
  138. --disable-r \
  139. --enable-ruby \
  140. --enable-swig \
  141. --enable-tcl \
  142. --with-visio
  143. make %{?_smp_mflags}
  144. %install
  145. rm -rf $RPM_BUILD_ROOT __doc
  146. make DESTDIR=$RPM_BUILD_ROOT \
  147. docdir=$RPM_BUILD_ROOT%{_docdir}/%{name} \
  148. pkgconfigdir=%{_libdir}/pkgconfig \
  149. install
  150. find ${RPM_BUILD_ROOT} -type f -name "*.la" -exec rm -f {} ';'
  151. chmod -x $RPM_BUILD_ROOT%{_datadir}/%{name}/lefty/*
  152. cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/doc __doc
  153. rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/doc
  154. rm -rf %{buildroot}%{_libdir}/graphviz/python2
  155. %clean
  156. rm -rf $RPM_BUILD_ROOT
  157. # run "dot -c" to generate plugin config in %{_libdir}/%{name}/config
  158. %post
  159. /sbin/ldconfig
  160. %{_bindir}/dot -c
  161. # if there is no dot after everything else is done, then remove config
  162. %postun
  163. if [ $1 -eq 0 ]; then
  164. rm -f %{_libdir}/graphviz/config || :
  165. fi
  166. %files
  167. %defattr(-,root,root)
  168. %license COPYING
  169. %doc AUTHORS ChangeLog NEWS README
  170. %{_bindir}/*
  171. %dir %{_datadir}/%{name}
  172. %{_datadir}/%{name}/gvpr
  173. %{_datadir}/%{name}/lefty
  174. %{_mandir}/man1/*
  175. %{_mandir}/man7/*
  176. %dir %{_libdir}/%{name}
  177. %{_libdir}/*.so.*
  178. %{_libdir}/%{name}/*.so.*
  179. %exclude %{_libdir}/graphviz/*/*
  180. %files devel
  181. %defattr(-,root,root)
  182. %{_includedir}/%{name}
  183. %{_libdir}/*.so
  184. %{_libdir}/%{name}/*.so
  185. %{_libdir}/pkgconfig/*.pc
  186. %{_datadir}/%{name}/graphs
  187. %{_mandir}/man3/*.3.gz
  188. %files doc
  189. %defattr(-,root,root,-)
  190. %doc __doc/*
  191. %files guile
  192. %defattr(-,root,root,-)
  193. %{_libdir}/graphviz/guile/
  194. %{_mandir}/man3/gv.3guile*
  195. %files lua
  196. %defattr(-,root,root,-)
  197. %{_libdir}/graphviz/lua/
  198. %{_libdir}/lua*/*
  199. %{_mandir}/man3/gv.3lua*
  200. %files perl
  201. %defattr(-,root,root,-)
  202. %{_libdir}/graphviz/perl/
  203. %{perl_vendorarch}/*
  204. %{_mandir}/man3/gv.3perl*
  205. %files -n python3-graphviz
  206. %defattr(-,root,root,-)
  207. %{_libdir}/graphviz/python3/
  208. %{_libdir}/python3*/*
  209. %{_mandir}/man3/gv.3python*
  210. %files ruby
  211. %defattr(-,root,root,-)
  212. %{_libdir}/graphviz/ruby/
  213. %{_libdir}/*ruby*/*
  214. %{_mandir}/man3/gv.3ruby*
  215. %files tcl
  216. %defattr(-,root,root)
  217. %{_libdir}/%{name}/tcl/*
  218. %{_libdir}/tcl*/*
  219. %{_datadir}/%{name}/demo
  220. # hack to include gv.3tcl only if available
  221. # always includes tcldot.3tcl, gdtclft.3tcl
  222. %{_mandir}/man3/*.3tcl*
  223. %changelog
  224. * Mon Nov 22 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.49.3-2
  225. - rebuilt with perl-5.34.0.
  226. * Mon Nov 15 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.49.3-1
  227. - new upstream release.
  228. - built with ruby-3.0.2.
  229. * Wed May 12 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.47.1-1
  230. - new upstream release.
  231. * Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.44.1-1
  232. - new upstream release.
  233. * Mon Mar 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.42.2-1
  234. - built with ruby-2.6.5.
  235. - added python3 support.
  236. - dropped Patch0.
  237. - imported Patch0-2 from rawhide.
  238. * Tue Sep 10 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.40.1-2
  239. - rebuilt with guile-2.2.
  240. * Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.40.1-1
  241. - updated to 2.40.1.
  242. - dropped all patches.
  243. - imported Patch0 from rawhide.
  244. * Wed Jun 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.38.0-4
  245. - rebuild with gcc-5.4.0
  246. * Sat Sep 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.38.0-3
  247. - rebuild with ruby-2.2.3
  248. * Sun Mar 15 2015 Ryoichi INAGAKI <ryo1@toki.waaseda.jp> 2.38.0-2
  249. - added Patch0-5 from Fedora
  250. - rebuilt with guile 2.0.11
  251. - changed BR: tcl-devel, tk-devel instead of tcl, tk
  252. - added lua subpackage
  253. * Sat Jun 28 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 2.38.0-1
  254. - update to 2.38.0
  255. * Wed Jan 15 2014 NAKAMURA Kenta <kenta@vinelinux.org> 2.36.0-1
  256. - new upstream release
  257. * Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.30.1-2
  258. - rebuilt with gd-2.1.0.
  259. * Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
  260. - new upstream release
  261. * Mon Jan 7 2013 IWAI, Masaharu <iwai@alib.jp> 2.28.0-3
  262. - build with Tcl/Tk 8.5.7-1
  263. - stop running autoreconf
  264. - add Vendor and Distribution tags
  265. * Sun Nov 11 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-2
  266. - re-enable ruby binding, which is accidentally disabled in 2.28.0-1
  267. - rewrite config_ruby.rb to build with ruby-1.9.3
  268. - add search path for ruby/config.h to CPPFLAGS for configure
  269. * Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
  270. - new upstream release
  271. - remove Patch10 (graphviz-2.26.3_dont_regard_tiger_as_the_only_ppc.patch)
  272. - add BuildRequires: librsvg2-devel
  273. * Sun Oct 10 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.26.3-2
  274. - add Patch10 to avoid build failure on ppc
  275. * Sat Oct 9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.3-1
  276. - new upstream release
  277. - built with rpm-4.8.1
  278. - split doc, guile, perl, python, ruby subpackage
  279. * Thu Apr 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-3
  280. - rebuild with libtool-2.2.6a
  281. * Sun Nov 09 2008 Shu KONNO <owa@bg.wakwak.com> 2.20.3-1
  282. - new upstream release
  283. * Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-2
  284. - rebuild with libXaw.so.7 (libXaw-1.0.5)
  285. * Wed Jul 16 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.20.2-1
  286. - new upstream release
  287. * Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.16.1-0vl1
  288. - new upstream release
  289. - build with expat-2.0.1
  290. - add man7
  291. * Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 2.12-0vl2
  292. - rebuild with tcl/tk-8.4.16
  293. * Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.12-0vl1
  294. - new upstream release
  295. - add BuildPrereq: swig
  296. - delete BuildPrereq: gd-progs gd-devel
  297. - add --with-mylibgd and --disable-FEATURE to configure option
  298. - update %%files
  299. * Sun Jul 30 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.6-0vl2
  300. - added BuildPrereq: ruby-devel
  301. * Tue Oct 11 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6-0vl1
  302. - new upstream release
  303. - add BuildPrereq: libtool-ltdl-devel
  304. - move pkgconfig files to %%{_libdir}/pkgconfig
  305. - add --disable-rpath --disable-static to configure option
  306. - add %%post to every package
  307. * Mon Jan 24 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2-0vl1
  308. - new upstream release
  309. - BuildPrereq: tcl >= 8.4, tk >= 8.4
  310. - add BuildPrereq: gd-progs gd-devel flex bison pkgconfig
  311. - update %%files
  312. - remove lines about Vine2.6
  313. - change License to CPL
  314. * Sun May 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.12-0vl1
  315. - source upgrade
  316. - remove patch0 and commented lines
  317. * Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.10-0vl2
  318. - build for VineSeed
  319. * Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.10-0vl1
  320. - source upgrade
  321. - change spec to build both VineSeed and Vine2.5/2.6
  322. - add BuildPrereq: expat-devel and Requires: libexpat
  323. - add patch0 to build against freetype2-2.1.7
  324. - stop using autogen.sh script
  325. - add BuildPrereq: tcl >= 8.3 tk >= 8.3 (VineSeed)
  326. - add graphviz-tcl package (VineSeed)
  327. * Thu Aug 7 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.9-0vl2
  328. - rebuild for new Vine
  329. * Wed Mar 05 2003 Kunio Murasawa <murasawa@fa2.so-net.ne.jp> 1.9-0vl1
  330. - import from offical site (src.rpm)