foomatic-vl.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591
  1. %define enginever 4.0.13
  2. Summary: Foomatic printer database.
  3. Name: foomatic
  4. Version: %{enginever}
  5. Release: 2%{?_dist_release}
  6. Group: system
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. Packager: tomop, daisuke, machino
  10. License: GPL
  11. URL: https://openprinting.github.io/
  12. Source0: http://www.linuxprinting.org/download/foomatic/foomatic-db-engine-%{enginever}.tar.gz
  13. Patch101: foomatic-manpages.patch
  14. # backported from upstream https://github.com/OpenPrinting/foomatic-db-engine/commit/75de02d
  15. Patch102: 0001-Recognize-fractional-numbers-in-PageSize.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  17. Requires: cups-filters
  18. Requires: dbus
  19. Requires: foomatic-db
  20. Requires: hplip
  21. Requires: perl >= 2:5.34.0
  22. # For 'rm' in post
  23. Requires: fileutils
  24. BuildRequires: cups
  25. BuildRequires: perl >= 2:5.34.0
  26. BuildRequires: libxml2-devel
  27. BuildRequires: autoconf, automake
  28. BuildRequires: mpage
  29. BuildRequires: dbus-devel
  30. Provides: perl(Foomatic::GrovePath)
  31. # For 'rm' and '/sbin/service' in post
  32. Requires(pre): coreutils initscripts
  33. Obsoletes: foomatic-db < 4.0
  34. Obsoletes: foomatic-ppd < 4.0
  35. Obsoletes: foomatic-ppd-gimp-print < 4.0
  36. Obsoletes: foomatic-ppd-gimp-print-ijs < 4.0
  37. Obsoletes: foomatic-ppd-omni < 4.0
  38. # We need ghostscript to have the gimp-print-4.2.0 driver, and hpijs 1.1.
  39. Conflicts: ghostscript < 7.05
  40. %description
  41. Foomatic is a comprehensive, spooler-independent database of printers,
  42. printer drivers, and driver descriptions. It contains utilities to
  43. generate driver description files and printer queues for CUPS, LPD,
  44. LPRng, and PDQ using the database. There is also the possibility to
  45. read the PJL options out of PJL-capable laser printers and take them
  46. into account at the driver description file generation.
  47. There are spooler-independent command line interfaces to manipulate
  48. queues (foomatic-configure) and to print files/manipulate jobs
  49. (foomatic printjob).
  50. The site http://www.linuxprinting.org/ is based on this database.
  51. %debug_package
  52. %prep
  53. %setup -q -n foomatic-db-engine-%{version}
  54. # Ship more manpages.
  55. %patch101 -p1 -b .manpages
  56. # backported from upstream https://github.com/OpenPrinting/foomatic-db-engine/commit/75de02d
  57. %patch102 -p1 -b .pagesize-fract
  58. chmod a+x mkinstalldirs
  59. %build
  60. export LIB_CUPS=%{_libdir}/cups
  61. export CUPS_BACKENDS=%{_libdir}/cups/backend
  62. export CUPS_FILTERS=%{_libdir}/cups/filter
  63. export CUPS_PPDS=%{_datadir}/cups/model
  64. aclocal
  65. autoconf
  66. %configure --disable-xmltest
  67. make PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS"
  68. %install
  69. make DESTDIR=%buildroot PREFIX=%{_prefix} \
  70. INSTALLSITELIB=%{perl_vendorlib} \
  71. INSTALLSITEARCH=%{perl_vendorarch} \
  72. install
  73. # Use relative, not absolute, symlink for CUPS driver.
  74. ln -sf ../../../bin/foomatic-ppdfile %{buildroot}%{_libdir}/cups/driver/foomatic
  75. mkdir -p %{buildroot}%{_var}/cache/foomatic
  76. echo cups > %{buildroot}%{_sysconfdir}/foomatic/defaultspooler
  77. # Remove things we don't ship.
  78. rm -rf \
  79. %{buildroot}%{_libdir}/ppr \
  80. %{buildroot}%{_sysconfdir}/foomatic/filter.conf.sample \
  81. %{buildroot}%{_datadir}/foomatic/templates
  82. #%{buildroot}%%{_libdir}/perl5/site_perl
  83. find %{buildroot} -name .packlist | xargs rm -f
  84. %post
  85. /bin/rm -f /var/cache/foomatic/*
  86. exit 0
  87. %clean
  88. rm -fr %buildroot $RPM_BUILD_DIR/%{name}
  89. %files
  90. %defattr(-,root,root)
  91. %doc ChangeLog COPYING README TODO
  92. %dir %{_sysconfdir}/foomatic
  93. %config(noreplace) %{_sysconfdir}/foomatic/defaultspooler
  94. %{_bindir}/*
  95. %{_sbindir}/*
  96. %{perl_vendorlib}/Foomatic
  97. %{_libdir}/cups/driver/*
  98. %{_datadir}/foomatic
  99. %{_mandir}/*/*
  100. %{_var}/cache/foomatic
  101. %changelog
  102. * Sun Nov 21 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.13-2
  103. - rebuilt with perl-5.34.0.
  104. - imported Patch103 from rawhide.
  105. * Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.13-1
  106. - new upstream release.
  107. - rebuilt with perl-5.26.
  108. * Sun Oct 4 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.12-2
  109. - removed foomatic-filters (moved to cups-filters).
  110. - moved foomatic-db as a standalone package.
  111. * Tue Jun 9 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.12-1
  112. - new upstream release.
  113. * Mon Jun 30 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 4.0.11-2
  114. - rebuild with perl-5.16
  115. - add BR: dbus-devel
  116. * Sun Jun 8 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.11-1
  117. - new upstream release.
  118. * Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.9-1
  119. - new upstream release.
  120. * Mon Jun 06 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-2
  121. - added hplip and coreutils to "Requires:".
  122. - removed hpijs and fileutils from "Requires:".
  123. * Wed Apr 06 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-1
  124. - new upstream release.
  125. - dropped Source3 (no longer provided by upstream).
  126. - updated Patch2.
  127. * Thu Mar 24 2011 IWAI, Masaharu <iwai@alib.jp> 4.0.1-3
  128. - rebuild with perl 5.12.3
  129. * Fri Jul 24 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 4.0.1-2
  130. - add Requires: hpijs
  131. * Fri May 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-1
  132. - new upstream release
  133. * Sun Mar 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.0-1
  134. - new upstream release.
  135. - applied some patches from Fedora development.
  136. - remove subpackages.
  137. * Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 3.0.2-1vl5
  138. - applied new versioning policy
  139. - used rpm macros: %%perl_sitelib %%perl_sitearch
  140. - added foomatic-db-engine-3.1-20050411-combo-xml.patch
  141. - added foomatic-db-engine-3.1-20050411-perl-data.patch
  142. - fixed permission of %%{_datadir}/foomatic/db
  143. * Sat Dec 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 3.0.2-0vl5
  144. - add BuildRequires: libxml2-devel, mpage, Omni
  145. - use %%{_prefix}/lib/{cups,ppr} instead of %%{_libdir}/{cups,ppr}
  146. - run foomatic-cleanupdrivers, foomatic-compiledb with 'perl -Ilib'
  147. - not create ppd-omni package if omni support is disabled
  148. * Mon Apr 11 2005 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl4
  149. - updated foomatic-db to 20050411
  150. - updated foomatic-db-engine to 3.1-20050411
  151. - updated foomatic-db-hpijs to 1.5-20050411
  152. - updated foomatic-filters to 3.1-20050411
  153. * Wed Jan 12 2005 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl3
  154. - updated foomatic-db to 20050112
  155. - updated foomatic-db-engine to 3.1-20050112
  156. - updated foomatic-db-hpijs to 1.5-20050112
  157. * Tue Dec 21 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl2
  158. - updated foomatic-db to 20041220
  159. - updated foomatic-db-hpijs to 1.5-20041220
  160. * Sun Sep 19 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl1
  161. - updated foomatic-db to 20040919
  162. - updated foomatic-db-engine to 3.0.2
  163. - updated foomatic-db-hpijs to 1.5-20040919
  164. - updated foomatic-filters to 3.0.2
  165. * Wed May 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.1-0vl4
  166. - update foomatic-db to 20040526
  167. - update foomatic-db-hpijs to 1.5-20040526
  168. * Tue May 25 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.1-0vl3
  169. - sprit foomatic-ppd to ppd,ppd-hpijs,ppd-omni,ppd-gimp-print,
  170. ppd-gimp-print-ijs
  171. - add Requires: to ppd-* subpackages.
  172. * Thu Apr 15 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.0.1-0vl2
  173. - new upstream version
  174. -- Omni-printers-0.9.1
  175. -- gimp-print-foomatic-db-4.2.6
  176. - foomatic.spec -> foomatic-vl.spec
  177. * Fri Feb 20 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.1-0vl1
  178. - new upstream version
  179. -- foomatic-filters-3.0.1
  180. -- foomatic-db-engine-3.0.1
  181. -- foomatic-db-20040219
  182. -- foomatic-db-hpijs-1.5-20040219
  183. * Mon Jan 26 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl11
  184. - new upstream version
  185. -- foomatic-filters-3.0.1rc3(bug fix. in configure script)
  186. -- defined filterver
  187. - dropped patch101
  188. * Sun Jan 25 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl10
  189. - new upstream cvs version(foomatic-3.0.1rc2)
  190. -- foomatic-db-20040125
  191. -- foomatic-db-engine-3.0.1rc2
  192. -- foomatic-db-hpijs-1.5-20040125
  193. -- foomatic-filters-3.0.1rc2
  194. - added patch101
  195. -- tests diris null in foomatic-filters-3.0.1rc2
  196. * Fri Jan 23 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl9
  197. - new upstream cvs version
  198. -- foomatic-db-20040123
  199. -- foomatic-db-engine-3.0-20040123
  200. -- foomatic-db-hpijs-1.5-20040123
  201. -- foomatic-filters-3.0-20040123
  202. - dropped old patches
  203. * Sat Dec 13 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl8
  204. - built on perl-5.8.2
  205. * Tue Nov 11 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl7
  206. - separated foomatic-db package included xml files
  207. * Mon Nov 10 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl6
  208. - added description of ppd sub package
  209. * Sun Nov 09 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl5
  210. - separated foomatic-ppd package included PPD files
  211. * Sun Nov 09 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl4
  212. - new upstream version
  213. -- foomatic-db-20031109, foomatic-db-engine-3.0-20031109
  214. -- foomatic-filters-3.0-20031109, foomatic-db-hpijs-1.4-1
  215. - dropped patches
  216. -- foomatic-filters-path.patch(patch0)
  217. -- foomatic-2.0.2-fontpath.patch(patch3)
  218. - updated patches
  219. -- foomatic-filters-3.0-20031109-libdir.patch (patch1)
  220. -- foomatic-db-engine-3.0-20031109-libdir.patch (patch2)
  221. -- foomatic-filters-3.0-20031109-vine.patch (patch100)
  222. * Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl3
  223. - built on perl-5.8.1
  224. - fixed install section in spec file
  225. * Sat Aug 30 2003 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 3.0.0-0vl2
  226. - fix some bugs of foomatic-filters.
  227. A
  228. * Sat Jun 07 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl1
  229. - new upstream version
  230. -- rewrote spec file
  231. -- added some patches from rawhide(foomatic-3.0.0-5)
  232. - enable cups support
  233. * Sun Apr 20 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.2-0vl2
  234. - imported some patches from foomatic-2.0.2-18
  235. -- added foomatic-2.0.2-psc2210.patch
  236. -- added foomatic-2.0.2-duplex184.patch
  237. * Sun Mar 02 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.2-0vl1
  238. - imported foomatic-2.0.2-15
  239. * Tue Feb 4 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-15
  240. - Update data-generators to CVS.
  241. * Thu Jan 30 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-14
  242. - Use hpijs, not hpijs-rss (we don't ship the RSS patch now).
  243. * Thu Jan 23 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-13
  244. - Pacify printers that don't understand duplex (bug #82385).
  245. * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 2.0.2-12
  246. - rebuilt
  247. * Tue Jan 21 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-11
  248. - Add autodetect info for HP DeskJet 656C. It doesn't really do
  249. IEEE 1284 IDs, but since it's a USB device we can figure out it's
  250. manufacturer and model anyway.
  251. * Thu Jan 9 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-10
  252. - Set GS_FONTPATH in gs wrapper (bug #81410).
  253. * Sat Jan 4 2003 Jeff Johnson <jbj@redhat.com> 2.0.2-9
  254. - use internal dep generator.
  255. * Sun Dec 15 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-8
  256. - Add several device IDs.
  257. * Sat Dec 14 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-7
  258. - Update Omni printers to 0.7.2.
  259. - No longer need Omni badxml patch.
  260. * Sat Dec 14 2002 Tim Powers <timp@redhat.com> 2.0.2-6
  261. - don't use rpms internal dep generator
  262. * Fri Dec 6 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-5
  263. - Omni XML wasn't well-formed.
  264. * Wed Nov 20 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-4
  265. - Update gimp-print data.
  266. - Add 'generic postscript' model.
  267. * Mon Nov 11 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-3
  268. - Update Omni printers to 0.7.1.
  269. * Tue Oct 22 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-2
  270. - Fix file manifest for perl modules.
  271. - Add autodetect information for HP DeskJet 990C.
  272. * Mon Oct 21 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-1
  273. - 2.0.2.
  274. - No longer need 67973, 970c patches.
  275. - Remove cups-drivers-* packages (no longer needed).
  276. - Remove files not shipped. Ship filter.conf.
  277. - Conditionally restart cups.
  278. - Use libdir.
  279. - Don't put things in site_perl; use vendor_perl instead (bug #73528).
  280. * Fri Aug 9 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.6
  281. - Fix autodetect information for HPDJ970C.
  282. * Thu Aug 8 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.5
  283. - For gimp-print, use the Ghostscript stp driver in preference to the
  284. IJS interface.
  285. * Thu Jul 25 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.4
  286. - Quieten scriptlets.
  287. * Fri Jul 5 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.3
  288. - Fix autodetect information for HPLJ2100/2100M.
  289. * Fri Jun 21 2002 Tim Powers <timp@redhat.com> 1.9-1.20020617.2
  290. - automated rebuild
  291. * Wed Jun 19 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020617.2
  292. - Omni 0.7.0 printers.
  293. * Mon Jun 17 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020617.1
  294. - Update to CVS.
  295. - Remove some more explicit perl dependencies that are picked up
  296. automatically.
  297. * Wed May 29 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.3
  298. - Remove explicit perl-Storable dependency; it should be perl(Storable),
  299. and that is picked up automatically.
  300. * Tue May 28 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.2
  301. - Fix release number.
  302. - Drop gen-ppds from the file manifest---use foomatic-compiledb instead
  303. (bug #63622).
  304. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  305. - automated rebuild
  306. * Thu May 23 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.1
  307. - Remove ghostscript UPP drivers that are gone in 7.05.
  308. * Sat May 18 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.0.1
  309. - Update to CVS.
  310. - Updated requirements.
  311. - Updated path and libdir patches.
  312. - Drop hpijs 1.0.2 patch.
  313. - foomatic-datafile has moved to %%{_bindir}.
  314. - Update gimp-print data to 4.2.1.
  315. - Update Omni printer data to 0.6.1.
  316. * Thu Apr 4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.3
  317. - Fix the hpijs option data too (bug #62587).
  318. * Wed Apr 3 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.2
  319. - Back off to 1.0.2 for hpijs driver data (bug #62587).
  320. * Thu Mar 14 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.1
  321. - Update to CVS.
  322. * Wed Mar 6 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020306.1
  323. - Update to CVS.
  324. - Patches no longer needed: conffile, sys, cachedir, fd0.
  325. - Adapted path patch.
  326. * Tue Mar 5 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.10
  327. - Fix bug #58319.
  328. - Drop dbg patch.
  329. * Mon Feb 25 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.9
  330. - Fix file lists.
  331. * Mon Feb 25 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.8
  332. - Fix %post scriplet bug (bug #59942).
  333. * Thu Feb 21 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.7
  334. - Rebuild in new environment.
  335. * Wed Feb 13 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.6
  336. - Merge cups-drivers. No epoch needed.
  337. - Require perl-URI.
  338. * Wed Feb 06 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.5
  339. - Cache fix.
  340. * Mon Feb 4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.4
  341. - Don't ship backup files.
  342. * Mon Feb 4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.3
  343. - Rebuild to pick up new perl installsitelib.
  344. * Thu Jan 31 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.2
  345. - Fix a thinko in DB.pl.
  346. * Wed Jan 30 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.1
  347. - Update to CVS.
  348. - No longer need the cachedir patch.
  349. - Fix config file path.
  350. - Look in /usr/local/bin last, not first, in lpdomatic (bug #57915).
  351. * Tue Jan 29 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020129.1
  352. - Update to CVS.
  353. - Patches no longer needed: prepend, fd3.
  354. - Use RPM_OPT_FLAGS.
  355. - Allow non-root users to use foomatic-datafile (bug #58956).
  356. * Sat Jan 26 2002 Jeff Johnson <jbj@redhat.com> 1.1-0.20020124.2
  357. - added Provides: perl(Foomatic::GrovePath)
  358. * Thu Jan 24 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020124.1
  359. - Update to CVS.
  360. - Updated Omni printers to those in Omni 0.5.1.
  361. - Updated patches: prepend, fd3.
  362. - Patches no longer needed: utf8, lpdomatic.
  363. - Added gimp-print (formerly stp) foomatic db info, and removed the old
  364. stp.xml file.
  365. - Conflict with ghostscript if it doesn't have gimp-print-4.2.0 yet.
  366. * Fri Jan 18 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20011218.2
  367. - REALLY fix PCL fixup code (bug #55909, others).
  368. - PreReq fileutils, initscripts (bug #56984).
  369. - Fix prepends in lpdomatic (bug #57371).
  370. - Run foomatic-cleanupdrivers during install, to remove driver entries
  371. with no command line.
  372. - Put lpdomatic in /usr/sbin again.
  373. - Fix foomatic-gswrapper's file descriptor manipulations (bug #56871).
  374. * Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011218.1
  375. - re-imported from upstream to fix some perl fixup code on pcl printers.
  376. * Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011217.2
  377. - fix the rest of the quoting issues with foomatic-combo-xml with the patch
  378. - foomatic-1.1-20011217-quotes.patch. This has been sent upstream.
  379. * Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011217.1
  380. - respin to pull in latest foomatic database, fixes:
  381. - properly use the cache in relation to foomatic-combo-xml's output
  382. - fix _some_ of the quoting issues with calling foomatic-combo-xml
  383. * Wed Dec 5 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011205.1
  384. - respin to pull in latest foomatic database, fixes:
  385. - droping half of a large job
  386. - -Mutf8 added to the upstream filters
  387. - miscelaneous printer db updates
  388. * Thu Nov 29 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.8
  389. - added Requires: fileutils for the 'rm' in post
  390. * Mon Nov 26 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.7
  391. - /var/chache => /var/cache, doh!
  392. * Fri Nov 16 2001 Nalin Dahyabhai <nalin@redhat.com> 1.1-0.20011018.6
  393. - fix %%post scriptlet
  394. * Tue Nov 13 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.5
  395. - changed the patch to use the -Mutf8 command line option,
  396. - and to restart the printserver, after rebuilding the settings.
  397. * Fri Nov 9 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.4
  398. - grumble. Some drivers use inline perl scripts, and need the 'use utf8;'
  399. - pragma. Without it, they break on _some_ of their options.
  400. * Wed Oct 31 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.3
  401. - patched lpdomatic to prepend PostScript options in the _right_ place.
  402. * Thu Oct 25 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.2
  403. - zap the foomatic cache on install
  404. * Thu Oct 18 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.1
  405. - rolled to pull in latest information.
  406. - added Omni printers to the printer list.
  407. * Fri Oct 05 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011005.1
  408. - rolled to pull in an ia64 fix to foomatic-combo-xml.c
  409. * Mon Oct 01 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011001.1
  410. - rolled to pull in foomatic fixes to foomatic-combo-xml.c
  411. * Wed Sep 05 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010905.1
  412. - upgraded to latest foomatic, we now have fast overview generation!
  413. - this means that there is no prebuilt overview file.
  414. * Tue Aug 28 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010828.1
  415. - WOW! The latest foomatic uses Till Kamppeter's C based combo compiler.
  416. - It is now fast enough that there is no real benifit to precompiling.
  417. - NOTE: this forces the package to stop being noarched.
  418. * Mon Aug 27 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010827.1
  419. - fresh pull, maybe it fixes the build errors.
  420. * Sat Aug 25 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010825.1
  421. - did a fresh database pull, which contains the old japanese printers as well.
  422. - removed japanese hack.
  423. * Tue Aug 14 2001 Akira TAGOH <tagoh@redhat.com> 1.1-0.20010717.5
  424. - Add Japanese printer entry.
  425. * Mon Aug 6 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.4
  426. - move the cache back to /var, sigh.
  427. * Mon Jul 23 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.2
  428. - made foomatic pre-compute its db
  429. * Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.1
  430. - imported from mandrake.
  431. * Tue Jul 17 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010717mdk
  432. - Added job listing/removal/manipulation and queue control to
  433. foomatic-printjob
  434. - Support for printing multiple copies with PDQ
  435. * Sat Jul 14 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010714mdk
  436. - Included the cupsomatic filter script
  437. - When a queue is set up, default options can be set now
  438. - Help messages of foomatic-configure and foomatic-printjob cleaned up.
  439. * Fri Jul 13 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010713mdk
  440. - Many bugfixes in "foomatic-printjob".
  441. - "foomatic-configure" adds the Foomatic config file directory automatically
  442. to the search paths of PDQ.
  443. - Printing a help page under PDQ was broken.
  444. * Thu Jul 12 2001 Stefan van der Eijk <stefan@eijk.nu> 1.1-0.20010712mdk
  445. - BuildRequires: perl-devel
  446. * Wed Jul 11 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010711mdk
  447. - initial release.
  448. - Deleted the obsolete drivers "stp", "cZ11", and "hpdj".
  449. - Patch applied which flushes the memory cache regularly, otherwise
  450. foomatic-configure would hang when the Foomatic data of GIMP-Print is
  451. installed.