perl-Devel-GlobalDestruction-vl.spec 4.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139
  1. # Package is noarch from perl 5.13.7
  2. %global noarch_package %(perl -e 'print (($] >= 5.013007) ? 1 : 0);')
  3. Name: perl-Devel-GlobalDestruction
  4. Version: 0.04
  5. Release: 1%{?_dist_release}
  6. License: GPL+ or Artistic
  7. Group: Development/Libraries
  8. Summary: Expose PL_dirty, the flag that marks global destruction
  9. Url: http://search.cpan.org/dist/Devel-GlobalDestruction
  10. Source: http://search.cpan.org/CPAN/authors/id/F/FL/FLORA/Devel-GlobalDestruction-%{version}.tar.gz
  11. %if %{noarch_package}
  12. BuildArch: noarch
  13. %endif
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -nu)
  15. BuildRequires: perl(ExtUtils::MakeMaker)
  16. BuildRequires: perl(Sub::Exporter)
  17. BuildRequires: perl(XSLoader)
  18. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  19. # Don't "provide" private Perl libs
  20. %{?perl_default_filter}
  21. %description
  22. Perl's global destruction is a little tricky to deal with with respect to
  23. finalizers because it's not ordered and objects can sometimes disappear.
  24. Writing defensive destructors is hard and annoying, and usually if global
  25. destruction is happening you only need the destructors that free up non
  26. process local resources to actually execute.
  27. For these constructors you can avoid the mess by simply bailing out if
  28. global destruction is in effect.
  29. %prep
  30. %setup -q -n Devel-GlobalDestruction-%{version}
  31. %build
  32. perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
  33. make %{?_smp_mflags}
  34. %install
  35. rm -rf %{buildroot}
  36. make pure_install DESTDIR=%{buildroot}
  37. find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
  38. find %{buildroot} -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
  39. find %{buildroot} -depth -type d -exec rmdir {} ';' 2>/dev/null
  40. %{_fixperms} %{buildroot}
  41. %check
  42. make test
  43. %clean
  44. rm -rf %{buildroot}
  45. %files
  46. %defattr(-,root,root,-)
  47. %doc Changes t/
  48. %if %{noarch_package}
  49. %{perl_vendorlib}/Devel/
  50. %else
  51. %{perl_vendorarch}/auto/Devel/
  52. %{perl_vendorarch}/Devel/
  53. %endif
  54. %{_mandir}/man3/Devel::GlobalDestruction.3pm*
  55. %changelog
  56. * Mon Mar 05 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.04-1
  57. - initial build for Vine Linux
  58. * Fri Jan 13 2012 Paul Howarth <paul@city-fan.org> - 0.04-1
  59. - Update to 0.04
  60. - To detect a perl with ${^GLOBAL_PHASE}, check for the feature itself
  61. instead of a specific perl version
  62. - Update the documentation to reflect the use of ${^GLOBAL_PHASE} if available
  63. - Stop depending on Scope::Guard for the tests
  64. - Upgrade ppport.h from version 3.13 to 3.19
  65. - Drop no-longer-necessary buildreq perl(Scope::Guard)
  66. - Use DESTDIR rather than PERL_INSTALL_ROOT
  67. - BR: perl(XSLoader)
  68. * Wed Jan 11 2012 Paul Howarth <paul@city-fan.org> - 0.03-3
  69. - Fedora 17 mass rebuild
  70. * Wed Jun 29 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.03-2
  71. - Perl mass rebuild
  72. * Fri Jun 24 2011 Paul Howarth <paul@city-fan.org> - 0.03-1
  73. - Update to 0.03
  74. - Drop the XS code on perl versions recent enough to have ${^GLOBAL_PHASE}
  75. (5.13.7 onwards)
  76. - Require at least Perl 5.6
  77. - Use XSLoader without a fallback to DynaLoader
  78. - Use our instead of use vars
  79. - This release by FLORA -> update source URL
  80. - Package is noarch from perl 5.13.7
  81. - Package Changes file
  82. - Use %%{?perl_default_filter}
  83. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.02-12
  84. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  85. * Thu Dec 16 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.02-11
  86. - Rebuild to fix problems with vendorarch/lib (#661697)
  87. * Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.02-10
  88. - Mass rebuild with perl-5.12.0
  89. * Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.02-9
  90. - Mass rebuild with perl-5.12.0
  91. * Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 0.02-8
  92. - rebuild against perl 5.10.1
  93. * Sun Aug 23 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.02-7
  94. - bump
  95. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.02-6
  96. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  97. * Sat May 23 2009 Chris Weyl <cweyl@alumni.drew.edu> - 0.02-5
  98. - Stripping bad provides of private Perl extension libs
  99. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.02-4
  100. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  101. * Mon Nov 03 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.02-3
  102. - bump
  103. * Sat Nov 01 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.02-2
  104. - tweak summary
  105. * Sun Oct 26 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.02-1
  106. - clean up for review submission
  107. * Sun Oct 19 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.02-0.1
  108. - initial RPM packaging
  109. - generated with cpan2dist (CPANPLUS::Dist::RPM version 0.0.5)