perl-Data-OptList-vl.spec 4.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139
  1. Name: perl-Data-OptList
  2. Summary: Parse and validate simple name/value option pairs
  3. Version: 0.107
  4. Release: 1%{?_dist_release}
  5. License: GPL+ or Artistic
  6. Group: Development/Libraries
  7. URL: http://search.cpan.org/dist/Data-OptList/
  8. Source0: http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/Data-OptList-%{version}.tar.gz
  9. BuildArch: noarch
  10. BuildRequires: perl(ExtUtils::MakeMaker) >= 6.30
  11. BuildRequires: perl(List::Util)
  12. BuildRequires: perl(Params::Util)
  13. BuildRequires: perl(Sub::Install) >= 0.921
  14. BuildRequires: perl(Test::More)
  15. BuildRequires: perl(Test::Pod)
  16. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  17. # Obsolete/provide old -tests subpackage (can be removed in F19 development cycle)
  18. Obsoletes: %{name}-tests < %{version}-%{release}
  19. Provides: %{name}-tests = %{version}-%{release}
  20. %description
  21. Hashes are great for storing named data, but if you want more than one entry
  22. for a name, you have to use a list of pairs. Even then, this is really boring
  23. to write:
  24. $values = [
  25. foo => undef,
  26. bar => undef,
  27. baz => undef,
  28. xyz => { ... },
  29. ];
  30. With Data::OptList, you can do this instead:
  31. $values = Data::OptList::mkopt([
  32. qw(foo bar baz),
  33. xyz => { ... },
  34. ]);
  35. This works by assuming that any defined scalar is a name and any reference
  36. following a name is its value.
  37. %prep
  38. %setup -q -n Data-OptList-%{version}
  39. %build
  40. perl Makefile.PL INSTALLDIRS=vendor
  41. make %{?_smp_mflags}
  42. %install
  43. make pure_install DESTDIR=%{buildroot}
  44. find %{buildroot} -type f -name .packlist -exec rm -f {} \;
  45. find %{buildroot} -depth -type d -exec rmdir {} \; 2>/dev/null
  46. %{_fixperms} %{buildroot}
  47. %check
  48. make test RELEASE_TESTING=1
  49. %files
  50. %doc Changes LICENSE README t/
  51. %{perl_vendorlib}/Data/
  52. %{_mandir}/man3/Data::OptList.3pm*
  53. %changelog
  54. * Mon Mar 05 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.107-1
  55. - initial build for Vine Linux
  56. * Sat Jan 21 2012 Paul Howarth <paul@city-fan.org> - 0.107-5
  57. - obsolete/provide old -tests subpackage to support upgrades
  58. * Fri Jan 20 2012 Paul Howarth <paul@city-fan.org> - 0.107-4
  59. - drop -tests subpackage (general lack of interest in this), but include
  60. them as documentation for the main package
  61. - drop redundant %%{?perl_default_filter}
  62. - don't use macros for commands
  63. - can't find any dependency cycle so drop %%{?perl_bootstrap} usage
  64. - drop ExtUtils::MakeMaker version requirement to 6.30, actual working minimum
  65. * Wed Jan 11 2012 Paul Howarth <paul@city-fan.org> - 0.107-3
  66. - package LICENSE file
  67. - run test suite even when bootstrapping, as it should still pass
  68. - run release tests too
  69. - enhance %%description so it makes sense
  70. - BR: perl(Test::More)
  71. * Tue Jun 28 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.107-2
  72. - Perl mass rebuild
  73. - add perl_bootstrap macro
  74. * Wed May 11 2011 Iain Arnell <iarnell@gmail.com> 0.107-1
  75. - update to latest upstream version
  76. - clean up spec for modern rpmbuild
  77. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.106-4
  78. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  79. * Thu Dec 16 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.106-3
  80. - rebuild to fix problems with vendorarch/lib (#661697)
  81. * Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.106-2
  82. - Mass rebuild with perl-5.12.0
  83. * Mon Mar 08 2010 Chris Weyl <cweyl@alumni.drew.edu> 0.106-1
  84. - update by Fedora::App::MaintainerTools 0.004
  85. - PERL_INSTALL_ROOT => DESTDIR
  86. - updating to latest GA CPAN version (0.106)
  87. - added a new br on perl(ExtUtils::MakeMaker) (version 6.42)
  88. - added a new br on perl(List::Util) (version 0)
  89. - altered br on perl(Sub::Install) (0.92 => 0.921)
  90. - added a new req on perl(List::Util) (version 0)
  91. - added a new req on perl(Params::Util) (version 0.14)
  92. - added a new req on perl(Sub::Install) (version 0.921)
  93. * Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 0.104-4
  94. - rebuild against perl 5.10.1
  95. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.104-3
  96. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  97. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.104-2
  98. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  99. * Wed Feb 11 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.104-1
  100. - update to 0.104
  101. * Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.103-2
  102. - Rebuild for perl 5.10 (again)
  103. * Thu Jan 24 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0.103-1
  104. - rebuild for new perl
  105. - bump to 0.103
  106. - fix license tag
  107. * Thu Sep 07 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.101-2
  108. - bump
  109. * Sat Sep 02 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.101-1
  110. - Specfile autogenerated by cpanspec 1.69.1.