perl-Class-Load-vl.spec 7.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193
  1. %define perl_bootstrap 1
  2. Name: perl-Class-Load
  3. Version: 0.18
  4. Release: 1%{?dist}
  5. Summary: A working (require "Class::Name") and more
  6. Group: Development/Libraries
  7. License: GPL+ or Artistic
  8. URL: http://search.cpan.org/dist/Class-Load/
  9. Source0: http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/Class-Load-%{version}.tar.gz
  10. BuildArch: noarch
  11. # ===================================================================
  12. # Module build requirements
  13. # ===================================================================
  14. BuildRequires: perl(ExtUtils::MakeMaker)
  15. # ===================================================================
  16. # Module requirements
  17. # ===================================================================
  18. BuildRequires: perl(base)
  19. BuildRequires: perl(Carp)
  20. BuildRequires: perl(Data::OptList)
  21. BuildRequires: perl(Module::Implementation) >= 0.04
  22. BuildRequires: perl(Module::Runtime) >= 0.012
  23. BuildRequires: perl(Package::Stash) >= 0.14
  24. BuildRequires: perl(strict)
  25. BuildRequires: perl(Try::Tiny)
  26. BuildRequires: perl(warnings)
  27. # ===================================================================
  28. # Regular test suite requirements
  29. # ===================================================================
  30. # Class::Load::XS -> Class::Load
  31. %if 0%{!?perl_bootstrap:1}
  32. BuildRequires: perl(Class::Load::XS)
  33. %endif
  34. BuildRequires: perl(Test::Fatal)
  35. BuildRequires: perl(Test::More)
  36. BuildRequires: perl(Test::Without::Module)
  37. BuildRequires: perl(version)
  38. # ===================================================================
  39. # Author/Release test requirements
  40. # ===================================================================
  41. # Pod::Coverage::Moose -> Moose -> Class::Load
  42. %if 0%{!?perl_bootstrap:1}
  43. BuildRequires: perl(Pod::Coverage::Moose)
  44. %endif
  45. BuildRequires: perl(Test::CPAN::Changes)
  46. BuildRequires: perl(Test::EOL)
  47. BuildRequires: perl(Test::NoTabs)
  48. BuildRequires: perl(Test::Pod)
  49. BuildRequires: perl(Test::Pod::Coverage)
  50. BuildRequires: perl(Test::Requires)
  51. BuildRequires: perl(Test::Spelling), aspell-en
  52. # ===================================================================
  53. # Runtime requirements
  54. # ===================================================================
  55. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  56. # Also requires core module perl(Exporter) via a "use base" construct
  57. %description
  58. require EXPR only accepts Class/Name.pm style module names, not Class::Name.
  59. How frustrating! For that, we provide load_class 'Class::Name'.
  60. It's often useful to test whether a module can be loaded, instead of throwing
  61. an error when it's not available. For that, we provide
  62. try_load_class 'Class::Name'.
  63. Finally, sometimes we need to know whether a particular class has been loaded.
  64. Asking %%INC is an option, but that will miss inner packages and any class for
  65. which the filename does not correspond to the package name. For that, we
  66. provide is_class_loaded 'Class::Name'.
  67. %prep
  68. %setup -q -n Class-Load-%{version}
  69. %build
  70. perl Makefile.PL INSTALLDIRS=vendor
  71. make %{?_smp_mflags}
  72. %install
  73. make pure_install DESTDIR=%{buildroot}
  74. find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
  75. find %{buildroot} -depth -type d -exec rmdir {} ';' 2>/dev/null
  76. %{_fixperms} %{buildroot}
  77. %check
  78. make test %{!?perl_bootstrap:RELEASE_TESTING=1}
  79. %files
  80. %doc Changes LICENSE README
  81. %{perl_vendorlib}/Class/
  82. %{_mandir}/man3/Class::Load.3pm*
  83. %changelog
  84. * Sat Feb 18 2012 Paul Howarth <paul@city-fan.org> - 0.18-1
  85. - Update to 0.18:
  86. - Require Package::Stash ≥ 0.14 (CPAN RT#75095)
  87. * Sun Feb 12 2012 Paul Howarth <paul@city-fan.org> - 0.17-1
  88. - Update to 0.17:
  89. - Require Module::Runtime 0.012, which has a number of useful bug fixes
  90. - A bug in Class::Load caused test failures when Module::Runtime 0.012 was
  91. used with Perl 5.8.x (CPAN RT#74897)
  92. * Thu Feb 9 2012 Paul Howarth <paul@city-fan.org> - 0.15-1
  93. - Update to 0.15:
  94. - Small test changes to accomodate latest version of Module::Implementation
  95. - BR: at least version 0.04 of perl(Module::Implementation)
  96. * Tue Feb 7 2012 Paul Howarth <paul@city-fan.org> - 0.14-1
  97. - Update to 0.14:
  98. - Use Module::Implementation to handle loading the XS or PP versions of the
  99. code; using this module fixes a few bugs
  100. - Under taint mode, setting an implementation in the
  101. CLASS_LOAD_IMPLEMENTATION env var caused a taint error
  102. - An invalid value in the CLASS_LOAD_IMPLEMENTATION env var is now detected
  103. and reported immediately; no attempt is made to load an invalid
  104. implementation
  105. - BR: perl(Module::Implementation)
  106. - BR: perl(base), perl(Carp), perl(strict) and perl(warnings) for completeness
  107. - Drop version requirement for perl(Package::Stash), no longer present upstream
  108. - Drop explicit runtime dependencies, no longer needed
  109. - Don't BR: perl(Class::Load::XS) or perl(Pod::Coverage::Moose) if we're
  110. bootstrapping
  111. - Don't run the release tests when bootstrapping as the Pod coverage test will
  112. fail in the absence of Pod::Coverage::Moose
  113. * Tue Jan 10 2012 Paul Howarth <paul@city-fan.org> - 0.13-2
  114. - Fedora 17 mass rebuild
  115. * Thu Dec 22 2011 Paul Howarth <paul@city-fan.org> - 0.13-1
  116. - Update to 0.13:
  117. - Fix some bugs with our use of Try::Tiny, which could cause warnings on some
  118. systems where Class::Load::XS wasn't installed (CPAN RT#72345)
  119. - BR: perl(Test::Without::Module)
  120. * Tue Oct 25 2011 Paul Howarth <paul@city-fan.org> - 0.12-1
  121. - Update to 0.12:
  122. - Require Module::Runtime ≥ 0.011, which fixes problems with Catalyst under
  123. Perl 5.8 and 5.10
  124. - Add versioned runtime dependencies for Module::Runtime and Package::Stash
  125. * Wed Oct 5 2011 Paul Howarth <paul@city-fan.org> - 0.11-1
  126. - Update to 0.11:
  127. - Don't accept package names that start with a digit
  128. - Rewrite some of the guts to use Module::Runtime rather than reimplementing
  129. its functionality
  130. - BR: perl(Module::Runtime) ≥ 0.009
  131. - Drop all support for older distributions as required module
  132. Module::Runtime ≥ 0.009 will not be available prior to F-16
  133. * Tue Sep 6 2011 Paul Howarth <paul@city-fan.org> - 0.10-1
  134. - Update to 0.10:
  135. - Fix is_class_loaded to ignore $ISA (but still look for @ISA) when trying to
  136. determine whether a class is loaded
  137. - Lots of internals cleanup
  138. - BR: perl(Package::Stash) ≥ 0.32 and perl(Try::Tiny)
  139. - Update patches to apply cleanly
  140. * Tue Aug 16 2011 Paul Howarth <paul@city-fan.org> - 0.08-1
  141. - Update to 0.08:
  142. - The previous version was missing a prereq declaration for Data::OptList
  143. (CPAN RT#70285)
  144. - This release by DROLSKY -> update source URL
  145. - Package new documentation: LICENSE and README
  146. - Add build requirements for new release tests and run them:
  147. - perl(Pod::Coverage::Moose)
  148. - perl(Test::CPAN::Changes)
  149. - perl(Test::EOL)
  150. - perl(Test::NoTabs)
  151. - perl(Test::Pod)
  152. - perl(Test::Pod::Coverage)
  153. - perl(Test::Requires)
  154. - perl(Test::Spelling) and aspell-en
  155. - Add patch for building with ExtUtils::MakeMaker < 6.30
  156. - Add patch for building with Test::More < 0.88
  157. - Add patch for building without Test::Requires
  158. - Add patch for fixing spell checker word list
  159. - Don't try to run the POD Coverage test if we don't have Pod::Coverage::Moose
  160. * Tue Jun 21 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.06-5
  161. - Perl mass rebuild
  162. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.06-4
  163. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  164. * Tue Dec 21 2010 Paul Howarth <paul@city-fan.org> - 0.06-3
  165. - Drop explicit dependency on core module perl(Exporter) (#656408)
  166. * Tue Nov 23 2010 Paul Howarth <paul@city-fan.org> - 0.06-2
  167. - Sanitize spec for Fedora submission
  168. * Mon Nov 22 2010 Paul Howarth <paul@city-fan.org> - 0.06-1
  169. - Initial RPM version