R-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324
  1. %define pkg_version 2.11.0
  2. %define pkg_release 2%{?_dist_release}
  3. Summary: A language for data analysis and graphics
  4. Summary(ja): データ解析・グラフィック化の言語
  5. Name: R
  6. Version: %{pkg_version}
  7. Release: %{pkg_release}
  8. Source0: ftp://cran.r-project.org/pub/R/src/base/R-2/%{name}-%{version}.tar.gz
  9. #Patch0: R-release.diff.gz
  10. License: GPL2
  11. Group: Applications/Engineering
  12. URL: http://www.r-project.org
  13. Requires: libgfortran
  14. BuildRequires: gcc-c++
  15. BuildRequires: gcc-gfortran libgfortran
  16. BuildRequires: tetex texinfo tcl tk
  17. BuildRequires: libpng-devel libjpeg-devel
  18. BuildRequires: readline-devel libtermcap-devel
  19. BuildRequires: zlib-devel bzip2-devel XOrg-devel
  20. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  21. Vendor: Project Vine
  22. Distribution: Vine Linux
  23. Packager: Toshiaki Ara <ara_t@384.jp>
  24. %description
  25. 'GNU S' - A language and environment for statistical computing and
  26. graphics. R is similar to the award-winning S system, which was
  27. developed at Bell Laboratories by John Chambers et al. It provides
  28. a wide variety of statistical and graphical techniques (linear and
  29. nonlinear modelling, statistical tests, time series analysis,
  30. classification, clustering, ...).
  31. R is designed as a true computer language with control-flow
  32. constructions for iteration and alternation, and it allows users to
  33. add additional functionality by defining new functions.
  34. For computationally intensive tasks, C, C++ and Fortran code
  35. can be linked and called at run time.
  36. %description -l ja
  37. 'GNU S' - 統計解析とグラフィックスのプログラミング言語と環境。
  38. Rは、ベル研究所のJohn Chambersらが開発した輝けるS言語に似ており、
  39. 線形・非線型モデル、統計検定、時系列分析、クラスター分析など
  40. 幅広い統計解析・視覚化手法を提供する。
  41. Rは、条件分岐や反復計算などの制御構造を持つ正真正銘のコンピュータ言語
  42. として設計されており、ユーザが新たに関数を組み込むことが可能である。
  43. また、計算量が多いときにはC、 C++、Fortranなどのコードとリンクさせて
  44. 使用することができる。
  45. %package devel
  46. Summary: files for development of R packages.
  47. Summary(ja): Rパッケージ開発用ファイル
  48. Group: Development/Libraries
  49. Requires: R = %{version}-%{release}
  50. %description devel
  51. Install R-devel if you are going to develop or compile R packages.
  52. This is just a stub package containing the documentation on "Writing R
  53. Extensions". However, installing it will ensure that the build
  54. environment for R packages is correct.
  55. %description -l ja devel
  56. Rパッケージを開発したりコンパイルする場合には、このR-develを
  57. インストールします。R-exts.pdf ("Writing R Extensions": 英文)
  58. が含まれているだけのサブパッケージですが、正しくRパッケージを
  59. 開発するための助けになるでしょう。
  60. %package -n libRmath
  61. Summary: standalone math library from the R project
  62. Summary(ja): 単独で動作するRプロジェクトの数理ライブラリ
  63. Group: System Environment/Libraries
  64. %description -n libRmath
  65. A standalone library of mathematical and statistical functions derived
  66. from the R project. This packages provides the shared libRmath library.
  67. %description -l ja -n libRmath
  68. 単独で動作するRプロジェクトの数理統計ライブラリで、libRmath.soという
  69. 共有ライブラリを提供する。
  70. %package -n libRmath-devel
  71. Summary: standalone math library from the R project
  72. Summary(ja): libRmathの開発ライブラリ
  73. Group: Development/Libraries
  74. Requires: libRmath = %{version}-%{release}
  75. %description -n libRmath-devel
  76. A standalone library of mathematical and statistical functions derived
  77. from the R project. This packages provides the header files.
  78. %description -l ja -n libRmath-devel
  79. libRmathのヘッダファイル(Rmath.h)
  80. %prep
  81. %{__rm} -rf ${RPM_BUILD_ROOT}
  82. %setup -q
  83. #%patch0 -p1
  84. %build
  85. export R_BROWSER="%{_bindir}/firefox"
  86. %configure
  87. %{__make} %{?_smp_mflags}
  88. (cd src/nmath/standalone; %{__make} %{?_smp_mflags})
  89. LANG=C make check-all
  90. %{__make} pdf
  91. #We can only "make info" if we have an up to date version of texinfo
  92. %{?INFO: %{__make} info}
  93. %install
  94. %{__make} install DESTDIR=${RPM_BUILD_ROOT} install-pdf %{?INFO:install-info}
  95. %{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir
  96. %{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir.old
  97. #Install libRmath files
  98. (cd src/nmath/standalone; %{__make} install DESTDIR=${RPM_BUILD_ROOT})
  99. mkdir -p ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
  100. echo "%{_libdir}/R/lib" > ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/%{name}-%{_arch}.conf
  101. #Fix lication of R_HOME_DIR in shell wrapper
  102. sed -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
  103. > ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
  104. chmod 755 ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
  105. sed -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
  106. > ${RPM_BUILD_ROOT}%{_bindir}/R
  107. chmod 755 ${RPM_BUILD_ROOT}%{_bindir}/R
  108. %files
  109. %defattr(-, root, root)
  110. %{_bindir}/R
  111. %{_bindir}/Rscript
  112. %{_libdir}/R
  113. %{?INFO:%{_infodir}/R-*.info*}
  114. %{_mandir}/man1/*
  115. /etc/ld.so.conf.d/*
  116. %files devel
  117. %defattr(-, root, root)
  118. %doc doc/manual/R-exts.pdf
  119. %files -n libRmath
  120. %defattr(-, root, root)
  121. %{_libdir}/libRmath.so
  122. %files -n libRmath-devel
  123. %defattr(-, root, root)
  124. %{_libdir}/pkgconfig/*.pc
  125. %{_includedir}/Rmath.h
  126. %clean
  127. %{__rm} -rf ${RPM_BUILD_ROOT}
  128. %post
  129. %if 0%{?INFO}
  130. # Create directory entries for info files
  131. # (optional doc files, so we must check that they are installed)
  132. for doc in admin data exts FAQ intro lang; do
  133. file=%{_infodir}/R-${doc}.info.gz
  134. if [ -e $file ]; then
  135. /sbin/install-info ${file} %{_infodir}/dir 2>/dev/null
  136. fi
  137. done
  138. %endif
  139. %{_syssbindir}/ldconfig
  140. %preun
  141. %if 0%{?INFO}
  142. if [ $1 = 0 ]; then
  143. # Delete directory entries for info files (if they were installed)
  144. for doc in admin data exts FAQ intro lang; do
  145. file=%{_infodir}/R-${doc}.info.gz
  146. if [ -e ${file} ]; then
  147. /sbin/install-info --delete R-${doc} %{_infodir}/dir 2>/dev/null
  148. fi
  149. done
  150. fi
  151. %endif
  152. %postun -p %{_syssbindir}/ldconfig
  153. %post -n libRmath -p %{_syssbindir}/ldconfig
  154. %postun -n libRmath -p %{_syssbindir}/ldconfig
  155. %changelog
  156. * Thu Apr 24 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-2vl5
  157. - recompiled because tcl/tk were not linked
  158. * Thu Apr 23 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-1vl5
  159. - Updated to 2.11.0
  160. - added Requires: libgfortran
  161. * Thu Dec 15 2009 Toshiaki Ara <ara_t@384.jp> 2.10.1-1vl5
  162. - Updated to 2.10.1
  163. * Thu Nov 06 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-3vl5
  164. - patched to 2.10.0
  165. * Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.0-2
  166. - spec in UTF-8
  167. * Thu Oct 27 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-1vl5
  168. - Updated to 2.10.0
  169. * Thu Sep 23 2009 Toshiaki Ara <ara_t@384.jp> 2.9.2-1vl5
  170. - Updated to 2.9.2
  171. - deleted BuildRequires: lapack-devel blas-devel
  172. - rewrote SPEC file
  173. * Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.5.1-0vl1
  174. - Updated to 2.5.1
  175. - added BuildRequires: gcc-gfortran for VineSeed
  176. - added BuildRequires: lapack-devel blas-devel
  177. - fixed %preun script
  178. * Wed Dec 20 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.4.1-0vl1
  179. - Updated to 2.4.1
  180. - Added INFO option
  181. - Exclude Japanese Rprofile.site
  182. * Mon Oct 30 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
  183. - Updated to 2.4.0
  184. * Mon Oct 2 2006 Martyn Plummer <plummer@iarc.fr> 1:2.3.1-2
  185. - Added optimization flags
  186. * Tue Jun 6 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.1-0vl1
  187. - Packaged for VineLinux3.2
  188. * Tue May 9 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl2
  189. - Use JAVA_HOME for R_JAVA_LD_LIBRARY_PATH
  190. * Mon May 8 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl1
  191. - Packaged for VineLinux3.2
  192. - Slipped texinfo
  193. - Fixed preun error
  194. - Preset Japanese fonts
  195. * Thu Jan 12 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
  196. - Packaged for VineLinux3.2
  197. * Tue Jan 3 2006 Martyn Plumer <plummber@iarc.fr> 1:2.2.1-1
  198. - Restored CAPABILITIES file lost in 2.2.1beta
  199. * Mon Dec 12 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.1beta-1
  200. - Configure uses --without-blas by default.
  201. - Install pdf manuals.
  202. - All toplevel documentation files are installed into _libdir/R
  203. as they may be required by R (qv note on AUTHORS and THANKS below).
  204. - Legacy scripts for rebuilding package indices removed.
  205. * Mon Sep 19 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.0-0
  206. - R now compiles with gcc 4.0.1 and default rpm optimization flags.
  207. * Wed Jul 13 2005 Martyn Plummer <plummer@iarc.fr> 1:2.1.1-2
  208. - The files AUTHORS and THANKS need to be installed into _libdir/R
  209. as they are required by the function contributors(). Previously
  210. they were installed only as documentation files.
  211. * Tue Jun 21 2005 Martyn Plummer <plummer@iarc.fr>
  212. - Corrected date error in SPEC file.
  213. * Sun Jun 19 2005 Martyn Plummer <plummer@iarc.fr>
  214. - Dropped support for Red Hat boxed set.
  215. - Synchronized with Fedora Extras 4 RPM by Tom Calloway
  216. including support for shared R library.
  217. - Added gfortran support. However, gcc 4.0.0 will not compile R correctly
  218. with the default optimization flags, so there is a temporary work-around.
  219. * Wed Jun 15 2005 Gernot Stocker <gernot.stocker@tugraz.at>
  220. - Adaptations for CentOS and Rocks-Linux, tested under Release 4.0
  221. * Sat Apr 30 2005 Joseph P. Skudlarek <Jskud@Jskud.com> 0:2.1.0-0.fdr.3
  222. - Install R-data.info file as well.
  223. - Make info processing conditional on texinfo version, not platform release,
  224. so that if a new enough version is installed, we will build and install info.
  225. * Mon Apr 18 2005 Martyn Plummer <plummer@iarc.fr> 0:2.1.0-0.fdr.1
  226. - Built R 2.1.0. R now supports internationalization, so the patch
  227. to set the locale to "C" is now dropped.
  228. - install.packages() exits gracefully with a helpful message if
  229. the file INSTALL is not present, so this is now included in the
  230. R-devel package.
  231. * Mon Mar 14 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.5
  232. - Added support for Scientific Linux (http://www.scientificlinux.org)
  233. A distribution based on RHEL. Thanks to Jon Peatfield.
  234. * Mon Feb 28 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.4
  235. - Fixed file ownership in R-devel and libRmath packages
  236. * Wed Feb 16 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.3
  237. - R-devel package is now a stub package with no files, except a documentation
  238. file (RPM won't accept sub-packages with no files). R now conflicts
  239. with earlier (i.e 0:2.0.1-0.fdr.2) versions of R-devel.
  240. - Created libRmath subpackage with shared library.
  241. * Mon Jan 31 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.2
  242. - Created R-devel and libRmath-devel subpackages
  243. * Mon Nov 15 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.1
  244. - Built R 2.0.1
  245. * Wed Nov 10 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.3
  246. - Set R_PRINTCMD at configure times so that by default getOption(printcmd)
  247. gives "lpr".
  248. - Define macro fcx for all Fedora distributions. This replaces Rinfo
  249. * Tue Oct 12 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.2
  250. - Info support is now conditional on the macro Rinfo, which is only
  251. defined for Fedora 1 and 2.
  252. * Thu Oct 7 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.1
  253. - Built R 2.0.0
  254. - There is no longer a BUGS file, so this is not installed as a
  255. documentation file.