libpwquality-vl.spec 5.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205
  1. Summary: A library for password generation and password quality checking
  2. Name: libpwquality
  3. Version: 1.4.2
  4. Release: 1%{?_dist_release}
  5. Group: System Environment/Base
  6. Vendor: Project Vine
  7. Distribution: Vine Linux
  8. # The package is BSD licensed with option to relicense as GPLv2+
  9. # - this option is redundant as the BSD license allows that anyway.
  10. License: BSD or GPLv2+
  11. Source0: https://github.com/libpwquality/libpwquality/releases/download/libpwquality-%{version}/libpwquality-%{version}.tar.bz2
  12. %global _moduledir /%{_lib}/security
  13. %global _secconfdir %{_sysconfdir}/security
  14. Requires: cracklib-dicts >= 2.8
  15. Requires: pam
  16. BuildRequires: cracklib
  17. BuildRequires: gettext
  18. BuildRequires: pam-devel
  19. BuildRequires: python-devel
  20. BuildRequires: python-rpm-macros
  21. BuildRequires: python3-devel
  22. BuildRequires: python3-rpm-macros
  23. URL: https://fedorahosted.org/libpwquality/
  24. # we don't want to provide private python extension libs
  25. %define __provides_exclude_from ^(%{python_sitearch}|%{python3_sitearch})/.*\.so$.
  26. %description
  27. This is a library for password quality checks and generation
  28. of random passwords that pass the checks.
  29. This library uses the cracklib and cracklib dictionaries
  30. to perform some of the checks.
  31. %package devel
  32. Group: Development/Libraries
  33. Summary: Files needed for developing PAM-aware applications and modules for PAM
  34. Requires: libpwquality = %{version}-%{release}
  35. Requires: pkgconfig
  36. %description devel
  37. Files needed for development of applications using the libpwquality
  38. library.
  39. See the pwquality.h header file for the API.
  40. %package -n python-pwquality
  41. Group: Development/Libraries
  42. Summary: Python bindings for the libpwquality library
  43. Requires: libpwquality = %{version}-%{release}
  44. %description -n python-pwquality
  45. This is pwquality Python module that provides Python bindings
  46. for the libpwquality library. These bindings can be used
  47. for easy password quality checking and generation of random
  48. pronounceable passwords from Python applications.
  49. %package -n python3-pwquality
  50. Group: Development/Libraries
  51. Summary: Python bindings for the libpwquality library
  52. Requires: libpwquality = %{version}-%{release}
  53. %description -n python3-pwquality
  54. This is pwquality Python module that provides Python bindings
  55. for the libpwquality library. These bindings can be used
  56. for easy password quality checking and generation of random
  57. pronounceable passwords from Python applications.
  58. %prep
  59. %setup -q
  60. rm -rf %{py3dir}
  61. cp -a . %{py3dir}
  62. %build
  63. %configure \
  64. --with-securedir=%{_moduledir} \
  65. --with-pythonsitedir=%{python_sitearch} \
  66. --with-python-binary=%{__python} \
  67. --disable-static
  68. make %{?_smp_mflags}
  69. pushd %{py3dir}
  70. %configure \
  71. --with-securedir=%{_moduledir} \
  72. --with-pythonsitedir=%{python3_sitearch} \
  73. --with-python-binary=%{__python3} \
  74. --disable-static
  75. make %{?_smp_mflags}
  76. popd
  77. %install
  78. make install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
  79. pushd %{py3dir}
  80. make -C python install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
  81. popd
  82. pushd $RPM_BUILD_ROOT%{_libdir}
  83. mv libpwquality.so.* $RPM_BUILD_ROOT/%{_lib}/
  84. ln -sf ../../%{_lib}/libpwquality.so.*.* libpwquality.so
  85. popd
  86. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  87. rm -f $RPM_BUILD_ROOT%{_moduledir}/*.la
  88. mkdir $RPM_BUILD_ROOT%{_secconfdir}/pwquality.conf.d
  89. %find_lang libpwquality
  90. %check
  91. # Nothing yet
  92. %post -p /sbin/ldconfig
  93. %postun -p /sbin/ldconfig
  94. %files -f libpwquality.lang
  95. %defattr(-,root,root,-)
  96. %{!?_licensedir:%global license %%doc}
  97. %license COPYING
  98. %doc README NEWS AUTHORS
  99. %{_bindir}/pwmake
  100. %{_bindir}/pwscore
  101. %{_moduledir}/pam_pwquality.so
  102. /%{_lib}/libpwquality.so.*
  103. %config(noreplace) %{_secconfdir}/pwquality.conf
  104. %{_mandir}/man1/*
  105. %{_mandir}/man5/*
  106. %{_mandir}/man8/*
  107. %files devel
  108. %defattr(-,root,root,-)
  109. %{_includedir}/pwquality.h
  110. %{_libdir}/libpwquality.so
  111. %{_libdir}/pkgconfig/*.pc
  112. %{_mandir}/man3/*
  113. %files -n python-pwquality
  114. %defattr(-,root,root,-)
  115. %{python_sitearch}/pwquality.so
  116. %{python_sitearch}/*.egg-info
  117. %files -n python3-pwquality
  118. %defattr(-,root,root,-)
  119. %{python3_sitearch}/*.so
  120. %{python3_sitearch}/*.egg-info
  121. %changelog
  122. * Sun Apr 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.2-1
  123. - new upstream release.
  124. - dropped Patch1: fixed in upstream.
  125. * Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.0-1
  126. - new upstream release.
  127. - added python3 support.
  128. * Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.0-1
  129. - new upstream release
  130. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
  131. - new upstream release
  132. * Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.3-2
  133. - rebuild with VineSeed environment
  134. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.3-1
  135. - new upstream release
  136. * Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
  137. - initial build for Vine Linux
  138. * Thu Aug 16 2012 Tomas Mraz <tmraz@redhat.com> 1.2.0-1
  139. - add maxsequence check for too long monotonic character sequence.
  140. - clarified alternative licensing to GPLv2+.
  141. - add local_users_only option to skip the pwquality checks for
  142. non-locals. (thanks to Stef Walter)
  143. * Wed Jun 13 2012 Tomas Mraz <tmraz@redhat.com> 1.1.1-1
  144. - use rpm built-in filtering of provides (rhbz#830153)
  145. - remove strain debug fprintf() (rhbz#831567)
  146. * Thu May 24 2012 Tomas Mraz <tmraz@redhat.com> 1.1.0-1
  147. - fix leak when throwing PWQError exception
  148. - added pkgconfig file
  149. - call the simplicity checks before the cracklib check
  150. - add enforce_for_root option to the PAM module
  151. - updated translations from Transifex
  152. * Thu Dec 8 2011 Tomas Mraz <tmraz@redhat.com> 1.0.0-1
  153. - added a few additional password quality checks
  154. - bugfix in configuration file parsing
  155. * Fri Nov 11 2011 Tomas Mraz <tmraz@redhat.com> 0.9.9-1
  156. - added python bindings and documentation
  157. * Mon Oct 10 2011 Tomas Mraz <tmraz@redhat.com> 0.9-2
  158. - fixes for problems found in review (missing BR on pam-devel,
  159. License field, Source URL, Require pam, other cleanups)
  160. * Mon Oct 3 2011 Tomas Mraz <tmraz@redhat.com> 0.9-1
  161. - first spec file for libpwquality