libcap-ng-vl.spec 7.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define _unpackaged_files_terminate_build 1
  3. Summary: An alternate posix capabilities library
  4. Name: libcap-ng
  5. Version: 0.7.10
  6. Release: 1%{?_dist_release}
  7. Group: System Environment/Libraries
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: LGPLv2+
  11. URL: http://people.redhat.com/sgrubb/libcap-ng/
  12. Source0: http://people.redhat.com/sgrubb/libcap-ng/%{name}-%{version}.tar.gz
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  14. BuildRequires: kernel-headers >= 2.6.11
  15. BuildRequires: libattr-devel
  16. %description
  17. Libcap-ng is a library that makes using posix capabilities easier
  18. %package devel
  19. Summary: Header files for libcap-ng library
  20. License: LGPLv2+
  21. Group: Development/Libraries
  22. Requires: kernel-headers >= 2.6.11
  23. Requires: %{name} = %{version}-%{release}
  24. Requires: pkgconfig
  25. %description devel
  26. The libcap-ng-devel package contains the files needed for developing
  27. applications that need to use the libcap-ng library.
  28. %package python
  29. Summary: Python bindings for libcap-ng library
  30. License: LGPLv2+
  31. Group: Development/Libraries
  32. BuildRequires: python-devel swig
  33. BuildRequires: python-rpm-macros
  34. Requires: %{name} = %{version}-%{release}
  35. %description python
  36. The libcap-ng-python package contains the bindings so that libcap-ng
  37. and can be used by python applications.
  38. %package python3
  39. Summary: Python3 bindings for libcap-ng library
  40. License: LGPLv2+
  41. Group: Development/Libraries
  42. BuildRequires: python3-devel swig
  43. BuildRequires: python3-rpm-macros
  44. Requires: %{name} = %{version}-%{release}
  45. %description python3
  46. The libcap-ng-python3 package contains the bindings so that libcap-ng
  47. and can be used by python3 applications.
  48. %package utils
  49. Summary: Utilities for analysing and setting file capabilities
  50. License: GPLv2+
  51. Group: Development/Libraries
  52. Requires: %{name} = %{version}-%{release}
  53. %description utils
  54. The libcap-ng-utils package contains applications to analyse the
  55. posix capabilities of all the program running on a system. It also
  56. lets you set the file system based capabilities.
  57. %package -n compat32-%{name}
  58. Summary: An alternate posix capabilities library
  59. Requires: %{name} = %{version}-%{release}
  60. %description -n compat32-%{name}
  61. Libcap-ng is a library that makes using posix capabilities easier
  62. %package -n compat32-%{name}-devel
  63. Summary: Header files for libcap-ng library
  64. License: LGPLv2+
  65. Group: Development/Libraries
  66. Requires: %{name}-devel = %{version}-%{release}
  67. %description -n compat32-%{name}-devel
  68. The libcap-ng-devel package contains the files needed for developing
  69. applications that need to use the libcap-ng library.
  70. %prep
  71. %setup -q
  72. %build
  73. %configure --libdir=/%{_lib} --with-python --with-python3
  74. make %{?_smp_mflags}
  75. %install
  76. rm -rf $RPM_BUILD_ROOT
  77. make DESTDIR="${RPM_BUILD_ROOT}" install
  78. # Move the symlink
  79. rm -f $RPM_BUILD_ROOT/%{_lib}/%{name}.so
  80. mkdir -p $RPM_BUILD_ROOT%{_libdir}
  81. VLIBNAME=$(ls $RPM_BUILD_ROOT/%{_lib}/%{name}.so.*.*.*)
  82. LIBNAME=$(basename $VLIBNAME)
  83. ln -s ../../%{_lib}/$LIBNAME $RPM_BUILD_ROOT%{_libdir}/%{name}.so
  84. # Move the pkgconfig file
  85. mv $RPM_BUILD_ROOT/%{_lib}/pkgconfig $RPM_BUILD_ROOT%{_libdir}
  86. # Remove a couple things so they don't get picked up
  87. rm -f $RPM_BUILD_ROOT/%{_lib}/libcap-ng.la
  88. rm -f $RPM_BUILD_ROOT/%{_lib}/libcap-ng.a
  89. rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/_capng.a
  90. rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/_capng.la
  91. %check
  92. make check
  93. %clean
  94. rm -rf $RPM_BUILD_ROOT
  95. %post -p /sbin/ldconfig
  96. %postun -p /sbin/ldconfig
  97. %post -n compat32-%{name} -p /sbin/ldconfig
  98. %postun -n compat32-%{name} -p /sbin/ldconfig
  99. %files
  100. %defattr(-,root,root,-)
  101. %license COPYING.LIB
  102. %attr(0755,root,root) /%{_lib}/libcap-ng.so.*
  103. %files devel
  104. %defattr(-,root,root,-)
  105. %attr(0644,root,root) %{_mandir}/man3/*
  106. %attr(0644,root,root) %{_includedir}/cap-ng.h
  107. %attr(0755,root,root) %{_libdir}/libcap-ng.so
  108. %attr(0644,root,root) %{_datadir}/aclocal/cap-ng.m4
  109. %{_libdir}/pkgconfig/libcap-ng.pc
  110. %files python
  111. %defattr(-,root,root,-)
  112. %attr(755,root,root) /%{_libdir}/python?.?/site-packages/_capng.so
  113. %{python_sitearch}/capng.py*
  114. %files python3
  115. %defattr(-,root,root,-)
  116. %attr(755,root,root) %{python3_sitearch}/*
  117. %{python3_sitearch}/capng.py*
  118. %files utils
  119. %defattr(-,root,root,-)
  120. %doc COPYING
  121. %attr(0755,root,root) %{_bindir}/*
  122. %attr(0644,root,root) %{_mandir}/man8/*
  123. %if %{build_compat32}
  124. %files -n compat32-%{name}
  125. %defattr(-,root,root,-)
  126. %attr(0755,root,root) /%{_lib}/libcap-ng.so.*
  127. %files -n compat32-%{name}-devel
  128. %defattr(-,root,root,-)
  129. %attr(0755,root,root) %{_libdir}/libcap-ng.so
  130. %{_libdir}/pkgconfig/libcap-ng.pc
  131. %endif
  132. %changelog
  133. * Sun Apr 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.7.10-1
  134. - new upstream release.
  135. * Tue Feb 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.7.9-1
  136. - new upstream release.
  137. - added compat32-* packages.
  138. - enabled python3 modules.
  139. * Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.3-2
  140. - rebuild with VineSeed environment
  141. * Mon Jan 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.3-1
  142. - new upstream release
  143. * Sun Oct 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.1-1
  144. - new upstream release
  145. * Mon Feb 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.6-2
  146. - rebuild with python-2.7.2
  147. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.6-1
  148. - initial build for Vine Linux
  149. * Fri Jun 24 2011 Steve Grubb <sgrubb@redhat.com> 0.6.6-1
  150. - New upstream release
  151. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.5-2
  152. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  153. * Wed Nov 03 2010 Steve Grubb <sgrubb@redhat.com> 0.6.5-1
  154. - New upstream release fixing 2.6.36 kernel header issue
  155. * Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 0.6.4-4
  156. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  157. * Thu Jun 17 2010 Steve Grubb <sgrubb@redhat.com> 0.6.4-3
  158. - Only open regular files in filecap
  159. * Mon May 24 2010 Steve Grubb <sgrubb@redhat.com> 0.6.4-2
  160. - In utils subpackage added a requires statement.
  161. * Thu May 06 2010 Steve Grubb <sgrubb@redhat.com> 0.6.4-1
  162. - New upstream release fixing multi-threading issue
  163. * Wed Apr 28 2010 Steve Grubb <sgrubb@redhat.com> 0.6.3-2
  164. - filecap shows full capabilities if a file has any
  165. * Thu Mar 11 2010 Steve Grubb <sgrubb@redhat.com> 0.6.3-1
  166. - New upstream release
  167. * Tue Feb 16 2010 Steve Grubb <sgrubb@redhat.com> 0.6.2-4
  168. - Use global macro and require pkgconfig for devel subpackage
  169. * Fri Oct 09 2009 Steve Grubb <sgrubb@redhat.com> 0.6.2-3
  170. - Apply patch to retain setpcap only if clearing bounding set
  171. * Sat Oct 03 2009 Steve Grubb <sgrubb@redhat.com> 0.6.2-2
  172. - Apply patch correcting pscap and netcap acct detection
  173. * Mon Sep 28 2009 Steve Grubb <sgrubb@redhat.com> 0.6.2-1
  174. - New upstream release
  175. * Sun Jul 26 2009 Steve Grubb <sgrubb@redhat.com> 0.6.1-1
  176. - New upstream release
  177. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6-2
  178. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  179. * Mon Jun 29 2009 Steve Grubb <sgrubb@redhat.com> 0.6-1
  180. - New upstream release
  181. * Sun Jun 21 2009 Steve Grubb <sgrubb@redhat.com> 0.5.1-1
  182. - New upstream release
  183. * Fri Jun 19 2009 Steve Grubb <sgrubb@redhat.com> 0.5-1
  184. - New upstream release
  185. * Fri Jun 12 2009 Steve Grubb <sgrubb@redhat.com> 0.4.2-1
  186. - New upstream release
  187. * Fri Jun 12 2009 Steve Grubb <sgrubb@redhat.com> 0.4.1-1
  188. - Initial build.