module-init-tools-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543
  1. Summary: Kernel module management utilities.
  2. Summary(ja): カーネルモジュール管理ユーティリティ
  3. Name: module-init-tools
  4. Version: 3.12
  5. Release: 1%{?_dist_release}
  6. License: GPLv2+
  7. Group: System Environment/Kernel
  8. Source: http://www.kernel.org/pub/linux/utils/kernel/module-init-tools/module-init-tools-%{version}.tar.bz2
  9. Source1: http://www.kernel.org/pub/linux/utils/kernel/module-init-tools/module-init-tools-%{version}.tar.bz2.sign
  10. Source2: modprobe-dist.conf
  11. Source3: weak-modules
  12. Source4: depmod-dist.conf
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: zlib-devel, docbook-utils
  15. BuildRequires: zlib-static
  16. Exclusiveos: Linux
  17. Requires(post): chkconfig, coreutils
  18. Obsoletes: modutils-devel, modutils
  19. Provides: modutils = %{version}
  20. %description
  21. The module-init-tools package includes various programs needed for automatic
  22. loading and unloading of modules under 2.6 and later kernels, as well
  23. as other module management programs. Device drivers and filesystems
  24. are two examples of loaded and unloaded modules.
  25. %description -l ja
  26. module-init-tools パッケージには,バージョン 2.6 以上の kernel モジュールを
  27. 自動的にロード/アンロードする為の様々なプログラムや,モジュール管理の
  28. 為のプログラムなどが収められています.モジュールとしては,デバイスドライバ,
  29. ファイルシステム,その他が挙げられます.
  30. %prep
  31. %setup -q
  32. %build
  33. export CC=gcc
  34. export CFLAGS="$RPM_OPT_FLAGS -DCONFIG_NO_BACKWARDS_COMPAT=1"
  35. %configure --enable-zlib
  36. make
  37. %install
  38. rm -rf $RPM_BUILD_ROOT
  39. %makeinstall sbindir=$RPM_BUILD_ROOT/sbin
  40. install -m 755 generate-modprobe.conf \
  41. $RPM_BUILD_ROOT/sbin
  42. install -m 644 modprobe.conf.5 \
  43. $RPM_BUILD_ROOT/%{_mandir}/man5/modprobe.d.5
  44. install -m 644 depmod.conf.5 \
  45. $RPM_BUILD_ROOT/%{_mandir}/man5/depmod.d.5
  46. mkdir -p $RPM_BUILD_ROOT/etc
  47. mkdir -p $RPM_BUILD_ROOT/etc/modprobe.d
  48. install -m 644 %{SOURCE2} $RPM_BUILD_ROOT/etc/modprobe.d/modprobe-dist.conf
  49. install -m 755 %{SOURCE3} $RPM_BUILD_ROOT/sbin/weak-modules
  50. mkdir -p $RPM_BUILD_ROOT/etc/depmod.d
  51. install -m 644 %{SOURCE4} $RPM_BUILD_ROOT/etc/depmod.d/depmod-dist.conf
  52. mv $RPM_BUILD_ROOT/%{_bindir}/lsmod $RPM_BUILD_ROOT/sbin
  53. touch $RPM_BUILD_ROOT/etc/modprobe.d/modprobe.conf
  54. %clean
  55. rm -rf $RPM_BUILD_ROOT
  56. %post
  57. if [ -f /etc/modprobe.conf -a ! -f /etc/modprobe.d/modprobe.conf ] ; then
  58. mv -f /etc/modprobe.conf /etc/modprobe.d/modprobe.conf
  59. fi
  60. %files
  61. %defattr(-,root,root)
  62. /etc/modprobe.d
  63. /etc/depmod.d
  64. /sbin/*
  65. %{_mandir}/*/*
  66. %ghost %config(noreplace) %verify(not md5 size mtime) /etc/modprobe.d/modprobe.conf
  67. %changelog
  68. * Wed Apr 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.12-1
  69. - new upstream release
  70. * Tue May 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8-4
  71. - remove kernel 2.4 compatibility from %%post
  72. * Wed May 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8-3
  73. - move /etc/modprobe.conf to /etc/modprobe.d/modprobe.conf
  74. * Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8-2
  75. - rename /etc/modprobe.d/{depmod,modprobe}.conf.dist to
  76. {depmod,modprobe}-dist.conf
  77. * Sun May 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8-1
  78. - new upstream release
  79. - add BR: zlib-static
  80. * Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6-1
  81. - new upstream release
  82. - rename to module-init-tools
  83. - Provides: modutils, Obsoletes: modules, modutils-devel
  84. - drop modutils compatibility support
  85. * Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 3.2.2-1vl5
  86. - applied new versioning policy, spec in utf-8
  87. * Mon Oct 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.2-0vl4
  88. - add Patch102 to build with gcc4
  89. - enable combined-rmmod for insmod.static (initramfs needs rmmod)
  90. * Sun Oct 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.2-0vl3
  91. - update modprobe.conf.dist
  92. - load mmc_block when sdhci is loaded
  93. * Sun Aug 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.2-0vl2
  94. - enable %%build_small
  95. - add modutils-devel subpackage for internal use.
  96. * Sun Mar 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.2-0vl1
  97. - update module-init-tools-3.2.2
  98. - use module-init-tools version for package version
  99. - update modprobe.conf.dist, move to /etc/modprobe.d
  100. - remove "include" statement from /etc/modprobe.conf if found.
  101. * Thu May 6 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.27-0vl1
  102. - new upstream release
  103. - modutils-2.4.27
  104. - module-init-tools-3.0
  105. - import fedora fixes
  106. * Wed May 5 2004 Bill Nottingham <notting@redhat.com> 2.4.26-16
  107. - fix sound restoring on module load when done via OSS compat
  108. * Thu Apr 15 2004 Bill Nottingham <notting@redhat.com> 2.4.26-15
  109. - don't buildreq autoconf-2.13 (#116770)
  110. - sound-slot-0/snd-card-0 hacking-around
  111. * Mon Mar 29 2004 Bill Nottingham <notting@redhat.com> 2.4.26-14
  112. - modinfo: use new modinfo if passed <foo>.ko
  113. * Tue Mar 23 2004 Steve Dickson <SteveD@RedHat.com>
  114. - Added the mounting of /proc/fs/nfsd to modprobe.conf.dist
  115. so it gets mounted when nfsd is loaded.
  116. * Tue Mar 16 2004 Steve Dickson <SteveD@RedHat.com>
  117. - /var/lib/nfs/rpc_pipefs not /var/lib/rpc_pipes should be
  118. mounted when sunrpc is loaded.
  119. * Fri Mar 12 2004 Steve Dickson <SteveD@RedHat.com>
  120. - umount rpc_pipefs when sunrpc is unloaded
  121. * Thu Mar 11 2004 Bill Nottingham <notting@redhat.com> 2.4.26-9
  122. - add nfsv4 aliases to modprobe.conf.dist
  123. - clean out upstreamed aliases in modprobe.conf.dist
  124. - mount rpc_pipefs when sunrpc is loaded
  125. * Fri Mar 5 2004 Bill Nottingham <notting@redhat.com> 2.4.26-7
  126. - blacklist eth1394 (#117383)
  127. * Mon Feb 23 2004 Bill Nottingham <notting@redhat.com> 2.4.26-6
  128. - update module-init-tools to 3.0pre10
  129. - fix modinfo (#116305)
  130. - always include /etc/modprobe.conf.dist (don't require the line in modprobe.conf)
  131. - ship a static modprobe.conf.dist, don't generate it at build time
  132. - clean up modprobe.conf.dist a little (#113772, #113768)
  133. * Wed Feb 11 2004 Bill Nottingham <notting@redhat.com>
  134. - don't use trampolines in insmod, working around #106005
  135. * Thu Jan 29 2004 Bill Nottingham <notting@redhat.com> 2.4.26-3
  136. - fix irda (#114268), bluetooth (#114019) and alsa aliases
  137. * Wed Jan 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.4.26-2vl1
  138. - syncd with fedora
  139. * Fri Nov 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.26-0vl1
  140. - new upstream release
  141. * Thu May 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.25-0vl1
  142. - new upstream release
  143. * Tue Dec 10 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.22-0vl3
  144. - enable build with dietlibc also on ppc and alpha
  145. * Tue Dec 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.22-0vl2
  146. - enable zlib
  147. - remove pre-defined "above"s. it's not needed for Vine Linux.
  148. * Sun Dec 8 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.22-0vl1
  149. - new upstream release
  150. * Sun Sep 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.20-0vl1
  151. - new upstream release
  152. * Thu Jul 18 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.16-1vl2
  153. - BuildPreReq: dietlibc for ix86 only
  154. * Tue Jul 09 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.16-1vl1
  155. - new upstream release
  156. * Sun May 05 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.14-1vl2
  157. - rebuild with diet.
  158. - merged with Skipjack.
  159. * Mon Apr 1 2002 Bill Nottingham <notting@redhat.com> 2.4.14-2
  160. - fix support for symbols that contain _R (<streeter@redhat.com>)
  161. * Thu Mar 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.4.14-1vl1
  162. - source update
  163. * Sat Mar 2 2002 Bill Nottingham <notting@redhat.com> 2.4.14-1
  164. - update to 2.4.14
  165. - take out genksyms.old, no more buildprereq for gperf
  166. * Thu Feb 28 2002 Bill Nottingham <notting@redhat.com> 2.4.13-7/8
  167. - rebuild against diet
  168. - reenable rmmod in the library version, shrink it too
  169. * Wed Feb 27 2002 Bill Nottingham <notting@redhat.com> 2.4.13-5
  170. - rebuild in earlier environments
  171. * Fri Feb 22 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.4.13-4vl1
  172. - modified for Vine
  173. - merged devel-package with parent package
  174. * Sun Feb 10 2002 Bill Nottingham <notting@redhat.com> 2.4.13-4
  175. - various space shavings in -devel
  176. * Fri Feb 8 2002 Bill Nottingham <notting@redhat.com> 2.4.13-3
  177. - bump rev
  178. - buildprereq gperf
  179. * Mon Feb 4 2002 Bill Nottingham <notting@redhat.com> 2.4.13-1
  180. - update to 2.4.13
  181. - fix GPL symbol export
  182. * Wed Jan 30 2002 Bill Nottingham <notting@redhat.com> 2.4.12-9
  183. - shrink insmod.static
  184. * Thu Jan 24 2002 Bill Nottingham <notting@redhat.com> 2.4.12-8
  185. - fix installation of extra libraries (#58427)
  186. * Thu Jan 17 2002 Bill Nottingham <notting@redhat.com> 2.4.12-7
  187. - hack to allow depmod of 64bit kernels on 32bit PPC
  188. * Tue Jan 15 2002 Bill Nottingham <notting@redhat.com> 2.4.12-6
  189. - more ppc64 fixes
  190. * Thu Jan 10 2002 Bill Nottingham <notting@redhat.com> 2.4.12-5
  191. - fix build on combined 32/64 targets (ppc/sparc)
  192. * Tue Dec 11 2001 Matt Wilson <msw@redhat.com>
  193. - added a -devel subpackage that contains libraries that apps can use
  194. to implement insmod and rmmod
  195. * Tue Dec 4 2001 Bill Nottingham <notting@redhat.com>
  196. - get rid of some obsolete patches, other tweaks
  197. * Thu Nov 29 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  198. - update to 2.4.12
  199. * Sat Nov 17 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  200. - update to 2.4.11
  201. * Tue Oct 2 2001 Bill Nottingham <notting@redhat.com>
  202. - update to 2.4.10
  203. - deprecate -i, -m arguments to depmod
  204. * Tue Sep 25 2001 Bill Nottingham <notting@redhat.com>
  205. - update to 2.4.9
  206. * Wed Aug 29 2001 Bill Nottingham <notting@redhat.com>
  207. - replace modutils-2.4.6-error patch with version that was integrated
  208. upstream
  209. * Sat Aug 18 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  210. - disable char-major-4 for s390/s390x
  211. * Mon Jul 8 2001 Bill Nottingham <notting@redhat.com>
  212. - remove /etc/cron.d/kmod
  213. * Fri Jul 6 2001 Bill Nottingham <notting@redhat.com>
  214. - update to 2.4.6
  215. - alias binfmt-0000 off (#9709)
  216. - turn off 'modules.conf is more recent than modules.dep' message (#14276,
  217. others)
  218. - return nonzero from depmod if there are errors (#40935)
  219. - fix manpage typo (#33123)
  220. * Thu Jul 05 2001 Karsten Hopp <karsten@redhat.de>
  221. - new S390 patch from IBM
  222. * Tue Jun 26 2001 Elliot Lee <sopwith@redhat.com> 2.4.5-3
  223. - Add modutils-2.4.5-stblocal.patch from Jakub. See the e-mail message
  224. inside the patch file for details.
  225. - Use smp_mflags macro
  226. * Thu Jun 21 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  227. - add s390/s390x support
  228. * Tue Apr 24 2001 Bill Nottingham <notting@redhat.com>
  229. - update to 2.4.5
  230. * Tue Mar 6 2001 Bill Nottingham <notting@redhat.com>
  231. - add default post/preun for binfmt_misc
  232. * Mon Feb 19 2001 Bill Nottingham <notting@redhat.com>
  233. - change ipv6 alias to 'alias net-pf-10 off'
  234. * Tue Feb 13 2001 Bill Nottingham <notting@redhat.com>
  235. - add 'net-pf-10 ipv6' alias (#25405)
  236. * Sun Jan 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  237. - change "#ifdef s390" -> "#if defined(__s390__) || defined(__s390x__)"
  238. * Tue Jan 23 2001 Bill Nottingham <notting@redhat.com>
  239. - update to 2.4.2
  240. - ship a genksyms.old
  241. * Fri Jan 19 2001 Bill Nottingham <notting@redhat.com>
  242. - fix ppp aliases
  243. * Tue Jan 9 2001 Bill Nottingham <notting@redhat.com>
  244. - oops, I blew away other people's changes. Fix that.
  245. - only have tty-ldisc-11 in the aliases once
  246. * Mon Jan 8 2001 Bill Nottingham <notting@redhat.com>
  247. - update to 2.4.0
  248. - tweak irda aliases
  249. - remove vixie-cron dependency (it's not *required*)
  250. - add missing %build (where did that go?)
  251. * Sun Jan 7 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  252. - 2.4.0
  253. - Get rid of obsolete char-major-60==ircom-tty patch
  254. (moved to 161)
  255. * Sat Jan 06 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  256. - add "ctc{0,1,2} -> ctc" alias for s390
  257. * Sat Dec 23 2000 Bill Nottingham <notting@redhat.com>
  258. - add missing comma in alias list
  259. - add irda aliases
  260. * Tue Dec 12 2000 Bill Nottingham <notting@redhat.com>
  261. - add char-major-108 ppp_async alias
  262. * Mon Dec 11 2000 Bill Nottingham <notting@redhat.com>
  263. - fix ide-probe aliases (now ide-probe-mod)
  264. * Wed Nov 22 2000 Matt Wilson <msw@redhat.com>
  265. - 2.3.21, fixes more security problems.
  266. * Thu Nov 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  267. - 2.3.20, fixes security holes
  268. * Tue Oct 31 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  269. - 2.3.19
  270. - add IrDA devices to alias patch
  271. - update source URL
  272. * Thu Oct 26 2000 Bill Nottingham <notting@redhat.com>
  273. - fix ia64 module loading
  274. * Mon Oct 2 2000 Bill Nottingham <notting@redhat.com>
  275. - stupid ia64 tricks
  276. * Fri Sep 29 2000 Jeff Johnson <jbj@redhat.com>
  277. - upgrade to 2.3.17.
  278. - sparc64 ELF hacks.
  279. * Mon Aug 21 2000 Michael K. Johnson <johnsonm@redhat.com>
  280. - Use %{_mandir} for removing kerneld-related man pages.
  281. * Wed Aug 9 2000 Jakub Jelinek <jakub@redhat.com>
  282. - fix build on SPARC
  283. * Tue Aug 8 2000 Jakub Jelinek <jakub@redhat.com>
  284. - update to 2.3.14
  285. * Tue Jul 25 2000 Bill Nottingham <notting@redhat.com>
  286. - update to 2.3.13
  287. - turn psaux off again
  288. - remove sound patch; it's obsolete
  289. * Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
  290. - rebuild to cope with glibc locale binary incompatibility
  291. * Thu Jul 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  292. - 2.3.12
  293. - fix up ia64
  294. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  295. - automatic rebuild
  296. * Sat Jul 1 2000 Florian La Roche <laroche@redhat.com>
  297. - add aliases for cipcb[0-3]
  298. * Wed Jun 14 2000 Matt Wilson <msw@redhat.com>
  299. - fix build on combined 32/64 bit sparc
  300. * Thu Jun 1 2000 Bill Nottingham <notting@redhat.com>
  301. - modules.confiscation
  302. * Wed May 17 2000 Bill Nottingham <notting@redhat.com>
  303. - add ia64 patch from Intel
  304. * Wed May 17 2000 Jakub Jelinek <jakub@redhat.com>
  305. - fix build with glibc 2.2
  306. * Tue May 09 2000 Doug Ledford <dledford@redhat.com>
  307. - Correct %description to reflect that we don't build kerneld by default
  308. * Fri Apr 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  309. - 2.3.11
  310. * Mon Apr 3 2000 Bill Nottingham <notting@redhat.com>
  311. - fix net-pf-* aliases for ipx, appletalk
  312. * Fri Mar 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  313. - 2.3.10
  314. * Thu Feb 17 2000 Matt Wilson <msw@redhat.com>
  315. - added alias for agpgart
  316. * Mon Feb 14 2000 Bill Nottingham <notting@redhat.com>
  317. - hardcode psaux alias to off everywhere
  318. * Thu Feb 3 2000 Bill Nottingham <notting@redhat.com>
  319. - add a symlink from conf.modules.5 to modules.conf.5
  320. * Fri Jan 29 2000 Bill Nottingham <notting@redhat.com>
  321. - fix breakage *correctly*
  322. * Sat Jan 22 2000 Bill Nottingham <notting@redhat.com>
  323. - fix breakage of our own cause w.r.t sound modules
  324. * Thu Jan 06 2000 Jakub Jelinek <jakub@redhat.com>
  325. - update to 2.3.9.
  326. - port RH patches from 2.1.121 to 2.3.9 where needed.
  327. - disable warning about conf.modules for now, in 7.0
  328. we should move to modules.conf.
  329. * Wed Oct 13 1999 Jakub Jelinek <jakub@redhat.com>
  330. - hardcode psaux alias on sparc to off.
  331. * Tue Oct 05 1999 Bill Nottingham <notting@redhat.com>
  332. - hardcode parport aliases....
  333. * Mon Oct 04 1999 Cristian Gafton <gafton@redhat.com>
  334. - rebuild against new glibc in the sparc tree
  335. * Wed Sep 15 1999 Jakub Jelinek <jakub@redhat.com>
  336. - rewrite sparckludge so that separate *64 binaries
  337. are not needed anymore.
  338. * Sat Sep 11 1999 Cristian Gafton <gafton@redhat.com>
  339. - apply the last patch in the %prep section (doh!)
  340. * Mon Apr 19 1999 Cristian Gafton <gafton@redhat.com>
  341. - add support for the ppp compression modules by default
  342. * Tue Apr 13 1999 Michael K. Johnson <johnsonm@redhat.com>
  343. - add cron.d file to run rmmod -as
  344. * Fri Apr 09 1999 Cristian Gafton <gafton@redhat.com>
  345. - take out kerneld
  346. * Mon Apr 05 1999 Cristian Gafton <gafton@redhat.com>
  347. - add patch to make all raid personalities recognized
  348. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  349. - auto rebuild in the new build environment (release 7)
  350. * Thu Mar 18 1999 Cristian Gafton <gafton@redhat.com>
  351. - obsoletes modules
  352. - get rid of the /lib/modules/preferred hack
  353. * Mon Mar 15 1999 Bill Nottingham <notting@redhat.com>
  354. - added support for /lib/modules/foo/pcmcia
  355. - make kerneld initscript not start by default
  356. * Tue Feb 23 1999 Matt Wilson <msw@redhat.com>
  357. - added sparc64 support from UltraPenguin
  358. * Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
  359. - call libtoolize to allow it to compile on the arm
  360. * Wed Dec 23 1998 Jeff Johnson <jbj@redhat.com>
  361. - search /lib/modules/preferred before defaults but after specified paths.
  362. * Tue Nov 17 1998 Cristian Gafton <gafton@redhat.com>
  363. - upgraded to version 2.1.121
  364. * Thu Nov 05 1998 Erik Troan <ewt@redhat.com>
  365. - added -m, -i options
  366. * Thu Oct 01 1998 Michael K. Johnson <johnsonm@redhat.com>
  367. - fix syntax error I introduced when enhancing initscript
  368. * Wed Sep 30 1998 Michael K. Johnson <johnsonm@redhat.com>
  369. - enhance initscript
  370. * Fri Aug 28 1998 Jeff Johnson <jbj@redhat.com>
  371. - recompile statically linked binary for 5.2/sparc
  372. * Tue Jul 28 1998 Jeff Johnson <jbj@redhat.com>
  373. - pick up ultrapenguin patches (not applied for now).
  374. - pre-generate keyword.c so gperf doesn't have to be present (not applied).
  375. - util/sys_cm.c: fix create_module syscall (signed return on sparc too)
  376. * Wed Jul 15 1998 Jeff Johnson <jbj@redhat.com>
  377. - correct %postun typos
  378. * Fri May 01 1998 Erik Troan <ewt@redhat.com>
  379. - added /lib/modules/preferred to search path
  380. * Fri Apr 24 1998 Prospector System <bugs@redhat.com>
  381. - translations modified for de, fr, tr
  382. * Tue Apr 07 1998 Cristian Gafton <gafton@redhat.com>
  383. - updated to 2.1.85
  384. - actually make use of the BuildRoot
  385. * Fri Apr 3 1998 Jakub Jelinek <jj@ultra.linux.cz>
  386. - Fix sparc64, add modinfo64 on sparc.
  387. * Wed Mar 23 1998 Jakub Jelinek <jj@ultra.linux.cz>
  388. - Handle EM_SPARCV9, kludge to support both 32bit and 64bit kernels
  389. from the same package on sparc/sparc64.
  390. * Fri Nov 7 1997 Michael Fulbright
  391. - removed warning message when conf.modules exists and is a empty
  392. * Tue Oct 28 1997 Erik Troan <ewt@redhat.com>
  393. - patched to honor -k in options
  394. - added modprobe.1
  395. - added init script
  396. * Thu Oct 23 1997 Erik Troan <ewt@redhat.com>
  397. - removed bogus strip of lsmod (which is a script)
  398. * Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
  399. - updated to 2.1.55
  400. - builds in a buildroot
  401. * Mon Aug 25 1997 Erik Troan <ewt@redhat.com>
  402. - added insmod.static
  403. * Sun Aug 24 1997 Erik Troan <ewt@redhat.com>
  404. - built on Intel
  405. - combined rmmod and insmod