tk-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347
  1. Summary: A Tcl/Tk development environment: tk
  2. Summary(ja): Tcl/Tk 開発環境: tk
  3. Name: tk
  4. Version: 8.6.13
  5. %global majorver %(echo %{version} | sed -e 's/\.[0-9]*$//')
  6. %global minorver %(echo %{version} | sed -e 's/^.*\.//')
  7. Release: 1%{?_dist_release}
  8. Group: programming
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. License: TCL
  12. URL: https://tcl.sourceforge.net/
  13. Source0: https://prdownloads.sourceforge.net/tcl/%{name}%{version}-src.tar.gz
  14. # https://core.tcl-lang.org/tk/tktview/dccd82bdc70dc25bb6709a6c14880a92104dda43
  15. Patch3: tk-8.6.10-font-sizes-fix.patch
  16. Buildroot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: autoconf
  18. BuildRequires: libX11-devel
  19. BuildRequires: libXft-devel
  20. BuildRequires: tcl-devel = %{version}
  21. Requires: tcl >= %{majorver}
  22. Provides: libtk%{majorver}.so
  23. %description
  24. Tk is a X Windows widget set designed to work closely with the tcl
  25. scripting language. It allows you to write simple programs with full
  26. featured GUI's in only a little more time then it takes to write a
  27. text based interface. Tcl/Tk applications can also be run on Windows
  28. and Macintosh platforms.
  29. %description -l ja
  30. Tk は tcl スクリプト言語と密接に動作するようにデザインされた X Window
  31. System のウィジェットセットです。 テキストベースのインターフェースを
  32. 採用してるので、あらゆる特徴をもった GUI を少ない時間で、簡単なプログラ
  33. ムで書くことができます。Tcl/Tk アプリケーションは Windows や Macintosh
  34. のプラットフォームで実行することもできます。
  35. %package devel
  36. Summary: Tk graphical toolkit development files
  37. Summary(ja): Tk ツールキットの開発環境
  38. Group: programming
  39. Requires: %{name} = %{version}-%{release}
  40. Requires: tcl-devel = %{version}
  41. Requires: libX11-devel
  42. Requires: libXft-devel
  43. %description devel
  44. Tk is a X Windows widget set designed to work closely with the tcl
  45. scripting language. It allows you to write simple programs with full
  46. featured GUI's in only a little more time then it takes to write a
  47. text based interface. Tcl/Tk applications can also be run on Windows
  48. and Macintosh platforms.
  49. The package contains the development files and man pages for tk.
  50. %debug_package
  51. %prep
  52. %setup -n %{name}%{version} -q
  53. sed -i -e 's/555/755/g' unix/Makefile.in
  54. sed -i -e 's/@SHLIB_LD@/@SHLIB_LD@ -fPIC -Wl,-soname,libtk%{majorver}.so/' unix/Makefile.in
  55. %build
  56. cd unix
  57. autoconf
  58. export CFLAGS="%{optflags} -fPIC"
  59. %configure \
  60. --disable-rpath \
  61. --enable-threads
  62. make %{?_smp_mflags} TK_LIBRARY=%{_datadir}/%{name}%{majorver}
  63. %install
  64. rm -rf $RPM_BUILD_ROOT
  65. make install -C unix INSTALL_ROOT=$RPM_BUILD_ROOT TK_LIBRARY=%{_datadir}/%{name}%{majorver}
  66. ln -s wish%{majorver} $RPM_BUILD_ROOT%{_bindir}/wish
  67. # for linking with -l%{name}
  68. ln -s lib%{name}%{majorver}.so $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so
  69. mkdir -p $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/{generic/ttk,unix}
  70. find generic unix -name "*.h" -exec cp -p '{}' $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/'{}' ';'
  71. ( cd $RPM_BUILD_ROOT/%{_includedir}
  72. for i in *.h ; do
  73. [ -f $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/generic/$i ] && ln -sf ../../$i $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/generic ;
  74. done
  75. )
  76. # remove buildroot traces
  77. sed -i -e "s|$PWD/unix|%{_libdir}|; s|$PWD|%{_includedir}/%{name}-private|" $RPM_BUILD_ROOT/%{_libdir}/%{name}Config.sh
  78. rm -rf $RPM_BUILD_ROOT/%{_datadir}/%{name}%{majorver}/tkAppInit.c
  79. rm -rf $RPM_BUILD_ROOT/%{_datadir}/%{name}%{majorver}/prolog.ps
  80. %clean
  81. rm -rf $RPM_BUILD_ROOT
  82. %files
  83. %defattr(-,root,root,-)
  84. %license license.terms
  85. %doc README changes
  86. %{_bindir}/wish*
  87. %{_datadir}/tk%{majorver}
  88. %{_libdir}/libtk%{majorver}.so
  89. %{_libdir}/tk%{majorver}
  90. %{_libdir}/tkConfig.sh
  91. %{_mandir}/man1/*
  92. %{_mandir}/mann/*
  93. %files devel
  94. %defattr(-,root,root)
  95. %{_includedir}/*
  96. %{_libdir}/libtk.so
  97. %{_libdir}/libtkstub%{majorver}.a
  98. %{_libdir}/tkConfig.sh
  99. %{_libdir}/pkgconfig/tk.pc
  100. %{_mandir}/man3/*
  101. %changelog
  102. * Sat Oct 21 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.6.13-1
  103. - new upstream release.
  104. - dropped ldconfig scriptlets.
  105. - imported Patch3 from rawhide.
  106. * Wed Jul 01 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.6.10-1
  107. - new upstream release.
  108. * Fri Oct 04 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.6.9-1
  109. - new upstream release.
  110. - dropped Patch102: get same effects by sed and configure options.
  111. - dropped Patch101: get same effects by sed.
  112. - dropped Patch103: fixed in upstream.
  113. - dropped Patch105: fixed in upstream.
  114. * Mon Jan 26 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.5.15-2
  115. - split development files into devel subpackage
  116. - added BR: libXft-devel
  117. * Wed Jan 15 2014 NAKAMURA Kenta <kenta@vinelinux.org> 8.5.15-1
  118. - new upstream release
  119. - drop obsolete patche (Patch104)
  120. * Fri Jan 4 2013 IWAI, Masaharu <iwai@alib.jp> 8.5.7-1
  121. - update to 5.8.7: sync Red Hat Enterprise Linux 6 tk-8.4.19-4vl6
  122. - update License: TCL
  123. - drop obsolete patches
  124. - lib-perm patch (Patch2)
  125. - lastevent patch (Patch3)
  126. - tkBind patch (Patch4)
  127. - add some patches from RHEL tk-8.5.7-6.el6
  128. - make patch (Patch101)
  129. - conf patch (Patch102)
  130. - seg_input patch (Patch103)
  131. - color patch (Patch104)
  132. - nofont sigsegv patch (Patch105)
  133. - add some documents
  134. - update build and install section: sync RHEL tk-8.5.7-6.el6
  135. * Thu Apr 21 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.4.19-4
  136. - added "BuildRequires: imake".
  137. * Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.19-3
  138. - rebuilt with rpm-4.8.1-3
  139. * Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.19-2
  140. - rebuilt with tcl-8.4.19-2
  141. - dropt Patch4: tk-8.4.18-tkBind.patch
  142. * Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.19-1
  143. - new upstream release
  144. - add Patch3,4 to fix bug (broken if built with xproto-7.x)
  145. * Mon Jun 08 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.18-2
  146. - spec in utf-8
  147. * Mon May 12 2008 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.18-1
  148. - rebuild with xorg-x11-7.3
  149. - remove Requires: XFree86-libs
  150. - add BuildRequires: libX11-devel
  151. - use autoconf instead of autoconf217
  152. * Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.18-0vl1
  153. - updated tk to 8.4.18
  154. - included CVE-2008-0553
  155. * Mon Oct 08 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.16-0vl1
  156. - updated tk to 8.4.16
  157. * Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.15-0vl1
  158. - updated tk to 8.4.15
  159. - rebuilt with new toolchain
  160. * Wed May 10 2006 IWAI, Masaharu <iwai@alib.jp> 8.4.13-0vl1
  161. - updated tk to 8.4.13
  162. * Sat Jan 28 2006 Shu KONNO <owa@bg.wakwak.com> 8.4.12-0vl1
  163. - updated tk to 8.4.12
  164. - updated tk-%%{version}-lib-perm.patch
  165. * Fri Sep 09 2005 Shu KONNO <owa@bg.wakwak.com> 8.4.11-0vl1
  166. - dropped tk-8.3.5-tclm4-soname.patch (fixed tcl.m4)
  167. - replaced tk-8.4.4-lib-perm.patch with tk-8.4.11-lib-perm.patch
  168. - dropped tk-8.4.5-no_rpath.patch (fixed tcl.m4)
  169. - dropped tk-8.4.6-tkUnixWm.patch (fixed invalid 118n title)
  170. * Sat Jun 11 2005 Shu KONNO <owa@bg.wakwak.com> 8.4.6-0vl2
  171. - added tk-8.4.6-tkUnixWm.patch
  172. * Thu Jun 24 2004 Shu KONNO <owa@bg.wakwak.com> 8.4.6-0vl1
  173. - updated tk to 8.4.6
  174. * Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.5-3vl2
  175. - syncd with fedora
  176. * Fri Dec 12 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-3
  177. - add private header files needed to build tix in /usr/include/tk-private
  178. * Mon Dec 1 2003 Thomas Woerner <twoerner@redhat.com> 8.4.5-2
  179. - removed rpath (patch 3)
  180. * Thu Nov 27 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-1
  181. - new package split out from tcltk
  182. - update to tk 8.4.5 (#88429)
  183. - filtered changelog for tk
  184. - buildrequire autoconf213 (#110583) [mvd@mylinux.com.ua]
  185. - remove build remnants from tkConfig.sh
  186. * Tue Apr 01 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl2
  187. - fix buildrequires and requires section
  188. * Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl1
  189. - update based on BitWalk's tcltk-8.4.2-83bw
  190. * Thu Nov 15 2001 Kazuhusa TAKEI <takei@linux.or.jp> 8.0.5_jp-10vl3
  191. - splite source package
  192. - add include files
  193. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
  194. - expand some macros.. (FIXME)
  195. * Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
  196. - use %configure macros
  197. - add Patch 47,50
  198. * Thu May 31 2001 <sagami@vinelinux.org>
  199. - 8.0.5_jp-10
  200. - unexpand old %%{configure}, new one causes build failure
  201. - fixed missing libtkx.so libtclx.so symlink in /usr/lib
  202. - install manpages into %%{_mandir} and mode 644
  203. * Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  204. - 8.0.5_jp-9
  205. - modified %install section to handle compressed man pages
  206. - fixed /usr/lib/tk8.0jp/demos.jp/images symlink
  207. * Sun Jul 2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
  208. - changed default fonts
  209. * Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
  210. - added defattr
  211. * Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
  212. - added some symlinks, such as libtcl8.0.so.
  213. - obsoletes version number using _jp, now 8.0.5-31vl1
  214. * Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
  215. - Apply Tcl/Tk 8.0 Japanese Patch 1.7
  216. * Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
  217. - fix tclX symlinks.
  218. - compile on systems where SIGPWR == SIGLOST.
  219. * Sat May 1 1999 Jeff Johnson <jbj@redhat.com>
  220. - update tcl/tk to 8.0.5.
  221. - avoid "containing" in Tix (#2332).
  222. * Thu Apr 8 1999 Jeff Johnson <jbj@redhat.com>
  223. - use /usr/bin/write in kibitz (#1320).
  224. - use cirrus.sprl.umich.edu in weather (#1926).
  225. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  226. - auto rebuild in the new build environment (release 28)
  227. * Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
  228. - whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
  229. * Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
  230. - expect does unaligned access on alpha (#989)
  231. - upgrade tcl/tk/tclX to 8.0.4
  232. - upgrade expect to 5.28.
  233. - add itcl 3.0.1
  234. * Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
  235. - call libtoolize to allow building on the arm
  236. - build for glibc 2.1
  237. - strip binaries
  238. * Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
  239. - update tcl/tk/tclX to 8.0.3, expect is updated also.
  240. * Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
  241. - expect: mkpasswd needs delay before sending password (problem #576)
  242. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  243. - translations modified for de, fr, tr
  244. * Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
  245. - fixed expect binaries exec permissions
  246. * Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
  247. - updated to Tix 4.1.0.006
  248. - updated version numbers of tcl/tk to relflect includsion of p2
  249. * Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
  250. - updated tcl/tk to patch level 2
  251. - updated tclX to 8.0.2
  252. * Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
  253. - fixed filelist for tix... replacing path to the expect binary in scripts
  254. was leaving junk files around.
  255. * Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
  256. - added patch to remove libieee test in configure.in for tcl and tk.
  257. Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
  258. solution for all systems
  259. - fixed src urls
  260. * Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
  261. - removed version numbers from descriptions
  262. * Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
  263. - updated to tcl/tk 8.0 and related versions of packages
  264. * Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
  265. - built against glibc
  266. - fixed dangling tclx/tkx symlinks