tix-vl.spec 9.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297
  1. %{!?tcl_version: %global tcl_version %(echo 'puts $tcl_version' | tclsh)}
  2. %{!?tcl_sitearch: %global tcl_sitearch %{_libdir}/tcl%{tcl_version}}
  3. %{!?tcl_sitelib: %global tcl_sitelib %{_datadir}/tcl%{tcl_version}}
  4. %define tcl_major 8.6
  5. %define tk_major 8.6
  6. %define thread_major 2.8
  7. %define tix_major 8.4
  8. %define tixversion %{tix_major}.3
  9. ## can't find all provides
  10. #define _use_internal_dependency_generator 0
  11. Summary: A Tcl/Tk development environment: tix
  12. Summary(ja): Tcl/Tk 開発環境: tix
  13. Name: tix
  14. Version: %{tixversion}
  15. Release: 6%{?_dist_release}
  16. Group: programming
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. License: BSD
  20. URL: https://tix.sourceforge.net/
  21. Source0: Tix%{tixversion}-src.tar.gz
  22. # 0: Fixes BZ#81297 (soname of libraries)
  23. Patch0: tix-8.4.2-link.patch
  24. Patch1: tix-8.4.3-tcl86.patch
  25. Patch2: tix-8.4.3-covscan-fixes.patch
  26. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  27. BuildRequires: tcl-devel >= %{tcl_major}
  28. BuildRequires: tk-devel >= %{tk_major}
  29. BuildRequires: tcl-thread
  30. BuildRequires: libX11-devel
  31. Requires: tcl >= %{tcl_major}
  32. Requires: tk >= %{tk_major}
  33. Requires: tcl-thread
  34. %description
  35. Tix (Tk Interface Extension), an add-on for the Tk widget set, is an
  36. extensive set of over 40 widgets. In general, Tix widgets are more
  37. complex and more capable than the widgets provided in Tk. Tix widgets
  38. include a ComboBox, a Motif-style FileSelectBox, an MS Windows-style
  39. FileSelectBox, a PanedWindow, a NoteBook, a hierarchical list, a
  40. directory tree and a file manager.
  41. Install the tix package if you want to try out more complicated widgets
  42. for Tk. You'll also need to have the tcl and tk packages installed.
  43. %description -l ja
  44. Tk ウィジェットセットのためのアドオンである、Tix (Tk Interface Extension)
  45. は 40 ウィジェットを超える拡張セットです。Tix ウィジェットの多くが、
  46. Tk から供給されるウィジェットよりも高機能です。Tix ウィジェットは
  47. コンボボックス、Motif スタイルのファイルボックス、MS Windows スタイルの
  48. ファイルボックス、パネルウィンドウ、ノートブック、階層リスト、
  49. ディレクトリツリー、ファイルマネージャを含んでいます。
  50. Tk で、より複雑ななウィジェットを試したい時には、tix パッケージをインストール
  51. してください。tcl と tk のパッケージもインストールする必要があります。
  52. %debug_package
  53. %prep
  54. %setup -q -n Tix%{tixversion}
  55. %patch0 -p1 -b .link
  56. %patch1 -p1 -b .tcl86
  57. %patch2 -p1 -b .covscan-fixes
  58. # Remove executable permission of images in html documentation
  59. chmod ugo-x docs/html/gif/tix/*.png docs/html/gif/tix/*.gif \
  60. docs/html/gif/tix/*/*.gif
  61. # Fix end-of-line encoding
  62. sed -i 's/\r//' docs/Release-8.4.0.txt
  63. %build
  64. # make the libraries reentrant
  65. RPM_OPT_FLAGS="$RPM_OPT_FLAGS -D_REENTRANT"
  66. %configure \
  67. --libdir=%{tcl_sitearch} \
  68. --with-tcl=%{_libdir} \
  69. --with-tk=%{_libdir} \
  70. --enable-shared \
  71. --disable-threads \
  72. ;
  73. make %{?_smp_mflags} all PKG_LIB_FILE=libTix.so
  74. %install
  75. rm -rf ${RPM_BUILD_ROOT}
  76. make install DESTDIR=$RPM_BUILD_ROOT PKG_LIB_FILE=libTix.so
  77. # move shared lib to tcl sitearch
  78. mv $RPM_BUILD_ROOT%{tcl_sitearch}/Tix%{version}/libTix.so \
  79. $RPM_BUILD_ROOT%{tcl_sitearch}/
  80. # make links
  81. ln -sf ../libTix.so \
  82. $RPM_BUILD_ROOT%{tcl_sitearch}/Tix%{version}/libTix.so
  83. ln -sf tcl%{tcl_version}/Tix%{version}/libTix.so $RPM_BUILD_ROOT%{_libdir}/libTix.so
  84. ln -sf tcl%{tcl_version}/Tix%{version}/libTix.so $RPM_BUILD_ROOT%{_libdir}/libtix.so
  85. install -d $RPM_BUILD_ROOT%{_mandir}/man1
  86. install -d $RPM_BUILD_ROOT%{_mandir}/mann
  87. install -m 644 man/tixwish.1 $RPM_BUILD_ROOT%{_mandir}/man1
  88. install -m 644 man/*.n $RPM_BUILD_ROOT%{_mandir}/mann
  89. install -d $RPM_BUILD_ROOT%{_includedir}
  90. install -m 0644 generic/tix.h $RPM_BUILD_ROOT%{_includedir}/tix.h
  91. ## others
  92. SHAREDDIR=$RPM_BUILD_ROOT%{_datadir}/tix-%{version}
  93. install -d $SHAREDDIR/demos/bitmaps
  94. install -d $SHAREDDIR/demos/samples
  95. install -m 755 demos/widget $SHAREDDIR/demos
  96. install -m 644 demos/{*.tcl,tclIndex} $SHAREDDIR/demos
  97. install -m 644 demos/bitmaps/* $SHAREDDIR/demos/bitmaps
  98. install -m 644 demos/samples/* $SHAREDDIR/demos/samples
  99. cp -a tests $SHAREDDIR
  100. %files
  101. %defattr(-,root,root,-)
  102. %{tcl_sitearch}/libTix.so
  103. %{tcl_sitearch}/Tix%{version}
  104. %{_datadir}/tix-%{tixversion}
  105. %{_mandir}/man1/tixwish.1.gz
  106. %{_libdir}/libtix.so
  107. %{_libdir}/libTix.so
  108. %{_includedir}/*.h
  109. %{_mandir}/mann/*.n.gz
  110. %doc ChangeLog README.txt man/html man/index.html
  111. %changelog
  112. * Sat Oct 21 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.4.3-6
  113. - rebuilt with current environment.
  114. * Tue Oct 15 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.4.3-5
  115. - moved .so to fix warnings of ldconfig.
  116. * Fri Oct 04 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.4.3-4
  117. - rebuilt with tcl/tk-8.6.9.
  118. - dropped all patches.
  119. - imported Patch0-2 from rawhide.
  120. * Wed Dec 31 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.4.3-3
  121. - rebuilt with tcl/tk 8.5.15 and thread 2.7.1
  122. * Thu Feb 24 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.3-2
  123. - added BR: libX11-devel
  124. * Tue Feb 22 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.3-1
  125. - updated tix to 8.4.3
  126. - dropt tix-8.1.4-perf.patch
  127. - dropt tix-8.2.0b1-dirtree.patch
  128. - added "cp -p libTix8.4.3.so libtix8.4.so"
  129. - rebuilt with file-5.05-2
  130. * Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.2-2
  131. - rebuilt with tcl/tk-8.4.19-2
  132. * Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.2-1vl5
  133. - applied new versioning policy
  134. * Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.2-0vl3
  135. - rebuild with tcl/tk-8.4.18
  136. * Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.2-0vl2
  137. - rebuild with tcl/tk-8.4.16
  138. * Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.2-0vl1
  139. - updated tix to 8.4.2
  140. - rebuilt with new toolchain
  141. * Sat Jan 28 2006 Shu KONNO <owa@bg.wakwak.com> 8.2.0-0vl5
  142. - rebuild for tcl/tk-8.4.12, and x86_64 architecture support
  143. * Fri Sep 09 2005 Shu KONNO <owa@bg.wakwak.com> 8.2.0-0vl4
  144. - changed url to http://tix.sourceforge.net/download.shtml
  145. - rebuild for tcl/tk-8.4.11
  146. * Wed Jun 30 2004 Shu KONNO <owa@bg.wakwak.com> 8.2.0-0vl3
  147. - rebuild for tcl/tk-8.4.6
  148. * Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.2.0-0vl2
  149. - rebuild for tcl/tk-8.4.5
  150. * Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.2.0-0vl1
  151. - update based on BitWalk's tcltk-8.4.2-83bw
  152. * Thu Nov 15 2001 Kazuhusa TAKEI <takei@linux.or.jp> 8.0.5_jp-10vl3
  153. - splite source package
  154. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
  155. - expand some macros.. (FIXME)
  156. * Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
  157. - use %configure macros
  158. - add Patch 47,50
  159. * Thu May 31 2001 <sagami@vinelinux.org>
  160. - 8.0.5_jp-10
  161. - unexpand old %%{configure}, new one causes build failure
  162. - fixed missing libtkx.so libtclx.so symlink in /usr/lib
  163. - install manpages into %%{_mandir} and mode 644
  164. * Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  165. - 8.0.5_jp-9
  166. - modified %install section to handle compressed man pages
  167. - fixed /usr/lib/tk8.0jp/demos.jp/images symlink
  168. * Sun Jul 2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
  169. - changed default fonts
  170. * Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
  171. - added defattr
  172. * Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
  173. - added some symlinks, such as libtcl8.0.so.
  174. - obsoletes version number using _jp, now 8.0.5-31vl1
  175. * Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
  176. - Apply Tcl/Tk 8.0 Japanese Patch 1.7
  177. * Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
  178. - fix tclX symlinks.
  179. - compile on systems where SIGPWR == SIGLOST.
  180. * Sat May 1 1999 Jeff Johnson <jbj@redhat.com>
  181. - update tcl/tk to 8.0.5.
  182. - avoid "containing" in Tix (#2332).
  183. * Thu Apr 8 1999 Jeff Johnson <jbj@redhat.com>
  184. - use /usr/bin/write in kibitz (#1320).
  185. - use cirrus.sprl.umich.edu in weather (#1926).
  186. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  187. - auto rebuild in the new build environment (release 28)
  188. * Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
  189. - whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
  190. * Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
  191. - expect does unaligned access on alpha (#989)
  192. - upgrade tcl/tk/tclX to 8.0.4
  193. - upgrade expect to 5.28.
  194. - add itcl 3.0.1
  195. * Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
  196. - call libtoolize to allow building on the arm
  197. - build for glibc 2.1
  198. - strip binaries
  199. * Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
  200. - update tcl/tk/tclX to 8.0.3, expect is updated also.
  201. * Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
  202. - expect: mkpasswd needs delay before sending password (problem #576)
  203. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  204. - translations modified for de, fr, tr
  205. * Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
  206. - fixed expect binaries exec permissions
  207. * Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
  208. - updated to Tix 4.1.0.006
  209. - updated version numbers of tcl/tk to relflect includsion of p2
  210. * Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
  211. - updated tcl/tk to patch level 2
  212. - updated tclX to 8.0.2
  213. * Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
  214. - fixed filelist for tix... replacing path to the expect binary in scripts
  215. was leaving junk files around.
  216. * Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
  217. - added patch to remove libieee test in configure.in for tcl and tk.
  218. Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
  219. solution for all systems
  220. - fixed src urls
  221. * Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
  222. - removed version numbers from descriptions
  223. * Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
  224. - updated to tcl/tk 8.0 and related versions of packages
  225. * Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
  226. - built against glibc
  227. - fixed dangling tclx/tkx symlinks