vala-vl.spec 9.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299
  1. %global api_ver 0.10
  2. Summary: A modern programming language for GNOME
  3. Summary: GNOME 用のモダンなプログラミング言語
  4. Name: vala
  5. Version: 0.9.7
  6. Release: 1%{?_dist_release}
  7. Group: Development/Languages
  8. # Most files are LGPLv2.1+, curses.vapi is 2-clause BSD
  9. License: LGPLv2+ and BSD
  10. URL: http://live.gnome.org/Vala
  11. Source0: http://download.gnome.org/sources/vala/0.9/vala-%{version}.tar.bz2
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  13. BuildRequires: gtk2-devel flex bison devhelp xulrunner-devel >= 1.9
  14. Requires: gtk2-devel
  15. %description
  16. Vala is a new programming language that aims to bring modern programming
  17. language features to GNOME developers without imposing any additional
  18. runtime requirements and without using a different ABI compared to
  19. applications and libraries written in C.
  20. valac, the Vala compiler, is a self-hosting compiler that translates
  21. Vala source code into C source and header files. It uses the GObject
  22. type system to create classes and interfaces declared in the Vala source
  23. code. It's also planned to generate GIDL files when gobject-
  24. introspection is ready.
  25. The syntax of Vala is similar to C#, modified to better fit the GObject
  26. type system.
  27. %package devel
  28. Summary: Development files for %{name}
  29. Group: Development/Libraries
  30. Requires: %{name} = %{version}-%{release}
  31. Requires: pkgconfig
  32. %description devel
  33. Vala is a new programming language that aims to bring modern programming
  34. language features to GNOME developers without imposing any additional
  35. runtime requirements and without using a different ABI compared to
  36. applications and libraries written in C.
  37. This package contains development files for %{name}. This is not necessary for
  38. using the %{name} compiler.
  39. %package tools
  40. Summary: Tools for creating projects and bindings for %{name}
  41. Group: Development/Languages
  42. License: LGPLv2+
  43. Requires: %{name} = %{version}-%{release}
  44. Requires: gnome-common intltool libtool
  45. Provides: %{name}-vapigen = %{version}-%{release}
  46. Obsoletes: %{name}-vapigen < %{version}-%{release}
  47. %description tools
  48. Vala is a new programming language that aims to bring modern programming
  49. language features to GNOME developers without imposing any additional
  50. runtime requirements and without using a different ABI compared to
  51. applications and libraries written in C.
  52. This package contains tools to generate Vala projects, as well as API bindings
  53. from existing C libraries, allowing access from Vala programs.
  54. %package doc
  55. Summary: Documentation for %{name}
  56. Group: Documentation
  57. License: LGPLv2+
  58. Requires: %{name} = %{version}-%{release}
  59. Requires: devhelp
  60. Provides: %{name}-docs = %{version}-%{release}
  61. Obsoletes: %{name}-docs < %{version}-%{release}
  62. %description doc
  63. Vala is a new programming language that aims to bring modern programming
  64. language features to GNOME developers without imposing any additional
  65. runtime requirements and without using a different ABI compared to
  66. applications and libraries written in C.
  67. This package contains documentation in a devhelp HTML book.
  68. %prep
  69. %setup -q
  70. %build
  71. %configure --enable-vapigen
  72. # Don't use rpath!
  73. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  74. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  75. make %{?_smp_mflags}
  76. # checks currently utilize installed Vala, not the one being compiled
  77. #%check
  78. #make check
  79. %install
  80. rm -rf $RPM_BUILD_ROOT
  81. make install DESTDIR=$RPM_BUILD_ROOT
  82. rm $RPM_BUILD_ROOT%{_libdir}/libvala-%{api_ver}.la
  83. %clean
  84. rm -rf $RPM_BUILD_ROOT
  85. %post -p /sbin/ldconfig
  86. %postun -p /sbin/ldconfig
  87. %files
  88. %defattr(-,root,root,-)
  89. %doc AUTHORS ChangeLog COPYING INSTALL MAINTAINERS NEWS README THANKS
  90. %{_bindir}/vala
  91. %{_bindir}/valac
  92. %{_bindir}/vala-%{api_ver}
  93. %{_bindir}/valac-%{api_ver}
  94. %{_datadir}/vala-%{api_ver}
  95. %{_libdir}/libvala-%{api_ver}.so.*
  96. %{_mandir}/*/valac*
  97. %files devel
  98. %defattr(-,root,root,-)
  99. %{_includedir}/vala-%{api_ver}
  100. %{_libdir}/libvala-%{api_ver}.so
  101. %{_libdir}/pkgconfig/vala-%{api_ver}.pc
  102. %{_datadir}/aclocal/vala.m4
  103. %files tools
  104. %defattr(-,root,root,-)
  105. %{_bindir}/vala-gen-introspect
  106. %{_bindir}/vapicheck
  107. %{_bindir}/vapigen
  108. %{_bindir}/vala-gen-introspect-%{api_ver}
  109. %{_bindir}/vapicheck-%{api_ver}
  110. %{_bindir}/vapigen-%{api_ver}
  111. %{_libdir}/vala-%{api_ver}
  112. %{_mandir}/*/*gen*
  113. %files doc
  114. %defattr(-,root,root,-)
  115. %{_datadir}/devhelp/books/vala-%{api_ver}
  116. %changelog
  117. * Sun Aug 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.7-1
  118. - new upstream release
  119. * Wed Aug 11 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.5-1
  120. - new upstream release
  121. * Fri Aug 6 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.4-1
  122. - new upstream release
  123. * Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.8.1-1
  124. - new upstream release
  125. * Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
  126. - new upstream release
  127. - change BuildRequires: gecko-libs -> xulrunner-devel
  128. * Wed Feb 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.10-1
  129. - new upstream release
  130. * Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.9-1
  131. - new upstream release
  132. * Tue Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.7-1
  133. - new upstream release
  134. * Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.5-1
  135. - initial build for Vine Linux
  136. * Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.5-1
  137. - Update to 0.7.5
  138. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.4-3
  139. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  140. * Tue Jul 14 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-2
  141. - Patch broken ModuleInit attribute (upstream bug 587444)
  142. * Tue Jul 7 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-1
  143. - Update to 0.7.4
  144. * Wed Jun 3 2009 Peter Robinson <pbrobinson@gmail.com> - 0.7.3-1
  145. - Update to 0.7.3
  146. * Sat Apr 18 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.1-1
  147. - Update to 0.6.1
  148. * Mon Feb 23 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.7-1
  149. - Update to 0.5.7
  150. * Tue Jan 27 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.6-1
  151. - Update to 0.5.6
  152. * Tue Dec 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.3-1
  153. - Update to 0.5.3
  154. * Mon Dec 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-3
  155. - Fix bug in Emacs version detection
  156. * Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-2
  157. - Use buildsystem variables to determine available Emacs version
  158. - BR on gecko-devel >= 1.9, since older version is also in RHEL repo
  159. * Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-1
  160. - Update to 0.5.2
  161. * Sun Nov 23 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.1-1
  162. - Update to 0.5.1
  163. * Fri Aug 22 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.5-1
  164. - Update to 0.3.5
  165. * Tue Jul 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.4-2
  166. - Add vala-mode for editing Vala code in Emacs
  167. * Tue Jul 1 2008 Lennart Poettering <lpoetter@redhat.com> - 0.3.4-1
  168. - Update to 0.3.4
  169. * Wed Jun 4 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.3-1
  170. - Update to 0.3.3
  171. * Fri May 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.2-1
  172. - Update to 0.3.2
  173. * Thu Apr 10 2008 Michel Salim <salimma@fedoraproject.org> - 0.2.0-1
  174. - Update to 0.2.0
  175. * Wed Mar 5 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.7-1
  176. - Update to 0.1.7
  177. - -tool subpackage now requires gnome-common, intltool and libtoolize
  178. for out-of-the-box vala-gen-project support
  179. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.1.6-2
  180. - Autorebuild for GCC 4.3
  181. * Sat Jan 19 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.6-1
  182. - Update to 0.1.6
  183. - Revert vapi addition, needed declarations have been inlined (r846)
  184. - Rename -docs subpackage to -doc, to comply with guidelines
  185. * Tue Jan 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.5-5
  186. - Manually add Gee vapi file to package (bz #428692)
  187. * Tue Dec 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-4
  188. - Backport patch to autodetect location of automake shared files
  189. * Tue Dec 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-3
  190. - Add build dependency on gtk2-devel
  191. * Tue Dec 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-2
  192. - Enable project generator tool
  193. * Tue Nov 27 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-1
  194. - Update to 0.1.5
  195. * Sun Nov 11 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-2
  196. - Add build dependency on devhelp
  197. * Fri Oct 19 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-1
  198. - Update to 0.1.4
  199. - Put newly-added documentation in its own subpackage (depends on devhelp)
  200. * Mon Sep 17 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-5
  201. - vapigen subpackage: add missing Require: on perl-XML-Twig
  202. * Sat Sep 8 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-4
  203. - Split -vapigen subpackage. It is functionally self-contained and the license
  204. is more restricted
  205. - Updated license declarations
  206. * Wed Sep 5 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-3
  207. - Licensing and URL updates
  208. * Tue Sep 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-2
  209. - Enable binding generation tools
  210. * Sun Sep 2 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-1
  211. - Update to 0.1.3
  212. * Sun Mar 25 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.8-1
  213. - Update to 0.0.8
  214. * Wed Mar 7 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.7-1
  215. - Update to 0.0.7
  216. * Wed Feb 28 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.6-1
  217. - Update to 0.0.6
  218. * Mon Nov 6 2006 Michel Salim <salimma@fedoraproject.org> - 0.0.5-1
  219. - Initial package