curl-vl.spec 9.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
  3. Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
  4. Name: curl
  5. Version: 7.24.0
  6. Release: 1%{?_dist_release}
  7. License: MIT/X
  8. Group: Applications/Internet
  9. Source: http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
  10. URL: http://curl.haxx.se/
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: openssl-devel libidn-devel zlib-devel
  13. BuildRequires: openldap-devel gnutls-devel
  14. Requires: openssl libidn zlib
  15. Vendor: Project Vine
  16. Distribution: Vine Linux
  17. %description
  18. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  19. Dict servers, using any of the supported protocols. cURL is designed
  20. to work without user interaction or any kind of interactivity. cURL
  21. offers many useful capabilities, like proxy support, user
  22. authentication, FTP upload, HTTP post, and file transfer resume.
  23. %package devel
  24. Summary: Files needed for building applications with libcurl.
  25. Group: Development/Libraries
  26. Requires: %{name} = %{version}-%{release}
  27. Requires: openssl-devel libidn-devel zlib-devel
  28. %description devel
  29. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  30. Dict servers, using any of the supported protocols. The curl-devel
  31. package includes files needed for developing applications which can
  32. use cURL's capabilities internally.
  33. #'
  34. ## to build compat32 for x86_64 architecture support
  35. %package -n compat32-%{name}
  36. Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
  37. Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
  38. Group: System Environment/Libraries
  39. %description -n compat32-%{name}
  40. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  41. Dict servers, using any of the supported protocols. cURL is designed
  42. to work without user interaction or any kind of interactivity. cURL
  43. offers many useful capabilities, like proxy support, user
  44. authentication, FTP upload, HTTP post, and file transfer resume.
  45. %package -n compat32-%{name}-devel
  46. Summary: Files needed for building applications with libcurl.
  47. Group: Development/Libraries
  48. %description -n compat32-%{name}-devel
  49. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  50. Dict servers, using any of the supported protocols. The curl-devel
  51. package includes files needed for developing applications which can
  52. use cURL's capabilities internally.
  53. #'
  54. %prep
  55. %setup -q
  56. %build
  57. %configure --with-ssl=%{_prefix} --with-gnutls --with-libidn --enable-ipv6 --disable-static
  58. %ifarch alpha
  59. make %{?_smp_mflags} CFLAGS=""
  60. %else
  61. make %{?_smp_mflags}
  62. %endif
  63. %install
  64. rm -rf $RPM_BUILD_ROOT
  65. make DESTDIR=$RPM_BUILD_ROOT install
  66. rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
  67. %clean
  68. rm -rf $RPM_BUILD_ROOT
  69. %post -p /sbin/ldconfig
  70. %postun -p /sbin/ldconfig
  71. %files
  72. %defattr(-,root,root)
  73. %doc CHANGES COPYING README
  74. %doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
  75. %doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
  76. %doc docs/TheArtOfHttpScripting docs/TODO
  77. %{_bindir}/curl
  78. #{_datadir}/curl/*
  79. %{_libdir}/*.so.*
  80. %{_mandir}/man1/curl.1*
  81. %files devel
  82. %defattr(-,root,root)
  83. %{_bindir}/curl-config
  84. %{_includedir}/curl
  85. %{_libdir}/*.so
  86. %{_libdir}/pkgconfig/*.pc
  87. %{_mandir}/man1/curl-config.1*
  88. %{_mandir}/man3/*
  89. ## to build compat32 for x86_64 architecture support
  90. %if %{build_compat32}
  91. %files -n compat32-%{name}
  92. %defattr(-,root,root)
  93. %{_libdir}/*.so.*
  94. %files -n compat32-%{name}-devel
  95. %defattr(-,root,root)
  96. %{_libdir}/*.so
  97. %{_libdir}/pkgconfig/*.pc
  98. %endif
  99. %changelog
  100. * Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
  101. - new upstream release
  102. * Sun Jul 3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
  103. - add patch100 for fix CVE-2011-2192 (gssapi)
  104. - add Vendor/Distri tags
  105. * Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
  106. - rebuild with openssl-1.0.0c
  107. * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
  108. - rebuilt with rpm-4.8.1 for pkg-config
  109. * Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
  110. - new upstream release
  111. * Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
  112. - new upstream release with security fix
  113. * Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
  114. - added compat32 subpackages
  115. * Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
  116. - new upstream release
  117. - use "_smp_mflags" flag
  118. * Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
  119. - rebuild with openldap-2.4.11
  120. - add BR: openldap-devel
  121. - remove static library
  122. * Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
  123. - new upstream release with security fix (CVE-2009-0037)
  124. * Sun Jul 6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
  125. - new upstream release
  126. * Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
  127. - new upstream release
  128. * Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
  129. - new upstream release
  130. * Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
  131. - new upstream release
  132. * Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
  133. - new upstream release
  134. * Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
  135. - rebuilt with openssl-0.9.8e
  136. * Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
  137. - new upstream release
  138. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
  139. - new upstream release
  140. * Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
  141. - new upstream release
  142. - add pkgconfig file to devel package
  143. * Wed Dec 7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
  144. - new upstream release
  145. * Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
  146. - new upstream release
  147. * Fri Sep 2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
  148. - new upstream release
  149. * Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
  150. - added libidn, zlib in Requires
  151. - added libidn-devel, zlib-devel in BuildPrereq
  152. - added zlib-devel in curl-devel's Requires
  153. * Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
  154. - added openssl-devel, libidn-devel in curl-devel's Requires
  155. * Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
  156. - new upstream release
  157. * Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
  158. - new upstream release
  159. - rebuild with openssl-0.9.7d
  160. * Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
  161. - upstream release
  162. * Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
  163. - add %%{_datadir}/curl/* to %%files section
  164. * Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
  165. - source upgrade
  166. * Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
  167. - source upgrade
  168. - add PreReq: ldconfig
  169. - add %%{_libdir}/*.la to %%files devel section
  170. * Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
  171. - build for VineSeed
  172. - add Requires: openssl
  173. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  174. - automated rebuild
  175. * Wed Jan 9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
  176. - 7.9.2
  177. * Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
  178. - include curl-config in curl-devel
  179. - update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
  180. * Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
  181. - added openssl-devel build req
  182. * Mon May 21 2001 Tim Powers <timp@redhat.com>
  183. - built for the distro
  184. * Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
  185. - upgrade to curl-7.7.2.
  186. - enable IPv6.
  187. * Fri Mar 2 2001 Tim Powers <timp@redhat.com>
  188. - rebuilt against openssl-0.9.6-1
  189. * Thu Jan 4 2001 Tim Powers <timp@redhat.com>
  190. - fixed mising ldconfigs
  191. - updated to 7.5.2, bug fixes
  192. * Mon Dec 11 2000 Tim Powers <timp@redhat.com>
  193. - updated to 7.5.1
  194. * Mon Nov 6 2000 Tim Powers <timp@redhat.com>
  195. - update to 7.4.1 to fix bug #20337, problems with curl -c
  196. - not using patch anymore, it's included in the new source. Keeping
  197. for reference
  198. * Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
  199. - fix bogus req in -devel package
  200. * Fri Oct 20 2000 Tim Powers <timp@redhat.com>
  201. - devel package needed defattr so that root owns the files
  202. * Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
  203. - update to 7.3
  204. - apply vsprintf/vsnprintf patch from Colin Phipps via Debian
  205. * Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
  206. - enable SSL support
  207. - fix packager tag
  208. - move buildroot to %%{_tmppath}
  209. * Tue Aug 1 2000 Tim Powers <timp@redhat.com>
  210. - fixed vendor tag for bug #15028
  211. * Mon Jul 24 2000 Prospector <prospector@redhat.com>
  212. - rebuilt
  213. * Tue Jul 11 2000 Tim Powers <timp@redhat.com>
  214. - workaround alpha build problems with optimizations
  215. * Mon Jul 10 2000 Tim Powers <timp@redhat.com>
  216. - rebuilt
  217. * Mon Jun 5 2000 Tim Powers <timp@redhat.com>
  218. - put man pages in correct place
  219. - use %%makeinstall
  220. * Mon Apr 24 2000 Tim Powers <timp@redhat.com>
  221. - updated to 6.5.2
  222. * Wed Nov 3 1999 Tim Powers <timp@redhat.com>
  223. - updated sources to 6.2
  224. - gzip man page
  225. * Mon Aug 30 1999 Tim Powers <timp@redhat.com>
  226. - changed group
  227. * Thu Aug 26 1999 Tim Powers <timp@redhat.com>
  228. - changelog started
  229. - general cleanups, changed prefix to /usr, added manpage to files section
  230. - including in Powertools