QtRuby-vl.spec 7.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258
  1. %define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.8.6)
  2. %global ruby_vendorlib %(ruby -rrbconfig -e 'puts RbConfig::CONFIG["vendorlibdir"]')
  3. %global ruby_vendorarch %(ruby -rrbconfig -e 'puts RbConfig::CONFIG["vendorarchdir"]')
  4. Name: QtRuby
  5. Summary: Ruby bindings for Qt4
  6. Summary(ja): Qt4 の Ruby バインディング
  7. Version: 4.14.3
  8. Release: 1%{?_dist_release}
  9. License: LGPLv2+ and GPLv2+
  10. Group: System Environment/Libraries
  11. URL: https://techbase.kde.org/Development/Languages/Ruby
  12. Source0: http://download.kde.org/stable/%{version}/src/qtruby-%{version}.tar.xz
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: cmake
  15. BuildRequires: phonon-devel
  16. BuildRequires: qimageblitz-devel
  17. BuildRequires: qt4-devel
  18. BuildRequires: qscintilla-devel
  19. BuildRequires: qwt-qt4-devel
  20. BuildRequires: ruby-devel >= 1.8
  21. BuildRequires: smokeqt-devel >= %{version}
  22. # common name some other distros use
  23. Provides: ruby-qt = %{version}-%{release}
  24. Requires: qt4 >= %{_qt4_version}
  25. Requires: ruby >= 1.8
  26. Requires: smokeqt >= %{version}
  27. %description
  28. %{summary}.
  29. %package devel
  30. Summary: Development libraries for %{name}
  31. Summary(ja): %{name} の開発用ファイル
  32. Group: Development/Libraries
  33. Requires: %{name} = %{version}-%{release}
  34. Provides: ruby-qt-devel = %{version}-%{release}
  35. %description devel
  36. This package contains development files for the Ruby bindings
  37. for the Qt libraries.
  38. %prep
  39. %setup -q -n qtruby-%{version}
  40. %build
  41. mkdir -p %{_target_platform}
  42. pushd %{_target_platform}
  43. %cmake \
  44. -DCUSTOM_RUBY_SITE_ARCH_DIR:PATH=%{ruby_vendorarch} \
  45. -DCUSTOM_RUBY_SITE_LIB_DIR:PATH=%{ruby_vendorlib} \
  46. ..
  47. popd
  48. make %{?_smp_mflags} -C %{_target_platform}
  49. %install
  50. rm -rf $RPM_BUILD_ROOT
  51. make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
  52. %post -p /sbin/ldconfig
  53. %postun -p /sbin/ldconfig
  54. %clean
  55. rm -rf $RPM_BUILD_ROOT
  56. %files
  57. %defattr(-,root,root,-)
  58. %doc AUTHORS COPYING COPYING.LIB README
  59. %{_libdir}/libqtruby4shared.so.*
  60. %{ruby_vendorlib}/Qt*.rb
  61. %{ruby_vendorlib}/Qt/
  62. %{ruby_vendorlib}/phonon/
  63. %{ruby_vendorlib}/qscintilla/
  64. %{ruby_vendorlib}/qtdeclarative/
  65. %{ruby_vendorlib}/qtscript/
  66. %{ruby_vendorlib}/qttest/
  67. %{ruby_vendorlib}/qtuitools/
  68. %{ruby_vendorlib}/qtwebkit/
  69. %{ruby_vendorlib}/qwt/
  70. %{ruby_vendorarch}/*.so
  71. %files devel
  72. %defattr(-,root,root,-)
  73. %{_bindir}/rbqtapi
  74. %{_bindir}/rbrcc
  75. %{_bindir}/rbuic4
  76. %{_includedir}/qtruby
  77. %{_libdir}/libqtruby4shared.so
  78. %{_datadir}/qtruby4
  79. %changelog
  80. * Sun Jan 11 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.14.3-1
  81. - updated to 4.14.3
  82. * Wed Nov 12 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.14.2-2
  83. - installed modules to vendor_ruby
  84. - fixed URL
  85. * Sun Nov 9 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.14.2-1
  86. - splitted from kdebindings
  87. * Thu Jun 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.4-1
  88. - new upstream release
  89. * Thu Apr 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1
  90. - updated to 4.6.1
  91. - added BR: kdesdk-devel
  92. - disabled attica plugins temporaly
  93. - rebuilt with mono-2.10.1
  94. * Sun Sep 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-2
  95. - rebuilt with rpm-4.8.1 for pkg-config
  96. * Sat Sep 18 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-1
  97. - new upstream release
  98. - added Patch50
  99. - added more japanese summaries
  100. * Tue Aug 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-1
  101. - new upstream release
  102. * Sun Jul 4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-1
  103. - new upstream release
  104. * Fri May 7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
  105. - new upstream release
  106. * Thu Apr 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
  107. - new upstream release
  108. * Tue Mar 9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
  109. - new upstream release
  110. - added -DCMAKE_SKIP_RPATH:BOOL=OFF option to cmake
  111. (see https://bugs.kde.org/show_bug.cgi?id=214824)
  112. - built with new toolchain
  113. * Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.3-1
  114. - new upstream release
  115. * Thu Oct 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-4
  116. - merged 4.3.1-2 %changelog
  117. - re-define %%{mono_dir} to %{_prefix}/lib/mono (again)
  118. * Tue Oct 27 2009 Shu KONNO <owa@bg.wakwak.com> 4.3.2-3
  119. - use %%{_prefix}/lib for mono-dll (for x86_64)
  120. * Tue Oct 27 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-2
  121. - new upstream release
  122. - built with PyQt4-4.6
  123. * Sun Sep 06 2009 NAKAMURA Kenta <kenta@vinelinux.org> 4.3.1-2
  124. - define %%{mono_dir} to specify mono library install path
  125. * Sun Sep 6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
  126. - new upstream release
  127. - fixed ruby modules installation path
  128. * Thu Aug 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
  129. - new upstream release
  130. - spilt sub package based on Fedora
  131. * Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
  132. - applied new versioning policy
  133. - added Patch1
  134. (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=484191)
  135. * Fri Nov 23 2007 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.8-0vl3
  136. - added --with-qt-libraries option
  137. * Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
  138. - rebuild for VineSeed
  139. * Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
  140. - new upstream release
  141. * Mon Jun 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
  142. - rebuild for VineSeed
  143. * Thu May 31 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
  144. - new upstream release
  145. - update Patch0
  146. - drop Patch1
  147. * Mon Jan 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
  148. - new upstream release
  149. - add Patch1
  150. - add --enable-libsuffix option
  151. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
  152. - rebuild for VineSeed
  153. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
  154. - new upstream release
  155. * Wed Aug 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
  156. - rebuild for VineSeed
  157. * Wed Aug 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
  158. - new upstream release
  159. * Thu Jun 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
  160. - rebuild for VineSeed
  161. * Thu Jun 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
  162. - new upstream release
  163. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
  164. - rebuild for VineSeed
  165. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
  166. - new upstream release
  167. * Wed Feb 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
  168. - rebuild for VineSeed
  169. * Wed Feb 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
  170. - new upstream release
  171. - renew BuildPrereq and build section
  172. - renew %%files
  173. - enable python
  174. - change spec to make main and devel package
  175. - add BuildPrereq: ruby ruby-devel
  176. - add Patch0 to install ruby-bindings under /usr/lib/ruby
  177. * Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-1vl1
  178. - build for VineSeed
  179. - disable python and mozilla
  180. - objprelink (i386 only)
  181. * Wed Nov 21 2001 Than Ngo <than@redhat.com> <bero@redhat.com> 2.2.2-1
  182. - 2.2.2
  183. - build kmozilla binding only on x86/alpha
  184. * Thu Aug 9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-2
  185. - Make sure %%{name}-kmozilla isn't built on ia64
  186. * Mon Jul 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010723.2
  187. - Move python bindings to separate package
  188. - Add perl bindings
  189. - Shut up rpmlint
  190. * Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  191. - 2.1
  192. * Sun Jan 28 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  193. - initial RPM