123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353 |
- %bcond_with test
- %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
- %define ver_suffix %(echo "%{version}" | cut -d . -f 1)
- %define _unpackaged_files_terminate_build 1
- Summary: OpenMP runtime for clang
- Summary(ja): clang用OpenMPランタイム
- Name: libomp
- Version: 17.0.2
- %define shortver %(echo %{version} | cut -d. -f1)
- Release: 1%{?_dist_release}
- Group: system
- Vendor: Project Vine
- Distribution: Vine Linux
- License: NCSA
- URL: https://llvm.org/
- Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/openmp-%{version}.src.tar.xz
- # patches
- BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
- BuildRequires: cmake
- BuildRequires: ninja
- BuildRequires: libffi-devel >= 3.3
- BuildRequires: elfutils-libelf-devel
- BuildRequires: clang-tools-extra
- # The AMDGCN device RTL requires clang and llvm-link to build
- BuildRequires: clang
- BuildRequires: llvm
- # libomptarget needs the llvm cmake files
- BuildRequires: llvm-devel
- BuildRequires: llvm-static
- %description
- The package contains the OpenMP runtime for clang.
- %package devel
- Summary: OpenMP header files
- Summary(ja): OpenMPヘッダファイル
- Group: programming
- Requires: clang-devel%{?isa} = %{version}
- %description devel
- The package contains the OpenMP header files.
- %debug_package
- %prep
- %autosetup -p2 -n openmp-%{version}.src
- %build
- # LTO causes build failures in this package. Disable LTO for now
- %define _lto_cflags %{nil}
- %cmake \
- -GNinja \
- -DLIBOMP_INSTALL_ALIASES=OFF \
- -DCMAKE_MODULE_PATH=%{_datadir}/llvm/cmake/Modules \
- -DLLVM_DIR=%{_libdir}/cmake/llvm \
- -DCMAKE_INSTALL_INCLUDEDIR=%{_libdir}/clang/%{shortver}/include \
- %if 0%{?__isa_bits} == 64
- -DOPENMP_LIBDIR_SUFFIX=64 \
- %else
- -DOPENMP_LIBDIR_SUFFIX= \
- %endif
- -DCMAKE_SKIP_RPATH:BOOL=ON \
- -DLIBOMP_HAVE_VERSION_SCRIPT_FLAG:BOOL=ON
- %cmake_build
- %install
- rm -rf %{buildroot}
- %cmake_install
- # Remove static libraries with equivalent shared libraries
- rm -f %{buildroot}%{_libdir}/libarcher_static.a
- %if %{with test}
- %check
- %cmake_build --target check-openmp
- %endif
- %clean
- rm -rf %{buildroot}
- %files
- %license LICENSE.TXT
- %{_libdir}/libarcher.so
- %{_libdir}/libomp.so
- %{_libdir}/libompd.so
- %ifnarch %{ix86} %{arm}
- %{_libdir}/libomptarget.so.*
- %{_libdir}/libomptarget.rtl.*.so*
- %endif
- %files devel
- %ifnarch %{ix86} %{arm}
- %{_libdir}/libomptarget.devicertl.a
- %endif
- %{_libdir}/clang/%{shortver}/include/omp.h
- %{_libdir}/clang/%{shortver}/include/omp-tools.h
- %{_libdir}/clang/%{shortver}/include/ompt.h
- %{_libdir}/clang/%{shortver}/include/ompt-multiplex.h
- %{_libdir}/cmake/openmp/FindOpenMPTarget.cmake
- %ifnarch %{ix86} %{arm}
- %{_libdir}/libomptarget.so
- %{_libdir}/libomptarget.rtl.*.so
- %{_libdir}/libomptarget-*.bc
- %endif
- %changelog
- * Sat Oct 07 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 17.0.2-1
- - new upstream release.
- * Sun Oct 01 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 17.0.1-1
- - new upstream release.
- * Mon May 29 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 16.0.4-1
- - new upstream release.
- * Fri Dec 16 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 15.0.6-1
- - new upstream release.
- * Thu Oct 06 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 15.0.2-1
- - new upstream release.
- * Thu Sep 08 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 15.0.0-1
- - new upstream release.
- * Thu Jun 16 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 14.0.5-1
- - new upstream release.
- - updated Patch0.
- * Thu Feb 03 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 13.0.1-1
- - new upstream release.
- * Fri Oct 22 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 13.0.0-1
- - new upstream release.
- * Wed Aug 11 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.1-1
- - new upstream release.
- * Sat Apr 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.0-1
- - devided libomp from llvm.
- - new upstream release.
- * Fri Oct 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-2
- - enabled to build utils.
- * Thu Oct 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-1
- - new upstream release.
- * Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.1-1
- - new upstream release.
- * Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-2
- - rebuilt with libffi-3.3.
- * Fri Mar 27 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-1
- - new upstream release.
- * Sun Dec 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.1-1
- - new upstream release.
- * Sun Sep 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-2
- - dropped all patches.
- - switched build-system to ninja.
- - switched python to python3.
- * Fri Sep 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-1
- - new upstream release.
- - added OpenMP.
- * Sun Dec 16 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.1-1
- - fixed %%files.
- * Wed Dec 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.0-1
- - new upstream release.
- - dropped Patch0, 4, 5, 100 and 200.
- - imported Patch3, 7, 12, 15, 100, 101, 102 and 400 from rawhide.
- - renamed a subpackage "llvm-libs".
- - added a subpackage "lld".
- * Tue Jan 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-2
- - added subpackages "llvm-static", "python-lldb" and "python-clang".
- * Mon Jan 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-1
- - new upstream release.
- - dropped Patch1 and 2: fixed in upstream.
- - imported Patch0, 3-5, 100 and 200 from rawhide.
- - disabled Patch1002: no longer needed?
- * Fri Aug 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.1-1
- - new upstream release.
- - switched to cmake.
- - disable ocaml binding as default.
- - updated Patch1000 and 1002.
- - disabled Patch1000 as default.
- - cleanup patches.
- * Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-2
- - rebuild with gcc-5.4.0
- * Sat Sep 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.2-1
- - new upstream release
- - added BR: ocaml-ctypes
- * Thu Jun 4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.1-1
- - new upstream release
- - dropt Patch 1, 201 and 1001
- - updated Patch 1000
- * Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.5.1-1
- - updated to 3.5.1
- - added Patch1, 2, 100, 101, 200, 201 and 202 from Fedora
- - added clang-libs, lldb, lldb-devel and compat32-llvm-libs subpackage
- - obsoleted clang-doc
- - built with ocaml 4.02.1
- * Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-2
- - fix <BTS:2832>
- - fix configure option "--with-c-include-dirs"
- - update Patch1000: clang-3.5.0-driver-ld.gold.patch
- - update Patch1001: clang-3.5.0-driver-lib64.patch
- - update Patch1002: clang-3.5.0-driver-vine.patch
- * Tue Oct 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-1
- - update to 3.5.0
- - remove Patch11 (clang-hardfloat-hack.patch)
- * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3-2
- - rebuild with libffi-3.0.13
- * Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3-1
- - update to 3.3
- * Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-2
- - ld.gold (patch1000,1001)
- - add /%{_lib} to ld search path
- - add support *-vine-linux gcc (patch1002)
- * Fri Nov 30 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-1
- - update to 3.1
- * Tue Jan 24 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 3.0-1
- - updated to 3.0 release
- * Sun Jan 15 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 2.9-3
- - added patch 2-4 to support -O4 link-time optimization
- * Fri Sep 9 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.9-2
- - disable -fno-var-tracking-assignments on ppc
- (seems like gcc-4.4.5 still doesn't support this)
- * Thu Aug 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9-1
- - new upstream release
- - add BR: libffi-devel
- - add R: libffi-devel to -devel
- * Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-1
- - initial build for Vine Linux
- * Sun May 2 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-1
- - Update to final 2.7 release
- * Sun Mar 28 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-0.1.pre1
- - Update to first 2.7 pre-release
- * Fri Sep 18 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.6.pre2
- - Update to 2.6 pre-release2
- - -devel subpackage now virtually provides -static
- * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.5.pre1
- - Disable var tracking assignments on PPC
- * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.4.pre1
- - Don't adjust clang include dir; files there are noarch (bz#521893)
- - Enable clang unit tests
- - clang and clang-analyzer renamed; no longer depend on llvm at runtime
- * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.3.pre1
- - Package Clang's static analyzer tools
- * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.2.pre1
- - PIC is now enabled by default; explicitly disable on %%{ix86}
- * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.1.pre1
- - First 2.6 prerelease
- - Enable Clang front-end
- - Enable debuginfo generation
- * Sat Sep 5 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-6
- - Disable assertions (needed by OpenGTL, bz#521261)
- - Align spec file with upstream build instructions
- - Enable unit tests
- * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-5
- - Only disable PIC on %%ix86; ppc actually needs it
- * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-4
- - Disable use of position-independent code on 32-bit platforms
- (buggy in LLVM <= 2.5)
- * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-3
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
- * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-2
- - Remove build scripts; they require the build directory to work
- * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-1
- - Update to 2.5
- - Package build scripts (bug #457881)
- * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-2
- - Patched build process for the OCaml binding
- * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-1
- - Update to 2.4
- - Package Ocaml binding
- * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-2
- - Add dependency on groff
- * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-1
- - LLVM 2.3
- * Thu May 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.2-4
- - fix license tags
- * Wed Mar 5 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.2-3
- - Fix compilation problems with gcc 4.3
- * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.2-2
- - Autorebuild for GCC 4.3
- * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-2
- - Fix review comments
- * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-1
- - Initial version
|