llvm-vl.spec 17 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572
  1. %bcond_with test
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. %define ver_suffix %(echo "%{version}" | cut -d . -f 1)
  4. %define _unpackaged_files_terminate_build 1
  5. # Build options:
  6. # Components skipped by default:
  7. %bcond_with doxygen
  8. # Documentation install path
  9. %global llvmdocdir() %{_docdir}/%1-%{version}
  10. %define _unpackaged_files_terminate_build 1
  11. # build order of LLVM family.
  12. # llvm
  13. # clang
  14. # lld
  15. # compiler-rt
  16. # lldb
  17. # libomp
  18. Summary: The Low Level Virtual Machine
  19. Summary(ja): LLVM - 低レベルバーチャルマシン
  20. Name: llvm
  21. Version: 17.0.2
  22. Release: 1%{?_dist_release}
  23. Group: programming
  24. Vendor: Project Vine
  25. Distribution: Vine Linux
  26. License: NCSA
  27. URL: https://llvm.org/
  28. Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/llvm-%{version}.src.tar.xz
  29. Source1: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/cmake-%{version}.src.tar.xz
  30. Source2: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/third-party-%{version}.src.tar.xz
  31. # multilib fixes
  32. Source10: llvm-config.h
  33. # patches
  34. # RHEL-specific patch to avoid unwanted recommonmark dep
  35. Patch101: 0101-Deactivate-markdown-doc.patch
  36. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  37. BuildRequires: binutils-devel
  38. BuildRequires: cmake
  39. BuildRequires: libedit-devel
  40. BuildRequires: libffi-devel
  41. BuildRequires: ncurses-devel
  42. BuildRequires: ninja
  43. BuildRequires: python3-devel
  44. BuildRequires: python3-rpm-macros
  45. BuildRequires: valgrind-devel
  46. BuildRequires: zlib-devel
  47. Requires: llvm-libs-extras = %{version}-%{release}
  48. %description
  49. LLVM is a compiler infrastructure designed for compile-time,
  50. link-time, runtime, and idle-time optimization of programs from
  51. arbitrary programming languages. The compiler infrastructure includes
  52. mirror sets of programming tools as well as libraries with equivalent
  53. functionality.
  54. %package devel
  55. Summary: Libraries and header files for LLVM
  56. Summary(ja): LLVM のライブラリおよびヘッダファイル
  57. Group: programming
  58. Requires: %{name} = %{version}-%{release}
  59. Requires: llvm-libs-extras = %{version}-%{release}
  60. Requires: libedit-devel
  61. %description devel
  62. This package contains library and header files needed to develop new
  63. native programs that use the LLVM infrastructure.
  64. %package doc
  65. Summary: Documentation for LLVM
  66. Summary(ja): LLVM のドキュメント
  67. Group: documentation
  68. BuildArch: noarch
  69. Requires: %{name} = %{version}-%{release}
  70. # might seem redundant, but needed to kill off the old arch-ed -doc subpackage
  71. Obsoletes: %{name}-doc < %{version}-%{release}
  72. %description doc
  73. Documentation for the LLVM compiler infrastructure.
  74. %package libs-extras
  75. Summary: extra files of LLVM shared libraries
  76. Summary(ja): LLVM 共有ライブラリの追加ファイル
  77. Group: system
  78. Requires: %{name} = %{version}-%{release}
  79. Requires: llvm%{ver_suffix}-libs = %{version}-%{release}
  80. %description libs-extras
  81. This package contains extra files of shared libraries for the LLVM
  82. compiler infrastructure.
  83. %package -n llvm%{ver_suffix}-libs
  84. Summary: LLVM shared libraries
  85. Summary(ja): LLVM 共有ライブラリ
  86. Group: system
  87. Obsoletes: llvm-libs < 15.0.0
  88. Obsoletes: llvm16-libs < 17.0.0
  89. Obsoletes: llvm15-libs < 16.0.0
  90. Obsoletes: llvm14-libs < 15.0.0
  91. Obsoletes: llvm13-libs < 14.0.0
  92. Obsoletes: llvm12-libs < 13.0.0
  93. %description -n llvm%{ver_suffix}-libs
  94. Shared libraries for the LLVM compiler infrastructure.
  95. %description -n llvm%{ver_suffix}-libs -l ja
  96. LLVM コンパイラ基盤の共有ライブラリです.
  97. %package static
  98. Summary: LLVM static libraries
  99. Summary(ja): LLVM 静的ライブラリ
  100. Group: programming
  101. Requires: llvm-devel = %{version}-%{release}
  102. %description static
  103. Static libraries for the LLVM compiler infrastructure.
  104. %description static -l ja
  105. LLVM コンパイラ基盤の静的ライブラリです.
  106. # compat32'
  107. %package -n compat32-%{name}%{ver_suffix}-libs
  108. Summary: LLVM shared libraries
  109. Summary(ja): LLVM 共有ライブラリ
  110. Group: system
  111. Provides: compat32-llvm-libs = %{version}-%{release}
  112. Requires: %{name}%{ver_suffix}-libs = %{version}-%{release}
  113. %description -n compat32-%{name}%{ver_suffix}-libs
  114. Shared libraries for the LLVM compiler infrastructure.
  115. %debug_package
  116. %prep
  117. %setup -q -T -b 1 -n cmake-%{version}.src
  118. cd ..
  119. mv -f cmake-%{version}.src cmake
  120. %setup -q -T -b 2 -n third-party-%{version}.src
  121. %autopatch -p2 -m200
  122. cd ..
  123. mv -f third-party-%{version}.src third-party
  124. %setup -q -T -b 0 -n llvm-%{version}.src
  125. %autopatch -p2 -M199
  126. pathfix%{python3_version}.py -i %{__python3} -pn \
  127. test/BugPoint/compile-custom.ll.py \
  128. tools/opt-viewer/*.py \
  129. utils/update_cc_test_checks.py
  130. %build
  131. %global _lto_cflags %{nil}
  132. %ifarch s390 s390x %{arm} %ix86 x86_64
  133. # Decrease debuginfo verbosity to reduce memory consumption during final library linking
  134. %global optflags %(echo %{optflags} | sed 's/-g /-g1 /')
  135. %endif
  136. %cmake \
  137. -GNinja \
  138. -DBUILD_SHARED_LIBS:BOOL=OFF \
  139. -DLLVM_PARALLEL_LINK_JOBS=1 \
  140. -DCMAKE_BUILD_TYPE=RelWithDebInfo \
  141. -DCMAKE_SKIP_RPATH:BOOL=ON \
  142. %ifarch %ix86 x86_64
  143. -DCMAKE_C_FLAGS_RELWITHDEBINFO="%{optflags} -DNDEBUG" \
  144. -DCMAKE_CXX_FLAGS_RELWITHDEBINFO="%{optflags} -DNDEBUG" \
  145. %endif
  146. %if 0%{?__isa_bits} == 64
  147. -DLLVM_LIBDIR_SUFFIX=64 \
  148. %else
  149. -DLLVM_LIBDIR_SUFFIX= \
  150. %endif
  151. \
  152. -DLLVM_TARGETS_TO_BUILD=all \
  153. -DLLVM_ENABLE_LIBCXX:BOOL=OFF \
  154. -DLLVM_ENABLE_ZLIB:BOOL=ON \
  155. -DLLVM_ENABLE_FFI:BOOL=ON \
  156. -DLLVM_ENABLE_RTTI:BOOL=ON \
  157. -DLLVM_USE_PERF:BOOL=ON \
  158. -DLLVM_BINUTILS_INCDIR=%{_includedir} \
  159. \
  160. -DLLVM_BUILD_RUNTIME:BOOL=ON \
  161. \
  162. -DLLVM_INCLUDE_TOOLS:BOOL=ON \
  163. -DLLVM_BUILD_TOOLS:BOOL=ON \
  164. \
  165. -DLLVM_INCLUDE_TESTS:BOOL=ON \
  166. -DLLVM_BUILD_TESTS:BOOL=ON \
  167. \
  168. -DLLVM_INCLUDE_EXAMPLES:BOOL=ON \
  169. -DLLVM_BUILD_EXAMPLES:BOOL=OFF \
  170. \
  171. -DLLVM_INCLUDE_BENCHMARKS=OFF \
  172. \
  173. -DLLVM_INCLUDE_UTILS:BOOL=ON \
  174. -DLLVM_INSTALL_UTILS:BOOL=ON \
  175. -DLLVM_UTILS_INSTALL_DIR:PATH=%{_bindir} \
  176. -DLLVM_TOOLS_INSTALL_DIR:PATH=bin \
  177. \
  178. -DLLVM_INCLUDE_DOCS:BOOL=ON \
  179. -DLLVM_ENABLE_SPHINX:BOOL=OFF \
  180. %if %{with doxygen}
  181. -DLLVM_ENABLE_DOXYGEN:BOOL=ON \
  182. %else
  183. -DLLVM_ENABLE_DOXYGEN:BOOL=OFF \
  184. %endif
  185. -DLLVM_BUILD_LLVM_DYLIB:BOOL=ON \
  186. -DLLVM_DYLIB_EXPORT_ALL:BOOL=ON \
  187. -DLLVM_LINK_LLVM_DYLIB:BOOL=ON \
  188. -DLLVM_BUILD_EXTERNAL_COMPILER_RT:BOOL=ON \
  189. -DLLVM_INSTALL_TOOLCHAIN_ONLY:BOOL=OFF \
  190. \
  191. -DLLVM_OPTIMIZED_TABLEGEN:BOOL=ON \
  192. # Build libLLVM.so first. This ensures that when libLLVM.so is linking, there
  193. # are no other compile jobs running. This will help reduce OOM errors on the
  194. # builders without having to artificially limit the number of concurrent jobs.
  195. %cmake_build --target LLVM
  196. %cmake_build
  197. %install
  198. %cmake_install
  199. pushd %{_vpath_builddir}
  200. #install -m755 ./bin/lli-child-target %{buildroot}%{_bindir}/lli-child-target
  201. # fix multi-lib
  202. mv -v %{buildroot}%{_bindir}/llvm-config{,-%{__isa_bits}}
  203. ln -sf llvm-config-%{__isa_bits} %{buildroot}%{_bindir}/llvm-config
  204. mv -v %{buildroot}%{_includedir}/llvm/Config/llvm-config{,-%{__isa_bits}}.h
  205. install -m 0644 %{SOURCE10} %{buildroot}%{_includedir}/llvm/Config/llvm-config.h
  206. # Add symlink to lto plugin in the binutils plugin directory.
  207. %{__mkdir_p} %{buildroot}%{_libdir}/bfd-plugins/
  208. ln -s ../LLVMgold.so %{buildroot}%{_libdir}/bfd-plugins/LLVMgold.so
  209. popd
  210. mkdir -p %{buildroot}%{_datadir}/llvm/cmake
  211. cp -Rv ../cmake/* %{buildroot}%{_datadir}/llvm/cmake/
  212. %if %{with test}
  213. %check
  214. ninja -C build check
  215. %endif
  216. %clean
  217. rm -rf %{buildroot}
  218. %posttrans devel
  219. # link llvm-config to the platform-specific file;
  220. # use ISA bits as priority so that 64-bit is preferred
  221. # over 32-bit if both are installed
  222. alternatives \
  223. --install \
  224. %{_bindir}/llvm-config \
  225. llvm-config \
  226. %{_bindir}/llvm-config-%{__isa_bits} \
  227. %{__isa_bits}
  228. %postun devel
  229. if [ $1 -eq 0 ]; then
  230. alternatives --remove llvm-config \
  231. %{_bindir}/llvm-config-%{__isa_bits}
  232. fi
  233. exit 0
  234. %files
  235. %defattr(-,root,root,-)
  236. %doc CREDITS.TXT README.txt
  237. %{_bindir}/*
  238. %exclude %{_bindir}/llvm-config
  239. %exclude %{_bindir}/llvm-config-%{__isa_bits}
  240. %doc %{_mandir}/man1/*
  241. %{_datadir}/opt-viewer
  242. %files libs-extras
  243. %{_libdir}/libLTO.so
  244. %{_libdir}/libRemarks.so
  245. %{_libdir}/LLVMgold.so
  246. %{_libdir}/bfd-plugins/LLVMgold.so
  247. %files -n llvm%{ver_suffix}-libs
  248. %defattr(-,root,root,-)
  249. %license LICENSE.TXT
  250. %{_libdir}/libLLVM-*.so
  251. %{_libdir}/libLTO.so.*
  252. %{_libdir}/libRemarks.so.*
  253. %files devel
  254. %defattr(-,root,root,-)
  255. %{_bindir}/llvm-config
  256. %{_bindir}/llvm-config-%{__isa_bits}
  257. %{_includedir}/%{name}
  258. %{_includedir}/%{name}-c
  259. %{_libdir}/libLLVM.so
  260. %{_libdir}/cmake/llvm
  261. %dir %{_datadir}/llvm
  262. %{_datadir}/llvm/cmake
  263. %files static
  264. %{_libdir}/*.a
  265. %files doc
  266. %defattr(-,root,root,-)
  267. %doc docs/*
  268. %if %{build_compat32}
  269. %files -n compat32-%{name}%{ver_suffix}-libs
  270. %defattr(-,root,root)
  271. %license LICENSE.TXT
  272. %{_libdir}/libLLVM-*.so
  273. %{_libdir}/libRemarks.so.*
  274. %endif
  275. %changelog
  276. * Fri Oct 06 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 17.0.2-1
  277. - new upstream release.
  278. * Sat Sep 30 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 17.0.1-1
  279. - new upstream release.
  280. * Sun May 28 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 16.0.4-1
  281. - new upstream release.
  282. * Fri Dec 16 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 15.0.6-1
  283. - new upstream release.
  284. * Wed Oct 05 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 15.0.2-1
  285. - new upstream release.
  286. * Wed Sep 07 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 15.0.0-1
  287. - new upstream release.
  288. * Wed Jun 15 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 14.0.5-1
  289. - new upstream release.
  290. * Thu Feb 03 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 13.0.1-1
  291. - new upstream release.
  292. * Fri Oct 22 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 13.0.0-1
  293. - new upstream release.
  294. - dropped Patch0.
  295. * Wed Aug 11 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.1-1
  296. - new upstream release.
  297. * Sat Apr 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.0-1
  298. - new upstream release.
  299. - separated into some packages.
  300. * Fri Oct 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-2
  301. - enabled to build utils.
  302. * Thu Oct 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-1
  303. - new upstream release.
  304. * Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.1-1
  305. - new upstream release.
  306. * Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-2
  307. - rebuilt with libffi-3.3.
  308. * Fri Mar 27 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-1
  309. - new upstream release.
  310. * Sun Dec 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.1-1
  311. - new upstream release.
  312. * Sun Sep 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-2
  313. - dropped all patches.
  314. - switched build-system to ninja.
  315. - switched python to python3.
  316. * Fri Sep 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-1
  317. - new upstream release.
  318. - added OpenMP.
  319. * Sun Dec 16 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.1-1
  320. - fixed %%files.
  321. * Wed Dec 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.0-1
  322. - new upstream release.
  323. - dropped Patch0, 4, 5, 100 and 200.
  324. - imported Patch3, 7, 12, 15, 100, 101, 102 and 400 from rawhide.
  325. - renamed a subpackage "llvm-libs".
  326. - added a subpackage "lld".
  327. * Tue Jan 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-2
  328. - added subpackages "llvm-static", "python-lldb" and "python-clang".
  329. * Mon Jan 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-1
  330. - new upstream release.
  331. - dropped Patch1 and 2: fixed in upstream.
  332. - imported Patch0, 3-5, 100 and 200 from rawhide.
  333. - disabled Patch1002: no longer needed?
  334. * Fri Aug 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.1-1
  335. - new upstream release.
  336. - switched to cmake.
  337. - disable ocaml binding as default.
  338. - updated Patch1000 and 1002.
  339. - disabled Patch1000 as default.
  340. - cleanup patches.
  341. * Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-2
  342. - rebuild with gcc-5.4.0
  343. * Sat Sep 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.2-1
  344. - new upstream release
  345. - added BR: ocaml-ctypes
  346. * Thu Jun 4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.1-1
  347. - new upstream release
  348. - dropt Patch 1, 201 and 1001
  349. - updated Patch 1000
  350. * Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.5.1-1
  351. - updated to 3.5.1
  352. - added Patch1, 2, 100, 101, 200, 201 and 202 from Fedora
  353. - added clang-libs, lldb, lldb-devel and compat32-llvm-libs subpackage
  354. - obsoleted clang-doc
  355. - built with ocaml 4.02.1
  356. * Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-2
  357. - fix <BTS:2832>
  358. - fix configure option "--with-c-include-dirs"
  359. - update Patch1000: clang-3.5.0-driver-ld.gold.patch
  360. - update Patch1001: clang-3.5.0-driver-lib64.patch
  361. - update Patch1002: clang-3.5.0-driver-vine.patch
  362. * Tue Oct 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-1
  363. - update to 3.5.0
  364. - remove Patch11 (clang-hardfloat-hack.patch)
  365. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3-2
  366. - rebuild with libffi-3.0.13
  367. * Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3-1
  368. - update to 3.3
  369. * Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-2
  370. - ld.gold (patch1000,1001)
  371. - add /%{_lib} to ld search path
  372. - add support *-vine-linux gcc (patch1002)
  373. * Fri Nov 30 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-1
  374. - update to 3.1
  375. * Tue Jan 24 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 3.0-1
  376. - updated to 3.0 release
  377. * Sun Jan 15 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 2.9-3
  378. - added patch 2-4 to support -O4 link-time optimization
  379. * Fri Sep 9 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.9-2
  380. - disable -fno-var-tracking-assignments on ppc
  381. (seems like gcc-4.4.5 still doesn't support this)
  382. * Thu Aug 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9-1
  383. - new upstream release
  384. - add BR: libffi-devel
  385. - add R: libffi-devel to -devel
  386. * Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-1
  387. - initial build for Vine Linux
  388. * Sun May 2 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-1
  389. - Update to final 2.7 release
  390. * Sun Mar 28 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-0.1.pre1
  391. - Update to first 2.7 pre-release
  392. * Fri Sep 18 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.6.pre2
  393. - Update to 2.6 pre-release2
  394. - -devel subpackage now virtually provides -static
  395. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.5.pre1
  396. - Disable var tracking assignments on PPC
  397. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.4.pre1
  398. - Don't adjust clang include dir; files there are noarch (bz#521893)
  399. - Enable clang unit tests
  400. - clang and clang-analyzer renamed; no longer depend on llvm at runtime
  401. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.3.pre1
  402. - Package Clang's static analyzer tools
  403. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.2.pre1
  404. - PIC is now enabled by default; explicitly disable on %%{ix86}
  405. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.1.pre1
  406. - First 2.6 prerelease
  407. - Enable Clang front-end
  408. - Enable debuginfo generation
  409. * Sat Sep 5 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-6
  410. - Disable assertions (needed by OpenGTL, bz#521261)
  411. - Align spec file with upstream build instructions
  412. - Enable unit tests
  413. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-5
  414. - Only disable PIC on %%ix86; ppc actually needs it
  415. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-4
  416. - Disable use of position-independent code on 32-bit platforms
  417. (buggy in LLVM <= 2.5)
  418. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-3
  419. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  420. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-2
  421. - Remove build scripts; they require the build directory to work
  422. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-1
  423. - Update to 2.5
  424. - Package build scripts (bug #457881)
  425. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-2
  426. - Patched build process for the OCaml binding
  427. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-1
  428. - Update to 2.4
  429. - Package Ocaml binding
  430. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-2
  431. - Add dependency on groff
  432. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-1
  433. - LLVM 2.3
  434. * Thu May 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.2-4
  435. - fix license tags
  436. * Wed Mar 5 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.2-3
  437. - Fix compilation problems with gcc 4.3
  438. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.2-2
  439. - Autorebuild for GCC 4.3
  440. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-2
  441. - Fix review comments
  442. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-1
  443. - Initial version