libcap-ng-vl.spec 7.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define _unpackaged_files_terminate_build 1
  3. Summary: An alternate posix capabilities library
  4. Name: libcap-ng
  5. Version: 0.8.3
  6. Release: 1%{?_dist_release}
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: LGPLv2+
  11. URL: http://people.redhat.com/sgrubb/libcap-ng/
  12. Source0: http://people.redhat.com/sgrubb/libcap-ng/%{name}-%{version}.tar.gz
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  14. BuildRequires: kernel-headers >= 2.6.11
  15. BuildRequires: libattr-devel
  16. %description
  17. Libcap-ng is a library that makes using posix capabilities easier
  18. %package devel
  19. Summary: Header files for libcap-ng library
  20. License: LGPLv2+
  21. Group: programming
  22. Requires: kernel-headers >= 2.6.11
  23. Requires: %{name} = %{version}-%{release}
  24. Requires: pkgconfig
  25. %description devel
  26. The libcap-ng-devel package contains the files needed for developing
  27. applications that need to use the libcap-ng library.
  28. %package python
  29. Summary: Python bindings for libcap-ng library
  30. License: LGPLv2+
  31. Group: programming
  32. BuildRequires: python-devel swig
  33. BuildRequires: python-rpm-macros
  34. Requires: %{name} = %{version}-%{release}
  35. %description python
  36. The libcap-ng-python package contains the bindings so that libcap-ng
  37. and can be used by python applications.
  38. %package python3
  39. Summary: Python3 bindings for libcap-ng library
  40. License: LGPLv2+
  41. Group: programming
  42. BuildRequires: python3-devel swig
  43. BuildRequires: python3-rpm-macros
  44. Requires: %{name} = %{version}-%{release}
  45. %description python3
  46. The libcap-ng-python3 package contains the bindings so that libcap-ng
  47. and can be used by python3 applications.
  48. %package utils
  49. Summary: Utilities for analysing and setting file capabilities
  50. License: GPLv2+
  51. Group: admin-tools
  52. Requires: %{name} = %{version}-%{release}
  53. %description utils
  54. The libcap-ng-utils package contains applications to analyse the
  55. posix capabilities of all the program running on a system. It also
  56. lets you set the file system based capabilities.
  57. %package -n compat32-%{name}
  58. Summary: An alternate posix capabilities library
  59. Group: system
  60. Requires: %{name} = %{version}-%{release}
  61. %description -n compat32-%{name}
  62. Libcap-ng is a library that makes using posix capabilities easier
  63. %package -n compat32-%{name}-devel
  64. Summary: Header files for libcap-ng library
  65. Group: programming
  66. License: LGPLv2+
  67. Requires: %{name}-devel = %{version}-%{release}
  68. %description -n compat32-%{name}-devel
  69. The libcap-ng-devel package contains the files needed for developing
  70. applications that need to use the libcap-ng library.
  71. %debug_package
  72. %prep
  73. %setup -q
  74. %build
  75. %configure --with-python --with-python3
  76. make %{?_smp_mflags}
  77. %install
  78. rm -rf $RPM_BUILD_ROOT
  79. make DESTDIR="${RPM_BUILD_ROOT}" install
  80. mkdir -p %{buildroot}/%{_lib}
  81. pushd %{buildroot}%{_libdir}
  82. for f in *.so.*; do
  83. ln -sf ..%{_libdir}/$f %{buildroot}/%{_lib}/$f
  84. done
  85. popd
  86. # Remove a couple things so they don't get picked up
  87. rm -f $RPM_BUILD_ROOT%{_libdir}/libcap-ng.la
  88. rm -f $RPM_BUILD_ROOT%{_libdir}/libcap-ng.a
  89. rm -f $RPM_BUILD_ROOT%{_libdir}/libdrop_ambient.la
  90. rm -f $RPM_BUILD_ROOT%{_libdir}/libdrop_ambient.a
  91. rm -f $RPM_BUILD_ROOT%{_libdir}/python?.?/site-packages/_capng.a
  92. rm -f $RPM_BUILD_ROOT%{_libdir}/python?.?/site-packages/_capng.la
  93. %check
  94. make check
  95. %clean
  96. rm -rf $RPM_BUILD_ROOT
  97. %files
  98. %defattr(-,root,root,-)
  99. %license COPYING.LIB
  100. %attr(0755,root,root) %{_libdir}/libcap-ng.so.*
  101. %attr(0755,root,root) %{_libdir}/libdrop_ambient.so.*
  102. /%{_lib}/libcap-ng.so.*
  103. /%{_lib}/libdrop_ambient.so.*
  104. %files devel
  105. %defattr(-,root,root,-)
  106. %attr(0644,root,root) %{_mandir}/man3/*
  107. %attr(0644,root,root) %{_mandir}/man7/*
  108. %attr(0644,root,root) %{_includedir}/cap-ng.h
  109. %attr(0755,root,root) %{_libdir}/libcap-ng.so
  110. %attr(0755,root,root) %{_libdir}/libdrop_ambient.so
  111. %attr(0644,root,root) %{_datadir}/aclocal/cap-ng.m4
  112. %{_libdir}/pkgconfig/libcap-ng.pc
  113. %files python
  114. %defattr(-,root,root,-)
  115. %attr(755,root,root) /%{_libdir}/python?.?/site-packages/_capng.so
  116. %{python_sitearch}/capng.py*
  117. %files python3
  118. %defattr(-,root,root,-)
  119. %attr(755,root,root) %{python3_sitearch}/*
  120. %{python3_sitearch}/capng.py*
  121. %files utils
  122. %defattr(-,root,root,-)
  123. %doc COPYING
  124. %attr(0755,root,root) %{_bindir}/*
  125. %attr(0644,root,root) %{_mandir}/man8/*
  126. %if %{build_compat32}
  127. %files -n compat32-%{name}
  128. %defattr(-,root,root,-)
  129. %attr(0755,root,root) %{_libdir}/libcap-ng.so.*
  130. %files -n compat32-%{name}-devel
  131. %defattr(-,root,root,-)
  132. %attr(0755,root,root) %{_libdir}/libcap-ng.so
  133. %{_libdir}/pkgconfig/libcap-ng.pc
  134. %endif
  135. %changelog
  136. * Thu Jun 15 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.8.3-1
  137. - new upstream release.
  138. * Wed Feb 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.8.2-1
  139. - new upstream release.
  140. * Sun Apr 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.7.10-1
  141. - new upstream release.
  142. * Tue Feb 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.7.9-1
  143. - new upstream release.
  144. - added compat32-* packages.
  145. - enabled python3 modules.
  146. * Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.3-2
  147. - rebuild with VineSeed environment
  148. * Mon Jan 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.3-1
  149. - new upstream release
  150. * Sun Oct 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.1-1
  151. - new upstream release
  152. * Mon Feb 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.6-2
  153. - rebuild with python-2.7.2
  154. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.6-1
  155. - initial build for Vine Linux
  156. * Fri Jun 24 2011 Steve Grubb <sgrubb@redhat.com> 0.6.6-1
  157. - New upstream release
  158. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.5-2
  159. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  160. * Wed Nov 03 2010 Steve Grubb <sgrubb@redhat.com> 0.6.5-1
  161. - New upstream release fixing 2.6.36 kernel header issue
  162. * Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 0.6.4-4
  163. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  164. * Thu Jun 17 2010 Steve Grubb <sgrubb@redhat.com> 0.6.4-3
  165. - Only open regular files in filecap
  166. * Mon May 24 2010 Steve Grubb <sgrubb@redhat.com> 0.6.4-2
  167. - In utils subpackage added a requires statement.
  168. * Thu May 06 2010 Steve Grubb <sgrubb@redhat.com> 0.6.4-1
  169. - New upstream release fixing multi-threading issue
  170. * Wed Apr 28 2010 Steve Grubb <sgrubb@redhat.com> 0.6.3-2
  171. - filecap shows full capabilities if a file has any
  172. * Thu Mar 11 2010 Steve Grubb <sgrubb@redhat.com> 0.6.3-1
  173. - New upstream release
  174. * Tue Feb 16 2010 Steve Grubb <sgrubb@redhat.com> 0.6.2-4
  175. - Use global macro and require pkgconfig for devel subpackage
  176. * Fri Oct 09 2009 Steve Grubb <sgrubb@redhat.com> 0.6.2-3
  177. - Apply patch to retain setpcap only if clearing bounding set
  178. * Sat Oct 03 2009 Steve Grubb <sgrubb@redhat.com> 0.6.2-2
  179. - Apply patch correcting pscap and netcap acct detection
  180. * Mon Sep 28 2009 Steve Grubb <sgrubb@redhat.com> 0.6.2-1
  181. - New upstream release
  182. * Sun Jul 26 2009 Steve Grubb <sgrubb@redhat.com> 0.6.1-1
  183. - New upstream release
  184. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6-2
  185. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  186. * Mon Jun 29 2009 Steve Grubb <sgrubb@redhat.com> 0.6-1
  187. - New upstream release
  188. * Sun Jun 21 2009 Steve Grubb <sgrubb@redhat.com> 0.5.1-1
  189. - New upstream release
  190. * Fri Jun 19 2009 Steve Grubb <sgrubb@redhat.com> 0.5-1
  191. - New upstream release
  192. * Fri Jun 12 2009 Steve Grubb <sgrubb@redhat.com> 0.4.2-1
  193. - New upstream release
  194. * Fri Jun 12 2009 Steve Grubb <sgrubb@redhat.com> 0.4.1-1
  195. - Initial build.