speech-dispatcher-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347
  1. %define with_nas 1
  2. %define with_pulse 1
  3. %define with_flite 1
  4. Name: speech-dispatcher
  5. Version: 0.8.1
  6. Release: 2%{?_dist_release}
  7. Summary: To provide a high-level device independent layer for speech synthesis
  8. Group: System Environment/Libraries
  9. # Almost all files are under GPLv2+, however
  10. # src/c/clients/spdsend/spdsend.h is licensed under GPLv2,
  11. # which makes %%_bindir/spdsend GPLv2.
  12. License: GPLv2+ and GPLv2
  13. URL: http://www.freebsoft.org/pub/projects/speechd/
  14. Source0: http://www.freebsoft.org/pub/projects/speechd/%{name}-%{version}.tar.gz
  15. Source1: http://www.nsitonline.in/hemant/stuff/speechd-rpm/speech-dispatcherd
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: espeak-devel
  18. BuildRequires: alsa-lib-devel
  19. BuildRequires: dotconf-devel
  20. BuildRequires: texinfo
  21. BuildRequires: libraw1394-devel
  22. BuildRequires: pulseaudio-libs-devel
  23. BuildRequires: libao-devel
  24. BuildRequires: glib2-devel
  25. BuildRequires: flite-devel
  26. BuildRequires: nas-devel
  27. BuildRequires: libtool-ltdl-devel
  28. Requires(post): /sbin/chkconfig
  29. Requires(preun): /sbin/chkconfig /sbin/service
  30. Requires(postun): /sbin/service
  31. Obsoletes: %{name}-python < 0.8.0
  32. %description
  33. * Common interface to different TTS engines
  34. * Handling concurrent synthesis requests – requests may come
  35. asynchronously from multiple sources within an application
  36. and/or from more different applications.
  37. * Subsequent serialization, resolution of conflicts and
  38. priorities of incoming requests
  39. * Context switching – state is maintained for each client
  40. connection independently, event for connections from
  41. within one application.
  42. * High-level client interfaces for popular programming languages
  43. * Common sound output handling – audio playback is handled by
  44. Speech Dispatcher rather than the TTS engine, since most engines
  45. have limited sound output capabilities.
  46. %package devel
  47. Summary: Development files for %{name}
  48. Summary(ja): %{name} の開発用ファイル
  49. Group: Development/Libraries
  50. License: GPLv2+
  51. Requires: speech-dispatcher = %{version}-%{release}
  52. %description devel
  53. The %{name}-devel package contains libraries and header files for
  54. developing applications that use %{name}.
  55. %package doc
  56. Summary: Documentation for speech-dispatcher
  57. Summary(ja): speech-dispatcher のドキュメント
  58. License: GPLv2+
  59. Group: Applications/Documentation
  60. BuildArch: noarch
  61. Requires: speech-dispatcher = %{version}-%{release}
  62. Requires(post): /sbin/install-info
  63. Requires(preun):/sbin/install-info
  64. %description doc
  65. speechd documentation
  66. %prep
  67. %setup -q
  68. %build
  69. # only for configure
  70. export LIBS="-lpulse -lpulse-simple"
  71. %configure \
  72. --disable-static \
  73. --with-alsa \
  74. --with-pulse \
  75. --with-flite \
  76. --sysconfdir=%{_sysconfdir} \
  77. --with-default-audio-method=pulse
  78. make %{?_smp_mflags}
  79. %install
  80. rm -rf $RPM_BUILD_ROOT
  81. for dir in \
  82. config/ doc/ include/ src/audio/ src/api/ src/modules/ src/tests/ src/server/ src/clients/
  83. do
  84. pushd $dir
  85. make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
  86. popd
  87. done
  88. #Install the init shell script
  89. mkdir -p $RPM_BUILD_ROOT%{_initrddir}
  90. install -p -m 0755 %{SOURCE1} $RPM_BUILD_ROOT%{_initrddir}/
  91. #Remove %{_infodir}/dir file
  92. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  93. cd ../../
  94. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  95. # Move the config files from /usr/share to /etc
  96. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/speech-dispatcher/clients
  97. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/speech-dispatcher/modules
  98. mv $RPM_BUILD_ROOT%{_datadir}/speech-dispatcher/conf/speechd.conf $RPM_BUILD_ROOT%{_sysconfdir}/speech-dispatcher/
  99. mv $RPM_BUILD_ROOT%{_datadir}/speech-dispatcher/conf/clients/* $RPM_BUILD_ROOT%{_sysconfdir}/speech-dispatcher/clients
  100. mv $RPM_BUILD_ROOT%{_datadir}/speech-dispatcher/conf/modules/* $RPM_BUILD_ROOT%{_sysconfdir}/speech-dispatcher/modules
  101. # Remove dummy sound
  102. rm -rf $RPM_BUILD_ROOT/%{_datadir}/sounds/
  103. # Create log dir
  104. mkdir -p -m 0700 $RPM_BUILD_ROOT%{_localstatedir}/log/speech-dispatcher/
  105. # enable pulseaudio as default with a fallback to alsa
  106. sed 's/# AudioOutputMethod "pulse,alsa"/AudioOutputMethod "pulse,alsa"/' %{buildroot}%{_sysconfdir}/speech-dispatcher/speechd.conf
  107. %clean
  108. rm -rf $RPM_BUILD_ROOT
  109. %post
  110. /sbin/ldconfig
  111. /sbin/chkconfig --add speech-dispatcherd
  112. %postun
  113. /sbin/ldconfig
  114. if [ "$1" -ge "1" ] ; then
  115. /sbin/service speech-dispatcherd condrestart >/dev/null 2>&1 || :
  116. fi
  117. %preun
  118. if [ $1 = 0 ] ; then
  119. /sbin/service speech-dispatcherd stop >/dev/null 2>&1
  120. /sbin/chkconfig --del speech-dispatcherd
  121. fi
  122. %post doc
  123. /sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir || :
  124. /sbin/install-info %{_infodir}/spd-say.info %{_infodir}/dir || :
  125. /sbin/install-info %{_infodir}/ssip.info %{_infodir}/dir || :
  126. /sbin/install-info %{_infodir}/%{name}-cs.info %{_infodir}/dir || :
  127. %preun doc
  128. if [ $1 = 0 ]; then
  129. /sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir || :
  130. /sbin/install-info --delete %{_infodir}/spd-say.info %{_infodir}/dir || :
  131. /sbin/install-info --delete %{_infodir}/ssip.info %{_infodir}/dir || :
  132. /sbin/install-info --delete %{_infodir}/%{name}-cs.info %{_infodir}/dir || :
  133. fi
  134. %files
  135. %defattr(-,root,root,-)
  136. %doc AUTHORS ChangeLog NEWS README TODO COPYING
  137. %config(noreplace) %{_sysconfdir}/speech-dispatcher/speechd.conf
  138. %config(noreplace) %{_sysconfdir}/speech-dispatcher/clients/*.conf
  139. %config(noreplace) %{_sysconfdir}/speech-dispatcher/modules/*.conf
  140. %dir %{_sysconfdir}/speech-dispatcher/
  141. %dir %{_sysconfdir}/speech-dispatcher/clients
  142. %dir %{_sysconfdir}/speech-dispatcher/modules
  143. %{_bindir}/*
  144. %{_libdir}/speech-dispatcher-modules/sd_*
  145. %dir %{_libdir}/speech-dispatcher-modules
  146. %{_libdir}/libspeechd.so.*
  147. %dir %{_libdir}/speech-dispatcher
  148. %{_libdir}/speech-dispatcher/spd*.so
  149. %dir %attr(0700, root, root) %{_localstatedir}/log/speech-dispatcher/
  150. %attr(0755,root,root)%{_initrddir}/speech-dispatcherd
  151. %files devel
  152. %defattr(-,root,root,-)
  153. %{_includedir}/*
  154. %{_libdir}/lib*.so
  155. %files doc
  156. %defattr(-,root,root,-)
  157. %{_infodir}/*
  158. %changelog
  159. * Tue Feb 17 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.8.1-2
  160. - rebuilt with flite 2.0
  161. - changed doc subpackage to noarch
  162. * Sun Dec 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.8.1-1
  163. - new upstream release
  164. - remove %%{name}-python subpackage
  165. - add BuildRequires: libtool-ltdl-devel
  166. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.7.1-2
  167. - rebuild with python-2.7.2
  168. * Sat Nov 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.7.1-1
  169. - new upstream release
  170. - remove all patches
  171. * Sun Mar 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.6.7-5
  172. - Initial build for Vine Linux
  173. * Wed Mar 3 2010 Peter Robinson <pbrobinson@gmail.com> - 0.6.7-4
  174. - Add patch to fix dso linking. Bug 564851
  175. * Sat Jan 9 2010 Peter Robinson <pbrobinson@gmail.com> - 0.6.7-3
  176. - Updated to the new python sysarch spec file reqs
  177. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.7-2
  178. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  179. * Wed May 20 2009 Peter Robinson <pbrobinson@gmail.com> - 0.6.7-1
  180. - New upstream release, some spec file cleanups.
  181. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.6-21
  182. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  183. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.6.6-20
  184. - Rebuild for Python 2.6
  185. * Sun Sep 21 2008 Ville Skyttä <ville.skytta at iki.fi> - 0.6.6-19
  186. - Fix Patch0:/%%patch mismatch.
  187. * Wed Jul 16 2008 Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-18
  188. - removed suid permission for speech-dispatcher binary.
  189. * Wed Jul 16 2008 Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-17
  190. - changing permissions of speech-dispatcher to 6711 (setuid and setguid)
  191. - relocating configuration files in case of OLPC branch.
  192. - excluding init script in case of OLPC branch.
  193. * Wed Jul 16 2008 Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-16
  194. - yet another release bump required :-/
  195. * Wed Jul 16 2008 Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-15
  196. - release bump
  197. * Sun Jul 13 2008 Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-14
  198. - conditional build required for OLPC Branch - Building without nas and
  199. pulse-audio support.
  200. * Mon Jun 23 2008 Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-13
  201. - changed permission of speech-dispatcherd to 0644 too.
  202. * Fri Jun 20 2008 Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-12
  203. - added BuildRequires: texinfo (for makeinfo)
  204. - changed permissions of Sourcex to 0644
  205. - incorporated modified init script by mtasaka
  206. - fixed a few more macros in changelog
  207. - modified location of Source1 and Patch0 to point to online locations
  208. * Wed Jun 18 2008 Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-11
  209. - fixed encoding of speech-dispatcher-cs.info file to UTF-8
  210. * Wed Jun 11 2008 Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-10
  211. - removed Requires(preun) duplicates
  212. - applied -p option correctly to install command
  213. - fixed macros in changelog to prevent them from exapnding
  214. - fixed the init script
  215. - added patch to change log directory of speech-dispatcher and start only espeak
  216. * Sun Jun 08 2008 Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-9
  217. - removed %%{_infodir}/dir file
  218. * Sat Jun 07 2008 Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-8
  219. - converted speech-dispatcher-cs.info to UTF-8 encoding
  220. - removed multiple file listings of /usr/lib/python2.5/site-packages/speechd/_test.py
  221. and fixed its mode
  222. - added init script as a SOURCE instead as a patch
  223. - duplicate Requires have now been removed
  224. - Timestamping of files has now been added
  225. - Install script fixed
  226. - init script fixed
  227. * Tue Jun 03 2008 Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-7
  228. - changed license of base package to GPLv2+ and GPL
  229. - changed license of all other packages to GPLv2+
  230. - fixed install sequence using cleaner for loop and pushd and popd commands
  231. - added init script for speech-dispatcher daemon
  232. - added COPYING to doc in base package
  233. - removed comment after /sbin/ldconfig
  234. - resolved rpmlint errors for base package [except UTF-8 encoding error for (cs) documentation file]
  235. - renamed long_message to spd_long_message and run_test to spd_run_test
  236. - reset mode of _test.py to 0755
  237. * Sun Apr 27 2008 Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-6
  238. - changed BR to pulseaudio-lib-devel
  239. - removed dotconf BR
  240. - gave ownership of /%%{python_sitelib}/speechd-0.3-py2.5.egg-info to python package if package is built for Fedora 9 or above
  241. * Sun Apr 13 2008 Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-5
  242. - Removed conitional building options
  243. - Added BuildRequires for dotconf-devel
  244. * Mon Feb 18 2008 Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-4
  245. - Manually specyfying make install for each src directory to be installed
  246. - Installing python package seprately by by-passing make install
  247. * Sun Feb 17 2008 Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-3
  248. - Added Requires(post), Requires(preun) for -doc package
  249. - Changed scriptlet from postun to preun for -doc package
  250. - Removed Epoch
  251. - Moved %%{_libdir}/lib*.so back to devel pacakge
  252. - Require dependecny on base pacakge is now set to %%{version}-%%{release} instead of %%{version}
  253. - removed --prefix=$RPM_BUILD_ROOT/%%{_prefix} against configure macro.
  254. -- -python subpackage does not build anymore.
  255. - removed python subpackag rules from SPEC file.
  256. * Sat Feb 16 2008 Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-2
  257. - fixed directory ownerships
  258. * Sat Feb 16 2008 Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-1
  259. - using newest version of speech-dispatcher
  260. - updated %%{_libdir}/libspeechd.so.2.0.4 to %%{_libdir}/libspeechd.so.2.0.5
  261. - python packages are being generated correctly now
  262. - must force prefix=$RPM_BUILD_ROOT/%%{_prefix} to enable python packages to get installed correctly.
  263. - finding and deleting .*la files in $RPM_BUILD_ROOT to avoid unpackaged files error.
  264. * Sat Feb 16 2008 Hemant Goyal <goyal.hemant@gmail.com> 0.6.5-4
  265. - updated build root
  266. * Sat Feb 16 2008 Hemant Goyal <goyal.hemant@gmail.com> 0.6.5-3
  267. - added macro to prevent error from stopping build for not including *.la files
  268. - added epoch to the SPEC
  269. - conditional build seems to be working correctly the old way only??
  270. - unified changelogs
  271. * Fri Feb 15 2008 Hemant Goyal <goyal.hemant@gmail.com> 0.6.5-2
  272. - Removed .la files
  273. - Removed doc-cs packages and merged it into doc package
  274. - Removed packaging of static files, and tested -without static_libs option for configure script
  275. - Moved symlink .so files from devel package to main package
  276. - Commented /sbin/ldconfig for devel package.