libgnomeprint-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417
  1. ## this could go, it's really just so we notice if the soname changes
  2. %define sover 0
  3. %define gettext_package libgnomeprint-2.2
  4. %define glib2_base_version 2.26.0
  5. %define glib2_version %{glib2_base_version}
  6. %define pango_version 1.28.2
  7. %define libxml2_version 2.7.7
  8. %define libart_lgpl_version 2.3.16
  9. %define libbonobo_version 2.32.0
  10. %define freetype_version 2.3.7
  11. %define gtk_doc_version 1.1
  12. Summary: Printing library for GNOME.
  13. Summary(ja): GNOME プリントライブラリ
  14. Name: libgnomeprint
  15. Version: 2.18.8
  16. Release: 3%{?_dist_release}
  17. License: LGPL
  18. Group: System Environment/Libraries
  19. Source: ftp://ftp.gnome.org/pub/gnome/sources/%{name}/2.18/%{name}-%{version}.tar.bz2
  20. Patch0: libgnomeprint-2.18.8-freetype-2.5.x.patch
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  22. BuildRequires: glib2-devel >= %{glib2_version}
  23. BuildRequires: pango-devel >= %{pango_version}
  24. BuildRequires: libxml2-devel >= %{libxml2_version}
  25. BuildRequires: libart_lgpl-devel >= %{libart_lgpl_version}
  26. BuildRequires: libbonobo-devel >= %{libbonobo_version}
  27. BuildRequires: freetype2 >= %{freetype_version}
  28. BuildRequires: gtk-doc >= %{gtk_doc_version}
  29. BuildRequires: libgnomecups-devel >= 0.2.0
  30. BuildRequires: bison
  31. BuildRequires: flex
  32. Requires: libgnomecups >= 0.1.13-0vl2
  33. Requires: urw-fonts
  34. Requires: ghostscript
  35. Requires: ghostscript-fonts
  36. Requires: libxml2
  37. Requires: perl
  38. Vendor: Project Vine
  39. Distribution: Vine Linux
  40. %description
  41. GNOME (GNU Network Object Model Environment) is a user-friendly set of
  42. applications and desktop tools to be used in conjunction with a window
  43. manager for the X Window System. The gnome-print package contains
  44. libraries and fonts needed by GNOME applications for printing.
  45. You should install the gnome-print package if you intend to use any of
  46. the GNOME applications that can print. If you would like to develop
  47. GNOME applications that can print you will also need to install the
  48. gnome-print devel package.
  49. %package devel
  50. Summary: Libraries and include files for developing GNOME applications.
  51. Summary(ja): libgnomeprint のライブラリとヘッダファイル
  52. Group: Development/Libraries
  53. Requires: %{name} = %{version}-%{release}
  54. Requires: glib2-devel >= %{glib2_version}
  55. Requires: pango-devel >= %{pango_version}
  56. Requires: libxml2-devel >= %{libxml2_version}
  57. Requires: libart_lgpl-devel >= %{libart_lgpl_version}
  58. Requires: libbonobo-devel >= %{libbonobo_version}
  59. Requires: freetype2 >= %{freetype_version}
  60. %description devel
  61. GNOME (GNU Network Object Model Environment) is a user-friendly set of
  62. applications and desktop tools to be used in conjunction with a window
  63. manager for the X Window System. The gnome-print-devel package
  64. includes the libraries and include files needed for developing
  65. applications that use the GNOME printing capabilities.
  66. You should install the gnome-print-devel package if you would like to
  67. develop GNOME applications that will use the GNOME print capabilities.
  68. You do not need to install the gnome-print-devel package if you just
  69. want to use the GNOME desktop environment.
  70. %prep
  71. %setup -q -n %{name}-%{version}
  72. %patch0 -p1 -b .ft
  73. %build
  74. %configure --disable-font-install --disable-gtk-doc
  75. make
  76. %install
  77. rm -rf $RPM_BUILD_ROOT
  78. # It would probably be cleaner to use install DESTDIR=$RPM_BUILD_ROOT
  79. # instead of %%makeinstall with this hack.
  80. %makeinstall
  81. # remove unpackaged files
  82. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  83. rm -f $RPM_BUILD_ROOT%{_libdir}/libgnomeprint/%{version}/modules/*.{a,la}
  84. rm -f $RPM_BUILD_ROOT%{_libdir}/libgnomeprint/%{version}/modules/*/*.{a,la}
  85. %clean
  86. rm -rf $RPM_BUILD_ROOT
  87. %post -p /sbin/ldconfig
  88. %postun -p /sbin/ldconfig
  89. %files
  90. %defattr(-, root, root)
  91. %doc AUTHORS COPYING ChangeLog NEWS README
  92. %dir %{_libdir}/libgnomeprint/%{version}
  93. %{_libdir}/libgnomeprint/%{version}/modules/*.so
  94. %{_libdir}/libgnomeprint/%{version}/modules/transports/*.so
  95. %{_libdir}/libgnomeprint/%{version}/modules/filters/*.so
  96. %{_libdir}/libgnomeprint*.so.*
  97. %{_datadir}/libgnomeprint
  98. %{_datadir}/locale/*/LC_MESSAGES/*.mo
  99. %files devel
  100. %defattr(-, root, root)
  101. %{_libdir}/libgnomeprint*.so
  102. %{_libdir}/*.a
  103. %{_includedir}/*
  104. %{_libdir}/pkgconfig/*.pc
  105. %{_datadir}/gtk-doc
  106. %changelog
  107. * Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.8-3
  108. - rebuild with VineSeed environment
  109. - add Patch0 (libgnomeprint-2.18.8-freetype-2.5.x.patch)
  110. * Sat Aug 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.8-2
  111. - change Requires: libxml2 instead of libxml
  112. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.8-1
  113. - new upstream release
  114. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.18.7-2
  115. - build with rpm-4.8.1-1 for pkg-config file
  116. * Thu Apr 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.7-1
  117. - new upstream release
  118. - add BuildRequires: bison, flex
  119. * Wed Mar 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.6-1
  120. - new upstream release
  121. * Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.5-1
  122. - new upstream release
  123. - build with gtk+2.14
  124. * Tue Mar 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.4-1vl5
  125. - new upstream release
  126. - removed BuildRequires: automake17
  127. * Wed Dec 12 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
  128. - new upstream release
  129. * Sun May 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.0-0vl2
  130. - rebuilt with new toolchain/environment
  131. * Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl1
  132. - new upstream release
  133. * Fri May 26 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-0vl3
  134. - changed Group to System Environment/Libraries
  135. * Sat Apr 22 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
  136. - add missing filter modules to %%files
  137. - remove unneeded static modules
  138. * Wed Sep 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
  139. - new upstream release
  140. * Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
  141. - new upstream release
  142. * Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.0-0vl1
  143. - new upstream release
  144. * Sun Jul 3 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.3-0vl1
  145. - new upstream version
  146. - drop all patches that are now upstream.
  147. * Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
  148. - new upstream version
  149. - drop all patches that are now upstream.
  150. * Wed Mar 02 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-0vl1
  151. - new upstream release
  152. - updated patch7,8 from Fedora Development
  153. - added Japanese summary to devel package
  154. * Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0.1-0vl1
  155. - new upstream release
  156. - add patch7,8 from fc
  157. * Fri Jul 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
  158. - add Patch11 from bugzilla.gnome.org to support ttc font's multiple face.
  159. * Sun Nov 30 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-0vl1
  160. - new upstream release
  161. * Mon Sep 29 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
  162. - new upstream release
  163. * Sun Sep 14 2003 KAZUKI SHIMURA <rito@pos.to> 2.3.1-0vl2
  164. - Oops, spec was in Shift_JIS. Fixed.
  165. * Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-0vl1
  166. - new upstream release
  167. * Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1.3-0vl1
  168. - new upstream release
  169. * Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
  170. - new upstream release
  171. * Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
  172. - new upstream release
  173. * Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.8-0vl1
  174. - new upstream release
  175. * Thu Jan 9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.7-0vl1
  176. - new upstream release
  177. * Sat Jan 4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.6-0vl1
  178. - new upstream release
  179. * Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
  180. - add patch1 to recognize .ttc font as TrueType font.
  181. * Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
  182. - add %%{_datadir}/libgnomeprint for %%files
  183. * Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
  184. - new upstream release
  185. * Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
  186. - build for Vine Linux
  187. - new upstream release from gnome-2.1.4
  188. * Thu Aug 15 2002 Akira TAGOH <tagoh@redhat.com> 1.116.0-2
  189. - libgnomeprint-1.116.0-correctps.patch: applied to fix the invalid PostScript.
  190. * Tue Aug 13 2002 Akira TAGOH <tagoh@redhat.com> 1.116.0-1
  191. - libgnomeprint-1.116.0-perfprint.patch: applied to fix the printing
  192. performance issue. (#66715)
  193. * Fri Jul 12 2002 Akira TAGOH <tagoh@redhat.com> 1.115.0-5
  194. - includes redhat-update-gnome-font-install2 script. (#66899)
  195. - fix the install path for fontmap.
  196. - add some directory owners.
  197. * Thu Jul 11 2002 Tim Powers <timp@redhat.com>
  198. - rebuilt
  199. * Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
  200. - 1.115.0
  201. - include gtk-doc docs
  202. - move pkg-config files to -devel package
  203. * Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
  204. - rebuild in different environment
  205. * Wed Jun 5 2002 Havoc Pennington <hp@redhat.com>
  206. - 1.114.0
  207. * Mon May 20 2002 Havoc Pennington <hp@redhat.com>
  208. - rebuild in different environment
  209. * Mon May 20 2002 Havoc Pennington <hp@redhat.com>
  210. - rebuild in different environment
  211. - add bonobo-activation requires to make build system happy
  212. * Mon May 20 2002 Havoc Pennington <hp@redhat.com>
  213. - 1.113.0
  214. * Fri May 3 2002 Havoc Pennington <hp@redhat.com>
  215. - rebuild for new libraries
  216. * Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
  217. - 1.112.0
  218. * Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
  219. - 1.111.0
  220. * Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
  221. - Version 1.110.0
  222. * Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
  223. - automake14
  224. * Mon Jan 7 2002 Havoc Pennington <hp@redhat.com>
  225. - 1.109.0.90 snap
  226. - remove .options patch which is upstream
  227. - remove .nofontmaps patch, upstream uses sysconfdir sometimes now
  228. and has --disable-font-install configure option
  229. - remove .fontmapdir, now fixed upstream
  230. * Tue Nov 27 2001 Havoc Pennington <hp@redhat.com>
  231. - rebuild due to build system fuckup
  232. * Tue Nov 27 2001 Havoc Pennington <hp@redhat.com>
  233. - cvs snap 1.106.0.90, glib 1.3.11
  234. * Sun Oct 28 2001 Havoc Pennington <hp@redhat.com>
  235. - new cvs snap, rebuild for glib 1.3.10, remove bogus gtk dep
  236. * Tue Oct 9 2001 Havoc Pennington <hp@redhat.com>
  237. - remove epoch screwup
  238. * Mon Oct 8 2001 Havoc Pennington <hp@redhat.com>
  239. - libgnomeprint package based on the gnome-print package
  240. * Mon Oct 8 2001 Havoc Pennington <hp@redhat.com>
  241. - use 0.30 tarball
  242. * Sat Sep 22 2001 Havoc Pennington <hp@redhat.com>
  243. - new cvs snap, with headers moved
  244. * Wed Aug 15 2001 Owen Taylor <otaylor@redhat.com>
  245. - Back out freetype change, for now, until we can get it in upstream.
  246. - Move gnome-print/<ver>/profiles back to datadir, and remove the %config.
  247. Making them %config doesn't seem compatible with locating them
  248. in gnome-print/<ver>.
  249. * Mon Aug 13 2001 Akira TAGOH <tagoh@redhat.com> 0.29-5
  250. - no replace profiles.
  251. * Mon Aug 13 2001 Akira TAGOH <tagoh@redhat.com> 0.29-4
  252. - Move profiles directory to /etc/gnome-print/<ver>/profiles/
  253. * Mon Aug 13 2001 Akira TAGOH <tagoh@redhat.com> 0.29-3
  254. - Add freetype support patch. (Bug#50360)
  255. * Sat Jul 21 2001 Owen Taylor <otaylor@redhat.com>
  256. - Add missing directory
  257. * Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
  258. - Upgrade to 0.29
  259. - Don't install run-gnome-font-install (#48466), run gnome-font-install directly.
  260. - Add BuildPrereq and make -devel package require gdk-pixbuf-devel
  261. - Make libgnomeprint package require gnome-print package; otherwise
  262. packages requiring libgnomeprint might not get a runtime environment
  263. - Add Prereq on ghostscript, since run-gnome-font-install parses output of 'gs -h'
  264. * Mon Jul 16 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
  265. - Kill output from run-gnome-font-install
  266. - s/Copyright/License/
  267. - Add post/postun scripts for the libgnomeprint subpackage
  268. * Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
  269. - Bump release + rebuild.
  270. * Fri Apr 20 2001 Jonathan Blandford <jrb@redhat.com>
  271. - new version (0.28)
  272. * Thu Mar 01 2001 Owen Taylor <otaylor@redhat.com>
  273. - Rebuild for GTK+-1.2.9 include paths
  274. * Fri Feb 23 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
  275. - langify
  276. - patch it to compile (didn't include locale.h when needed)
  277. - use %%{_tmppath}
  278. * Fri Feb 23 2001 Akira TAGOH <tagoh@redhat.com>
  279. - Fixed font problem for Japanese.
  280. - Fixed library dependency on VFlib (Bug#28331)
  281. * Wed Feb 21 2001 Philipp Knirsch <pknirsch@redhat.de>
  282. - Fixed bugzilla bug #27417, simple specfile %post fix.
  283. * Sun Feb 18 2001 Akira TAGOH <tagoh@redhat.com>
  284. - Fixed PostScript broken.
  285. - Added autoheader,automake,autoconf stuff.
  286. * Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  287. - add libtoolize to make porting to new archs easy
  288. * Tue Feb 06 2001 Akira TAGOH <tagoh@redhat.com>
  289. - Updated Japanese patch for Gnumeric.
  290. Created dummy .afm.
  291. * Mon Feb 05 2001 Akira TAGOH <tagoh@redhat.com>
  292. - Fixed gdk_fontset_load().
  293. - Added Japanese patch for Gnumeric.
  294. * Fri Feb 02 2001 Akira TAGOH <tagoh@redhat.com>
  295. - Added Japanese patch.
  296. Fixed Print and Preview with Japanese.
  297. * Fri Dec 29 2000 Matt Wilson <msw@redhat.com>
  298. - 0.25
  299. * Sat Aug 19 2000 Preston Brown <pbrown@redhat.com>
  300. - added "|| true" to %%post so that if font-install screws up we don't get a
  301. bad exit status. gnome-font-install expects that the directory specified by
  302. HOME env. var is writable, but it isn't always if you install with 'sudo'
  303. or the equivalent. bad. bad. bad.
  304. * Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
  305. - Up Epoch and release
  306. * Fri Jul 14 2000 Matt Wilson <msw@redhat.com>
  307. - redirect %%post script output to /dev/null
  308. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  309. - automatic rebuild
  310. * Thu Jun 29 2000 Owen Taylor <otaylor@redhat.com>
  311. - Spec file fixes