libglade2-vl.spec 9.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325
  1. %define __libtoolize :
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. %define libxml2_version 2.4.29
  4. %define gtk2_version 2.6.0
  5. %define pango_version 1.8.0
  6. Summary: The libglade library for loading user interfaces.
  7. Name: libglade2
  8. Version: 2.6.4
  9. Release: 6%{?_dist_release}
  10. License: LGPL
  11. Group: System Environment/Libraries
  12. Source: libglade-%{version}.tar.bz2
  13. #Source2: fixed-ltmain.sh
  14. URL: http://www.gnome.org/
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: libxml2-devel >= %{libxml2_version}
  17. BuildRequires: gtk2-devel >= %{gtk2_version}
  18. BuildRequires: pango-devel >= %{pango_version}
  19. BuildRequires: python-devel >= 2.2.1
  20. BuildRequires: python >= 2.2.1
  21. Requires(post): libxml2 >= %{libxml2_version}
  22. Requires(postun): libxml2 >= %{libxml2_version}
  23. Requires(post): xml-common
  24. Requires(postun): xml-common
  25. Vendor: Project Vine
  26. Distribution: Vine Linux
  27. %description
  28. Libglade is a small library that allows a program to load its user
  29. interface from am XML description at runtime. Libglade uses the XML
  30. file format used by the GLADE user interface builder GLADE, so
  31. libglade acts as an alternative to GLADE's code generation
  32. approach. Libglade also provides a simple interface for connecting
  33. handlers to the various signals in the interface (on platforms where
  34. the gmodule library works correctly, it is possible to connect all the
  35. handlers with a single function call). Once the interface has been
  36. instantiated, libglade gives no overhead, so other than the short
  37. initial interface loading time, there is no performance tradeoff.
  38. #'
  39. %package devel
  40. Summary: The files needed for libglade application development.
  41. Group: Development/Libraries
  42. Requires: %{name} = %{version}-%{release}
  43. Requires: libxml2-devel >= %{libxml2_version}
  44. Requires: gtk2-devel >= %{gtk2_version}
  45. Conflicts: libglade < 0.17
  46. %description devel
  47. The libglade-devel package contains the libraries and include files
  48. that you can use to develop libglade applications.
  49. %package -n compat32-%{name}
  50. Summary: The libglade library for loading user interfaces.
  51. Group: System Environment/Libraries
  52. Requires: %{name} = %{version}-%{release}
  53. %description -n compat32-%{name}
  54. Libglade is a small library that allows a program to load its user
  55. interface from am XML description at runtime. Libglade uses the XML
  56. file format used by the GLADE user interface builder GLADE, so
  57. libglade acts as an alternative to GLADE's code generation
  58. approach. Libglade also provides a simple interface for connecting
  59. handlers to the various signals in the interface (on platforms where
  60. the gmodule library works correctly, it is possible to connect all the
  61. handlers with a single function call). Once the interface has been
  62. instantiated, libglade gives no overhead, so other than the short
  63. initial interface loading time, there is no performance tradeoff.
  64. #'
  65. %package -n compat32-%{name}-devel
  66. Summary: The files needed for libglade application development.
  67. Group: Development/Libraries
  68. Requires: %{name}-devel = %{version}-%{release}
  69. Requires: compat32-%{name} = %{version}-%{release}
  70. Requires: compat32-libxml2-devel >= %{libxml2_version}
  71. Requires: compat32-gtk2-devel >= %{gtk2_version}
  72. %description -n compat32-%{name}-devel
  73. The libglade-devel package contains the libraries and include files
  74. that you can use to develop libglade applications.
  75. %prep
  76. %setup -q -n libglade-%{version}
  77. %build
  78. #rm ltmain.sh && cp %{SOURCE2} ltmain.sh
  79. %configure --disable-gtk-doc --disable-static
  80. make %{?_smp_mflags}
  81. %install
  82. rm -rf $RPM_BUILD_ROOT
  83. %makeinstall
  84. install -m755 libglade-convert $RPM_BUILD_ROOT%{_bindir}
  85. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
  86. %clean
  87. rm -rf $RPM_BUILD_ROOT
  88. %post
  89. /sbin/ldconfig
  90. CATALOG=/etc/xml/catalog
  91. /usr/bin/xmlcatalog --noout --add "system" \
  92. "http://glade.gnome.org/glade-2.0.dtd" \
  93. "file://%{_datadir}/xml/libglade/glade-2.0.dtd" $CATALOG
  94. %postun
  95. /sbin/ldconfig
  96. # remove entries only on removal of package
  97. if [ "$1" = 0 ]; then
  98. CATALOG=/etc/xml/catalog
  99. /usr/bin/xmlcatalog --noout --del \
  100. "file://%{_datadir}/xml/libglade/glade-2.0.dtd" $CATALOG
  101. fi
  102. %post -n compat32-%{name} -p /sbin/ldconfig
  103. %postun -n compat32-%{name} -p /sbin/ldconfig
  104. %files
  105. %defattr(-, root, root)
  106. %doc AUTHORS ChangeLog NEWS README COPYING
  107. %{_libdir}/lib*.so.*
  108. %{_datadir}/xml
  109. %files devel
  110. %defattr(-, root, root)
  111. %doc test-libglade.c
  112. %{_bindir}/*
  113. %{_libdir}/lib*.so
  114. %{_libdir}/pkgconfig/*.pc
  115. %{_includedir}/*
  116. %{_datadir}/gtk-doc
  117. %if %{build_compat32}
  118. %files -n compat32-%{name}
  119. %defattr(-, root, root)
  120. %{_libdir}/lib*.so.*
  121. %files -n compat32-%{name}-devel
  122. %defattr(-, root, root)
  123. %{_libdir}/lib*.so
  124. %endif
  125. %changelog
  126. * Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-6
  127. - rebuild with VineSeed environment
  128. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.6.4-5
  129. - build with rpm-4.8.1-1 for pkg-config file
  130. * Tue Mar 2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.6.4-4
  131. - rebuilt with new toolchain
  132. * Sun Jul 12 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.4-3
  133. - added compat32-libglade2-devel for x86_64 architecture
  134. * Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-2
  135. - add Requires(post,postun): xml-common
  136. - remove static library
  137. * Fri Apr 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.4-1
  138. - new upstream release
  139. * Mon Sep 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.3-1
  140. - new upstream release
  141. - run /usr/bin/xmlcatlog at %%post and %%postun section
  142. * Wed Apr 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.2-1vl5
  143. - used %%{?_dist_release} tag
  144. - removed lib*.la from devel package
  145. * Sat Nov 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.2-0vl1
  146. - new upstream release
  147. * Wed Aug 2 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.0-0vl1
  148. - new upstream release
  149. * Fri May 26 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.5.1-0vl2
  150. - added compat32-libglade2 package for x86_64 architecture support
  151. * Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-0vl1
  152. - new upstream version
  153. * Thu Feb 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-0vl1
  154. - new upstream release
  155. * Thu Jun 17 2004 Tomoya TAKA <taka@vinelinux.org> 2.4.0-0vl1
  156. - new upstream release
  157. - drop obsoleted Source2
  158. - s/COPYRIGHT/LICENSE/
  159. * Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.1-0vl2
  160. - rebuild with python2
  161. * Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.1-0vl1
  162. - build for Vine Linux
  163. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  164. - automated rebuild
  165. * Sat Jun 15 2002 Havoc Pennington <hp@redhat.com>
  166. - 2.0.0
  167. - check over file list, add XML DTD to it
  168. * Fri May 17 2002 Havoc Pennington <hp@redhat.com>
  169. - rebuild in different environment
  170. * Fri May 17 2002 Havoc Pennington <hp@redhat.com>
  171. - don't run auto*
  172. * Fri May 17 2002 Havoc Pennington <hp@redhat.com>
  173. - 1.99.12
  174. - remove gtk-doc hack, --disable-gtk-doc now works
  175. * Thu May 2 2002 Havoc Pennington <hp@redhat.com>
  176. - 1.99.11
  177. * Thu Apr 4 2002 Jeremy Katz <katzj@redhat.com>
  178. - 1.99.10
  179. * Tue Mar 19 2002 Alex Larsson <alexl@redhat.com>
  180. - Update autoconf dependency to 2.53
  181. * Mon Mar 11 2002 Alex Larsson <alexl@redhat.com>
  182. - Update to 1.99.9
  183. * Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
  184. - Bump for rebuild
  185. * Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
  186. - Bump for rebuild
  187. * Tue Feb 19 2002 Alex Larsson <alexl@redhat.com>
  188. - Add horrible buildroot check hacks. Require new Gtk+.
  189. * Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
  190. - rebuild for new gtk
  191. * Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
  192. - Rebuild against new GTK+
  193. * Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
  194. - put "nogtkdoc" patch back, it avoids X display requirement
  195. - automake14
  196. * Wed Jan 2 2002 Havoc Pennington <hp@redhat.com>
  197. - 1.99.5.90 snap
  198. - comment out "nogtkdoc" patch, don't run autoconf
  199. * Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
  200. - new 1.99.4.91 snap with Jacob's fixes, he
  201. assures me we are 1.99.4.90 ABI-compatible
  202. * Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
  203. - new 1.99.4.90 snap, gtk 1.3.11
  204. * Fri Oct 26 2001 Havoc Pennington <hp@redhat.com>
  205. - new snap, rebuild on gtk 1.3.10
  206. * Sat Oct 6 2001 Havoc Pennington <hp@redhat.com>
  207. - new snap, add hack to avoid trying to build docs
  208. - add the ltmain.sh hack to avoid relinking
  209. * Mon Sep 24 2001 Havoc Pennington <hp@redhat.com>
  210. - new snap
  211. * Fri Sep 21 2001 Havoc Pennington <hp@redhat.com>
  212. - convert libglade rpm to libglade2 rpm, initial build of libglade2
  213. * Mon Aug 20 2001 Jonathan Blandford <jrb@redhat.com>
  214. - Escape strings, #51966
  215. * Sun Jul 22 2001 Havoc Pennington <hp@redhat.com>
  216. - add build requires, bug #49508
  217. * Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
  218. - Bump release + rebuild.
  219. * Tue Apr 17 2001 Jonathan Blandford <jrb@redhat.com>
  220. - New Version.
  221. * Thu Mar 01 2001 Owen Taylor <otaylor@redhat.com>
  222. - Rebuild for GTK+-1.2.9 include paths
  223. * Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  224. - add libtoolize to make porting to new archs easy
  225. * Fri Dec 29 2000 Matt Wilson <msw@redhat.com>
  226. - 0.14
  227. - added patch for gtk-doc scanner linkage
  228. * Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
  229. - Up Epoch and release
  230. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  231. - automatic rebuild
  232. * Thu Jun 29 2000 Owen Taylor <otaylor@redhat.com>
  233. - specfile fixes
  234. * Wed May 31 2000 Owen Taylor <otaylor@redhat.com>
  235. - Upgraded to libglade-0.13
  236. - Use %makeinstall, since that is required when %configure is used.
  237. * Fri May 19 2000 Owen Taylor <otaylor@redhat.com>
  238. - Upgraded to libglade-0.12
  239. * Tue Sep 07 1999 Elliot Lee <sopwith@redhat.com>
  240. - Updated RHL 6.1 package to libglade-0.5
  241. * Sun Nov 1 1998 James Henstridge <james@daa.com.au>
  242. - Updated the dependencies of the devel package, so users must have gtk+-devel.
  243. * Sun Oct 25 1998 James Henstridge <james@daa.com.au>
  244. - Initial release 0.0.1