libbonobo-vl.spec 9.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343
  1. %define dbus_version 1.4.0
  2. %define dbus_glib_version 0.88
  3. %define libxml2_version 2.7.7
  4. %define orbit2_version 2.14.19
  5. %define po_package libbonobo-2.0
  6. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  7. Summary: Bonobo component system
  8. Summary(ja): Bonobo コンポーネントシステム
  9. Name: libbonobo
  10. Version: 2.32.1
  11. Release: 2%{?_dist_release}
  12. URL: http://ftp.gnome.org/
  13. Source0: %{name}-%{version}.tar.bz2
  14. Patch0: %{name}-2.32.1-GStaticRecMutex.patch
  15. Patch10: %{name}-2.14.0-i18n-help.patch
  16. License: LGPL
  17. Group: System Environment/Libraries
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. BuildRequires: libxml2-devel >= %{libxml2_version}
  20. BuildRequires: ORBit2-devel >= %{orbit2_version}
  21. BuildRequires: dbus-devel >= %{dbus_version}
  22. BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
  23. BuildRequires: popt-devel
  24. BuildRequires: flex
  25. BuildRequires: byacc
  26. BuildRequires: gtk-doc
  27. Obsoletes: bonobo-activation
  28. Provides: bonobo-activation
  29. Vendor: Project Vine
  30. Distribution: Vine Linux
  31. %description
  32. Bonobo is a component system based on CORBA, used by the GNOME desktop.
  33. %description -l ja
  34. Bonobo は GNUME デスクトップで使われている CORBA ベースのコンポーネント
  35. システムです。
  36. %package devel
  37. Summary: Libraries and headers for libbonobo
  38. Summary: libbonobo のライブラリおよびヘッダ
  39. Group: Development/Libraries
  40. Requires: %{name} = %{version}-%{release}
  41. Requires: ORBit2-devel >= %{orbit2_version}
  42. Requires: libxml2-devel >= %{libxml2_version}
  43. Obsoletes: bonobo-activation-devel
  44. Provides: bonobo-activation-devel
  45. Conflicts: bonobo-devel < 1.0.8
  46. %description devel
  47. Bonobo is a component system based on CORBA, used by the GNOME desktop.
  48. This package contains header files used to compile programs that
  49. use Bonobo.
  50. %description devel -l ja
  51. Bonobo は GNOME デスクトップで使われている CORBA ベースのコンポーネント
  52. システムです。
  53. このパッケージは Bonobo を使うプログラムをコンパイルするために必要な
  54. ヘッダファイルが収録されています。
  55. # compat32
  56. %package -n compat32-%{name}
  57. Summary: Bonobo component system
  58. Summary(ja): Bonobo コンポーネントシステム
  59. Group: System Environment/Libraries
  60. Requires: %{name} = %{version}-%{release}
  61. %description -n compat32-%{name}
  62. Bonobo is a component system based on CORBA, used by the GNOME desktop.
  63. %description -n compat32-%{name} -l ja
  64. Bonobo は GNUME デスクトップで使われている CORBA ベースのコンポーネント
  65. システムです。
  66. %package -n compat32-%{name}-devel
  67. Summary: Libraries and headers for libbonobo
  68. Summary: libbonobo のライブラリおよびヘッダ
  69. Group: Development/Libraries
  70. Requires: %{name}-devel = %{version}-%{release}
  71. Requires: compat32-%{name} = %{version}-%{release}
  72. Requires: compat32-ORBit2-devel >= %{orbit2_version}
  73. Requires: compat32-libxml2-devel >= %{libxml2_version}
  74. %description -n compat32-%{name}-devel
  75. Bonobo is a component system based on CORBA, used by the GNOME desktop.
  76. This package contains header files used to compile programs that
  77. use Bonobo.
  78. %description -n compat32-%{name}-devel -l ja
  79. Bonobo は GNOME デスクトップで使われている CORBA ベースのコンポーネント
  80. システムです。
  81. このパッケージは Bonobo を使うプログラムをコンパイルするために必要な
  82. ヘッダファイルが収録されています。
  83. %prep
  84. %setup -q -n %{name}-%{version}
  85. %patch0 -p1 -b .mutex
  86. %patch10 -p1 -b .i18n-help
  87. %build
  88. %configure --disable-static
  89. make
  90. %install
  91. rm -rf $RPM_BUILD_ROOT
  92. %makeinstall
  93. ## just kill this wherever it lives
  94. rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo-2.0/samples/bonobo-echo-2
  95. rm -f $RPM_BUILD_ROOT%{_prefix}/lib/bonobo-2.0/samples/bonobo-echo-2
  96. ## kill other stuff
  97. rm $RPM_BUILD_ROOT%{_bindir}/echo-client-2
  98. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  99. find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
  100. %find_lang %{po_package}
  101. %clean
  102. rm -rf $RPM_BUILD_ROOT
  103. %post -p /sbin/ldconfig
  104. %postun -p /sbin/ldconfig
  105. %post -n compat32-%{name} -p /sbin/ldconfig
  106. %postun -n compat32-%{name} -p /sbin/ldconfig
  107. %files -f %{po_package}.lang
  108. %defattr(-,root,root)
  109. %doc AUTHORS COPYING ChangeLog NEWS README
  110. %{_libdir}/lib*.so.*
  111. %{_libdir}/bonobo
  112. %{_libdir}/orbit-2.0/*.so*
  113. %{_bindir}*
  114. %{_libexecdir}/*
  115. %{_sbindir}/*
  116. %dir %{_sysconfdir}/bonobo-activation
  117. %config %{_sysconfdir}/bonobo-activation/*
  118. %{_mandir}/man*/*
  119. %files devel
  120. %defattr(-,root,root)
  121. #{_libdir}/lib*.a
  122. %{_libdir}/lib*.so
  123. %{_libdir}/pkgconfig/*.pc
  124. %{_includedir}/*
  125. %{_datadir}/idl
  126. %{_datadir}/gtk-doc
  127. # compat32
  128. %if %{build_compat32}
  129. %files -n compat32-%{name}
  130. %defattr(-,root,root)
  131. %{_libdir}/lib*.so.*
  132. %{_libdir}/bonobo
  133. %{_libdir}/orbit-2.0/*.so*
  134. %files -n compat32-%{name}-devel
  135. %defattr(-,root,root)
  136. %{_libdir}/lib*.so
  137. %endif
  138. %changelog
  139. * Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
  140. - rebuild with VineSeed environment
  141. - add Patch0 (libbonobo-2.32.1-GStaticRecMutex.patch)
  142. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
  143. - new upstream release
  144. * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
  145. - new upstream release
  146. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.24.3-2
  147. - build with rpm-4.8.1-1 for pkg-config file
  148. * Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.3-1
  149. - new upstream release
  150. - add BuildRequires: dbus-devel, dbus-glib-devel, popt-devel, flex, byacc
  151. * Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-1
  152. - new upstream release
  153. * Sun Jul 19 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.24.1-2
  154. - added --disable-static configure option
  155. - added compat32 package for x86_64 arch support
  156. * Fri Mar 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
  157. - new upstream release
  158. * Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
  159. - new upstream release
  160. * Sun Jan 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.3-0vl1
  161. - new upstream release
  162. * Sat Nov 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
  163. - new upstream release
  164. * Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl2
  165. - add upstream patch1
  166. * Tue Apr 24 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl1
  167. - new upstream release
  168. * Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
  169. - update Patch0 to fix more help message translation.
  170. * Fri May 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
  171. - add bindtextdomain_codeset in bonobo-activation initialize
  172. to fix corruption of help option message.(Patch0)
  173. * Wed Mar 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
  174. - new upstream release
  175. * Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.1-0vl1
  176. - new upstream release
  177. * Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
  178. - new upstream release
  179. * Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
  180. - new upstream release
  181. * Wed Mar 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
  182. - new upstream release
  183. * Thu Feb 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.1-0vl1
  184. - new upstream release
  185. * Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
  186. - new upstream release
  187. * Sat Jan 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.3-0vl1
  188. - new upstream release
  189. * Mon Dec 22 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-0vl1
  190. - new upstream release
  191. - rebuild with new toolchains
  192. * Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
  193. - new upstream release
  194. * Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
  195. - new upstream release
  196. * Wed Aug 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl1
  197. - new upstream release
  198. * Tue Jun 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
  199. - new upstream release
  200. * Fri Apr 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
  201. - new upstream release
  202. * Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
  203. - new upstream release
  204. * Sat Dec 14 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.0-0vl1
  205. - build for Vine Linux
  206. * Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
  207. - Fix find_lang
  208. * Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
  209. - rebuild in different environment
  210. * Wed Jun 5 2002 Havoc Pennington <hp@redhat.com>
  211. - 2.0.0
  212. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  213. - automated rebuild
  214. * Mon May 20 2002 Havoc Pennington <hp@redhat.com>
  215. - rebuild in different environment
  216. * Mon May 20 2002 Havoc Pennington <hp@redhat.com>
  217. - 1.117.0
  218. * Fri May 3 2002 Havoc Pennington <hp@redhat.com>
  219. - 1.116.0
  220. * Thu Apr 4 2002 Jeremy Katz <katzj@redhat.com>
  221. - 1.113.0
  222. * Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
  223. - 1.111.0
  224. * Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
  225. - Version 1.110.0
  226. - Rebuild for dependencies
  227. - Intltoolize, the included version has problems with our Perl
  228. * Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
  229. - automake-1.4
  230. * Wed Jan 2 2002 Havoc Pennington <hp@redhat.com>
  231. - 1.108.0.90 cvs snap
  232. * Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
  233. - 1.107.0, glib 1.3.11
  234. * Fri Oct 26 2001 Havoc Pennington <hp@redhat.com>
  235. - rebuild for new glib, new snap
  236. * Fri Oct 5 2001 Havoc Pennington <hp@redhat.com>
  237. - rebuild for new glib
  238. * Thu Sep 27 2001 Havoc Pennington <hp@redhat.com>
  239. - move to 1.103.0 tarball
  240. - call automake after patching Makefile.am
  241. - patch for parallel install
  242. * Fri Sep 21 2001 Havoc Pennington <hp@redhat.com>
  243. - add some requires
  244. * Tue Sep 18 2001 Havoc Pennington <hp@redhat.com>
  245. - conflict with bonobo < 1.0.8 to avoid header conflicts
  246. - update group
  247. * Mon Sep 17 2001 Havoc Pennington <hp@redhat.com>
  248. - moved IDL files into subdir
  249. - remove smp_mflags, libbonobo does not like those
  250. * Thu Sep 13 2001 Havoc Pennington <hp@redhat.com>
  251. - remove IDL files as temporary hack
  252. * Wed Sep 12 2001 Havoc Pennington <hp@redhat.com>
  253. - Initial build.