kbd-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394
  1. Summary: Tools for configuring the console (keyboard, virtual terminals, etc.)
  2. Summary(ja): コンソール(キーボードや仮想ターミナル等)を設定するツール群
  3. Name: kbd
  4. Version: 1.12
  5. Release: 22%{?_dist_release}
  6. License: GPL
  7. Group: System Environment/Base
  8. Source0: ftp://ftp.kernel.org/pub/linux/utils/kbd/kbd-%{version}.tar.bz2
  9. Source1: ftp://ftp.kernel.org/pub/linux/utils/kbd/kbd-%{version}.tar.bz2.sign
  10. #Source2: kbdrate.apps
  11. #Source3: kbdrate.pam
  12. Source4: kbd-latsun-fonts.tar.bz2
  13. Requires: pam >= 0.66-4, /etc/pam.d/system-auth, usermode
  14. BuildRequires: bison, flex, gettext
  15. BuildRoot: %{_tmppath}/%{name}-root
  16. Patch0: kbd-1.12-sparc.patch
  17. Patch1: kbd-1.08-compose.patch
  18. Patch2: kbd-1.08-terminal.patch
  19. Patch3: kbd-1.08-rukbd.patch
  20. Patch4: kbd-1.12-setfont-man.patch
  21. Patch5: kbd-1.12-Meta_utf8.patch
  22. Patch6: kbd-1.12-nostrip.patch
  23. Patch7: kbd-1.12-alias.patch
  24. Patch8: kbd-1.12-dir.patch
  25. Patch9: kbd-1.12-no-user-map.patch
  26. Patch10: kbd-1.12-resizecon-man.patch
  27. Patch11: kbd-1.12-gr-el.patch
  28. Patch12: kbd-1.12-keycodes-man.patch
  29. Obsoletes: console-tools open
  30. Provides: console-tools open
  31. Conflicts: util-linux < 2.11r-9
  32. Requires(pre): initscripts >= 5.86-1
  33. ExcludeArch: s390 s390x
  34. Vendor: Project Vine
  35. Distribution: Vine Linux
  36. %description
  37. The %{name} package contains tools for managing a Linux
  38. system's console's behavior, including the keyboard, the screen
  39. fonts, the virtual terminals and font files.
  40. %prep
  41. %setup -q -a 4
  42. %patch0 -p1 -b .sparc
  43. %patch1 -p1
  44. %patch2 -p1 -b .terminal
  45. %patch3 -p1
  46. %patch4 -p1 -b .man
  47. %patch5 -p1 -b .Meta_utf8
  48. %patch6 -p1 -b .nostrip
  49. %patch7 -p1 -b .alias
  50. %patch8 -p1 -b .dir
  51. %patch9 -p1 -b .no-user-map
  52. %patch10 -p1 -b .resizecon-man
  53. %patch11 -p1 -b .gr-el
  54. %patch12 -p1 -b .keycodes-man
  55. # 7-bit maps are obsolete; so are non-euro maps
  56. pushd data/keymaps/i386
  57. mv qwerty/fi.map qwerty/fi-old.map
  58. cp qwerty/fi-latin9.map qwerty/fi.map
  59. cp qwerty/pt-latin9.map qwerty/pt.map
  60. cp qwerty/sv-latin1.map qwerty/se-latin1.map
  61. mv azerty/fr.map azerty/fr-old.map
  62. cp azerty/fr-latin9.map azerty/fr.map
  63. cp azerty/fr-latin9.map azerty/fr-latin0.map # legacy alias
  64. popd
  65. # Default to latarcyrheb-sun16 font for unicode
  66. perl -pi -e 's/LatArCyrHeb-16/latarcyrheb-sun16/' src/unicode_start
  67. %build
  68. export OLD_PO_FILE_INPUT=yes
  69. # We don't use % {configure} because the ./configure included here does not
  70. # understand most of the options.
  71. CFLAGS="$RPM_OPT_FLAGS"; export CFLAGS
  72. ./configure --prefix=%{_prefix} --datadir=/lib/kbd --mandir=%{_mandir}
  73. # Override CFLAGS because this configure ignores them anyway, and LDFLAGS
  74. # because it defaults to -s, but that's a build policy decision.
  75. make CFLAGS="$RPM_OPT_FLAGS" LDFLAGS=
  76. %install
  77. rm -rf $RPM_BUILD_ROOT
  78. # Basic install.
  79. make install DESTDIR=$RPM_BUILD_ROOT
  80. # The rhpl keyboard layout table is indexed by kbd layout names, so we need a
  81. # Korean keyboard
  82. ln -s us.map.gz $RPM_BUILD_ROOT/lib/kbd/keymaps/i386/qwerty/ko.map.gz
  83. # Move binaries which we use before /usr is mounted from %{_bindir} to /bin.
  84. for binary in setfont dumpkeys kbd_mode unicode_start unicode_stop ; do
  85. mv $RPM_BUILD_ROOT%{_bindir}/$binary $RPM_BUILD_ROOT/bin
  86. done
  87. # Some microoptimization
  88. sed -i -e 's,\<kbd_mode\>,/bin/kbd_mode,g;s,\<setfont\>,/bin/setfont,g' \
  89. $RPM_BUILD_ROOT/bin/unicode_start
  90. # Set up kbdrate to be userhelpered.
  91. #mkdir -p $RPM_BUILD_ROOT%{_sbindir}
  92. #mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/security/console.apps
  93. #mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pam.d
  94. #mv $RPM_BUILD_ROOT%{_bindir}/kbdrate $RPM_BUILD_ROOT%{_sbindir}
  95. #ln -s consolehelper $RPM_BUILD_ROOT%{_bindir}/kbdrate
  96. #install -c -m644 %{SOURCE2} \
  97. # $RPM_BUILD_ROOT%{_sysconfdir}/security/console.apps/kbdrate
  98. #install -c -m644 %{SOURCE3} \
  99. # $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/kbdrate
  100. rm -f %{buildroot}/%{_bindir}/kbdrate
  101. # Link open to openvt
  102. ln -s openvt $RPM_BUILD_ROOT%{_bindir}/open
  103. %find_lang %{name}
  104. %clean
  105. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  106. %triggerun -- kbd < 1.08-10.2
  107. /sbin/chkconfig --del keytable || :
  108. %files -f %{name}.lang
  109. %defattr(-,root,root)
  110. %doc CHANGES CREDITS README doc/kbd.FAQ*.html doc/font-formats/*.html doc/utf/utf*
  111. /bin/*
  112. %{_bindir}/*
  113. %{_mandir}/*/*
  114. /lib/kbd
  115. %changelog
  116. * Mon Dec 30 2013 oji TOYODA <bsyamato@sea.plala.or.jp> 1.12-22
  117. - rebuild with VineSeed environment
  118. * Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.12-21vl5
  119. - applied new versioning policy, spec in utf-8
  120. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12-21vl1
  121. - initial build for Vine Linux based on Fedora package.
  122. * Tue Jan 9 2007 Miloslav Trmac <mitr@redhat.com> - 1.12-21
  123. - Add a "ko" (Korean) keyboard layout, equivalent to the "us" layout
  124. Resolves: #220151
  125. * Thu Dec 7 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-20
  126. - Document that setkeycodes doesn't affect USB keyboards and that the kernel
  127. doesn't provide the raw scan codes by default
  128. Resolves: #211803
  129. * Tue Oct 31 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-19
  130. - Ship "el" translation instead of the obsolete "gr" translation
  131. Resolves: #210749
  132. - Fix %% quoting in %%changelog
  133. * Fri Sep 29 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-18
  134. - Add a missing tilde to U+00E3 in latarcyrheb-sun16.psfu (#204470)
  135. * Fri Jul 14 2006 Jesse Keating <jkeating@redhat.com> - 1.12-17
  136. - Obsoletes/Provides open
  137. - Create a symlink from open to openvt
  138. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.12-16.1
  139. - rebuild
  140. * Sun Jul 9 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-16
  141. - Don't include <asm/kbdio.h> on SPARC (#198040, patch by Dennis Gilmore
  142. <dennis@ausil.us>)
  143. * Mon May 29 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-15
  144. - Fix missing BuildRequires (#193406)
  145. * Mon Mar 27 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-14
  146. - Don't install resizecons.8 on non-x86 (#186877, patch by Keiichi Mori
  147. <kmori@redhat.com>)
  148. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.12-13.2
  149. - bump again for double-long bug on ppc(64)
  150. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.12-13.1
  151. - rebuilt for new gcc4.1 snapshot and glibc changes
  152. * Fri Jan 20 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-13
  153. - Fix build with new coreutils
  154. - Hardcode paths in unicode_start to avoid a few file lookups (#178329)
  155. - Drop unnecessary Prereq: sed mktemp
  156. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  157. - rebuilt
  158. * Thu Dec 1 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-12
  159. - Don't reload the keymap in unicode_start (#172425)
  160. * Fri Nov 11 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-11
  161. - Don't ship character set lists (they are already in glibc-common) and an
  162. obsolete copy of kbd.FAQ
  163. * Fri May 20 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-10
  164. - Don't attempt to open directories as source files (#141634, original patch by
  165. Paul Nasrat)
  166. * Tue May 17 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-9
  167. - Fix another violation of C aliasing rules (#157720, patch by Jan Kratochvil)
  168. * Sat Mar 12 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-8
  169. - Fix violation of C aliasing rules (#150440)
  170. * Sun Mar 6 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-7
  171. - Don't run ldconfig
  172. - Don't strip executables
  173. * Fri Mar 4 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-6
  174. - Rebuild with gcc4
  175. * Sun Feb 20 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-5
  176. - Put "Meta_acute" back in German keymaps, just ignore it in (loadkeys -u)
  177. (patch by Jochen Schmitt)
  178. - Don't ship patch backup files, simpler way
  179. * Sat Feb 19 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-4
  180. - Don't ship a patch backup file
  181. - Mention in setfont.8 that 512-glyph fonts reduce the number of available
  182. colors (#140935, patch by Dmitry Butskoj)
  183. - Remove "Meta_acute" from German keymaps (#143124)
  184. - Make the %%triggerun script condition more precise, ignore failure of the
  185. script
  186. * Mon Feb 14 2005 Adrian Havill <havill@redhat.com>
  187. - rebuilt
  188. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  189. - rebuilt
  190. * Thu Feb 26 2004 Adrian Havill <havill@redhat.com>
  191. - update to 1.12
  192. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  193. - rebuilt
  194. * Wed Jan 14 2004 Bill Nottingham <notting@redhat.com> 1.08-12
  195. - remove speakup patch at request of author
  196. * Fri Oct 10 2003 Bill Nottingham <notting@redhat.com> 1.08-11
  197. - remove keytable init script (#106783)
  198. * Tue Aug 12 2003 Adrian Havill <havill@rtedhat.com> 1.08-10.1
  199. - bump for RHEL
  200. * Tue Aug 12 2003 Adrian Havill <havill@rtedhat.com> 1.08-10
  201. - apply the rukbd patch (#78218)
  202. * Thu Jul 31 2003 Adrian Havill <havill@redhat.com> 1.08-9
  203. - don't print "plus before..." warnings about non-supported capslock
  204. in unimode <Andries.Brouwer@cwi.nl> (#81855)
  205. * Wed Jul 30 2003 Adrian Havill <havill@redhat.com> 1.08-8
  206. - replaced Russian keyboard map with working UTF-8 equivalent (#79338)
  207. * Thu Jul 24 2003 Adrian Havill <havill@redhat.com> 1.08-7
  208. - make euro/latin-9 the default instead of latin-1 and 7-bit (#97013)
  209. - fix swedish keymap; se, not sv (#88791)
  210. - add fr-latin0 legacy alias of fr-latin-9 (#88324)
  211. - add ".map" ext to filename param of init script (#90562)
  212. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  213. - rebuilt
  214. * Thu Mar 06 2003 Florian La Roche <Florian.LaRoche@redhat.de>
  215. - build new rpm
  216. * Fri Feb 21 2003 Florian La Roche <Florian.LaRoche@redhat.de>
  217. - ExcludeArch mainframe
  218. * Thu Jan 30 2003 Bill Nottingham <notting@redhat.com> 1.08-4
  219. - remove condrestart from initscript
  220. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  221. - rebuilt
  222. * Fri Dec 6 2002 Nalin Dahyabhai <nalin@redhat.com> 1.08-2
  223. - only output terminal unicode init sequence if both stdout and stderr are
  224. connected to terminals, so that it doesn't show up when script outputs
  225. get piped to files
  226. * Fri Nov 22 2002 Nalin Dahyabhai <nalin@redhat.com> 1.08-1
  227. - update to 1.08
  228. - drop updates which went mainline
  229. * Mon Nov 11 2002 Nalin Dahyabhai <nalin@redhat.com> 1.06-27
  230. - add detached signature
  231. - remove directory names from PAM configuration so that the same config file
  232. can be used for any arch on multilib systems
  233. * Wed Sep 4 2002 Bill Nottingham <notting@redhat.com> 1.06-26
  234. - don't munge /etc/sysconfig/i18n
  235. * Tue Sep 3 2002 Bill Nottingham <notting@redhat.com> 1.06-25
  236. - don't run setsysfont in upgrade trigger on console-tools
  237. * Thu Aug 29 2002 Jakub Jelinek <jakub@redhat.com> 1.06-24
  238. - use cyr-sun16 cyrillic chars in latarcyrheb-sun16 font
  239. instead of old LatArCyrHeb-16 chars
  240. - add Euro character to latarcyrheb-sun16
  241. - use latarcyrheb-sun16 by default in unicode_start script
  242. * Tue Aug 27 2002 Jakub Jelinek <jakub@redhat.com> 1.06-23
  243. - add back lat[02]-sun16 fonts plus latarcyrheb-sun16 font
  244. * Thu Aug 22 2002 Karsten Hopp <karsten@redhat.de>
  245. - needs to conflict with older util-linux packages
  246. (kbdrate moved between packages)
  247. * Tue Aug 13 2002 Bill Nottingham <notting@redhat.com> 1.06-21
  248. - remove Evil Hack in favor of slightly-less-evil-hack in initscripts
  249. * Tue Jul 9 2002 Bill Nottingham <notting@redhat.com> 1.06-20
  250. - fix speakup keymap names
  251. * Tue Jul 09 2002 Phil Knirsch <pknirsch@redhat.com> 1.06-19
  252. - Evil hack to make setfont work correctly on all consoles (#68018)
  253. * Thu Jun 27 2002 Bill Nottingham <notting@redhat.com> 1.06-18
  254. - move unicode_stop to /bin too
  255. - fix path to loadkeys in keytable.init
  256. - add in speakup keymaps
  257. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  258. - automated rebuild
  259. * Tue Jun 11 2002 Nalin Dahyabhai <nalin@redhat.com> 1.06-16
  260. - fix incorrect path in console.apps configuration file
  261. * Thu May 30 2002 Bill Nottingham <notting@redhat.com> 1.06-14
  262. - move some more stuff to /bin (unicode_start and dependencies)
  263. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  264. - automated rebuild
  265. * Mon Feb 25 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-12
  266. - Rebuild in new environment
  267. * Wed Jan 30 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-11
  268. - Oops, actually list the pam files in %%files
  269. * Tue Jan 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-10
  270. - Add and consolehelper'ify kbdrate
  271. * Tue Jan 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-9
  272. - Re-remove kbdrate
  273. * Thu Jan 24 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-7
  274. - Fix build in current environment
  275. - Get rid of kbdrate, it's in util-linux these days
  276. * Wed Jul 18 2001 Matt Wilson <msw@redhat.com>
  277. - added a patch (Patch4) that allows --tty= in setfont
  278. - modified patch not to break translations
  279. * Tue Jul 3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-4
  280. - Add cyrillic patches from leon@geon.donetsk.ua (#47144)
  281. * Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-3
  282. - Fix "Alt+AltGr=Compose" in qwertz-keyboards
  283. * Mon Jun 25 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-2
  284. - Fix "make install" and init script (#45327)
  285. * Sat Jun 16 2001 Than Ngo <than@redhat.com>
  286. - update to 1.0.6
  287. - use %%{_tmppath}
  288. - use find_lang
  289. - support new gettext
  290. - remove some patch files, which are included in 1.0.6
  291. - fix to use RPM_OPT_FLAGS
  292. * Thu May 3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.05-3
  293. - Fix up resizecons
  294. * Wed May 2 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.05-2
  295. - Build everything, obsoletes console-tools
  296. - s/Copyright:/License:/
  297. - License is GPL, not just distributable
  298. - Add our compose mappings from old console-tools
  299. - Add triggerpostun -- console-tools magic to get sane fonts and mappings
  300. * Tue Apr 17 2001 Erik Troan <ewt@redhat.com>
  301. - initial packaging for kbdrate