gamin-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define python_archlib %(python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)')
  3. Summary: Library providing the FAM File Alteration Monitor API
  4. Summary(ja): FAM (File Alteration Monitor) API を提供するライブラリ
  5. Name: gamin
  6. Version: 0.1.10
  7. Release: 6%{?_dist_release}
  8. License: LGPLv2
  9. Group: System Environment/Daemons
  10. Source: gamin-%{version}.tar.bz2
  11. # patch from ubuntu
  12. # https://bugs.launchpad.net/ubuntu/+source/gamin/+bug/829504
  13. Patch10: 21_no_g_const_return.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. URL: http://www.gnome.org/~veillard/gamin/
  16. Obsoletes: fam
  17. Provides: fam
  18. BuildRequires: glib2-devel, python, python-devel
  19. Vendor: Project Vine
  20. Distribution: Vine Linux
  21. %description
  22. The Gamin library provides an API and ABI compatible file alteration
  23. monitor mechanism compatible with FAM but not dependent on a system wide
  24. daemon.
  25. %description -l ja
  26. Gamin ライブラリは FAM と API/ABI 互換のファイル変更検知システムを提供
  27. します。FAM とは違いシステムワイドなデーモンを利用せず、ユーザ毎のヘル
  28. パープログラムをオンデマンドに起動します。
  29. %package devel
  30. Summary: Development files for the Gamin library
  31. Summary(ja): Gamin ライブラリの開発用ファイル
  32. Group: Development/Libraries
  33. Requires: gamin = %{version}-%{release}
  34. Obsoletes: fam-devel
  35. Provides: fam-devel
  36. %description devel
  37. The Gamin library provides an API and ABI compatible file alteration
  38. monitor mechanism compatible with FAM but not dependent on a system wide
  39. daemon.
  40. %description devel -l ja
  41. Gamin ライブラリは FAM と API/ABI 互換のファイル変更検知システムを提供
  42. します。FAM とは違いシステムワイドなデーモンを利用せず、ユーザ毎のヘル
  43. パープログラムをオンデマンドに起動します。
  44. %package python
  45. Summary: Python bindings for the Gamin library
  46. Summary(ja): Gamin ライブラリ用の Python バインディング
  47. Group: Development/Libraries
  48. Requires: gamin = %{version}-%{release}
  49. Requires: python
  50. #Requires: %{_libdir}/python%(echo `python -c "import sys; print sys.version[0:3]"`)
  51. %description python
  52. The gamin-python package contains a module that allow monitoring of
  53. files and directories from the Python language based on the support
  54. of the gamin package.
  55. %description python -l ja
  56. gamin-python は gamin ライブラリを利用して Python 言語からファイルや
  57. ディレクトリのモニタリングを行うためのモジュールです。
  58. ## to build compat32 for x86_64 architecture support
  59. %package -n compat32-%{name}
  60. Summary: Library providing the FAM File Alteration Monitor API
  61. Summary(ja): FAM (File Alteration Monitor) API を提供するライブラリ
  62. Group: System Environment/Daemons
  63. Requires: gamin = %{version}-%{release}
  64. %description -n compat32-%{name}
  65. The Gamin library provides an API and ABI compatible file alteration
  66. monitor mechanism compatible with FAM but not dependent on a system wide
  67. daemon.
  68. %description -n compat32-%{name} -l ja
  69. Gamin ライブラリは FAM と API/ABI 互換のファイル変更検知システムを提供
  70. します。FAM とは違いシステムワイドなデーモンを利用せず、ユーザ毎のヘル
  71. パープログラムをオンデマンドに起動します。
  72. %package -n compat32-%{name}-devel
  73. Summary: Development files for the Gamin library
  74. Summary(ja): Gamin ライブラリの開発用ファイル
  75. Group: Development/Libraries
  76. Requires: compat32-gamin = %{version}-%{release}
  77. %description -n compat32-%{name}-devel
  78. The Gamin library provides an API and ABI compatible file alteration
  79. monitor mechanism compatible with FAM but not dependent on a system wide
  80. daemon.
  81. %description -n compat32-%{name}-devel -l ja
  82. Gamin ライブラリは FAM と API/ABI 互換のファイル変更検知システムを提供
  83. します。FAM とは違いシステムワイドなデーモンを利用せず、ユーザ毎のヘル
  84. %prep
  85. %setup -q
  86. %patch10 -p1
  87. find server/ -type f -exec sed -i 's/G_CONST_RETURN/const/' {} ';'
  88. %build
  89. %configure
  90. %__make %{?_smp_mflags}
  91. %install
  92. rm -fr %{buildroot}
  93. make install DESTDIR=$RPM_BUILD_ROOT
  94. ## remove unuse files
  95. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  96. rm -f $RPM_BUILD_ROOT%{python_archlib}/*.la
  97. %clean
  98. rm -fr %{buildroot}
  99. %post -p /sbin/ldconfig
  100. %postun -p /sbin/ldconfig
  101. %post -n compat32-%{name} -p /sbin/ldconfig
  102. %postun -n compat32-%{name} -p /sbin/ldconfig
  103. %files
  104. %defattr(-, root, root)
  105. %doc AUTHORS ChangeLog NEWS README Copyright TODO
  106. %doc doc/*.html
  107. %doc doc/*.gif
  108. %doc doc/*.txt
  109. %{_libdir}/lib*.so.*
  110. %{_libexecdir}/gam_server
  111. %files devel
  112. %defattr(-, root, root)
  113. %{_libdir}/lib*.so
  114. %{_libdir}/*a
  115. %{_includedir}/fam.h
  116. %{_libdir}/pkgconfig/gamin.pc
  117. %files python
  118. %defattr(-, root, root)
  119. %doc AUTHORS ChangeLog NEWS README Copyright TODO
  120. %{_libdir}/python*/site-packages/gamin.py*
  121. %{_libdir}/python*/site-packages/_gamin*
  122. %doc python/tests/*.py
  123. %doc doc/python.html
  124. %if %{build_compat32}
  125. %files -n compat32-%{name}
  126. %defattr(-, root, root)
  127. %{_libdir}/lib*.so.*
  128. %files -n compat32-%{name}-devel
  129. %defattr(-, root, root)
  130. %{_libdir}/lib*.so
  131. %{_libdir}/*a
  132. %{_libdir}/pkgconfig/gamin.pc
  133. %endif
  134. %changelog
  135. * Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.10-6
  136. - rebuild with VineSeed environment
  137. * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.10-5
  138. - rebuild with python-2.7.2
  139. - add Patch10 (21_no_g_const_return.patch)
  140. * Sun Apr 17 2011 IWAI, Masaharu <iwai@alib.jp> 0.1.10-4
  141. - update Requires for python subpackage
  142. - drop directory dependency
  143. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 0.1.10-3
  144. - build with rpm-4.8.1-1 for pkg-config file
  145. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.1.10-2
  146. - rebuild with python-2.6
  147. * Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.10-1
  148. - new upstream release
  149. * Sun Sep 28 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.1.9-3
  150. - fix license tag to LGPLv2
  151. - import patches from Fedora development
  152. - Patch0: don't poll for non-existant watched files
  153. - Patch1: Fix a memory leak
  154. - Patch2: workaround for missing struct ucred in glibc headers
  155. (fixed x86_64/ppc compilation)
  156. * Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 0.1.9-2
  157. - spec in utf-8
  158. - removed *.la
  159. * Sat May 10 2008 NAKAMURA Kenta <kenta@vinelinux.org> 0.1.9-1
  160. - added compat32-* packages for x86_64 architecture support
  161. - applied new versioning policy
  162. * Wed Mar 05 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.1.9-0vl1
  163. - new upstream release
  164. - Patch10 was included in upstream, dropped
  165. * Fri Apr 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.1.8-0vl2
  166. - added Patch10 (<BTS:507>) which should be fixed in the new upstream release
  167. * Sun Nov 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.8-0vl1
  168. - new upstream release
  169. * Mon Sep 4 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.1.7-0vl2
  170. - stop removing *.la
  171. * Tue Jun 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.7-0vl1
  172. - initial build for Vine Linux
  173. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.1.7-1.2.1
  174. - bump again for double-long bug on ppc(64)
  175. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.1.7-1.2
  176. - rebuilt for new gcc4.1 snapshot and glibc changes
  177. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  178. - rebuilt
  179. * Thu Oct 27 2005 Daniel Veillard <veillard@redhat.com> 0.1.7-1
  180. - hopefully fixes gam_server crashes
  181. - some portability fixes
  182. - removed a minor leak
  183. * Thu Sep 8 2005 Daniel Veillard <veillard@redhat.com> 0.1.6-1
  184. - revamp of the inotify back-end
  185. - memory leak fix
  186. - various fixes and cleanups
  187. * Tue Aug 9 2005 Daniel Veillard <veillard@redhat.com> 0.1.5-1
  188. - Improvement of configuration, system wide configuration files and
  189. per filesystem type default
  190. - Rewrite of the inotify back-end, reduce resources usage, tuning in
  191. case of busy resources
  192. - Documentation updates
  193. - Changes to compile inotify back-end on various architectures
  194. - Debugging output improvements
  195. * Tue Aug 2 2005 Daniel Veillard <veillard@redhat.com> 0.1.3-1
  196. - Fix to compile on older gcc versions
  197. - Inotify back-end changes and optimizations
  198. - Debug ouput cleanup, pid and process name reports
  199. - Dropped kernel monitor bugfix
  200. - Removed the old glist copy used for debugging
  201. - Maintain mounted filesystems knowledge, and per fstype preferences
  202. * Wed Jul 13 2005 Daniel Veillard <veillard@redhat.com> 0.1.2-1
  203. - inotify back end patches, ready for the new inotify support in kernel
  204. - lot of server code cleanup patches
  205. - fixed an authentication problem
  206. * Fri Jun 10 2005 Daniel Veillard <veillard@redhat.com> 0.1.1-1
  207. - gamin_data_conn_event fix
  208. - crash from bug gnome #303932
  209. - Inotify and mounted media #171201
  210. - mounted media did not show up on Desktop #159748
  211. - write may not be atomic
  212. - Monitoring a directory when it is a file
  213. - Portability to Hurd/Mach and various code cleanups
  214. - Added support for ~ as user home alias in .gaminrc
  215. * Thu May 12 2005 Daniel Veillard <veillard@redhat.com> 0.1.0-1
  216. - Close inherited file descriptors on exec of gam_server
  217. - Cancelling a monitor send back a FAMAcknowledge
  218. - Fixed for big files > 2GB
  219. - Bug when monitoring a non existing directory
  220. - Make client side thread safe
  221. - Unreadable directory fixes
  222. - Better flow control handling
  223. - Updated to latest inotify version: 0.23-6
  224. * Tue Mar 15 2005 Daniel Veillard <veillard@redhat.com> 0.0.26-1
  225. - Fix an include problem showing up with gcc4</li>
  226. - Fix the crash on failed tree assert bug #150471 based on patch from Dean Brettle
  227. - removed an incompatibility with SGI FAM #149822
  228. * Tue Mar 1 2005 Daniel Veillard <veillard@redhat.com> 0.0.25-1
  229. - Fix a configure problem reported by Martin Schlemmer
  230. - Fix the /media/* and /mnt/* mount blocking problems from 0.0.24 e.g. #142637
  231. - Fix the monitoring of directory using poll and not kernel
  232. * Fri Feb 18 2005 Daniel Veillard <veillard@redhat.com> 0.0.24-1
  233. - more documentation
  234. - lot of serious bug fixes including Gnome Desktop refresh bug
  235. - extending the framework for more debug (configure --enable-debug-api)
  236. - extending the python bindings for watching the same resource multiple times
  237. and adding debug framework support
  238. - growing the regression tests a lot based on python bindings
  239. - inotify-0.19 patch from John McCutchan
  240. - renamed python private module to _gamin to follow Python PEP 8
  241. * Tue Feb 8 2005 Daniel Veillard <veillard@redhat.com> 0.0.23-1
  242. - memory corruption fix from Mark on the client side
  243. - extending the protocol and API to allow skipping Exists and EndExists
  244. events to avoid deadlock on reconnect or when they are not used.
  245. * Mon Jan 31 2005 Daniel Veillard <veillard@redhat.com> 0.0.22-1
  246. - bit of python bindings improvements, added test
  247. - fixed 3 bugs
  248. * Wed Jan 26 2005 Daniel Veillard <veillard@redhat.com> 0.0.21-1
  249. - Added Python support
  250. - Updated for inotify-0.18
  251. * Thu Jan 6 2005 Daniel Veillard <veillard@redhat.com> 0.0.20-1
  252. - Frederic Crozat seems to have found the GList corruption which may fix
  253. #132354 and related problems
  254. - Frederic Crozat also fixed poll only mode
  255. * Fri Dec 3 2004 Daniel Veillard <veillard@redhat.com> 0.0.19-1
  256. - still chasing the loop bug, made another pass at checking GList,
  257. added own copy with memory poisonning of GList implementation.
  258. - fixed a compile issue when compiling without debug
  259. * Fri Nov 26 2004 Daniel Veillard <veillard@redhat.com> 0.0.18-1
  260. - still chasing the loop bug, checked and cleaned up all GList use
  261. - patch from markmc to minimize load on busy apps
  262. * Wed Oct 20 2004 Daniel Veillard <veillard@redhat.com> 0.0.16-1
  263. - chasing #132354, lot of debugging, checking and testing and a bit
  264. of refactoring
  265. * Sat Oct 16 2004 Daniel Veillard <veillard@redhat.com> 0.0.15-1
  266. - workaround to detect loops and avoid the nasty effects, see RedHat bug #132354
  267. * Sun Oct 3 2004 Daniel Veillard <veillard@redhat.com> 0.0.14-1
  268. - Found and fixed the annoying bug where update were not received
  269. should fix bugs ##132429, #133665 and #134413
  270. - new mechanism to debug on-the-fly by sending SIGUSR2 to client or server
  271. - Added documentation about internals
  272. * Fri Oct 1 2004 Daniel Veillard <veillard@redhat.com> 0.0.13-1
  273. - applied portability fixes
  274. - hardened the code while chasing a segfault
  275. * Thu Sep 30 2004 Daniel Veillard <veillard@redhat.com> 0.0.12-1
  276. - potential fix for a hard to reproduce looping problem.
  277. * Mon Sep 27 2004 Daniel Veillard <veillard@redhat.com> 0.0.11-1
  278. - update to the latest version of inotify
  279. - inotify support compiled in by default
  280. - fix ABI FAM compatibility problems #133162
  281. * Tue Sep 21 2004 Daniel Veillard <veillard@redhat.com> 0.0.10-1
  282. - more documentation
  283. - Added support for a configuration file $HOME/.gaminrc
  284. - fixes FAM compatibility issues with FAMErrno and FamErrlist #132944
  285. * Wed Sep 1 2004 Daniel Veillard <veillard@redhat.com> 0.0.9-1
  286. - fix crash with konqueror #130967
  287. - exclude kernel (dnotify) monitoring for /mnt//* /media//*
  288. * Thu Aug 26 2004 Daniel Veillard <veillard@redhat.com> 0.0.8-1
  289. - Fixes crashes of the gam_server
  290. - try to correct the kernel/poll switching mode
  291. * Tue Aug 24 2004 Daniel Veillard <veillard@redhat.com> 0.0.7-1
  292. - add support for both polling and dnotify simultaneously
  293. - fixes monitoring of initially missing files
  294. - load control on very busy resources #124361, desactivating
  295. dnotify and falling back to polling for CPU drain
  296. * Thu Aug 19 2004 Daniel Veillard <veillard@redhat.com> 0.0.6-1
  297. - fixes simple file monitoring should close RH #129974
  298. - relocate gam_server in $(libexec)
  299. * Thu Aug 5 2004 Daniel Veillard <veillard@redhat.com> 0.0.5-1
  300. - Fix a crash when the client binary forks the gam_server and an
  301. atexit handler is run.
  302. * Wed Aug 4 2004 Daniel Veillard <veillard@redhat.com> 0.0.4-1
  303. - should fix KDE build problems