1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071 |
- %define pkgname Sub-Install
- # Basic Information
- Name: perl-%{pkgname}
- Version: 0.925
- Release: 1%{?_dist_release}
- License: Artistic or GPL
- Group: Development/Libraries
- Source0: http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/%{pkgname}-%{version}.tar.gz
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- Vendor: Project Vine
- Distribution: Vine Linux
- Packager: yasumichi
- Summary: install subroutines into packages easily
- Summary(ja): 簡単にパッケージにサブルーチンをインストールする
- # Dependency
- Requires: perl
- Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
- BuildRequires: perl
- %description
- This module makes it easy to install subroutines into packages without the
- unslightly mess of no strict or typeglobs lying about where just anyone can
- see them.
- #%%description -l ja
- %prep
- %setup -q -n Sub-Install-0.925
- %build
- perl Makefile.PL
- %{__make}
- %install
- %{__rm} -rf ${RPM_BUILD_ROOT}
- %{__make} install DESTDIR=${RPM_BUILD_ROOT}
- find $RPM_BUILD_ROOT%{_prefix} -type f -print |
- sed "s@^$RPM_BUILD_ROOT@@g" |
- grep -v ^%{_mandir} |
- grep -v perllocal.pod |
- grep -v "\.packlist" > %{name}.files
- if [ "$(cat %{name}.files)X" = "X" ] ; then
- echo "ERROR: EMPTY FILE LIST"
- exit -1
- fi
- # remove unnecessary files.
- %{__rm} ${RPM_BUILD_ROOT}%{perl_archlib}/perllocal.pod
- %{__rm} ${RPM_BUILD_ROOT}%{perl_sitearch}/auto/Sub/Install/.packlist
- %clean
- %{__rm} -rf ${RPM_BUILD_ROOT}
- %files -f %{name}.files
- %defattr(-,root,root)
- %doc Changes LICENSE README
- %{_mandir}/*/*
- %changelog
- * Mon Oct 10 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.925-1
- - initial build for Vine Linux
|