pacemaker-vl.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495
  1. %global gname haclient
  2. %global uname hacluster
  3. %global pcmk_docdir %{_docdir}/%{name}
  4. # Supported cluster stacks, must support at least one
  5. %bcond_without ais
  6. %bcond_with heartbeat
  7. # ESMTP is not available in RHEL, only in EPEL. Allow people to build
  8. # the RPM without ESMTP in case they choose not to use EPEL packages
  9. %bcond_without esmtp
  10. # SNMP trap support only works with Net-SNMP 5.4 and above
  11. %bcond_without snmp
  12. # We generate some docs using Publican, but its not available everywhere
  13. %bcond_with publican
  14. %global specversion 3
  15. %global upstream_version Pacemaker-1.1.2
  16. %global upstream_prefix Pacemaker-1-1-
  17. # Keep around for when/if required
  18. #global alphatag %{upstream_version}.hg
  19. %global pcmk_release %{?alphatag:0.}%{specversion}%{?alphatag:.%{alphatag}}%{?dist}
  20. # When downloading directly from Mercurial, it will automatically add a prefix
  21. # Invoking 'hg archive' wont but you can add one with:
  22. # hg archive -t tgz -p "$upstream_prefix-$upstream_version" -r $upstream_version $upstream_version.tar.gz
  23. Name: pacemaker
  24. Summary: Scalable High-Availability cluster resource manager
  25. Summary(ja): スケーラブル高可用クラスタリソースマネージャ
  26. Version: 1.1.2
  27. Release: 2%{?_dist_release}
  28. License: GPLv2+ and LGPLv2+
  29. Url: http://www.clusterlabs.org
  30. Group: System Environment/Daemons
  31. Source0: http://hg.clusterlabs.org/pacemaker/1.1/archive/%{upstream_version}.tar.bz2
  32. Patch1: bug-lf-2401.patch
  33. Patch2: doc-validation.patch
  34. Patch3: pacemaker-1.1.2-fix-docbook-detection.patch
  35. Patch4: pacemaker-1.1.2-dont-use-find-to-detect-host-env.patch
  36. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  37. AutoReqProv: on
  38. Requires(pre): cluster-glue
  39. Requires: resource-agents
  40. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  41. # Required for core functionality
  42. BuildRequires: automake autoconf libtool pkgconfig libtool-ltdl-devel python-devel
  43. BuildRequires: glib2-devel cluster-glue-libs-devel libxml2-devel libxslt-devel
  44. BuildRequires: pkgconfig python-devel gcc-c++ bzip2-devel gnutls-devel pam-devel
  45. # Enables optional functionality
  46. BuildRequires: help2man ncurses-devel openssl-devel
  47. %if %{with esmtp}
  48. BuildRequires: libesmtp-devel
  49. %endif
  50. %if %{with snmp}
  51. BuildRequires: net-snmp-devel >= 5.4
  52. Requires: net-snmp
  53. %endif
  54. %if %{with ais}
  55. BuildRequires: corosynclib-devel
  56. %endif
  57. %if %{with heartbeat}
  58. BuildRequires: heartbeat-devel heartbeat-libs
  59. %endif
  60. %if %{with publican}
  61. %ifarch i386 x86_64
  62. BuildRequires: publican
  63. %endif
  64. %endif
  65. %description
  66. Pacemaker is an advanced, scalable High-Availability cluster resource
  67. manager for Linux-HA (Heartbeat) and/or OpenAIS.
  68. It supports "n-node" clusters with significant capabilities for
  69. managing resources and dependencies.
  70. It will run scripts at initialization, when machines go up or down,
  71. when related resources fail and can be configured to periodically check
  72. resource health.
  73. %package -n pacemaker-libs
  74. License: GPLv2+ and LGPLv2+
  75. Summary: Libraries used by the Pacemaker cluster resource manager and its clients
  76. Summary(ja): Libraries used by the Pacemaker cluster resource manager and its clients
  77. Group: System Environment/Daemons
  78. Requires: %{name} = %{version}-%{release}
  79. %description -n pacemaker-libs
  80. Pacemaker is an advanced, scalable High-Availability cluster resource
  81. manager for Linux-HA (Heartbeat) and/or OpenAIS.
  82. It supports "n-node" clusters with significant capabilities for
  83. managing resources and dependencies.
  84. It will run scripts at initialization, when machines go up or down,
  85. when related resources fail and can be configured to periodically check
  86. resource health.
  87. %package -n pacemaker-libs-devel
  88. License: GPLv2+ and LGPLv2+
  89. Summary: Pacemaker development package
  90. Summary(ja): Pacemaker 開発パッケージ
  91. Group: Development/Libraries
  92. Requires: %{name}-libs = %{version}-%{release}
  93. Requires: cluster-glue-libs-devel
  94. %if %{with ais}
  95. Requires: corosynclib-devel
  96. %endif
  97. %if %{with heartbeat}
  98. Requires: heartbeat-devel
  99. %endif
  100. %description -n pacemaker-libs-devel
  101. Headers and shared libraries for developing tools for Pacemaker.
  102. Pacemaker is an advanced, scalable High-Availability cluster resource
  103. manager for Linux-HA (Heartbeat) and/or OpenAIS.
  104. It supports "n-node" clusters with significant capabilities for
  105. managing resources and dependencies.
  106. It will run scripts at initialization, when machines go up or down,
  107. when related resources fail and can be configured to periodically check
  108. resource health.
  109. %package cts
  110. License: GPLv2+ and LGPLv2+
  111. Summary: Test framework for cluster-related technologies like Pacemaker
  112. Summary(ja): Test framework for cluster-related technologies like Pacemaker
  113. Group: System Environment/Daemons
  114. Requires: python
  115. %description cts
  116. Test framework for cluster-related technologies like Pacemaker
  117. %package doc
  118. License: GPLv2+ and LGPLv2+
  119. Summary: Documentation for Pacemaker
  120. Summary(ja): Documentation for Pacemaker
  121. Group: Documentation
  122. %description doc
  123. Documentation for Pacemaker.
  124. Pacemaker is an advanced, scalable High-Availability cluster resource
  125. manager for OpenAIS/Corosync.
  126. It supports "n-node" clusters with significant capabilities for
  127. managing resources and dependencies.
  128. It will run scripts at initialization, when machines go up or down,
  129. when related resources fail and can be configured to periodically check
  130. resource health.
  131. %prep
  132. %setup -q -n %{upstream_prefix}%{upstream_version}
  133. %patch1 -p1
  134. %patch2 -p0
  135. %patch3 -p1
  136. %patch4 -p1
  137. %build
  138. ./autogen.sh
  139. %{configure} \
  140. %{!?_with_heartbeat:--without-hearbeat} \
  141. %{?_without_ais} \
  142. %{?_without_esmtp} \
  143. %{?_without_snmp} \
  144. --disable-ansi \
  145. --docdir=%{pcmk_docdir} \
  146. --localstatedir=%{_var} \
  147. --enable-fatal-warnings=no
  148. make %{_smp_mflags}
  149. %install
  150. rm -rf %{buildroot}
  151. make DESTDIR=%{buildroot} install
  152. # Scripts that need should be executable
  153. chmod a+x %{buildroot}/%{_datadir}/pacemaker/tests/cts/CTSlab.py
  154. chmod a+x %{buildroot}/%{_datadir}/pacemaker/tests/cts/extracttests.py
  155. # These are not actually scripts
  156. find %{buildroot} -name '*.xml' -type f -print0 | xargs -0 chmod a-x
  157. find %{buildroot} -name '*.xsl' -type f -print0 | xargs -0 chmod a-x
  158. find %{buildroot} -name '*.rng' -type f -print0 | xargs -0 chmod a-x
  159. find %{buildroot} -name '*.dtd' -type f -print0 | xargs -0 chmod a-x
  160. # Dont package static libs or compiled python
  161. find %{buildroot} -name '*.a' -type f -print0 | xargs -0 rm -f
  162. find %{buildroot} -name '*.la' -type f -print0 | xargs -0 rm -f
  163. # Don't package these either
  164. rm -f %{buildroot}/%{_libdir}/heartbeat/hb2openais-helper.py
  165. rm -f %{buildroot}/%{_libdir}/heartbeat/crm_primitive.py
  166. rm -f %{buildroot}/%{_libdir}/service_crm.so
  167. rm -f %{buildroot}/usr/lib/ocf/resource.d/pacemaker/pingd
  168. %clean
  169. rm -rf %{buildroot}
  170. %post -n pacemaker-libs -p /sbin/ldconfig
  171. %postun -n pacemaker-libs -p /sbin/ldconfig
  172. %files
  173. ###########################################################
  174. %defattr(-,root,root)
  175. %exclude %{_datadir}/pacemaker/tests
  176. %{_datadir}/pacemaker
  177. %{_datadir}/snmp/mibs/PCMK-MIB.txt
  178. %{_libdir}/heartbeat/*
  179. %{_sbindir}/cibadmin
  180. %{_sbindir}/crm_attribute
  181. %{_sbindir}/crm_diff
  182. %{_sbindir}/crm_failcount
  183. %{_sbindir}/crm_master
  184. %{_sbindir}/crm_mon
  185. %{_sbindir}/crm
  186. %{_sbindir}/crm_simulate
  187. %{_sbindir}/crm_resource
  188. %{_sbindir}/crm_report
  189. %{_sbindir}/crm_standby
  190. %{_sbindir}/crm_verify
  191. %{_sbindir}/crmadmin
  192. %{_sbindir}/iso8601
  193. %{_sbindir}/attrd_updater
  194. %{_sbindir}/ptest
  195. %{_sbindir}/crm_shadow
  196. %{_sbindir}/cibpipe
  197. %{_sbindir}/crm_node
  198. %{_sbindir}/fence_legacy
  199. %{_sbindir}/stonith_admin
  200. %{python_sitelib}/crm
  201. #%{_mandir}/man8/*.8*
  202. %{_mandir}
  203. %if %{with heartbeat}
  204. %{_sbindir}/crm_uuid
  205. %else
  206. %exclude %{_sbindir}/crm_uuid
  207. %endif
  208. # Packaged elsewhere
  209. %exclude %{_datadir}/pacemaker/tests
  210. %doc COPYING
  211. %doc AUTHORS
  212. %dir %attr (750, %{uname}, %{gname}) %{_var}/lib/heartbeat/crm
  213. %dir %attr (750, %{uname}, %{gname}) %{_var}/lib/pengine
  214. %dir %attr (750, %{uname}, %{gname}) %{_var}/run/crm
  215. %dir /usr/lib/ocf
  216. %dir /usr/lib/ocf/resource.d
  217. /usr/lib/ocf/resource.d/pacemaker
  218. %if %{with ais}
  219. %{_libexecdir}/lcrso/pacemaker.lcrso
  220. %endif
  221. %files -n pacemaker-libs
  222. %defattr(-,root,root)
  223. %{_libdir}/libcib.so.*
  224. %{_libdir}/libcrmcommon.so.*
  225. %{_libdir}/libcrmcluster.so.*
  226. %{_libdir}/libpe_status.so.*
  227. %{_libdir}/libpe_rules.so.*
  228. %{_libdir}/libpengine.so.*
  229. %{_libdir}/libtransitioner.so.*
  230. %{_libdir}/libstonithd.so.*
  231. %doc COPYING.LIB
  232. %doc AUTHORS
  233. %files doc
  234. %defattr(-,root,root)
  235. %doc %{pcmk_docdir}
  236. %files cts
  237. %defattr(-,root,root)
  238. %{python_sitelib}/cts
  239. %{_datadir}/pacemaker/tests/cts
  240. %doc COPYING.LIB
  241. %doc AUTHORS
  242. %files -n pacemaker-libs-devel
  243. %defattr(-,root,root)
  244. %exclude %{_datadir}/pacemaker/tests/cts
  245. %{_datadir}/pacemaker/tests
  246. %{_includedir}/pacemaker
  247. %{_libdir}/*.so
  248. %doc COPYING.LIB
  249. %doc AUTHORS
  250. %changelog
  251. * Sun Mar 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.2-2
  252. - rebuild with openssl-1.0.0d
  253. * Sat Jul 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.2-1
  254. - initial build for Vine Linux
  255. * Mon Jun 21 2010 Andrew Beekhof <andrew@beekhof.net> - 1.1.2-3
  256. - publican is only available as a dependancy on i386/x86_64 machines
  257. * Fri Jun 11 2010 Andrew Beekhof <andrew@beekhof.net> - 1.1.2-2
  258. - Resolves rhbz#602239 - Added patch to documentation so that it passes validation
  259. - High: Core: Bug lf#2401 - Backed out changeset 6e6980376f01
  260. * Tue Jun 01 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.1.2-1.1
  261. - Mass rebuild with perl-5.12.0
  262. * Wed May 12 2010 Andrew Beekhof <andrew@beekhof.net> - 1.1.2-1
  263. - Update the tarball from the upstream 1.1.2 release
  264. + High: ais: Bug lf#2340 - Force rogue child processes to terminate after waiting 2.5 minutes
  265. + High: ais: Bug lf#2359 - Default expected votes to 2 inside Corosync/OpenAIS plugin
  266. + High: ais: Bug lf#2359 - expected-quorum-votes not correctly updated after membership change
  267. + High: ais: Bug rhbz#525552 - Move non-threadsafe calls to setenv() to after the fork()
  268. + High: ais: Do not count votes from offline nodes and calculate current votes before sending quorum data
  269. + High: ais: Ensure the list of active processes sent to clients is always up-to-date
  270. + High: ais: Fix previous commit, actually return a result in get_process_list()
  271. + High: ais: Fix two more uses of getpwnam() in non-thread-safe locations
  272. + High: ais: Look for the correct conf variable for turning on file logging
  273. + High: ais: Need to find a better and thread-safe way to set core_uses_pid. Disable for now.
  274. + High: ais: Use the threadsafe version of getpwnam
  275. + High: Core: Bug lf#2414 - Prevent use-after-free reported by valgrind when doing xpath based deletions
  276. + High: Core: Bump the feature set due to the new failcount expiry feature
  277. + High: Core: Fix memory leak in replace_xml_child() reported by valgrind
  278. + High: Core: fix memory leaks exposed by valgrind
  279. + High: crmd: Bug 2401 - Improved detection of partially active peers
  280. + High: crmd: Bug bnc#578644 - Improve handling of cancelled operations caused by resource cleanup
  281. + High: crmd: Bug lf#2379 - Ensure the cluster terminates when the PE is not available
  282. + High: crmd: Bug lf#2414 - Prevent use-after-free of the PE connection after it dies
  283. + High: crmd: Bug lf#2414 - Prevent use-after-free of the stonith-ng connection
  284. + High: crmd: Do not allow the target_rc to be misused by resource agents
  285. + High: crmd: Do not ignore action timeouts based on FSA state
  286. + High: crmd: Ensure we dont get stuck in S_PENDING if we loose an election to someone that never talks to us again
  287. + High: crmd: Fix memory leaks exposed by valgrind
  288. + High: crmd: Remove race condition that could lead to multiple instances of a clone being active on a machine
  289. + High: crmd: Send erase_status_tag() calls to the local CIB when the DC is fenced, since there is no DC to accept them
  290. + High: crmd: Use global fencing notifications to prevent secondary fencing operations of the DC
  291. + High: fencing: Account for stonith_get_info() always returning a pointer to the same static buffer
  292. + High: PE: Allow startup probes to be disabled - their calculation is a major bottleneck for very large clusters
  293. + High: PE: Bug lf#2317 - Avoid needless restart of primitive depending on a clone
  294. + High: PE: Bug lf#2358 - Fix master-master anti-colocation
  295. + High: PE: Bug lf#2361 - Ensure clones observe mandatory ordering constraints if the LHS is unrunnable
  296. + High: PE: Bug lf#2383 - Combine failcounts for all instances of an anonymous clone on a host
  297. + High: PE: Bug lf#2384 - Fix intra-set colocation and ordering
  298. + High: PE: Bug lf#2403 - Enforce mandatory promotion (colocation) constraints
  299. + High: PE: Bug lf#2412 - Correctly locate clone instances by their prefix
  300. + High: PE: Correctly implement optional colocation between primitives and clone resources
  301. + High: PE: Do not be so quick to pull the trigger on nodes that are coming up
  302. + High: PE: Fix memory leaks exposed by valgrind
  303. + High: PE: Fix memory leaks reported by valgrind
  304. + High: PE: Repair handling of unordered groups in RHS ordering constraints
  305. + High: PE: Rewrite native_merge_weights() to avoid Fix use-after-free
  306. + High: PE: Suppress duplicate ordering constraints to achieve orders of magnitude speed increases for large clusters
  307. + High: Shell: add support for xml in cli
  308. + High: Shell: always reload status if working with the cluster (bnc#590035)
  309. + High: Shell: check timeouts also against the default-action-timeout property
  310. + High: Shell: Default to using the status section from the live CIB (bnc#592762)
  311. + High: Shell: edit multiple meta_attributes sets in resource management (lf#2315)
  312. + High: Shell: enable comments (lf#2221)
  313. + High: Shell: implement new cibstatus interface and commands (bnc#580492)
  314. + High: Shell: improve configure commit (lf#2336)
  315. + High: Shell: new cibstatus import command (bnc#585471)
  316. + High: Shell: new configure filter command
  317. + High: Shell: restore error reporting in options
  318. + High: Shell: split shell into modules
  319. + High: Shell: support for the utilization element (old patch for the new structure)
  320. + High: Shell: update previous node lookup procedure to include the id where necessary
  321. + High: Tools: crm_mon - fix memory leaks exposed by valgrind
  322. * Thu Feb 11 2010 Andrew Beekhof <andrew@beekhof.net> - 1.1.1-0.1-60b7753f7310.hg
  323. - Update the tarball from upstream to version 60b7753f7310
  324. + First public release of the 1.1 series
  325. * Wed Dec 9 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0.5-5
  326. - Include patch of changeset 66b7bfd467f3:
  327. Some clients such as gfs_controld want a cluster name, allow one to be specified in corosync.conf
  328. * Thu Oct 29 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0.5-4
  329. - Include the fixes from CoroSync integration testing
  330. - Move the resource templates - they are not documentation
  331. - Ensure documentation is placed in a standard location
  332. - Exclude documentation that is included elsewhere in the package
  333. - Update the tarball from upstream to version ee19d8e83c2a
  334. + High: cib: Correctly clean up when both plaintext and tls remote ports are requested
  335. + High: PE: Bug bnc#515172 - Provide better defaults for lt(e) and gt(e) comparisions
  336. + High: PE: Bug lf#2197 - Allow master instances placemaker to be influenced by colocation constraints
  337. + High: PE: Make sure promote/demote pseudo actions are created correctly
  338. + High: PE: Prevent target-role from promoting more than master-max instances
  339. + High: ais: Bug lf#2199 - Prevent expected-quorum-votes from being populated with garbage
  340. + High: ais: Prevent deadlock - dont try to release IPC message if the connection failed
  341. + High: cib: For validation errors, send back the full CIB so the client can display the errors
  342. + High: cib: Prevent use-after-free for remote plaintext connections
  343. + High: crmd: Bug lf#2201 - Prevent use-of-NULL when running heartbeat
  344. + High: Core: Bug lf#2169 - Allow dtd/schema validation to be disabled
  345. + High: PE: Bug lf#2106 - Not all anonymous clone children are restarted after configuration change
  346. + High: PE: Bug lf#2170 - stop-all-resources option had no effect
  347. + High: PE: Bug lf#2171 - Prevent groups from starting if they depend on a complex resource which cannot
  348. + High: PE: Disable resource management if stonith-enabled=true and no stonith resources are defined
  349. + High: PE: Do not include master score if it would prevent allocation
  350. + High: ais: Avoid excessive load by checking for dead children every 1s (instead of 100ms)
  351. + High: ais: Bug rh#525589 - Prevent shutdown deadlocks when running on CoroSync
  352. + High: ais: Gracefully handle changes to the AIS nodeid
  353. + High: crmd: Bug bnc#527530 - Wait for the transition to complete before leaving S_TRANSITION_ENGINE
  354. + High: crmd: Prevent use-after-free with LOG_DEBUG_3
  355. + Medium: xml: Mask the "symmetrical" attribute on rsc_colocation constraints (bnc#540672)
  356. + Medium (bnc#520707): Tools: crm: new templates ocfs2 and clvm
  357. + Medium: Build: Invert the disable ais/heartbeat logic so that --without (ais|heartbeat) is available to rpmbuild
  358. + Medium: PE: Bug lf#2178 - Indicate unmanaged clones
  359. + Medium: PE: Bug lf#2180 - Include node information for all failed ops
  360. + Medium: PE: Bug lf#2189 - Incorrect error message when unpacking simple ordering constraint
  361. + Medium: PE: Correctly log resources that would like to start but cannot
  362. + Medium: PE: Stop ptest from logging to syslog
  363. + Medium: ais: Include version details in plugin name
  364. + Medium: crmd: Requery the resource metadata after every start operation
  365. * Fri Oct 9 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.0.5-3
  366. - rebuilt with new net-snmp
  367. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.0.5-2.1
  368. - rebuilt with new openssl
  369. * Wed Aug 19 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0.5-2
  370. - Add versioned perl dependancy as specified by
  371. https://fedoraproject.org/wiki/Packaging/Perl#Packages_that_link_to_libperl
  372. - No longer remove RPATH data, it prevents us finding libperl.so and no other
  373. libraries were being hardcoded
  374. - Compile in support for heartbeat
  375. - Conditionally add heartbeat-devel and corosynclib-devel to the -devel requirements
  376. depending on which stacks are supported
  377. * Mon Aug 17 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0.5-1
  378. - Add dependancy on resource-agents
  379. - Use the version of the configure macro that supplies --prefix, --libdir, etc
  380. - Update the tarball from upstream to version 462f1569a437 (Pacemaker 1.0.5 final)
  381. + High: Tools: crm_resource - Advertise --move instead of --migrate
  382. + Medium: Extra: New node connectivity RA that uses system ping and attrd_updater
  383. + Medium: crmd: Note that dc-deadtime can be used to mask the brokeness of some switches
  384. * Tue Aug 11 2009 Ville Skyttä <ville.skytta@iki.fi> - 1.0.5-0.7.c9120a53a6ae.hg
  385. - Use bzipped upstream tarball.
  386. * Wed Jul 29 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0.5-0.6.c9120a53a6ae.hg
  387. - Add back missing build auto* dependancies
  388. - Minor cleanups to the install directive
  389. * Tue Jul 28 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0.5-0.5.c9120a53a6ae.hg
  390. - Add a leading zero to the revision when alphatag is used
  391. * Tue Jul 28 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0.5-0.4.c9120a53a6ae.hg
  392. - Incorporate the feedback from the cluster-glue review
  393. - Realistically, the version is a 1.0.5 pre-release
  394. - Use the global directive instead of define for variables
  395. - Use the haclient/hacluster group/user instead of daemon
  396. - Use the _configure macro
  397. - Fix install dependancies
  398. * Fri Jul 24 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0.4-3
  399. - Include an AUTHORS and license file in each package
  400. - Change the library package name to pacemaker-libs to be more
  401. Fedora compliant
  402. - Remove execute permissions from xml related files
  403. - Reference the new cluster-glue devel package name
  404. - Update the tarball from upstream to version c9120a53a6ae
  405. + High: PE: Only prevent migration if the clone dependancy is stopping/starting on the target node
  406. + High: PE: Bug 2160 - Dont shuffle clones due to colocation
  407. + High: PE: New implementation of the resource migration (not stop/start) logic
  408. + Medium: Tools: crm_resource - Prevent use-of-NULL by requiring a resource name for the -A and -a options
  409. + Medium: PE: Prevent use-of-NULL in find_first_action()
  410. + Low: Build: Include licensing files
  411. * Tue Jul 14 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0.4-2
  412. - Reference authors from the project AUTHORS file instead of listing in description
  413. - Change Source0 to reference the project's Mercurial repo
  414. - Cleaned up the summaries and descriptions
  415. - Incorporate the results of Fedora package self-review
  416. * Tue Jul 14 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0.4-1
  417. - Initial checkin