OpenIPMI-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420
  1. # TODO: uses private copy of libedit, should be modified to use system one
  2. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  3. Summary: IPMI (Intelligent Platform Management Interface) library and tools
  4. Summary(ja): IPMI (Intelligent Platform Management Interface) ライブラリおよびツール
  5. Name: OpenIPMI
  6. Version: 2.0.18
  7. Release: 2%{?_dist_release}
  8. License: LGPLv2+ and GPLv2+ or BSD
  9. Group: System Environment/Base
  10. URL: http://sourceforge.net/projects/openipmi/
  11. Source: http://downloads.sourceforge.net/openipmi/%{name}-%{version}.tar.gz
  12. Source1: openipmi.sysconf
  13. Source2: openipmi.initscript
  14. Source3: openipmigui.desktop
  15. Source4: README.initscript
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  17. BuildRequires: gdbm-devel swig glib2-devel net-snmp-devel ncurses-devel
  18. BuildRequires: openssl-devel python-devel perl tcl tkinter
  19. BuildRequires: desktop-file-utils popt-devel
  20. Requires(post): chkconfig
  21. Requires(preun): chkconfig
  22. Patch1: OpenIPMI-2.0.18-pthread-pkgconfig.patch
  23. %description
  24. The Open IPMI project aims to develop an open code base to allow access to
  25. platform information using Intelligent Platform Management Interface (IPMI).
  26. This package contains the tools of the OpenIPMI project.
  27. %package libs
  28. Group: Development/Libraries
  29. Summary: The OpenIPMI runtime libraries
  30. Summary(ja): OpenIPMI ランタイムライブラリ
  31. %description libs
  32. The OpenIPMI-libs package contains the runtime libraries for shared binaries
  33. and applications.
  34. %package perl
  35. Group: Development/Libraries
  36. Summary: IPMI Perl language bindings
  37. Summary(ja): IPMI Perl 言語バインディング
  38. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  39. %description perl
  40. The OpenIPMI-perl package contains the Perl language bindings for OpenIPMI.
  41. %package python
  42. Group: Development/Libraries
  43. Summary: IPMI Python language bindings
  44. Summary(ja): IPMI Python 言語バインディング
  45. %description python
  46. The OpenIPMI-python package contains the Python language bindings for OpenIPMI.
  47. %package devel
  48. Group: Development/Libraries
  49. Summary: The development environment for the OpenIPMI project
  50. Summary(ja): OpenIPMIの開発キット
  51. Requires: pkgconfig
  52. Requires: %{name} = %{version}-%{release}
  53. %description devel
  54. The OpenIPMI-devel package contains the development libraries and header files
  55. of the OpenIPMI project.
  56. %package gui
  57. Group: System Environment/Base
  58. Summary: IPMI graphical user interface tool
  59. Summary(ja): IPMI GUI ツール
  60. Requires: tix tkinter %{name}-python = %{version}-%{release}
  61. %description gui
  62. The OpenIPMI-gui package contains the graphical user interface to monitor
  63. and control IPMI-enabled devices.
  64. %prep
  65. %setup -q
  66. %patch1 -p1
  67. %build
  68. export CFLAGS="-fPIC $RPM_OPT_FLAGS"
  69. %configure \
  70. --with-pythoninstall=%{python_sitearch} \
  71. --disable-dependency-tracking \
  72. --with-tcl=no \
  73. --with-glib12=no \
  74. --disable-static
  75. # get rid of rpath
  76. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  77. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  78. make # not %{?_smp_mflags} safe
  79. %install
  80. rm -rf $RPM_BUILD_ROOT
  81. make install DESTDIR=$RPM_BUILD_ROOT
  82. rm -rf $RPM_BUILD_ROOT/%{_libdir}/*.la
  83. install -d ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig
  84. install -m 644 %SOURCE1 ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig/ipmi
  85. install -d ${RPM_BUILD_ROOT}%{_initrddir}
  86. install -m 755 %SOURCE2 ${RPM_BUILD_ROOT}%{_initrddir}/ipmi
  87. desktop-file-install --vendor="fedora" --dir=${RPM_BUILD_ROOT}%{_datadir}/applications %{SOURCE3}
  88. install -m 644 %SOURCE4 .
  89. %post
  90. /sbin/chkconfig --add ipmi
  91. %preun
  92. if [ $1 = 0 ]; then
  93. service ipmi stop >/dev/null 2>&1
  94. /sbin/chkconfig --del ipmi
  95. fi
  96. %postun
  97. if [ "$1" -ge "1" ]; then
  98. service ipmi condrestart >/dev/null 2>&1 || :
  99. fi
  100. %post libs -p /sbin/ldconfig
  101. %postun libs -p /sbin/ldconfig
  102. %clean
  103. rm -rf $RPM_BUILD_ROOT
  104. %files
  105. %defattr(-,root,root)
  106. %doc CONFIGURING_FOR_LAN COPYING COPYING.BSD COPYING.LIB FAQ README README.Force README.MotorolaMXP README.initscript
  107. %config(noreplace) %{_sysconfdir}/sysconfig/ipmi
  108. %{_initrddir}/ipmi
  109. %{_bindir}/ipmicmd
  110. %{_bindir}/ipmilan
  111. %{_bindir}/ipmish
  112. %{_bindir}/ipmi_ui
  113. %{_bindir}/openipmicmd
  114. %{_bindir}/openipmish
  115. %{_bindir}/rmcp_ping
  116. %{_bindir}/solterm
  117. %{_mandir}/man1/ipmi_ui*
  118. %{_mandir}/man1/openipmicmd*
  119. %{_mandir}/man1/openipmish*
  120. %{_mandir}/man1/rmcp_ping*
  121. %{_mandir}/man1/solterm*
  122. %{_mandir}/man7/ipmi_cmdlang*
  123. %{_mandir}/man7/openipmi_conparms*
  124. %{_mandir}/man8/ipmilan*
  125. %files perl
  126. %defattr(-,root,root)
  127. %attr(644,root,root) %{perl_vendorarch}/OpenIPMI.pm
  128. %{perl_vendorarch}/auto/OpenIPMI/
  129. %files python
  130. %defattr(-,root,root)
  131. %{python_sitearch}/*OpenIPMI*
  132. %files libs
  133. %defattr(-,root,root)
  134. %{_libdir}/*.so.*
  135. %files devel
  136. %defattr(-,root,root)
  137. %{_includedir}/OpenIPMI
  138. %{_libdir}/*.so
  139. %{_libdir}/pkgconfig/*.pc
  140. %files gui
  141. %defattr(-,root,root)
  142. %{_bindir}/openipmigui
  143. %{_mandir}/man1/openipmigui*
  144. %{python_sitearch}/openipmigui
  145. %{_datadir}/applications/fedora-openipmigui.desktop
  146. %changelog
  147. * Sun Mar 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.18-2
  148. - rebuild with openssl-1.0.0d
  149. * Sat Jul 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.18-1
  150. - initial build for Vine Linux
  151. * Tue Jun 01 2010 Marcela Maslanova <mmaslano@redhat.com> - 2.0.18-2
  152. - Mass rebuild with perl-5.12.0
  153. * Wed May 5 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.18-1
  154. - updated to OpenIPMI-2.0.18
  155. - fixed OpenIPMIpthread pkgconfig file (#468067)
  156. * Mon May 3 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.17-1
  157. - updated to OpenIPMI-2.0.17
  158. * Thu Mar 18 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-12
  159. - implemented mandatory 'force-reload' command in ipmi service
  160. * Thu Mar 11 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-11
  161. - rebuild against new gdbm
  162. * Wed Mar 3 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-10
  163. - add README.initscript describing /etc/init.d/ipmi initscript exit codes
  164. (#562151)
  165. * Mon Feb 22 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-9
  166. - fix package License: field, there *are* sources with BSD header
  167. - distribute README files and COPYING in package
  168. * Tue Jan 5 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-8
  169. - fix package License: field, there is no source with BSD header
  170. * Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 2.0.16-7
  171. - rebuild against perl 5.10.1
  172. * Tue Dec 1 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-6
  173. - fix package compilation to remove rpmlint errors
  174. * Wed Sep 30 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-5
  175. - rebuilt with new net-snmp
  176. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 2.0.16-4
  177. - rebuilt with new openssl
  178. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.16-3
  179. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  180. * Wed Apr 15 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-2
  181. - fix compilation flags, debuginfo package is correctly generated now
  182. * Thu Mar 19 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-1
  183. - new upstream release
  184. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.14-11
  185. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  186. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 2.0.14-10
  187. - rebuild with new openssl
  188. * Thu Dec 11 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-9
  189. - fix linking without rpath, prelink won't screw up the libraries
  190. anymore (#475265)
  191. * Wed Dec 10 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-8
  192. - shorter probe interval is used in init script, making the service startup
  193. quicker in most situations (#475101)
  194. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.0.14-7
  195. - Rebuild for Python 2.6
  196. * Thu Oct 30 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-6
  197. - removed static libraries from the -devel subpackage
  198. - fixed openipmigui.desktop file
  199. * Thu Oct 23 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-5
  200. - fixed typos in the descriptions
  201. - added .desktop file for openipmigui tool
  202. * Mon Oct 20 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-4
  203. - fixed description of the package
  204. * Thu Oct 16 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-3
  205. - split ipmitool to separate package
  206. - added 'reload' functionality to init script
  207. - added seraparate -gui subpackage
  208. * Wed Jul 30 2008 Phil Knirsch <pknirsch@redhat.com> - 2.0.14-2
  209. - Fixed rpath problem in libOpenIPMIposix.so.0.0.1
  210. * Tue Jul 29 2008 Phil Knirsch <pknirsch@redhat.com> - 2.0.14-1
  211. - Fixed several specfile problems (#453751)
  212. - Update to OpenIPMI-2.0.14
  213. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.0.13-2
  214. - Autorebuild for GCC 4.3
  215. * Wed Dec 05 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.13-1
  216. - Updated to OpenIPMI-2.0.13
  217. - Rebuild due to new openssl
  218. * Wed Oct 10 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-3
  219. - Added missing perl-devel buildrequires
  220. * Mon Sep 24 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-2
  221. - Added missing popt-devel buildrequires
  222. * Fri Aug 17 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-2
  223. - Fix rebuild problems due to glibc change
  224. - License review and fixes
  225. * Tue Apr 24 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-1
  226. - Update to OpenIPMI-2.0.11
  227. * Tue Feb 27 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.6-8
  228. - Update for ipmitool-1.8.9
  229. * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 2.0.6-7
  230. - rebuild for python 2.5
  231. * Tue Nov 28 2006 Phil Knirsch <pknirsch@redhat.com> - 2.0.6-6.fc7
  232. - Update due to new net-snmp-5.4
  233. - Some specfile updates
  234. * Tue Jul 18 2006 Phil Knirsch <pknirsch@redhat.com> - 2.0.6-5
  235. - Fixed check for udev in initscript (#197956)
  236. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.0.6-4.1
  237. - rebuild
  238. * Fri Jun 16 2006 Bill Nottingham <notting@redhat.com> 2.0.6-4
  239. - don't include <linux/compiler.h>
  240. * Fri Jun 16 2006 Jon Masters <jcm@redhat.com> 2.0.6-3
  241. - Fix a build requires (needs glibc-kernheaders)
  242. * Thu Jun 15 2006 Jesse Keating <jkeating@redhat.com> 2.0.6-2
  243. - Bump for new glib2
  244. * Tue May 16 2006 Phil Knirsch <pknirsch@redhat.com> 2.0.6-1
  245. - Fixed bug with type conversion in ipmitool (#191091)
  246. - Added python bindings
  247. - Split off perl and python bindings in separate subpackages
  248. - Dropped obsolete patches
  249. - Added missing buildprereq on readline-devel
  250. - Made it install the python bindings properly on 64bit archs
  251. * Mon May 15 2006 Phil Knirsch <pknirsch@redhat.com>
  252. - Updated ipmitool to 1.8.8
  253. - Updated OpenIPMI to 2.0.6
  254. * Fri Feb 17 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-19
  255. - Added missing PreReq for chkconfig
  256. * Mon Feb 13 2006 Jesse Keating <jkeating@redhat.com> - 1.4.14-18.2.1
  257. - rebump for build order issues during double-long bump
  258. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.4.14-18.2
  259. - bump again for double-long bug on ppc(64)
  260. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.4.14-18.1
  261. - rebuilt for new gcc4.1 snapshot and glibc changes
  262. * Mon Feb 06 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-18
  263. - Updated ipmitool to latest upstream version.
  264. - Removed 3 patches for already fixed bugs in latest ipmitool.
  265. - Adapted warning message fix for ipmitool for latest version.
  266. * Tue Jan 24 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-17
  267. - Fixed some minor things in initscripts.
  268. * Mon Jan 09 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-16
  269. - Included FRU fix for displaying FRUs with ipmitool
  270. - Included patch for new option to specify a BMC password for IPMI 2.0 sessions
  271. * Tue Jan 03 2006 Radek Vokal <rvokal@redhat.com> 1.4.14-15
  272. - Rebuilt against new libnetsnmp
  273. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  274. - rebuilt
  275. * Wed Nov 23 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-14
  276. - Some more initscript and sysconfig updates from Dell.
  277. * Wed Nov 09 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-13
  278. - Rebuilt to link against latest openssl libs.
  279. - Fixed ipmitool not setting session privilege level (#172312)
  280. * Wed Nov 02 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-11
  281. - Rebuild to link against new net-snmp libs.
  282. * Tue Oct 11 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-10
  283. - Updated initscript to fix missing redhat-lsb bug (#169901)
  284. * Thu Sep 08 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-9
  285. - Another update to latest initscripts from Dell
  286. - Fixed some missing return statements for non-void functions (#164138)
  287. * Thu Sep 01 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-8
  288. - Updated initscript to latest version from Dell
  289. * Fri Aug 12 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-7
  290. - Fixed the unwanted output of failed module loading of the initscript. Behaves
  291. now like all our other initscripts (#165476)
  292. * Fri Aug 05 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-6
  293. - Fixed build problem on 64bit machines
  294. * Fri Jul 15 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-5
  295. - Fixed missing change to not autostart in the initscript
  296. * Wed Jul 06 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-4
  297. - Made the initscript a replacing configfile
  298. * Mon Jul 04 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-3
  299. - Updated versions of the initscripts and sysconf files
  300. - Fixed typo in preun script and changelog
  301. * Mon Jun 27 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-2
  302. - Updated to OpenIPMI-1.4.14
  303. - Split the main package into normal and libs package for multilib support
  304. - Added ipmitool-1.8.2 to OpenIPMI and put it in tools package
  305. - Added sysconf and initscript (#158270)
  306. - Fixed oob subscripts (#149142)
  307. * Wed Mar 30 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.11-5
  308. - Correctly put libs in the proper packages
  309. * Thu Mar 17 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.11-4
  310. - gcc4 rebuild fixes
  311. - Added missing gdbm-devel buildprereq
  312. * Wed Mar 02 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.11-3
  313. - bump release and rebuild with gcc 4
  314. * Tue Feb 08 2005 Karsten Hopp <karsten@redhat.de> 1.4.11-2
  315. - update
  316. * Tue Oct 26 2004 Phil Knirsch <pknirsch@redhat.com>
  317. - Initial version