swig-vl.spec 6.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237
  1. %define tcl 1
  2. %define guile 0
  3. Summary: Connects C/C++/Objective C to some high-level programming languages
  4. Summary(ja): C/C++/Objective C を高級プログラミング言語に接続するためのツール
  5. Name: swig
  6. Version: 4.1.1
  7. Release: 1%{?_dist_release}
  8. Group: programming
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. License: GPLv3+ and BSD
  12. URL: https://www.swig.org/
  13. Source: https://downloads.sourceforge.net/project/swig/swig/swig-%{version}/swig-%{version}.tar.gz
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  15. BuildRequires: lua-devel
  16. BuildRequires: pcre2-devel
  17. BuildRequires: perl
  18. BuildRequires: python3-devel
  19. BuildRequires: ruby-devel
  20. %if %{tcl}
  21. BuildRequires: tcl-devel
  22. %endif
  23. %if %{guile}
  24. BuildRequires: guile-devel
  25. %endif
  26. BuildRequires: autoconf, automake, gawk, nkf
  27. Obsoletes: swig-runtime
  28. %description
  29. Simplified Wrapper and Interface Generator (SWIG) is a software
  30. development tool for connecting C, C++ and Objective C programs with a
  31. variety of high-level programming languages. SWIG is primarily used
  32. with Perl, Python and Tcl/TK, but it has also been extended to Java,
  33. Eiffel and Guile. SWIG is normally used to create high-level
  34. interpreted programming environments, systems integration, and as a
  35. tool for building user interfaces
  36. %package doc
  37. Summary: Documentation files for SWIG
  38. Summary(ja): SWIG のドキュメント
  39. License: BSD
  40. Group: documentation
  41. BuildArch: noarch
  42. %description doc
  43. This package contains documentation for SWIG and useful examples
  44. %debug_package
  45. %prep
  46. %setup -q -n swig-%{version}
  47. # as written on https://fedoraproject.org/wiki/Packaging_talk:Perl, section 2
  48. # (specific req/prov filtering). Before you remove this hack make sure you don't
  49. # reintroduce https://bugzilla.redhat.com/show_bug.cgi?id=489421
  50. cat << \EOF > %{name}-prov
  51. #!/bin/sh
  52. %{__perl_provides} `perl -p -e 's|\S+%{_docdir}/%{name}-doc-%{version}\S+||'`
  53. EOF
  54. %global __perl_provides %{_builddir}/%{name}-%{version}/%{name}-prov
  55. chmod +x %{__perl_provides}
  56. cat << \EOF > %{name}-req
  57. #!/bin/sh
  58. %{__perl_requires} `perl -p -e 's|\S+%{_docdir}/%{name}-doc-%{version}\S+||'`
  59. EOF
  60. %global __perl_requires %{_builddir}/%{name}-%{version}/%{name}-req
  61. chmod +x %{__perl_requires}
  62. for all in CHANGES README; do
  63. iconv -f ISO88591 -t UTF8 < $all > $all.new
  64. touch -r $all $all.new
  65. mv -f $all.new $all
  66. done
  67. %build
  68. ./autogen.sh
  69. %configure \
  70. --with-python3=python3 \
  71. --with-2to3=2to3-3.11 \
  72. %{nil}
  73. make %{?_smp_mflags}
  74. # Test suite is currently broken
  75. #make check
  76. %install
  77. rm -rf %{buildroot}
  78. make clean-examples
  79. pushd Examples/
  80. # Remove all arch dependent files in Examples/
  81. find -type f -name 'Makefile.in' | xargs rm -f --
  82. # We don't want to ship files below.
  83. rm -rf test-suite
  84. find -type f -name '*.dsp' | xargs rm -f --
  85. find -type f -name '*.dsw' | xargs rm -f --
  86. # Convert files to UNIX format
  87. for all in `find -type f`; do
  88. nkf --unix $all
  89. chmod -x $all
  90. done
  91. popd
  92. make DESTDIR=%{buildroot} install
  93. %files
  94. %defattr(-,root,root,-)
  95. %{_bindir}/*
  96. %{_datadir}/swig
  97. %doc ANNOUNCE CHANGES CHANGES.current INSTALL
  98. %doc README TODO
  99. %license LICENSE LICENSE-GPL LICENSE-UNIVERSITIES COPYRIGHT
  100. %files doc
  101. %defattr(-,root,root,-)
  102. %doc Doc Examples
  103. %license LICENSE LICENSE-GPL LICENSE-UNIVERSITIES COPYRIGHT
  104. %changelog
  105. * Thu Oct 12 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.1-1
  106. - new upstream release.
  107. * Fri Mar 19 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.2-1
  108. - new upstream release.
  109. * Wed Oct 30 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.1-1
  110. - new upstream release.
  111. * Mon Jan 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.12-1
  112. - new upstream release.
  113. * Fri Jul 1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.10-1
  114. - new upstream release.
  115. * Wed Feb 4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.0.5-1
  116. - new upstream release
  117. - moved doc subpackage to Documentation Group
  118. * Mon Jun 16 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 3.0.2-1
  119. - update to 3.0.2
  120. * Fri Apr 18 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.0-1
  121. - update to 3.0.0
  122. - add BR: ruby-devel, lua-devel
  123. * Thu Oct 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.8-1
  124. - update to 2.0.8
  125. - build with pcre-8.31
  126. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.4-2
  127. - rebuild with python-2.7.2
  128. * Sat Oct 29 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.4-1
  129. - update to 2.0.4
  130. * Tue Mar 02 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.40-2
  131. - add missing man file(s) to the filelist
  132. * Mon Mar 01 2010 Shu KONNO <owa@bg.wakwak.com> 1.3.40-1
  133. - new upstream release
  134. - rebuild with new toolchain
  135. * Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.35-1
  136. - new upstream release
  137. * Wed Mar 28 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.31-0vl1
  138. - new upstream release
  139. - removed php-devel and ruby-devel from BuildPreReq:.
  140. * Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.29-0vl1
  141. - new upstream release
  142. - use %%configure
  143. - remove runtime subpackage
  144. * Sun Jan 23 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
  145. - 1.3.21-0vl2
  146. - un-libtoolize (tarball have already been libtoolized).
  147. - fix %%clean.
  148. - add guile-devel, php-devel, python-devel and ruby-devel to BuildPreReq:.
  149. * Wed Mar 03 2004 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
  150. - 1.3.21-0vl1
  151. - update version
  152. * Sat Dec 27 2003 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
  153. - 1.3.20-0vl1
  154. - update version
  155. * Tue Jun 03 2003 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
  156. - update version
  157. * Sun Mar 03 2002 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
  158. - update version
  159. * Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org>
  160. - import to Vine Linux
  161. * Wed Jul 19 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 1.3a3-1mdk
  162. - BM.
  163. - Clean up specs.
  164. - 1.3a3.
  165. * Tue Jun 20 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 1.1p5-5mdk
  166. - Use makeinstall macros.
  167. * Mon Apr 10 2000 Francis Galiegue <fg@mandrakesoft.com> 1.1p5-4mdk
  168. - Provides: swig
  169. * Mon Apr 3 2000 Pixel <pixel@mandrakesoft.com> 1.1p5-3mdk
  170. - rebuild with new perl
  171. - cleanup
  172. * Wed Mar 22 2000 Francis Galiegue <fg@mandrakesoft.com> 1.1p5-2mdk
  173. - Rebuilt on kenobi
  174. - Don't use prefix
  175. * Fri Mar 10 2000 Francis Galiegue <francis@mandrakesoft.com> 1.1p5-1mdk
  176. - First RPM for Mandrake