rsync-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355
  1. %bcond_with systemd
  2. #define prerelease pre2
  3. Summary: A program for synchronizing files over a network.
  4. Summary(ja): ネットワーク越しにファイルを同期させるプログラム
  5. Name: rsync
  6. Version: 3.2.7%{?prerelease:~%{prerelease}}
  7. Release: 1%{_dist_release}%{?with_systemd:.systemd}
  8. Group: network
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. Packager: daisuke
  12. License: GPLv3+
  13. URL: https://rsync.samba.org/
  14. Source: https://download.samba.org/pub/rsync/src%{?prerelease:-previews}/rsync-%{version}%{?prerelease:%{prerelease}}.tar.gz
  15. Source1: https://download.samba.org/pub/rsync/src%{?prerelease:-previews}/rsync-patches-%{version}%{?prerelease:%{prerelease}}.tar.gz
  16. Source2: rsyncd.socket
  17. Source3: rsyncd.service
  18. Source4: rsyncd.conf
  19. Source5: rsyncd.sysconfig
  20. Source6: rsyncd@.service
  21. Source100: rsync.xinetd
  22. #Added due to rhbz#1873975 - default-acls test fail on s390x due to libacl
  23. Patch1: rsync-3.2.2-runtests.patch
  24. # security fixes
  25. # none
  26. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  27. BuildRequires: libacl-devel libattr-devel popt-devel
  28. BuildRequires: lz4-devel openssl-devel libzstd-devel
  29. BuildRequires: acl attr
  30. %description
  31. Rsync uses a quick and reliable algorithm to very quickly bring
  32. remote and host files into sync. Rsync is fast because it just
  33. sends the differences in the files over the network (instead of
  34. sending the complete files). Rsync is often used as a very powerful
  35. mirroring process or just as a more capable replacement for the
  36. rcp command. A technical report which describes the rsync algorithm
  37. is included in this package.
  38. Install rsync if you need a powerful mirroring program.
  39. %description -l ja
  40. rsync は高速で信頼性の高いアルゴリズムを使い,遠隔ホスト上のファイルと
  41. 高速に同期させることが出来ます.rsync が高速に動作するのは,ネットワーク
  42. 上に流れるデータがファイルの差分だけだからです (ファイル全体をやりとり
  43. するのではなく).rsync は強力なミラリングツールとしても,rcp コマンドの
  44. 代替としても使うことが出来ます.rsync のアルゴリズムに関する技術情報は
  45. このパッケージに同梱されています.
  46. 強力なミラープログラムが必要ならば rsync をインストールして下さい.
  47. %package daemon
  48. Summary: Service for anonymous access to rsync
  49. Group: servers
  50. BuildArch: noarch
  51. Requires: %{name} = %{version}-%{release}
  52. %if %{with systemd}
  53. %{?systemd_requires}
  54. %else
  55. Requires: xinetd
  56. %endif
  57. %description daemon
  58. Rsync can be used to offer read only access to anonymous clients. This
  59. package provides the anonymous rsync service.
  60. %debug_package
  61. %prep
  62. %setup -q -n rsync-%{version}%{?prerelease:%{prerelease}}
  63. %setup -q -b 1 -n rsync-%{version}%{?prerelease:%{prerelease}}
  64. %patch1 -p1 -b .runtests
  65. # security fixes
  66. # none
  67. %build
  68. %configure --disable-xxhash
  69. make %{?_smp_mflags}
  70. %install
  71. rm -rf $RPM_BUILD_ROOT
  72. %makeinstall
  73. install -D -m644 %{SOURCE4} $RPM_BUILD_ROOT/%{_sysconfdir}/rsyncd.conf
  74. %if %{with systemd}
  75. install -D -m644 %{SOURCE3} $RPM_BUILD_ROOT/%{_unitdir}/rsyncd.service
  76. install -D -m644 %{SOURCE2} $RPM_BUILD_ROOT/%{_unitdir}/rsyncd.socket
  77. install -D -m644 %{SOURCE6} $RPM_BUILD_ROOT/%{_unitdir}/rsyncd@.service
  78. install -D -m644 %{SOURCE5} $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig/rsyncd
  79. %else
  80. mkdir -p $RPM_BUILD_ROOT/etc/xinetd.d
  81. install -m 644 %{SOURCE100} $RPM_BUILD_ROOT/etc/xinetd.d/rsync
  82. %endif
  83. %check
  84. make check
  85. chmod -x support/*
  86. %clean
  87. rm -rf $RPM_BUILD_ROOT
  88. %if %{with systemd}
  89. %post daemon
  90. %systemd_post rsyncd.service
  91. %preun daemon
  92. %systemd_preun rsyncd.service
  93. %postun daemon
  94. %systemd_postun_with_restart rsyncd.service
  95. %endif
  96. %files
  97. %defattr(-,root,root)
  98. %license COPYING
  99. %doc README* tech_report.tex support/
  100. %doc NEWS* TODO
  101. %{_bindir}/%{name}
  102. %{_bindir}/%{name}-ssl
  103. %config(noreplace) %{_sysconfdir}/rsyncd.conf
  104. %{_mandir}/man1/%{name}.1*
  105. %{_mandir}/man1/%{name}-ssl.1*
  106. %{_mandir}/man5/rsyncd.conf.5*
  107. %files daemon
  108. %if %{with systemd}
  109. %{_unitdir}/rsyncd.socket
  110. %{_unitdir}/rsyncd.service
  111. %{_unitdir}/rsyncd@.service
  112. %config(noreplace) %{_sysconfdir}/sysconfig/rsyncd
  113. %else
  114. %config(noreplace) /etc/xinetd.d/rsync
  115. %endif
  116. %changelog
  117. * Sun Oct 08 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.2.7-1
  118. - updated to 3.2.7.
  119. * Fri Sep 09 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.2.5-1
  120. - updated to 3.2.5.
  121. * Wed Aug 10 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.2.5~pre2-1
  122. - updated to 3.2.5pre2.
  123. - dropped Patch0.
  124. * Mon Oct 04 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.2.3-2
  125. - rebuilt with openssl-3.0.0.
  126. * Fri Sep 04 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.2.3-1
  127. - updated to 3.2.3.
  128. - re-impoerted all patches from rawhide.
  129. - added systemd support (disabled as default).
  130. * Wed Oct 16 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.1.3-1
  131. - updated to 3.1.2.
  132. - imported Patch1-3 from rawhide.
  133. - dropped Patch100-130.
  134. * Sat Jan 13 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.1.2-1
  135. - update to 3.1.2
  136. - add patch100-130 to fix security issue from debian
  137. - use make reconfigure in build section
  138. * Sat Nov 14 2015 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.1.1-2
  139. - added Patch100 to fix CVE-2014-9512
  140. * Fri Nov 07 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.1.1-1
  141. - new upstream release
  142. - deleted Patch100 to merge source
  143. * Wed Jun 11 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 3.1.0-2
  144. - add Patch100 to fix CVE-2014-2855
  145. * Sat Nov 23 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.1.0-1
  146. - new upstream release
  147. * Fri Jan 20 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.0.9-1
  148. - new upstream release
  149. * Sun May 22 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.0.8-1
  150. - new upstream release with security fixes
  151. - drop patch100 (is included in new release)
  152. * Sat Apr 2 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.0.7-2
  153. - add Patch100 for fix CVE-2011-1097 (filelist)
  154. - change specfile name (-vl)
  155. * Sat Jan 2 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.0.7-1
  156. - new upstream release
  157. * Thu Oct 8 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.0.6-1
  158. - new upstream release
  159. - changed License tag
  160. - added Patch0 from Debian
  161. - added BuildRequires: libattr-devel popt-devel
  162. - added patch -p1 -i patches/copy-devices.diff in %setup
  163. (to enable --copy-devices parameter)
  164. * Sun Sep 27 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.0.4-2
  165. - added BuildRequires: libacl-devel (to enable ACL)
  166. * Tue Sep 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.4-1
  167. - new upstream release
  168. - add rsync-patches (replaces patch1,2)
  169. use xattr.patch and acls.patch for backword compatibility
  170. * Sun Apr 13 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.0.2-1
  171. - new upstream release
  172. - add patch1,2 for backward compatibility from fc
  173. - new versioning policy
  174. * Tue Aug 21 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.9-0vl2
  175. - add Patch10 for CVE-2007-4091
  176. (rsync "f_name()" Function Directory Name Handling Off-By-One Vulnerability)
  177. * Wed Jan 10 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.9-0vl1
  178. - new upstream release
  179. - add Vendor/Distribution tag
  180. * Mon Mar 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-0vl1
  181. - new upstream release
  182. * Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.3-0vl1
  183. - new upstream release
  184. - drop obsolete patch1 which is merged in upstream.
  185. * Tue Aug 17 2004 SATO Masakiyo <info@pocomoco.net> 2.6.2-0vl2
  186. - added patch1 for a path-sanitizing bug
  187. * Wed May 5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.2-0vl1
  188. - new upstream release
  189. * Fri Apr 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-0vl1
  190. - new upstream release
  191. * Fri Dec 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.7-0vl1
  192. - new upstream release
  193. - security fix
  194. * Mon Apr 21 2003 IWAI Masaharu <iwai@alib.jp> 2.5.6-0vl1
  195. - new upstream release
  196. * Sun Sep 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.5-0vl1
  197. - new upstream release
  198. * Wed Mar 13 2002 Toru Sagami <sagami@vinelinux.org> 2.5.4-0vl1
  199. - updated to 2.5.4, which contains additional fix for zlib double-free bug.
  200. * Tue Mar 12 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 2.5.3-0vl1
  201. - upstream release
  202. * Sat Jan 26 2002 Toru Sagami <sagami@vinelinux.org> 2.5.2-0vl1
  203. - SECURITY FIXES:
  204. * Signedness security patch from Sebastian Krahmer
  205. - added more docs
  206. * Sun Jan 06 2002 Toru Sagami <sagami@vinelinux.org>
  207. - 2.5.1-0vl1
  208. * Sun Dec 2 2001 Yoichi Imai <yoichi@silver-forest.com>
  209. - 2.5.0-0vl1
  210. - update to 2.5.0
  211. - edit maxdel.patch for 2.5.0
  212. * Tue Jan 09 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  213. - 2.4.6-2vl1
  214. - based on 2.4.6-2 from Rawhide
  215. - added Japanese summary and description
  216. * Sat Sep 30 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  217. - add xinetd configuration
  218. * Tue Sep 26 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  219. - 2.4.6
  220. * Mon Jul 31 2000 Bill Nottingham <notting@redhat.com>
  221. - update to 2.4.4 - fixes yet another problem with rsh transport
  222. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  223. - automatic rebuild
  224. * Sat Jun 10 2000 Bill Nottingham <notting@redhat.com>
  225. - rebuild in new build env.
  226. * Mon Apr 10 2000 Bill Nottingham <notting@redhat.com>
  227. - update to 2.4.3
  228. * Tue Apr 4 2000 Bill Nottingham <notting@redhat.com>
  229. - update to 2.4.2
  230. * Tue Mar 7 2000 Bill Nottingham <notting@redhat.com>
  231. - fix maxdelete behavior so it isn't sent to older servers.
  232. * Mon Jan 31 2000 Jeff Johnson <jbj@redhat.com>
  233. - update to 2.4.1.
  234. * Fri Dec 17 1999 Bill Nottingham <notting@redhat.com>
  235. - update to 2.3.2
  236. * Sat Jun 12 1999 Jeff Johnson <jbj@redhat.com>
  237. - add "max. delete" patch to limit damage when server is hosed.
  238. * Wed Apr 07 1999 Bill Nottingham <notting@redhat.com>
  239. - update to 2.3.1.
  240. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  241. - auto rebuild in the new build environment (release 2)
  242. * Tue Mar 16 1999 Jeff Johnson <jbj@redhat.com>
  243. - update to 2.3.0.
  244. * Sat Mar 13 1999 Jeff Johnson <jbj@redhat.com>
  245. - update to 2.3.0 beta.
  246. * Fri Dec 18 1998 Bill Nottingham <notting@redhat.com>
  247. - update to 2.2.1
  248. * Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
  249. - updated to 2.1.1
  250. * Mon Aug 17 1998 Erik Troan <ewt@redhat.com>
  251. - updated to 2.1.0
  252. * Thu Aug 06 1998 Erik Troan <ewt@redhat.com>
  253. - buildrooted and attr-rophied
  254. - removed tech-report.ps; the .tex should be good enough
  255. * Mon Aug 25 1997 John A. Martin <jam@jamux.com>
  256. - Built 1.6.3-2 after finding no rsync-1.6.3-1.src.rpm although there
  257. was an ftp://ftp.redhat.com/pub/contrib/alpha/rsync-1.6.3-1.alpha.rpm
  258. showing no packager nor signature but giving
  259. "Source RPM: rsync-1.6.3-1.src.rpm".
  260. - Changes from 1.6.2-1 packaging: added '$RPM_OPT_FLAGS' to make, strip
  261. to '%build', removed '%prefix'.
  262. * Thu Apr 10 1997 Michael De La Rue <miked@ed.ac.uk>
  263. - rsync-1.6.2-1 packaged. (This entry by jam to credit Michael for the
  264. previous package(s).)