bash-vl.spec 16 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541
  1. %define bashversion 4.3
  2. %define patchlevel 11
  3. Summary: The GNU Bourne Again shell (bash).
  4. Summary(ja): GNU Bourne Again シェル (bash).
  5. Name: bash
  6. Version: %{bashversion}.%{patchlevel}
  7. Release: 1%{?_dist_release}
  8. Group: System Environment/Shells
  9. License: GPLv3+
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. Packager: daisuke
  13. Source0: ftp://ftp.gnu.org/pub/gnu/bash/bash-%{bashversion}.tar.gz
  14. Source10: bashrc-vine
  15. # Official upstream patches
  16. Patch1: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.3-patches/bash43-001
  17. Patch2: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.3-patches/bash43-002
  18. Patch3: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.3-patches/bash43-003
  19. Patch4: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.3-patches/bash43-004
  20. Patch5: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.3-patches/bash43-005
  21. Patch6: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.3-patches/bash43-006
  22. Patch7: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.3-patches/bash43-007
  23. Patch8: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.3-patches/bash43-008
  24. Patch9: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.3-patches/bash43-009
  25. Patch10: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.3-patches/bash43-010
  26. Patch11: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.3-patches/bash43-011
  27. # Other patches
  28. Patch101: bash-2.02-security.patch
  29. Patch102: bash-2.03-paths.patch
  30. Patch103: bash-2.03-profile.patch
  31. Patch104: bash-2.05a-interpreter.patch
  32. Patch105: bash-2.05b-debuginfo.patch
  33. Patch106: bash-2.05b-manso.patch
  34. Patch107: bash-2.05b-pgrp_sync.patch
  35. Patch108: bash-2.05b-readline-oom.patch
  36. Patch109: bash-2.05b-xcc.patch
  37. Patch110: bash-3.2-audit.patch
  38. Patch111: bash-3.2-ssh_source_bash.patch
  39. Patch112: bash-bashbug.patch
  40. Patch113: bash-infotags.patch
  41. Patch114: bash-requires.patch
  42. Patch115: bash-setlocale.patch
  43. Patch116: bash-tty-tests.patch
  44. # 484809, check if interp section is NOBITS
  45. Patch117: bash-4.0-nobits.patch
  46. # Do the same CFLAGS in generated Makefile in examples
  47. Patch118: bash-4.1-examples.patch
  48. # Builtins like echo and printf won't report errors
  49. # when output does not succeed due to EPIPE
  50. Patch119: bash-4.1-broken_pipe.patch
  51. # Enable system-wide .bash_logout for login shells
  52. Patch120: bash-4.2-rc2-logout.patch
  53. # Static analyzis shows some issues in bash-2.05a-interpreter.patch
  54. Patch121: bash-4.2-coverity.patch
  55. # Don't call malloc in signal handler
  56. Patch122: bash-4.1-defer-sigchld-trap.patch
  57. # 799958, updated info about trap
  58. Patch123: bash-4.2-manpage_trap.patch
  59. # https://www.securecoding.cert.org/confluence/display/seccode/INT32-C.+Ensure+that+operations+on+signed+integers+do+not+result+in+overflow
  60. Patch125: bash-4.2-size_type.patch
  61. Buildroot: %{_tmppath}/%{name}-%{version}-root
  62. BuildRequires: texinfo, bison, ncurses-devel, autoconf, gettext
  63. Obsoletes: bash <= 1.14.7
  64. Obsoletes: bash2
  65. %description
  66. Bash is a GNU project sh-compatible shell or command language
  67. interpreter. Bash (Bourne Again shell) incorporates useful features
  68. from the Korn shell (ksh) and the C shell (csh). Most sh scripts
  69. can be run by bash without modification.
  70. Bash offers several improvements over sh, including command line
  71. editing, unlimited size command history, job control, shell
  72. functions and aliases, indexed arrays of unlimited size and
  73. integer arithmetic in any base from two to 64. Bash is ultimately
  74. intended to conform to the IEEE POSIX P1003.2/ISO 9945.2 Shell and
  75. Tools standard.
  76. %package doc
  77. Summary: Documentation for the GNU Bourne Again shell (bash).
  78. Summary: GNU Bourne Again シェル向けドキュメント
  79. Group: Applications/Documentation
  80. Requires: %{name} = %{version}-%{release}
  81. Obsoletes: bash2-doc
  82. %description doc
  83. This is a separate documentation package for the GNU Bourne
  84. Again shell.
  85. %prep
  86. %setup -q -n %{name}-%{bashversion}
  87. # Official upstream patches
  88. %patch1 -p0 -b .001
  89. %patch2 -p0 -b .002
  90. %patch3 -p0 -b .003
  91. %patch4 -p0 -b .004
  92. %patch5 -p0 -b .005
  93. %patch6 -p0 -b .006
  94. %patch7 -p0 -b .007
  95. %patch8 -p0 -b .008
  96. %patch9 -p0 -b .009
  97. %patch10 -p0 -b .010
  98. %patch11 -p0 -b .011
  99. # Other patches
  100. %patch101 -p1 -b .security
  101. %patch102 -p1 -b .paths
  102. %patch103 -p1 -b .profile
  103. %patch104 -p1 -b .interpreter
  104. %patch105 -p1 -b .debuginfo
  105. %patch106 -p1 -b .manso
  106. %patch107 -p1 -b .pgrp_sync
  107. %patch108 -p1 -b .readline_oom
  108. %patch109 -p1 -b .xcc
  109. %patch110 -p1 -b .audit
  110. %patch111 -p1 -b .ssh_source_bash
  111. %patch112 -p1 -b .bashbug
  112. %patch113 -p1 -b .infotags
  113. %patch114 -p1 -b .requires
  114. %patch115 -p1 -b .setlocale
  115. %patch116 -p1 -b .tty_tests
  116. %patch117 -p1 -b .nobits
  117. %patch118 -p1 -b .examples
  118. %patch119 -p1 -b .broken_pipe
  119. %patch120 -p1 -b .logout
  120. %patch121 -p1 -b .coverity
  121. %patch122 -p1 -b .defer_sigchld_trap
  122. %patch123 -p1
  123. %patch125 -p1 -b .size_type
  124. echo %{version} > _distribution
  125. echo %{release} |sed 's/vl.*//' > _patchlevel
  126. %build
  127. %configure --with-bash-malloc=no
  128. make CPPFLAGS="-D_GNU_SOURCE -DRECYCLES_PIDS `getconf LFS_CFLAGS`"
  129. %install
  130. rm -rf %{buildroot}
  131. # Fix bug #83776
  132. perl -pi -e 's,bashref\.info,bash.info,' doc/bashref.info
  133. make DESTDIR=$RPM_BUILD_ROOT install
  134. pushd $RPM_BUILD_ROOT
  135. mkdir ./bin
  136. mv ./usr/bin/bash ./bin/bash
  137. ln -s bash ./bin/sh
  138. rm -f .%{_infodir}/dir
  139. popd
  140. ln -s bash.1 %{buildroot}%{_mandir}/man1/sh.1
  141. # make manpages for bash builtins as per suggestion in DOC/README
  142. pushd doc
  143. sed -e '
  144. /^\.SH NAME/, /\\- bash built-in commands, see \\fBbash\\fR(1)$/{
  145. /^\.SH NAME/d
  146. s/^bash, //
  147. s/\\- bash built-in commands, see \\fBbash\\fR(1)$//
  148. s/,//g
  149. b
  150. }
  151. d
  152. ' builtins.1 > man.pages
  153. for i in echo pwd test kill; do
  154. perl -pi -e "s,$i,,g" man.pages
  155. perl -pi -e "s, , ,g" man.pages
  156. done
  157. install -c -m 644 builtins.1 %{buildroot}%{_mandir}/man1/builtins.1
  158. for i in `cat man.pages` ; do
  159. echo .so man1/builtins.1 > %{buildroot}%{_mandir}/man1/$i.1
  160. chmod 0644 ${RPM_BUILD_ROOT}%{_mandir}/man1/$i.1
  161. done
  162. mkdir -p $RPM_BUILD_ROOT/etc/profile.d/
  163. install -m 644 %{SOURCE10} $RPM_BUILD_ROOT/etc/bashrc
  164. # Not for printf, false and true (conflict with coreutils)
  165. rm -f $RPM_BUILD_ROOT%{_mandir}/man1/printf.1
  166. rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/true.1
  167. rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/false.1
  168. popd
  169. %find_lang %{name}
  170. rm -rf $RPM_BUILD_ROOT/%{_docdir}/bash
  171. %clean
  172. rm -rf %{buildroot}
  173. # ***** bash doesn't use install-info. It's always listed in %{_infodir}/dir
  174. # to prevent prereq loops
  175. # post is in lua so that we can run it without any external deps. Helps
  176. # for bootstrapping a new install.
  177. # Jesse Keating 2009-01-29 (code from Ignacio Vazquez-Abrams)
  178. %post -p <lua>
  179. bashfound = false;
  180. shfound = false;
  181. f = io.open("/etc/shells", "r");
  182. if f == nil
  183. then
  184. f = io.open("/etc/shells", "w");
  185. else
  186. repeat
  187. t = f:read();
  188. if t == "/bin/bash"
  189. then
  190. bashfound = true;
  191. end
  192. if t == "/bin/sh"
  193. then
  194. shfound = true;
  195. end
  196. until t == nil;
  197. end
  198. f:close()
  199. f = io.open("/etc/shells", "a");
  200. if not bashfound
  201. then
  202. f:write("/bin/bash\n")
  203. end
  204. if not shfound
  205. then
  206. f:write("/bin/sh\n")
  207. end
  208. f:close()
  209. %files -f %{name}.lang
  210. %defattr(-,root,root)
  211. %doc CHANGES COPYING
  212. %doc examples
  213. %config(noreplace) /etc/bashrc
  214. /bin/bash
  215. /bin/sh
  216. %{_infodir}/bash.info*
  217. %{_mandir}/*/*
  218. %{_mandir}/*/..1*
  219. %{_bindir}/bashbug
  220. %files doc
  221. %defattr(-,root,root)
  222. %doc COMPAT NEWS NOTES POSIX RBASH
  223. %doc examples/functions/ examples/misc/
  224. %doc examples/scripts.noah/ examples/scripts.v2/ examples/scripts/
  225. %doc examples/startup-files/ examples/complete/ examples/loadables/
  226. %doc doc/*.ps doc/*.0 doc/*.html doc/article.txt
  227. %doc doc/FAQ doc/INTRO doc/article.ms doc/README
  228. %changelog
  229. * Wed May 14 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3.11-1
  230. - update to 4.3 patch level 11
  231. * Mon Mar 18 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.45-1
  232. - update to 4.2 patch level 45
  233. - import some patch from fedora package (122-127)
  234. - patch122: Don't call malloc in signal handler
  235. - patch123: #799958, updated info about trap
  236. - patch124: #695656, block the signal and unblock it after the
  237. new handler is installed
  238. - patch125: Use unsigned type for size
  239. https://www.securecoding.cert.org/confluence/display/seccode/INT32-C.+Ensure+that+operations+on+signed+integers+do+not+result+in+overflow
  240. - patch126: #903833, Fix missing close(), fixes fd leaks
  241. * Sat Oct 6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.2.37-2
  242. - remove postun lua script because bash will be never uninstalled
  243. * Mon Sep 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.37-1
  244. - update to 4.2 patch level 37
  245. * Fri Feb 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.20-1
  246. - update to 4.2 patch level 20
  247. * Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.8-1
  248. - update to 4.2 patch level 8
  249. - use lua script in post/postun
  250. - update patches from fedora
  251. * Fri Sep 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1-1
  252. - update to 4.1 patch level 7
  253. * Fri Mar 5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-9
  254. - check if /bin/grep exists on %%post script
  255. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-8
  256. - rebuilt with gcc-4.4.3-3 on ppc
  257. * Tue Feb 2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-7
  258. - rebuilt with new toolchain
  259. * Fri Dec 4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-6
  260. - revert changes on 3.2-5 (avoid a nasty dependency loop on bootstrapping)
  261. * Fri Dec 4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-5
  262. - add Requires(post): grep
  263. * Sat Oct 24 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-4
  264. - remove obsolete /bin/bash2 entry from /etc/shells
  265. * Mon Apr 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-3
  266. - add Requires(post): ncurses (should be added by find-requires..)
  267. * Sun Mar 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-2
  268. - add upstream patch (from 040 to 048)
  269. - build against ncurses-devel (libtinfo)
  270. - spec in utf-8
  271. * Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2-1vl5
  272. - added upstream patch (from 026 to 039)
  273. - added Japanese summary
  274. - applied new versioning policy
  275. * Fri Jan 18 2008 Shu KONNO <owa@bg.wakwak.com> 3.2-0vl2
  276. - rebuilt with libtermcap-devel
  277. * Fri Oct 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-0vl1
  278. - new upstream release
  279. - add upstream patch (from 001 to 025)
  280. - remove Provides: bash2
  281. * Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.05b-0vl4
  282. - rebuilt with new toolchain
  283. * Mon Sep 11 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.05b-0vl3
  284. - change doc Group to Applications/Documentation. <BTS:VineLinux:163>
  285. - quote CPPFLAGS to avoid configure error. <BTS:VineLinux:173>
  286. * Mon Jun 28 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.05b-0vl2
  287. - Don't read /etc/profile.d/*.sh in /etc/bashrc; done in /etc/profile
  288. * Wed Mar 10 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.05b-0vl1
  289. - update to 2.05b
  290. - rebuild with new toolchains
  291. - add make check
  292. - add %postun script based on Fedora development
  293. - README file moved doc package
  294. - update Patch5 and Patch8 from Fedora development
  295. - change Patch6
  296. - remove Patch2 and Patch100 (bash-2.05b supports multibyte string)
  297. - add Patch11--39 from Fedora development 2.05b-36
  298. * Tim Waugh <twaugh@redhat.com>
  299. - Fix parameter expansion in multibyte locales (bug #112657).
  300. - Speed up UTF-8 command-line redrawing in the common case (bug #102353,
  301. bug #110777).
  302. - Apply upstream patches (bug #109269 among others).
  303. - Fix bash.info (bug #83776).
  304. - Add bash205b-007 patch to fix bug #106876.
  305. - Avoid crashing on multibyte input when locale is set incorrectly
  306. (bug #74266).
  307. - LFS support (bug #103627).
  308. - Fix completion display when multibyte or control characters are to be
  309. shown (bug #90201).
  310. - Fix a warning message (bug #79629).
  311. - Don't build with AFS support (bug #86514).
  312. - Don't explicitly strip binaries (bug #85995).
  313. - Really fix bug #83331 for good.
  314. - Fix builtins.1.
  315. - Actually apply the patch (bug #83331).
  316. - Fix history/UTF-8 bug (bug #83331).
  317. - More tab-completion fixing (bug #72512).
  318. - Force pgrp synchronization (bug #81653).
  319. - Prevent prompt overwriting output (bug #74383).
  320. - Fix '-rbash' (bug #78455).
  321. - Add readline-init patch (bug #74925).
  322. - Add the (4) patches from ftp.gnu.org (bug #75888, bug #72512).
  323. - Ship '.' man page, which doesn't get picked up by glob.
  324. - Locale shell variables fix (bug #74701).
  325. * Elliot Lee <sopwith@redhat.com>
  326. - (patch26) Don't call 'size' in makefile. Pointless, and interferes with
  327. cross compiles.
  328. * Wed Oct 9 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.05-0vl1
  329. - update to 2.05
  330. - add README.jpatch to %doc
  331. - remove patch4 (bash2): revert command name in man pages to "bash"
  332. - fix perl command to remove man pages conflict with sh-utils
  333. - remove section of config.h.in from patch0 to prevent remake of configure
  334. - change patch9: define in config-top.h to avoid conflict with patch100
  335. - remove patches 7, 10 & 101
  336. * Mon Apr 8 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.04-1vl14
  337. - made a link for man sh
  338. * Thu Nov 15 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.04-1vl13
  339. - added missing %%post and %%triggerpostun section
  340. * Sun Jul 15 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  341. - 2.04-1vl12
  342. - now bash2 is finally bash
  343. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.04-1vl11
  344. - build for Playstation2
  345. * Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  346. - 2.04-1vl10
  347. - Provides: bash = %%{version}
  348. * Thu Jun 07 2001 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl9
  349. - added Provides: bash
  350. * Thu Jun 07 2001 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl8
  351. - Obsoletes: bash
  352. - changed Copyright to License
  353. * Fri Dec 29 2000 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
  354. - 2.04-1vl7
  355. - deleted: /etc/profile.d/alias.sh (which we have in /etc/skel/.bashrc)
  356. - corrected: bashrc-vine -> bashrc
  357. * Sat Dec 16 2000 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl6
  358. - combined bash-1.x and bash-2.x packages
  359. - added some patches from bash-2.04-13mdk
  360. * Sun Dec 10 2000 Jun Nishii <jun@vinelinux.org> 2.04-1vl5
  361. - fix spec macros
  362. - added tests
  363. * Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl5
  364. - build with gcc-2.95.3
  365. - partially used rpmmacros
  366. * Fri Sep 8 2000 Jun Nishii <jun@vinelinux.org>
  367. - minor bug fix in spec file
  368. * Sun Aug 27 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  369. - 2.04-1vl3
  370. - modified %install and %files section to handle compressed man page(s)
  371. * Thu Mar 23 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  372. - added pcomplete patch to fix complete if the candidate list is NULL.
  373. * Wed Mar 22 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  374. - updated to 2.04
  375. * Tue Sep 14 1999 Dale Lovelace <dale@redhat.com>
  376. - Remove annoying ^H's from documentation
  377. * Fri Jul 16 1999 Ken Estes <kestes@staff.mail.com>
  378. - patch to detect what executables are required by a script.
  379. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  380. - auto rebuild in the new build environment (release 4)
  381. * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
  382. - strip binaries.
  383. - include bash-doc correctly.
  384. * Thu Mar 18 1999 Preston Brown <pbrown@redhat.com>
  385. - fixed post/postun /etc/shells work.
  386. * Thu Mar 18 1999 Cristian Gafton <gafton@redhat.com>
  387. - updated again text in the spec file
  388. * Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
  389. - updated text in spec file.
  390. - update to 2.03.
  391. * Fri Feb 12 1999 Cristian Gafton <gafton@redhat.com>
  392. - build it as bash2 instead of bash
  393. * Tue Feb 9 1999 Bill Nottingham <notting@redhat.com>
  394. - set 'NON_INTERACTIVE_LOGIN_SHELLS' so profile gets read
  395. * Thu Jan 14 1999 Jeff Johnson <jbj@redhat.com>
  396. - rename man pages in bash-doc to avoid packaging conflicts (#606).
  397. * Wed Dec 02 1998 Cristian Gafton <gafton@redhat.com>
  398. - patch for the arm
  399. - use $RPM_ARCH-redhat-linux as the build target
  400. * Tue Oct 6 1998 Bill Nottingham <notting@redhat.com>
  401. - rewrite %pre, axe %postun (to avoid prereq loops)
  402. * Wed Aug 19 1998 Jeff Johnson <jbj@redhat.com>
  403. - resurrect for RH 6.0.
  404. * Sun Jul 26 1998 Jeff Johnson <jbj@redhat.com>
  405. - update to 2.02.1
  406. * Thu Jun 11 1998 Jeff Johnson <jbj@redhat.com>
  407. - Package for 5.2.
  408. * Mon Apr 20 1998 Ian Macdonald <ianmacd@xs4all.nl>
  409. - added POSIX.NOTES doc file
  410. - some extraneous doc files removed
  411. - minor .spec file changes
  412. * Sun Apr 19 1998 Ian Macdonald <ianmacd@xs4all.nl>
  413. - upgraded to version 2.02
  414. - Alpha, MIPS & Sparc patches removed due to lack of test platforms
  415. - glibc & signal patches no longer required
  416. - added documentation subpackage (doc)
  417. * Fri Nov 07 1997 Donnie Barnes <djb@redhat.com>
  418. - added signal handling patch from Dean Gaudet <dgaudet@arctic.org> that
  419. is based on a change made in bash 2.0. Should fix some early exit
  420. problems with suspends and fg.
  421. * Mon Oct 20 1997 Donnie Barnes <djb@redhat.com>
  422. - added %clean
  423. * Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
  424. - added comment explaining why install-info isn't used
  425. - added mips patch
  426. * Fri Oct 17 1997 Donnie Barnes <djb@redhat.com>
  427. - added BuildRoot
  428. * Tue Jun 03 1997 Erik Troan <ewt@redhat.com>
  429. - built against glibc