perl-Net-Daemon-vl.spec 3.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110
  1. Name: perl-Net-Daemon
  2. Version: 0.44
  3. Release: 11%{?dist}
  4. Summary: Perl extension for portable daemons
  5. Group: Development/Libraries
  6. License: GPL+ or Artistic
  7. URL: http://search.cpan.org/dist/Net-Daemon/
  8. Source0: http://search.cpan.org/CPAN/authors/id/M/MN/MNOONING/Net-Daemon/Net-Daemon-0.43.tar.gz
  9. #upstream report http://rt.cpan.org/Ticket/Display.html?id=39759
  10. Patch0: Net-Daemon-only-ithreads.patch
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  12. BuildArch: noarch
  13. # Correct for lots of packages, other common choices include eg. Module::Build
  14. BuildRequires: perl(ExtUtils::MakeMaker)
  15. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  16. %description
  17. Net::Daemon is an abstract base class for implementing portable server
  18. applications in a very simple way. The module is designed for Perl 5.006 and
  19. ithreads (and higher), but can work with fork() and Perl 5.004.
  20. The Net::Daemon class offers methods for the most common tasks a daemon
  21. needs: Starting up, logging, accepting clients, authorization, restricting
  22. its own environment for security and doing the true work. You only have to
  23. override those methods that aren't appropriate for you, but typically
  24. inheriting will safe you a lot of work anyways.
  25. %prep
  26. %setup -q -n Net-Daemon
  27. %patch0 -p1
  28. # generate our other two licenses...
  29. perldoc perlgpl > LICENSE.GPL
  30. perldoc perlartistic > LICENSE.Artistic
  31. %build
  32. %{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"
  33. make %{?_smp_mflags}
  34. %install
  35. rm -rf $RPM_BUILD_ROOT
  36. make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
  37. find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
  38. # Remove the next line from noarch packages (unneeded)
  39. find $RPM_BUILD_ROOT -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
  40. find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null ';'
  41. chmod -R u+w $RPM_BUILD_ROOT/*
  42. %check
  43. %{?!_with_network_tests:
  44. # Disable tests which will fail under mock
  45. rm t/config*
  46. rm t/fork*
  47. rm t/ithread*
  48. rm t/loop*
  49. rm t/single.t
  50. rm t/unix.t
  51. }
  52. make test
  53. %clean
  54. rm -rf $RPM_BUILD_ROOT
  55. %files
  56. %defattr(-,root,root,-)
  57. %doc ChangeLog README LICENSE.*
  58. %{perl_vendorlib}/*
  59. %{_mandir}/man3/*.3*
  60. %changelog
  61. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.44-11
  62. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  63. * Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.44-10
  64. - 661697 rebuild for fixing problems with vendorach/lib
  65. * Tue May 04 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.44-9
  66. - Mass rebuild with perl-5.12.0
  67. * Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 0.44-8
  68. - rebuild against perl 5.10.1
  69. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.44-7
  70. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  71. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.44-6
  72. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  73. * Mon Oct 13 2008 Petr Lautrbach <plautrba@redhat.com> 0.44-5
  74. - "--with network_tests" - don't remove network tests
  75. * Mon Oct 6 2008 Petr Lautrbach <plautrba@redhat.com> 0.44-4
  76. - Description and License fixed
  77. - Patch without backup
  78. * Mon Oct 6 2008 Petr Lautrbach <lautrba@redhat.com> 0.44-3
  79. - Requires: fixed
  80. * Fri Oct 3 2008 Petr Lautrbach <lautrba@redhat.com> 0.44-2
  81. - only-ithreads patch added
  82. - disabled tests which fail under mock
  83. * Fri Sep 26 2008 Petr Lautrbach <lautrba@redhat.com>
  84. - initial rpm release