libjpeg-turbo-vl.spec 8.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: A MMX/SSE2/SIMD accelerated library for manipulating JPEG image files
  3. Summary(ja): MMX/SSE2/SIMD でアクセラレーションされた libjpeg ライブラリ
  4. Name: libjpeg-turbo
  5. Version: 2.0.4
  6. Release: 2%{?_dist_release}
  7. Group: System Environment/Libraries
  8. License: IJG
  9. URL: http://sourceforge.net/projects/libjpeg-turbo
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
  13. Patch0: libjpeg-turbo-cmake.patch
  14. Patch1: libjpeg-turbo-CET.patch
  15. Patch1000: CVE-2020-13790.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  17. BuildRequires: cmake
  18. %ifarch %{ix86} x86_64
  19. BuildRequires: nasm
  20. %endif
  21. Obsoletes: libjpeg < 6b-50vl6
  22. Provides: libjpeg = 6b-50vl6
  23. %description
  24. The libjpeg-turbo package contains a library of functions for manipulating
  25. JPEG images
  26. %package devel
  27. Summary: Headers for the libjpeg-turbo library
  28. Summary(ja): libjpeg-turbo ライブラリのヘッダファイル
  29. Group: Development/Libraries
  30. Obsoletes: libjpeg-devel < 6b-50vl6
  31. Obsoletes: libjpeg-static < 6b-50vl6
  32. Provides: libjpeg-devel = 6b-50vl6
  33. Requires: libjpeg-turbo = %{version}-%{release}
  34. %description devel
  35. This package contains header files necessary for developing programs which
  36. will manipulate JPEG files using the libjpeg-turbo library
  37. %package utils
  38. Summary: Utilities for manipulating JPEG images
  39. Summary(ja): JPEG イメージを操作するためのユーティリティ
  40. Group: Applications/Multimedia
  41. Requires: libjpeg-turbo = %{version}-%{release}
  42. %description utils
  43. The libjpeg-turbo-utils package contains simple client programs for
  44. accessing the libjpeg functions. It contains cjpeg, djpeg, jpegtran,
  45. rdjpgcom and wrjpgcom. Cjpeg compresses an image file into JPEG format.
  46. Djpeg decompresses a JPEG file into a regular image file. Jpegtran
  47. can perform various useful transformations on JPEG files. Rdjpgcom
  48. displays any text comments included in a JPEG file. Wrjpgcom inserts
  49. text comments into a JPEG file.
  50. ## to build compat32 for x86_64 architecture support
  51. %package -n compat32-%{name}
  52. Summary: A MMX/SSE2 accelerated library for manipulating JPEG image files
  53. Summary(ja): MMX/SSE2 でアクセラレーションされた libjpeg ライブラリ
  54. Group: System Environment/Libraries
  55. Obsoletes: compat32-libjpeg < 6b-50vl6
  56. Provides: compat32-libjpeg = 6b-50vl6
  57. %description -n compat32-%{name}
  58. The libjpeg-turbo package contains a library of functions for manipulating
  59. JPEG images
  60. %package -n compat32-%{name}-devel
  61. Summary: Headers for the libjpeg-turbo library
  62. Summary(ja): libjpeg-turbo ライブラリのヘッダファイル
  63. Group: Development/Libraries
  64. Obsoletes: compat32-libjpeg-devel < 6b-50vl6
  65. Provides: compat32-libjpeg-devel = 6b-50vl6
  66. Requires: libjpeg-turbo = %{version}-%{release}
  67. %description -n compat32-%{name}-devel
  68. This package contains header files necessary for developing programs which
  69. will manipulate JPEG files using the libjpeg-turbo library
  70. %prep
  71. %setup -q
  72. %patch0 -p1
  73. %patch1 -p1
  74. %patch1000 -p1
  75. %build
  76. %ifarch %{ix86} x86_64
  77. export LDFLAGS="$RPM_LD_FLAGS -Wl,-z,ibt -Wl,-z,shstk"
  78. %endif
  79. mkdir jpeg6
  80. pushd jpeg6
  81. %{cmake} \
  82. -DCMAKE_SKIP_RPATH:BOOL=YES \
  83. -DCMAKE_SKIP_INSTALL_RPATH:BOOL=YES \
  84. -DENABLE_STATIC:BOOL=NO \
  85. ..
  86. make %{?_smp_mflags} V=1
  87. popd
  88. mkdir jpeg8
  89. pushd jpeg8
  90. %{cmake} \
  91. -DWITH_JPEG8=YES \
  92. -DCMAKE_SKIP_RPATH:BOOL=YES \
  93. -DCMAKE_SKIP_INSTALL_RPATH:BOOL=YES \
  94. -DENABLE_STATIC:BOOL=NO \
  95. ..
  96. make %{?_smp_mflags} V=1
  97. popd
  98. # Fix perms
  99. chmod -x README.md
  100. %install
  101. rm -rf %{buildroot}
  102. pushd jpeg6
  103. make install DESTDIR=%{buildroot}
  104. popd
  105. rm -rf %{buildroot}%{_mandir}/*
  106. rm -f %{buildroot}%{_includedir}/*
  107. rm -f %{buildroot}%{_bindir}/*
  108. rm -f %{buildroot}%{_libdir}/pkgconfig/*
  109. rm -f %{buildroot}%{_libdir}/lib*.so
  110. pushd jpeg8
  111. make install DESTDIR=%{buildroot}
  112. popd
  113. # Remove unwanted files
  114. rm -f %{buildroot}/%{_libdir}/lib{,turbo}jpeg.la
  115. %check
  116. pushd jpeg6
  117. LD_LIBRARY_PATH=%{buildroot}%{_libdir} make test %{?_smp_mflags}
  118. popd
  119. pushd jpeg8
  120. LD_LIBRARY_PATH=%{buildroot}%{_libdir} make test %{?_smp_mflags}
  121. popd
  122. %clean
  123. rm -rf %{buildroot}
  124. %post -p /sbin/ldconfig
  125. %postun -p /sbin/ldconfig
  126. %post -n compat32-%{name} -p /sbin/ldconfig
  127. %postun -n compat32-%{name} -p /sbin/ldconfig
  128. %files
  129. %defattr(-,root,root,-)
  130. %license LICENSE.md
  131. %doc README.md README.ijg ChangeLog.md
  132. %{_libdir}/libjpeg.so.*
  133. %{_libdir}/libturbojpeg.so.*
  134. %files devel
  135. %defattr(-,root,root,-)
  136. %doc coderules.txt jconfig.txt libjpeg.txt structure.txt example.c
  137. %{_includedir}/jconfig.h
  138. %{_includedir}/jerror.h
  139. %{_includedir}/jmorecfg.h
  140. %{_includedir}/jpegint.h
  141. %{_includedir}/jpeglib.h
  142. %{_includedir}/turbojpeg.h
  143. %{_libdir}/libjpeg.so
  144. %{_libdir}/libturbojpeg.so
  145. %{_libdir}/pkgconfig/libjpeg.pc
  146. %{_libdir}/pkgconfig/libturbojpeg.pc
  147. %files utils
  148. %defattr(-,root,root,-)
  149. %doc usage.txt wizard.txt
  150. %{_bindir}/cjpeg
  151. %{_bindir}/djpeg
  152. %{_bindir}/jpegtran
  153. %{_bindir}/rdjpgcom
  154. %{_bindir}/wrjpgcom
  155. %{_mandir}/man1/cjpeg.1*
  156. %{_mandir}/man1/djpeg.1*
  157. %{_mandir}/man1/jpegtran.1*
  158. %{_mandir}/man1/rdjpgcom.1*
  159. %{_mandir}/man1/wrjpgcom.1*
  160. ## to build compat32 for x86_64 architecture support
  161. %if %{build_compat32}
  162. %files -n compat32-%{name}
  163. %defattr(-,root,root)
  164. %{_libdir}/libjpeg.so.*
  165. %{_libdir}/libturbojpeg.so.*
  166. %files -n compat32-%{name}-devel
  167. %defattr(-,root,root)
  168. %{_libdir}/*.so
  169. %endif
  170. %changelog
  171. * Mon Jun 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.4-2
  172. - added Patch1000 to fix CVE-2020-13790.
  173. * Mon Feb 10 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.4-1
  174. - new upstream release.
  175. * Sat Oct 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.3-2
  176. - built both of libjpeg.so.62 and libjpeg.so.8.
  177. * Sun Sep 08 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.3-1
  178. - new upstream release.
  179. - dropped all patches.
  180. - imported Patch0 and 1 from rawhide.
  181. * Tue Dec 19 2017 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.5.3-1
  182. - update to 1.5.3
  183. - update Patch0,doc
  184. * Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
  185. - update to 1.4.2
  186. - update Patch0
  187. * Sun Sep 07 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.3.1-1
  188. - update to 1.3.1
  189. - ship turbojpeg library and headers
  190. * Sun Jul 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-2
  191. - rebuild with VineSeed environment
  192. * Mon Sep 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-1
  193. - new upstream release
  194. * Tue Mar 29 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
  195. - new upstream release
  196. * Tue Sep 14 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
  197. - initial build for Vine Linux
  198. * Wed Aug 04 2010 Adam Tkac <atkac redhat com> 1.0.0-3
  199. - fix huffman decoder to handle broken JPEGs well (#617469)
  200. * Fri Jul 02 2010 Adam Tkac <atkac redhat com> 1.0.0-2
  201. - add libjpeg-devel%%{_isa} provides to -devel subpkg to satisfy imlib-devel
  202. deps
  203. * Fri Jul 02 2010 Adam Tkac <atkac redhat com> 1.0.0-1
  204. - update to 1.0.0
  205. - patches merged
  206. - libjpeg-turbo-programs.patch
  207. - libjpeg-turbo-nosimd.patch
  208. - add libjpeg provides to the main package to workaround problems with broken
  209. java-1.6.0-openjdk package
  210. * Fri Jul 02 2010 Adam Tkac <atkac redhat com> 0.0.93-13
  211. - remove libjpeg provides from -utils subpkg
  212. * Wed Jun 30 2010 Rex Dieter <rdieter@fedoraproject.org> 0.0.93-12
  213. - move Obsoletes: libjpeg to main pkg
  214. * Wed Jun 30 2010 Rex Dieter <rdieter@fedoraproject.org> 0.0.93-11
  215. - -utils: Requires: %%name ...
  216. * Wed Jun 30 2010 Adam Tkac <atkac redhat com> 0.0.93-10
  217. - add Provides = libjpeg to -utils subpackage
  218. * Mon Jun 28 2010 Adam Tkac <atkac redhat com> 0.0.93-9
  219. - merge review related fixes (#600243)
  220. * Wed Jun 16 2010 Adam Tkac <atkac redhat com> 0.0.93-8
  221. - merge review related fixes (#600243)
  222. * Mon Jun 14 2010 Adam Tkac <atkac redhat com> 0.0.93-7
  223. - obsolete -static libjpeg subpackage (#600243)
  224. * Mon Jun 14 2010 Adam Tkac <atkac redhat com> 0.0.93-6
  225. - improve package description a little (#600243)
  226. - include example.c as %%doc in the -devel subpackage
  227. * Fri Jun 11 2010 Adam Tkac <atkac redhat com> 0.0.93-5
  228. - don't use "fc12" disttag in obsoletes/provides (#600243)
  229. * Thu Jun 10 2010 Adam Tkac <atkac redhat com> 0.0.93-4
  230. - fix compilation on platforms without MMX/SSE (#600243)
  231. * Thu Jun 10 2010 Adam Tkac <atkac redhat com> 0.0.93-3
  232. - package review related fixes (#600243)
  233. * Wed Jun 09 2010 Adam Tkac <atkac redhat com> 0.0.93-2
  234. - package review related fixes (#600243)
  235. * Fri Jun 04 2010 Adam Tkac <atkac redhat com> 0.0.93-1
  236. - initial package