self-build-ffmpeg-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310
  1. %define gpac_postinstall \
  2. gpac_postinstall_sh=$(mktemp) && \
  3. rpm -q --scripts self-build-gpac | \
  4. /bin/sed -e 's|posttrans[[:blank:]].*|\#!/bin/bash|' > ${gpac_postinstall_sh} && \
  5. /bin/bash ${gpac_postinstall_sh} && /bin/rm -f ${gpac_postinstall_sh}
  6. %define pkgname ffmpeg
  7. %define name self-build-%{pkgname}
  8. %define version 0.6.3
  9. #% define svndate 20110326
  10. %define release 2%{?svndate:.%svndate}%{?_dist_release}
  11. %define sourceurl0 http://ffmpeg.org/releases/%{pkgname}-%{version}.tar.bz2
  12. ## available for v0.6 or lower
  13. %define with_libfaad 1
  14. %define with_faac 1
  15. %define with_vaapi 1
  16. %define with_libvpx 1
  17. Summary: Package to automatically build %{pkgname} rpm package
  18. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  19. Name: %{name}
  20. Version: %{version}
  21. Release: %{release}
  22. Source0: %{pkgname}-vl.spec
  23. #Source1: %{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
  24. Source2: %{pkgname}-snapshot.sh
  25. Source90: ffmpeg.1.gz
  26. Source91: ffplay.1.gz
  27. Source92: ffserver.1.gz
  28. Source93: ffprobe.1.gz
  29. License: GPLv2+
  30. Group: Restricted Software
  31. Requires(post): self-build-setup >= 0.9.9
  32. #Requires(post): subversion
  33. # (build)requies of target package.
  34. Requires(post): bzip2-devel
  35. Requires(post): gsm-devel
  36. Requires(post): imlib2-devel
  37. Requires(post): libdc1394-devel
  38. Requires(post): libraw1394-devel
  39. Requires(post): librtmp-devel >= 2.3
  40. Requires(post): libtheora-devel
  41. %{?with_vaapi:Requires(post): libva-devel >= 0.31.0}
  42. Requires(post): libvdpau-devel
  43. Requires(post): libvorbis-devel
  44. %{?with_libvpx:Requires(post): libvpx-devel >= 0.9.1}
  45. %{?_with_opencore_amr:Requires(post): opencore-amr-devel}
  46. ##Requires(post): openjpeg-devel
  47. ##Requires(post): schroedinger-devel
  48. Requires(post): SDL-devel
  49. Requires(post): speex-devel
  50. ##Requires(post): texi2html
  51. Requires(post): zlib-devel
  52. Requires(post): libogg-devel
  53. Requires(post): yasm
  54. Requires(post): self-build-a52dec
  55. Requires(post): self-build-faac
  56. Requires(post): self-build-faad2
  57. Requires(post): self-build-lame
  58. Requires(post): self-build-libdca
  59. Requires(post): self-build-x264 >= 0.0.0-15.20110322
  60. Requires(post): self-build-xvidcore
  61. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  62. BuildArch: noarch
  63. Packager: munepi
  64. %description
  65. FFMpeg is a complete and free Internet live audio and video
  66. broadcasting solution for Linux/Unix. It also includes a
  67. digital VCR. It can encode in real time in many formats
  68. including MPEG1 audio and video, MPEG4, h263, ac3, asf, avi,
  69. real, mjpeg, and flash.
  70. If you install this package, it automaticaly downloads source
  71. code ,compile it, and create rpm packages of %{pkgname}-%{version}.
  72. And the created rpm packages are automatically installed
  73. if installation is executed by apt-get command or synaptic
  74. package manager.
  75. [Note]
  76. This package requires many other packages to compile
  77. target software. So it consume more disk space than usual.
  78. Also installation takes longer time because of compilation.
  79. (This will take a few minutes to quarter or half of an hour,
  80. depends on building environment)
  81. [About self-build package]
  82. For some kind of software, distributing of binary package
  83. may viorate the patent or law. Therefore we chose self-build
  84. packge, create binary package on your machine, for such kind
  85. of softwares instead of distributing binary package.
  86. Please obey the national law when you use the created binary
  87. packages. And if you want to use the softwares using patented
  88. thechnology, it may be required to get a permission, make an
  89. agreement or purchas a license. Please consider it with your
  90. purpose or way of use and take appropriate action.
  91. %description -l ja
  92. FFMpeg は Linux/Unix に対する完全にフリーなインターネットライ
  93. ブオーティオ・ビデオブロードキャスティングソリューションです.
  94. またデジタル VCR を含んでいます.MPEG1 オーディオ・ビデオ,
  95. MPEG4, h263, ac3, asf, avi, real, mjpeg, flash を含む
  96. 多様なフォーマットをリアルタイムにエンコードすることができます.
  97. このパッケージをインストールすると、自動的にソースコードを
  98. ダウンロードしてコンパイルし、%{pkgname}-%{version}
  99. の rpm パッケージを作成します。
  100. また apt-get コマンドや synaptic パッケージマネージャから実行
  101. した場合は、作成された rpm パッケージのインストールも自動的に
  102. 行います。
  103. [注意]
  104. コンパイルに必要な多くの関連パッケージを要求するので通常より
  105. ディスクの領域を多く消費します。
  106. またインストール時にコンパイルを行うため、通常より時間がかか
  107. る場合があります。(環境にもよりますが数分から数十分程度)
  108. [self-build パッケージについて]
  109. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  110. 違反する可能性があるものがあります。その為、このような問題が
  111. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  112. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  113. ジという方法を採っています。
  114. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  115. アのライセンス、および利用する国の各種法令に従ってください。
  116. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  117. センスの購入などが必要となる場合がありますので、利用する目的
  118. や形態に応じて各自で判断し適切な対応を取ってください。
  119. %prep
  120. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  121. %install
  122. %{__rm} -rf ${RPM_BUILD_ROOT}
  123. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  124. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  125. #%{__install} -p -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  126. #%{__install} -m 644 %{SOURCE2} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  127. %{__install} -m 644 %{SOURCE90} %{SOURCE91} %{SOURCE92} %{SOURCE93} \
  128. ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  129. %clean
  130. %{__rm} -rf ${RPM_BUILD_ROOT}
  131. %posttrans
  132. #/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec 77000
  133. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 77000
  134. /usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
  135. %{pkgname}-libs-%{version}-%{release} \
  136. %{pkgname}-devel-%{version}-%{release}
  137. ## Rebuild gpac with ffmpeg-devel
  138. # set locale
  139. case $LANG in
  140. ja*)LOCALE=ja ;;
  141. *) LOCALE=C ;;
  142. esac
  143. Rebuild_gpac_C(){
  144. echo -n " "
  145. echo "Rebuild gpac with ffmpeg-devel"
  146. }
  147. Rebuild_gpac_ja(){
  148. echo -n " "
  149. echo "ffmpeg-devel で gpac をリビルドします。"
  150. }
  151. Rebuild_gpac_$LOCALE
  152. %{gpac_postinstall}
  153. %files
  154. %defattr(-,root,root)
  155. %{_datadir}/%{name}
  156. %changelog
  157. * Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
  158. - added BuildArch: noarch
  159. * Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1
  160. - new upstream release
  161. * Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.2-1
  162. - new upstream release
  163. * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
  164. - required latest x264 build
  165. - added BuildRequires: librtmp-devel >= 2.3
  166. * Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
  167. - new upstream release
  168. * Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
  169. - unpacked source archives
  170. * Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
  171. - fixed some dependencies
  172. - Requires(post): libva-devel
  173. - Requires(post): libvpx-devel >= 0.9.1
  174. * Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
  175. - new upstream release
  176. * Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
  177. - bumped version to pre-0.6
  178. - updated source snapshot 20100410
  179. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
  180. - fixed self-build log size
  181. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
  182. - added ffprobe.1.gz
  183. * Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
  184. - updated source snapshot 20100401
  185. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
  186. - renamed %%{Source0} to ffmpeg-vl.spec
  187. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
  188. - updated source snapshot 20100216
  189. - rebuild with recent x264-devel
  190. - updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
  191. - added BuildRequires: libvdpau-devel
  192. * Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
  193. - dropped BuildArch: noarch
  194. - added ffmpeg.1, ffplay.1, ffserver.1
  195. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
  196. - avoided to execute self-build-rpm.sh on RPM transaction
  197. - moved %%post actions to %%posttrans
  198. * Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
  199. - added BuildArch: noarch
  200. - added ffmpeg-0.5-disable-texi2html.patch
  201. - dropped PreReq: texi2html
  202. * Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
  203. - added %%{gpac_postinstall} in %%post
  204. * Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
  205. - corrected release number
  206. * Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
  207. - new upstream release
  208. - added PreReq:
  209. - speex-devel
  210. - bzip2-devel
  211. * Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
  212. - change release to sync with ffmpeg
  213. * Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
  214. - changed to PreReq: self-build-faad2 >= 2.0 from faad2-devel
  215. * Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
  216. - 20090202 snapshot
  217. * Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
  218. - 20090110 snapshot
  219. - dropped some patches
  220. * Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
  221. - source updated (r15488)
  222. - fixed License: GPLv2+
  223. - added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
  224. - added BuildRequires: yasm (only %%ix86)
  225. - applied ffmpeg-cpu.patch (merged from RPM Fusion)
  226. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
  227. - spec in utf8
  228. * Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
  229. - run pre-allocate-rpm.sh in %%post
  230. - set PreReq: self-build-setup >= 0.8
  231. - change release number
  232. * Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
  233. - add "Source1: %{pkgname}-%{version}.r%{svnrev}.tar.gz",
  234. include Source1 in the binary package.
  235. - drop "Source100: ffmpeg-vine.patch".
  236. - drop "PreReq: subversion".
  237. * Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
  238. - build with new versioning policy
  239. - change to use svn export from svn checkout on post install
  240. - fix ffmpeg-vine.patch for libswscale/swscale.c.rej
  241. * Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
  242. - For all pre-required package that is provied by self-build,
  243. changed to its self-build package
  244. * Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
  245. - initial build for Vine Linux 4.2
  246. - snapshot 2008/01/28 + some Rev.11662 2008/01/29
  247. ### end of file