cpio-vl.spec 9.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292
  1. %ifos linux
  2. %define _bindir /bin
  3. %define _libexecdir /sbin
  4. %endif
  5. Summary: A GNU archiving program.
  6. Summary(ja): GNU アーカイブプログラム
  7. Name: cpio
  8. Version: 2.14
  9. Release: 1%{?_dist_release}
  10. Group: system,accessories
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. License: GPLv3
  14. URL: https://www.gnu.org/software/cpio/cpio.html
  15. Source: https://ftp.gnu.org/gnu/cpio/cpio-%{version}.tar.bz2
  16. Source1: cpio.1
  17. # We use SVR4 portable format as default.
  18. Patch1: cpio-2.9-rh.patch
  19. # fix warn_if_file_changed() and set exit code to 1 when cpio fails to store
  20. # file > 4GB (#183224)
  21. # http://lists.gnu.org/archive/html/bug-cpio/2006-11/msg00000.html
  22. Patch2: cpio-2.13-exitCode.patch
  23. # Support major/minor device numbers over 127 (bz#450109)
  24. # http://lists.gnu.org/archive/html/bug-cpio/2008-07/msg00000.html
  25. Patch3: cpio-2.13-dev_number.patch
  26. # Define default remote shell as /usr/bin/ssh (#452904)
  27. Patch4: cpio-2.9.90-defaultremoteshell.patch
  28. # Fix segfault with nonexisting file with patternnames (#567022)
  29. # http://savannah.gnu.org/bugs/index.php?28954
  30. # We have slightly different solution than upstream.
  31. Patch5: cpio-2.10-patternnamesigsegv.patch
  32. # Fix bad file name splitting while creating ustar archive (#866467)
  33. # (fix backported from tar's source)
  34. Patch7: cpio-2.10-longnames-split.patch
  35. # Cpio does Sum32 checksum, not CRC (downstream)
  36. Patch8: cpio-2.11-crc-fips-nit.patch
  37. # Extract: retain times for symlinks
  38. # downstream patch (#1486364)
  39. # https://www.mail-archive.com/bug-cpio@gnu.org/msg00605.html
  40. Patch11: cpio-2.11-retain-symlink-times.patch
  41. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  42. BuildRequires: texinfo autoconf gettext
  43. Requires(post): /sbin/install-info
  44. Requires(preun): /sbin/install-info
  45. %description
  46. GNU cpio copies files into or out of a cpio or tar archive. Archives
  47. are files which contain a collection of other files plus information
  48. about them, such as their file name, owner, timestamps, and access
  49. permissions. The archive can be another file on the disk, a magnetic
  50. tape, or a pipe. GNU cpio supports the following archive formats: binary,
  51. old ASCII, new ASCII, crc, HPUX binary, HPUX old ASCII, old tar and POSIX.1
  52. tar. By default, cpio creates binary format archives, so that they are
  53. compatible with older cpio programs. When it is extracting files from
  54. archives, cpio automatically recognizes which kind of archive it is reading
  55. and can read archives created on machines with a different byte-order.
  56. Install cpio if you need a program to manage file archives.
  57. %description -l ja
  58. GNU cpio は cpio アーカイブ或いは tar アーカイブにファイルをコピーしたり
  59. 取り出したりするプログラムです.アーカイブというのは,(1つ以上の)ファイルと
  60. その情報(ファイル名,オーナー,更新日付,パーミッション等)がまとめられた
  61. 1つのファイルのことです.アーカイブはディスク上のファイル,磁気テープ,
  62. 或いはパイプであっても構いません.
  63. GNU cpio がサポートしているアーカイブ形式は以下の通りです:
  64. バイナリ, old ASCII, new ASCII, crc, HPUX バイナリ, HPUX old ASCII,
  65. old tar, POSIX.1 tar
  66. デフォルトでは cpio はバイナリ形式のアーカイブを作成します.
  67. これは古いバージョンの cpio との互換性の為です.
  68. アーカイブを展開する場合は,cpio はアーカイブの形式を自動認識しますし,
  69. バイトオーダの異なる機械で作成されたアーカイブを読むことも可能です.
  70. ファイルアーカイブを扱うプログラムが必要なら,cpio をインストールして下さい.
  71. %debug_package
  72. %prep
  73. %autosetup -p1
  74. autoreconf -vif
  75. %build
  76. export CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -pedantic -fno-strict-aliasing -Wall $CFLAGS"
  77. %configure
  78. %make_build
  79. (cd po && make update-gmo)
  80. %install
  81. rm -rf $RPM_BUILD_ROOT
  82. %make_install
  83. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  84. rm -f $RPM_BUILD_ROOT/sbin/rmt
  85. rm -f $RPM_BUILD_ROOT%{_mandir}/man1/*.1*
  86. install -c -p -m 0644 %{SOURCE1} ${RPM_BUILD_ROOT}%{_mandir}/man1
  87. %find_lang %{name}
  88. %check
  89. rm -f ${RPM_BUILD_ROOT}/test/testsuite
  90. make check || {
  91. echo "### TESTSUITE.LOG ###"
  92. cat tests/testsuite.log
  93. exit 1
  94. }
  95. %clean
  96. rm -rf $RPM_BUILD_ROOT
  97. %files -f %{name}.lang
  98. %defattr(-,root,root)
  99. %license COPYING
  100. %doc AUTHORS NEWS README THANKS TODO
  101. %{_bindir}/*
  102. %{_mandir}/man*/*
  103. %{_infodir}/*.info*
  104. %changelog
  105. * Sat May 20 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.14-1
  106. - updated to 2.14.
  107. - dropped install-info scriptlets.
  108. - dropped Patch9, 10 and 12: fixed in upstream.
  109. * Tue Aug 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.13-2
  110. - imported Patch11 and 12 from rawhide.
  111. * Tue Feb 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.13-1
  112. - updated to 2.13.
  113. - dropped all patches.
  114. - imported Patch1-10 from rawhide.
  115. * Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12-1
  116. - update to 2.12
  117. - update Patch2 (cpio-2.12-rh.patch)
  118. - remove Patch7 (cpio-2.11-gets.patch)
  119. - remove Patch100 (cpio-2.11-CVE-2014-9112.patch)
  120. * Sun Jan 4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.11-3
  121. - reflected security fix based on Vine Linux/6.2
  122. * Tue Dec 23 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.11-2
  123. - add patch100 for fix CVE-2014-9112 (cpio's list_file())
  124. this patch is from fc21, thanks.
  125. * Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.11-2
  126. - rebuild with VineSeed environment
  127. - add Patch7 (cpio-2.11-gets.patch)
  128. * Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.11-1
  129. - new upstream release
  130. - rebuilt with current VineSeed
  131. * Fri Jan 1 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10-1
  132. - new upstream release
  133. * Sun Sep 21 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.9.90-1vl5
  134. - new upstream from alpha version
  135. - applied new versioning policy
  136. - spec in UTF-8
  137. - added Patch5 and 6 from FC
  138. * Fri Jul 18 2008 Kamil Dudka <kdudka@redhat.com> 2.9.90-2
  139. - Support major/minor device numbers over 127 (bz#450109)
  140. * Mon Mar 03 2008 Radek Brich <rbrich@redhat.com> 2.9-7
  141. - fix -dir_perm patch to restore permissions correctly even
  142. in passthrough mode -- revert affected code to cpio 2.8 state
  143. (bz#430835)
  144. * Sat Aug 25 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.9-1vl1
  145. - new upstream release
  146. * Sat Apr 16 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6-5vl1
  147. - based on Fedora development 2.6-5
  148. * Mon Jan 24 2005 Peter Vrabec <pvrabec@redhat.com>
  149. - insecure file creation (#145721)
  150. * Mon Jan 17 2005 Peter Vrabec <pvrabec@redhat.com>
  151. - fix symlinks pack (#145225)
  152. * Fri Jan 14 2005 Peter Vrabec <pvrabec@redhat.com>
  153. - new fixed version of lfs patch (#144688)
  154. * Tue Nov 09 2004 Peter Vrabec <pvrabec@redhat.com>
  155. - fixed "cpio -oH ustar (or tar) saves bad mtime date after Jan 10 2004" (#114580)
  156. * Mon Nov 01 2004 Peter Vrabec <pvrabec@redhat.com>
  157. - support large files > 2GB (#105617)
  158. * Wed Dec 04 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.5-1vl1
  159. - based on 2.5-1 from rawhide and built for Vine Linux
  160. - added Japanese summary and description
  161. * Mon Nov 18 2002 Jeff Johnson <jbj@redhat.com> 2.5-1
  162. - update 2.5, restack and consolidate patches.
  163. - don't apply (but include for now) freebsd and #56346 patches.
  164. - add url (#54598).
  165. * Thu Nov 7 2002 Jeff Johnson <jbj@redhat.com> 2.4.2-30
  166. - rebuild from CVS.
  167. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  168. - automated rebuild
  169. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  170. - automated rebuild
  171. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  172. - automated rebuild
  173. * Thu Nov 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.4.2-25
  174. - Fix up extraction of multiply linked files when the first link is
  175. excluded (Bug #56346)
  176. * Mon Oct 1 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.4.2-24
  177. - Merge and adapt patches from FreeBSD, this should fix FIFO handling
  178. * Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  179. - Add and adapt Debian patch (pl36), fixes #45285 and a couple of other issues
  180. * Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
  181. - Bump release + rebuild.
  182. * Tue Aug 8 2000 Jeff Johnson <jbj@redhat.com>
  183. - update man page with decription of -c behavior (#10581).
  184. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  185. - automatic rebuild
  186. * Thu Jun 29 2000 Preston Brown <pbrown@redhat.com>
  187. - patch from HJ Lu for better error codes upon exit
  188. * Mon Jun 5 2000 Jeff Johnson <jbj@redhat.com>
  189. - FHS packaging.
  190. * Wed Feb 9 2000 Jeff Johnson <jbj@redhat.com>
  191. - missing defattr.
  192. * Mon Feb 7 2000 Bill Nottingham <notting@redhat.com>
  193. - handle compressed manpages
  194. * Fri Dec 17 1999 Jeff Johnson <jbj@redhat.com>
  195. - revert the stdout patch (#3358), restoring original GNU cpio behavior
  196. (#6376, #7538), the patch was dumb.
  197. * Tue Aug 31 1999 Jeff Johnson <jbj@redhat.com>
  198. - fix infinite loop unpacking empty files with hard links (#4208).
  199. - stdout should contain progress information (#3358).
  200. * Sun Mar 21 1999 Crstian Gafton <gafton@redhat.com>
  201. - auto rebuild in the new build environment (release 12)
  202. * Sat Dec 5 1998 Jeff Johnson <jbj@redhat.com>
  203. - longlong dev wrong with "-o -H odc" headers (formerly "-oc").
  204. * Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
  205. - patch to compile on glibc 2.1, where strdup is a macro
  206. * Tue Jul 14 1998 Jeff Johnson <jbj@redhat.com>
  207. - Fiddle bindir/libexecdir to get RH install correct.
  208. - Don't include /sbin/rmt -- use the rmt from dump package.
  209. - Don't include /bin/mt -- use the mt from mt-st package.
  210. - Add prereq's
  211. * Tue Jun 30 1998 Jeff Johnson <jbj@redhat.com>
  212. - fix '-c' to duplicate svr4 behavior (problem #438)
  213. - install support programs & info pages
  214. * Mon Apr 27 1998 Prospector System <bugs@redhat.com>
  215. - translations modified for de, fr, tr
  216. * Fri Oct 17 1997 Donnie Barnes <djb@redhat.com>
  217. - added BuildRoot
  218. - removed "(used by RPM)" comment in Summary
  219. * Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
  220. - built against glibc
  221. - no longer statically linked as RPM doesn't use cpio for unpacking packages