pinentry-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393
  1. Name: pinentry
  2. Version: 1.2.1
  3. Release: 1%{?_dist_release}
  4. Summary: Collection of simple PIN or passphrase entry dialogs
  5. Group: accessories
  6. Vendor: Project Vine
  7. Distribution: Vine Linux
  8. # qt & qt4 subpackage have different license, see subpackage definitions
  9. License: GPLv2+
  10. URL: http://www.gnupg.org/aegypten/
  11. Source0: https://gnupg.org/ftp/gcrypt/pinentry/pinentry-%{version}.tar.bz2
  12. Source1: https://gnupg.org/ftp/gcrypt/pinentry/pinentry-%{version}.tar.bz2.sig
  13. # borrowed from opensuse
  14. Source10: pinentry-wrapper
  15. BuildRequires: gcr-devel
  16. BuildRequires: gtk2-devel
  17. BuildRequires: libcap-devel
  18. BuildRequires: ncurses-devel
  19. BuildRequires: libgpg-error-devel
  20. BuildRequires: libassuan-devel
  21. BuildRequires: libsecret-devel
  22. BuildRequires: pkgconfig(Qt5Core) pkgconfig(Qt5Gui) pkgconfig(Qt5Widgets)
  23. Provides: %{name}-curses = %{version}-%{release}
  24. %description
  25. Pinentry is a collection of simple PIN or passphrase entry dialogs which
  26. utilize the Assuan protocol as described by the aegypten project; see
  27. http://www.gnupg.org/aegypten/ for details.
  28. This package contains the curses (text) based version of the PIN entry dialog.
  29. %package gnome3
  30. Summary: Passphrase/PIN entry dialog for GNOME 3
  31. Group: accessories
  32. Requires: %{name} = %{version}-%{release}
  33. Provides: %{name}-gui = %{version}-%{release}
  34. %description gnome3
  35. Pinentry is a collection of simple PIN or passphrase entry dialogs which
  36. utilize the Assuan protocol as described by the aegypten project; see
  37. http://www.gnupg.org/aegypten/ for details.
  38. This package contains the GNOME 3 version of the PIN entry dialog.
  39. %package gtk
  40. Summary: Passphrase/PIN entry dialog based on GTK+
  41. Group: accessories
  42. Requires: %{name} = %{version}-%{release}
  43. Provides: %{name}-gui = %{version}-%{release}
  44. Provides: pinentry-gtk2 = %{version}-%{release}
  45. %description gtk
  46. Pinentry is a collection of simple PIN or passphrase entry dialogs which
  47. utilize the Assuan protocol as described by the aegypten project; see
  48. http://www.gnupg.org/aegypten/ for details.
  49. This package contains the GTK GUI based version of the PIN entry dialog.
  50. %package qt
  51. Summary: Passphrase/PIN entry dialog based on Qt5
  52. Group: accessories
  53. Requires: %{name} = %{version}-%{release}
  54. Provides: %{name}-gui = %{version}-%{release}
  55. Obsoletes: pinentry-qt4 < 0.8.0-2
  56. Provides: pinentry-qt5 = %{version}-%{release}
  57. %description qt
  58. Pinentry is a collection of simple PIN or passphrase entry dialogs which
  59. utilize the Assuan protocol as described by the aegypten project; see
  60. http://www.gnupg.org/aegypten/ for details.
  61. This package contains the Qt5 GUI based version of the PIN entry dialog.
  62. %package emacs
  63. Summary: Passphrase/PIN entry dialog based on emacs
  64. Group: accessories
  65. Requires: %{name} = %{version}-%{release}
  66. %description emacs
  67. Pinentry is a collection of simple PIN or passphrase entry dialogs which
  68. utilize the Assuan protocol as described by the aegypten project; see
  69. http://www.gnupg.org/aegypten/ for details.
  70. This package contains the emacs based version of the PIN entry dialog.
  71. %debug_package
  72. %prep
  73. %setup -q
  74. %build
  75. %if 0%{?fedora} > 22
  76. # FTBFS on f23/gcc5 without this
  77. CXXFLAGS="%{optflags} -std=c++11"
  78. %endif
  79. %configure \
  80. --disable-rpath \
  81. --disable-dependency-tracking \
  82. --without-libcap \
  83. --enable-pinentry-gnome3 \
  84. --enable-pinentry-gtk2 \
  85. --enable-pinentry-qt5 \
  86. --enable-pinentry-emacs \
  87. --enable-pinentry-curses \
  88. --enable-libsecret
  89. make %{?_smp_mflags}
  90. %install
  91. make install DESTDIR=$RPM_BUILD_ROOT
  92. # Symlink for Backward compatibility
  93. ln -s pinentry-gtk-2 $RPM_BUILD_ROOT%{_bindir}/pinentry-gtk
  94. ln -s pinentry-qt $RPM_BUILD_ROOT%{_bindir}/pinentry-qt4
  95. install -p -m755 -D %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}/pinentry
  96. # unpackaged files
  97. rm -fv $RPM_BUILD_ROOT%{_infodir}/dir
  98. %files
  99. %{!?_licensedir:%global license %%doc}
  100. %license COPYING
  101. %doc AUTHORS ChangeLog NEWS README THANKS TODO
  102. %{_bindir}/pinentry-curses
  103. %{_bindir}/pinentry
  104. %{_infodir}/pinentry.info*
  105. %files gnome3
  106. %{_bindir}/pinentry-gnome3
  107. %files gtk
  108. %{_bindir}/pinentry-gtk
  109. %{_bindir}/pinentry-gtk-2
  110. %files qt
  111. %{_bindir}/pinentry-qt
  112. # symlink for backward compatibility
  113. %{_bindir}/pinentry-qt4
  114. %files emacs
  115. %{_bindir}/pinentry-emacs
  116. %changelog
  117. * Thu Oct 19 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.2.1-1
  118. - new upstream release.
  119. * Thu Jul 14 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.2.0-1
  120. - new upstream release.
  121. - dropped install-info scriptlets.
  122. * Thu Feb 04 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.1.1-1
  123. - new upstream release.
  124. * Sun Mar 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.1.0-2
  125. - updated Source10.
  126. * Thu Mar 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.1.0-1
  127. - new upstream release.
  128. * Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> - 0.9.7-4
  129. - rebuild with gcc-5.4.0
  130. * Sun May 22 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.9.7-3
  131. - initial build for Vine Linux.
  132. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.7-2
  133. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  134. * Mon Dec 07 2015 Boris Ranto <branto@redhat.com> - 0.9.7-1
  135. - Rebase to latest upstream version
  136. * Tue Oct 27 2015 Stef Walter <stefw@redhat.com> - 0.9.6-4
  137. - Enable libsecret, which enables password caching in pinentry-gnome3
  138. - Resolves rhbz#1275567
  139. * Thu Oct 15 2015 Kalev Lember <klember@redhat.com> - 0.9.6-3
  140. - Add pinentry-gnome3 support to pinentry wrapper
  141. * Mon Sep 21 2015 Kalev Lember <klember@redhat.com> - 0.9.6-2
  142. - Build pinentry-gnome3
  143. * Fri Sep 11 2015 Boris Ranto <branto@redhat.com> - 0.9.6-1
  144. - Rebase to latest upstream version
  145. - Modify backwards compatible symlink for qt(4)
  146. - Enable pinentry-emacs since it was enabled by default in 0.9.5
  147. * Thu Jul 02 2015 Boris Ranto <branto@redhat.com> - 0.9.5-1
  148. - Rebase to latest upstream version
  149. - Removing qt4 pinentry patch -- got merged upstream
  150. - New package pinentry-emacs that hosts pinentry-emacs
  151. - New dependencies on libassuan and libgpg-error (de-bundling)
  152. * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.2-2
  153. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  154. * Thu May 14 2015 Boris Ranto <branto@redhat.com> - 0.9.2-1
  155. - Rebase to latest upstream version
  156. * Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 0.9.1-2
  157. - Rebuilt for GCC 5 C++11 ABI change
  158. * Wed Mar 25 2015 Boris Ranto <branto@redhat.com> - 0.9.1-1
  159. - Rebase to latest upstream version
  160. - There are no longer any moc files so there is no need to patch them
  161. * Fri Mar 13 2015 Rex Dieter <rdieter@fedoraproject.org> - 0.9.0-3
  162. - fix FTBFS on f23/gcc5
  163. - drop deprecated configure flags
  164. * Sat Feb 21 2015 Till Maas <opensource@till.name> - 0.9.0-2
  165. - Rebuilt for Fedora 23 Change
  166. https://fedoraproject.org/wiki/Changes/Harden_all_packages_with_position-independent_code
  167. * Wed Nov 12 2014 Boris Ranto <branto@redhat.com> - 0.9.0-1
  168. - Rebase to latest upstream version
  169. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-7
  170. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  171. * Tue Aug 12 2014 Boris Ranto <branto@redhat.com> - 0.8.3-6
  172. - fix bogus dates
  173. - upgrade pinentry-wrapper to handle corner cases better
  174. * Wed Jul 30 2014 Tom Callaway <spot@fedoraproject.org> - 0.8.3-5
  175. - fix license handling
  176. * Sat Jul 19 2014 Rex Dieter <rdieter@fedoraproject.org> 0.8.3-4
  177. - /usr/bin/pinentry should not check if stderr is opened (#787775)
  178. * Sat Jul 19 2014 Rex Dieter <rdieter@fedoraproject.org> - 0.8.3-3
  179. - .spec cleanup (drop support for old releases)
  180. - -gtk: Provides: pinentry-gtk2
  181. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-2
  182. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  183. * Thu Jan 30 2014 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.3-1
  184. - Update to latest upstream version (0.8.3)
  185. * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-11
  186. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  187. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-10
  188. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  189. * Wed Nov 14 2012 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.1-9
  190. - Fix macros expansions so that conditionals work
  191. * Mon Nov 12 2012 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.1-8
  192. - Fix up licenses for qt and qt4 subpackages (#875875)
  193. * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-7
  194. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  195. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-6
  196. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  197. * Mon Nov 14 2011 Adam Jackson <ajax@redhat.com> 0.8.1-5
  198. - Rebuild for new libpng
  199. * Tue Jul 26 2011 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.1-4
  200. - Improve wrapper to fallback to curses even with DISPLAY set (#622077)
  201. * Fri Feb 18 2011 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.1-3
  202. - Fix pinentry-curses running as root by disabling capabilities (#677670)
  203. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-2
  204. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  205. * Tue Feb 1 2011 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.1-1
  206. - Updated to latest upstream version (0.8.1)
  207. * Fri May 7 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.0-3
  208. - Fix X11 even race with gtk (#589998)
  209. - Fix qt4 problems with creating window in the background (#589532)
  210. * Thu Apr 29 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.8.0-2
  211. - -qt: build as qt4 version, and drop qt3 support (f13+ only)
  212. * Tue Apr 27 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.0-1
  213. - pinentry-0.8.0
  214. - pinentry-gtk keyboard grab fail results in SIGABRT (#585422)
  215. * Sun Apr 18 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.7.6-5
  216. - pinentry-gtk -g segfaults on focus change (#520236)
  217. * Sun Sep 13 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.7.6-4
  218. - Errors installing with --excludedocs (#515925)
  219. * Sun Sep 13 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.7.6-3
  220. - drop alternatives, use app-wrapper instead (borrowed from opensuse)
  221. - -qt4 experimental subpkg, -qt includes qt3 version again (#523488)
  222. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.6-2
  223. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  224. * Mon Jun 22 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.7.6-1
  225. - pinentry-0.7.6
  226. - -qt switched qt4 version, where applicable (f9+, rhel6+)
  227. - fixup scriptlets
  228. * Sat Apr 25 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.7.5-1
  229. - pinentry-0.7.5
  230. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.4-6
  231. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  232. * Tue Mar 25 2008 Rex Dieter <rdieter@fedoraproject.org> - 0.7.4-5
  233. - pinentry failed massrebuild attempt for GCC 4.3 (#434400)
  234. * Tue Mar 25 2008 Rex Dieter <rdieter@fedoraproject.org> - 0.7.4-4
  235. - s/qt-devel/qt3-devel/ (f9+)
  236. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.7.4-3
  237. - Autorebuild for GCC 4.3
  238. * Sun Feb 17 2008 Adam Tkac <atkac redhat com> - 0.7.4-2
  239. - rebuild against new libcap
  240. * Sun Dec 09 2007 Rex Dieter <rdieter[AT]fedoraproject.org> - 0.7.4-1
  241. - pinentry-0.7.4
  242. - BR: libcap-devel
  243. * Sat Aug 25 2007 Rex Dieter <rdieter[AT]fedoraproject.org> - 0.7.3-2
  244. - respin (BuildID)
  245. * Sat Aug 11 2007 Rex Dieter <rdieter[AT]fedoraproject.org> - 0.7.3-1
  246. - pinentry-0.7.3
  247. - License: GPLv2+
  248. * Thu May 10 2007 Rex Dieter <rdieter[AT]fedoraproject.org> - 0.7.2-15
  249. - respin (for ppc64)
  250. * Mon Dec 04 2006 Rex Dieter <rexdieter[AT]users.sf.net> - 0.7.2-14
  251. - -14 respin (to help retire ATrpms pinentry pkg)
  252. * Mon Aug 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> - 0.7.2-3
  253. - fc6 respin
  254. * Wed Aug 09 2006 Rex Dieter <rexdieter[AT]users.sf.net> - 0.7.2-2
  255. - fc6 respin
  256. * Wed Mar 01 2006 Rex Dieter <rexdieter[AT]users.sf.net>
  257. - fc5: gcc/glibc respin
  258. * Tue Oct 18 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.7.2-1
  259. - 0.7.2, docs patch applied upstream.
  260. - Switch to GTK2 in -gtk.
  261. - Fine tune dependencies.
  262. - Build with dependency tracking disabled.
  263. - Clean up obsolete pre-FC2 support.
  264. * Thu Apr 7 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 0.7.1-4
  265. - rebuilt
  266. * Wed Jun 30 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.7.1-0.fdr.3
  267. - BuildRequires qt-devel >= 3.2.
  268. * Sat May 22 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.7.1-0.fdr.2
  269. - Spec cleanups.
  270. * Sat Apr 24 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.7.1-0.fdr.1
  271. - Update to 0.7.1.
  272. * Fri Dec 26 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.7.0-0.fdr.1
  273. - Update to 0.7.0.
  274. - Split GTK+ and QT dialogs into subpackages.
  275. * Thu Jul 10 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.9-0.fdr.1
  276. - Update to 0.6.9.
  277. - Smoother experience with --excludedocs.
  278. - Don't change alternative priorities on upgrade.
  279. * Sat Mar 22 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.8-0.fdr.1
  280. - Update to current Fedora guidelines.
  281. * Wed Feb 12 2003 Warren Togami <warren@togami.com> 0.6.8-1.fedora.3
  282. - info/dir temporary workaround
  283. * Sat Feb 8 2003 Ville Skyttä <ville.skytta at iki.fi> - 0.6.8-1.fedora.1
  284. - First Fedora release.