xorg-x11-xinit-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347
  1. %define pkgname xinit
  2. Summary: X.Org X11 X Window System xinit startup scripts
  3. Summary(ja): X.Org X11 X ウィンドウシステム xinit スタートアップスクリプト
  4. Name: xorg-x11-%{pkgname}
  5. Version: 1.3.3
  6. Release: 1%{?_dist_release}
  7. License: MIT/X11
  8. Group: User Interface/X
  9. URL: http://www.x.org
  10. Source0: ftp://ftp.x.org/pub/individual/app/%{pkgname}-%{version}.tar.bz2
  11. Source10: xinitrc-common
  12. Source11: xinitrc
  13. Source12: Xclients
  14. Source13: Xmodmap
  15. Source14: Xresources
  16. # NOTE: Xsession is used by xdm/kdm/gdm and possibly others, so we keep it
  17. # here instead of the xdm package.
  18. Source16: Xsession
  19. Source17: localuser.sh
  20. Source18: xinit-compat.desktop
  21. Source100: ck-xinit-session.c
  22. Patch1: xinit-1.3.0-client-session.patch
  23. Patch2: xinit-1.0.7-poke-ck.patch
  24. Patch3: xinit-1.0.9-unset.patch
  25. Patch10: xinit-1.3.0-vine.patch
  26. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  27. BuildRequires: pkgconfig
  28. BuildRequires: libX11-devel
  29. BuildRequires: ConsoleKit-devel
  30. BuildRequires: autoconf
  31. BuildRequires: automake
  32. BuildRequires: libtool
  33. BuildRequires: dbus-devel
  34. BuildRequires: xorg-x11-util-macros
  35. # NOTE: startx needs xauth in order to run, but that is not picked up
  36. # automatically by rpm. (Bug #173684)
  37. Requires: xauth
  38. # next two are for localuser.sh
  39. Requires: coreutils
  40. Requires: xorg-x11-server-utils
  41. Requires: ConsoleKit-x11
  42. Requires: ConsoleKit-libs
  43. Requires: dbus-x11
  44. # NOTE: xinit, startx moved to xorg-x11-xinit during the X.Org X11R7
  45. # modularization. These Obsoletes lines ensure upgrades work smoothly.
  46. Obsoletes: XFree86, XOrg
  47. # NOTE: Most of the xinitrc scripts/config files are now in xorg-x11-xinit,
  48. # so the xinitrc package became unnecessary. The xdm configs/scripts move
  49. # to the xdm package.
  50. Obsoletes: xinitrc
  51. Provides: xinitrc
  52. Vendor: Project Vine
  53. Distribution: Vine Linux
  54. Packager: Takemikaduchi
  55. %description
  56. X.Org X11 X Window System xinit startup scripts
  57. %description -l ja
  58. X.Org X11 X Window System の xinit スタートアップ・スクリプト
  59. %package session
  60. Summary: Display manager support for ~/.xsession and ~/.Xclients
  61. Group: User Interface/X
  62. %description
  63. X.Org X11 X Window System xinit startup scripts
  64. %description session
  65. Allows legacy ~/.xsession and ~/.Xclients files to be used from display managers
  66. %prep
  67. %setup -q -n %{pkgname}-%{version}
  68. %patch1 -p1 -b .client-session
  69. #%patch2 -p1 -b .poke-ck
  70. %patch3 -p1 -b .unset
  71. %patch10 -p1 -b .vine
  72. %build
  73. autoreconf -i
  74. %configure
  75. # FIXME: Upstream should default to XINITDIR being this. Make a patch to
  76. # Makefile.am and submit it in a bug report or check into CVS.
  77. make XINITDIR=/etc/X11/xinit
  78. %{__cc} -o ck-xinit-session \
  79. `pkg-config --cflags ck-connector dbus-1` $RPM_OPT_FLAGS \
  80. $RPM_SOURCE_DIR/ck-xinit-session.c \
  81. `pkg-config --libs ck-connector dbus-1`
  82. %install
  83. rm -rf $RPM_BUILD_ROOT
  84. # FIXME: Upstream should default to XINITDIR being this. Make a patch to
  85. # Makefile.am and submit it in a bug report or check into CVS.
  86. %makeinstall XINITDIR=$RPM_BUILD_ROOT/etc/X11/xinit
  87. install -m755 ck-xinit-session $RPM_BUILD_ROOT/%{_bindir}
  88. install -m644 -D $RPM_SOURCE_DIR/xinit-compat.desktop $RPM_BUILD_ROOT%{_datadir}/xsessions/xinit-compat.desktop
  89. # Install custom xinitrc, etc.
  90. {
  91. install -m 644 %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/xinitrc-common
  92. for script in %{SOURCE11} %{SOURCE12} %{SOURCE16} ; do
  93. install -m 755 $script $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/${script##*/}
  94. done
  95. install -m 644 %{SOURCE13} $RPM_BUILD_ROOT%{_sysconfdir}/X11/Xmodmap
  96. install -m 644 %{SOURCE14} $RPM_BUILD_ROOT%{_sysconfdir}/X11/Xresources
  97. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/xinitrc.d
  98. install -m 755 %{SOURCE17} $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/xinitrc.d/localuser.sh
  99. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/Xclients.d
  100. }
  101. %clean
  102. rm -rf $RPM_BUILD_ROOT
  103. %files
  104. %defattr(-,root,root,-)
  105. %doc COPYING README ChangeLog
  106. %{_bindir}/startx
  107. %{_bindir}/xinit
  108. %{_bindir}/ck-xinit-session
  109. %dir %{_sysconfdir}/X11
  110. %dir %{_sysconfdir}/X11/xinit
  111. %{_sysconfdir}/X11/xinit/xinitrc
  112. %{_sysconfdir}/X11/xinit/xinitrc-common
  113. %config(noreplace) %{_sysconfdir}/X11/Xmodmap
  114. %config(noreplace) %{_sysconfdir}/X11/Xresources
  115. %dir %{_sysconfdir}/X11/xinit/Xclients.d
  116. %{_sysconfdir}/X11/xinit/Xclients
  117. %{_sysconfdir}/X11/xinit/Xsession
  118. %dir %{_sysconfdir}/X11/xinit/xinitrc.d
  119. %{_sysconfdir}/X11/xinit/xinitrc.d/*
  120. #%dir %{_mandir}/man1
  121. %{_mandir}/man1/startx.1*
  122. %{_mandir}/man1/xinit.1*
  123. %files session
  124. %defattr(-, root, root)
  125. %{_datadir}/xsessions/xinit-compat.desktop
  126. %changelog
  127. * Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.3-1
  128. - new upstream release
  129. * Sun Jan 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.2-1
  130. - new upstream release
  131. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.1-1
  132. - new upstream release
  133. * Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.0-1
  134. - new upstream release
  135. - update Patch1, Patch10
  136. * Fri Mar 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
  137. - new upstream release
  138. - updated SOURCE12, SOURCE100
  139. - Install xinitrc-common non-executable.
  140. - added a new subpackage to add ~/.xsessions and ~/.Xclients
  141. to session list
  142. * Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
  143. - new upstream release
  144. * Sun Jul 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.1-3
  145. - add Requires: dbus-x11
  146. * Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.1-2
  147. - add LXDE to Xclients
  148. * Sun Dec 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.1-1
  149. - new upstream release
  150. * Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-2
  151. - fix typo in Xsession (<BTS:644>)
  152. * Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
  153. - new upstream release
  154. * Fri Jun 27 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.0.7-3
  155. - spec in UTF-8
  156. - modify Source16: add CK_XINIT_SESSION calls
  157. * Fri May 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.7-2
  158. - add Patch10 to set display resolution.
  159. * Thu May 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.7-1
  160. - initial build for Vine Linux
  161. * Fri Oct 12 2007 Nalin Dahyabhai <nalin@redhat.com> 1.0.7-2
  162. - Try opening the console-kit session after the user's UID has already
  163. been granted access to the server by localuser.sh, so that console-kit-daemon
  164. can connect and ask the server for information just by having switch to the
  165. user's UID (#287941).
  166. * Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 1.0.7-1
  167. - xinit 1.0.7
  168. * Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.2-27
  169. - Rebuild for build id
  170. * Mon Aug 6 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-26
  171. - Bump release
  172. * Mon Aug 6 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-25
  173. - Fix typo: s/unask/umask/ - Bug 250882, Jan ONDREJ (ondrejj@salstar.sk)
  174. * Thu Aug 2 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-24
  175. - Fix bug 212167, CVE-2006-5214
  176. * Sun Jul 29 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-23
  177. - Fix Xsession to run the login shell inside the setgid ssh-agent, rather
  178. than the other way around. This preserves LD_LIBRARY_PRELOAD.
  179. Patch from Stefan Becker, bug 164869.
  180. * Fri Jul 27 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-22
  181. - Remove xinput.sh. Bug 244963.
  182. * Mon May 21 2007 Adam Jackson <ajax@redhat.com> 1.0.2-21
  183. - localuser.sh: Run silently.
  184. * Sun Apr 22 2007 Matthias Clasen <mclasen@redhat.com> 1.0.2-20
  185. - Don't install INSTALL
  186. * Thu Apr 19 2007 Warren Togami <wtogami@redhat.com> 1.0.2-19
  187. - disable SCIM by default in non-Asian languages #237054
  188. If you want to use SCIM, use im-chooser to enable it.
  189. * Mon Apr 02 2007 David Zeuthen <davidz@redhat.com> 1.0.2-18
  190. - Man pages are now in section 1, not in section 1x
  191. * Mon Apr 02 2007 David Zeuthen <davidz@redhat.com> 1.0.2-17
  192. - Also BR xorg-x11-util-macros since we autoreconf
  193. * Mon Apr 02 2007 David Zeuthen <davidz@redhat.com> 1.0.2-16
  194. - Add ConsoleKit support (#233183)
  195. * Mon Nov 27 2006 Adam Jackson <ajax@redhat.com> 1.0.2-15
  196. - Bump EVR to fix 6 to 7 updates.
  197. * Fri Nov 10 2006 Ray Strode <rstrode@redhat.com> - 1.0.2-14
  198. - start client in its own session with no controlling tty
  199. (bug 214649)
  200. * Mon Oct 23 2006 Kristian H淡gsberg <krh@redhat.com> - 1.0.2-13
  201. - Update Xsession to not use switchdesk for the hard coded kde and twm
  202. cases.
  203. * Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.0.2-12
  204. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  205. * Mon Sep 25 2006 Kristian H淡gsberg <krh@redhat.com> - 1.0.2-11.fc6
  206. - Bump and rebuild.
  207. * Mon Sep 25 2006 Kristian H淡gsberg <krh@redhat.com> - 1.0.2-10.fc6
  208. - Move hardcoded xsetroot background color to fallback cases (#205901).
  209. * Thu Aug 17 2006 Kristian H淡gsberg <krh@redhat.com> - 1.0.2-9.fc6
  210. - Start ssh-agent for startx also (#169259).
  211. * Sat Jul 22 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-8.fc6
  212. - Fix SourceN line for localuser.sh to not collide.
  213. * Fri Jul 21 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-7.fc6
  214. - Added localuser.sh.
  215. * Wed Jul 19 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-6.fc6
  216. - Added fix to Xclients script, based on patch from bug (#190799)
  217. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.0.2-5.1.fc6
  218. - rebuild
  219. * Wed Jul 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-5.fc6
  220. - Implemented changes to xinput.sh based on suggestions from (#194458)
  221. * Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-4
  222. - Added documentation to doc macro.
  223. * Tue Jun 20 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-3
  224. - Added xinit-1.0.2-setuid.diff to fix potential security issue (#196094)
  225. * Tue Jun 06 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-2
  226. - Added "BuildRequires: pkgconfig" for bug (#194187)
  227. * Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-1
  228. - Update xinit to 1.0.2
  229. * Thu Feb 16 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
  230. - Change Conflicts to Obsoletes for xorg-x11 and XFree86 (#181414)
  231. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
  232. - bump again for double-long bug on ppc(64)
  233. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
  234. - rebuilt for new gcc4.1 snapshot and glibc changes
  235. * Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
  236. - Updated to xinit 1.0.1 from X11R7.0
  237. * Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
  238. - Updated to xinit 1.0.0 from X11R7 RC4.
  239. - Changed manpage dir from man1x to man1 to match upstream default.
  240. * Tue Nov 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-6
  241. - Add "Requires: xauth" for startx, to fix bug (#173684)
  242. * Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.3-5
  243. - Do not provide xinit anymore, gdm has been fixed and that breaks things
  244. with the obsoletes
  245. * Sat Nov 12 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-4
  246. - Added Xsession script from xinitrc, as it is very similar codebase, which
  247. shares "xinitrc-common" anyway, and all of the display managers use it.
  248. * Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-3
  249. - Updated to xinit 0.99.3 from X11R7 RC2.
  250. * Mon Nov 07 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-3
  251. - Added "Provides: xinitrc = 5.0.0-1" for temporary compatibility between
  252. monolithic and modular X. This will be removed however for FC5.
  253. * Mon Oct 31 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
  254. - Import custom Red Hat xinit scripts from xinitrc package.
  255. - Obsolete xinitrc package, as we include the scripts/configs here now.
  256. - Fix all scripts/configs to avoid the now obsolete /usr/X11R6 prefix.
  257. * Mon Oct 31 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
  258. - Updated to xinit 0.99.2 from X11R7 RC1.
  259. - Change manpage location to 'man1x' in file manifest.
  260. * Wed Oct 05 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
  261. - Use Fedora-Extras style BuildRoot tag.
  262. - Update BuildRequires to use new library package names.
  263. - Tidy up spec file a bit.
  264. * Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
  265. - Initial build.