clearsilver-vl.spec 5.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213
  1. %bcond_with ruby
  2. Summary: A fast, powerful, and language-neutral HTML template system.
  3. Summary(ja): 高速、パワフルで言語中立なHTMLテンプレートシステム
  4. Name: clearsilver
  5. Version: 0.10.5
  6. Release: 14%{_dist_release}
  7. Group: programming
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. # Technically, the license is "Neotonic ClearSilver", but it is a copy of
  11. # ASL 1.1 with the trademarks as the only difference.
  12. License: ASL 1.1
  13. URL: http://clearsilver.net/
  14. Source0: http://clearsilver.net/downloads/%{name}-%{version}.tar.gz
  15. Patch0: clearsilver-0.10.5-conf.patch
  16. Patch1: clearsilver-0.10.5-regression.patch
  17. Patch2: clearsilver-0.10.5-CVE-2011-4357.patch
  18. Patch3: clearsilver-ruby-1.9.patch
  19. Patch4: clearsilver-ruby-2.2.patch
  20. # GCC 5 compatibility, bug #1190760
  21. Patch5: clearsilver-0.10.5-gcc5.patch
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  23. BuildRequires: perl
  24. BuildRequires: perl-generators
  25. BuildRequires: perl(ExtUtils::MakeMaker)
  26. %if %{with ruby}
  27. BuildRequires: ruby
  28. BuildRequires: ruby-devel >= 1.9.3
  29. %endif
  30. BuildRequires: zlib-devel
  31. BuildRequires: libxcrypt-devel
  32. %description
  33. ClearSilver is a fast, powerful, and language-neutral template system.
  34. It is designed to make it easy to create template driven static or
  35. dynamic websites.
  36. %description -l ja
  37. Clearsilver は高速、強力で言語中立なテンプレートシステムです。
  38. テンプレート駆動の静的あるいは動的な Web サイトの構築を
  39. 容易にすることを目指して設計されています。
  40. %package devel
  41. Summary: header files and development library for ClearSilver
  42. Summary(ja): ClearSilverのヘッダファイル・開発ライブラリ
  43. Group: programming
  44. Requires: clearsilver = %{version}-%{release}
  45. %description devel
  46. %{summary}.
  47. %package -n perl-%{name}
  48. Summary: Perl interface to the ClearSilver HTML templating system
  49. Requires: perl >= 2:5.34.0
  50. %description -n perl-%{name}
  51. %{summary}.
  52. %if %{with ruby}
  53. %package -n ruby-%{name}
  54. Summary: Ruby interface to the ClearSilver HTML templating system
  55. %description -n ruby-%{name}
  56. %{summary}.
  57. %endif
  58. %debug_package
  59. %prep
  60. %setup -q
  61. %patch0 -p1 -b .conf
  62. %patch1 -p1
  63. %patch2 -p1
  64. %if %{with ruby}
  65. %patch3 -p1
  66. %patch4 -p1
  67. %endif
  68. %patch5 -p2
  69. touch configure
  70. sed -i -r 's|(\$\(RUBY\) install.rb config) (--.*)|\1 --rb-dir="$(DESTDIR)%{ruby_vendorlibdir}" --so-dir="$(DESTDIR)%{ruby_vendorarchdir}" \2|' ruby/Makefile
  71. %build
  72. %configure \
  73. %if ! %{with ruby}
  74. --disable-ruby \
  75. %endif
  76. --disable-csharp
  77. %ifarch x86_64
  78. perl -pi -e 's/^(TARGETS =.+) test/$1/' cs/Makefile
  79. %endif
  80. make %{?_smp_mflags} OPTIMIZE="$RPM_OPT_FLAGS"
  81. cd perl && %{__perl} Makefile.PL INSTALLDIRS=vendor && cd ..
  82. ld -z relro -shared -fPIC --build-id -lc --whole-archive \
  83. -o libclearsilver.so.0.0.0 \
  84. ./libs/libneo_cgi.a \
  85. ./libs/libneo_cs.a \
  86. ./libs/libneo_utl.a
  87. %install
  88. rm -rf $RPM_BUILD_ROOT
  89. make DESTDIR=${RPM_BUILD_ROOT} install
  90. install -m755 libclearsilver.so.0.0.0 %{buildroot}%{_libdir}/
  91. ln -sf libclearsilver.so.0.0.0 %{buildroot}%{_libdir}/libclearsilver.so.0.0
  92. ln -sf libclearsilver.so.0.0.0 %{buildroot}%{_libdir}/libclearsilver.so.0
  93. ln -sf libclearsilver.so.0.0.0 %{buildroot}%{_libdir}/libclearsilver.so
  94. find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
  95. find $RPM_BUILD_ROOT -type f -name perllocal.pod -exec rm -f {} ';'
  96. find $RPM_BUILD_ROOT -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
  97. find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
  98. chmod -R u+w $RPM_BUILD_ROOT/*
  99. %clean
  100. rm -rf $RPM_BUILD_ROOT
  101. %files
  102. %defattr(-,root,root)
  103. %license CS_LICENSE LICENSE
  104. %doc INSTALL README
  105. %{_bindir}/*
  106. %{_libdir}/*.so.*
  107. %files devel
  108. %{_includedir}/ClearSilver/
  109. %{_libdir}/*.a
  110. %{_libdir}/*.so
  111. %{_mandir}/man*/*.gz
  112. %files -n perl-clearsilver
  113. %doc CS_LICENSE LICENSE
  114. %defattr(-,root,root,-)
  115. %{perl_vendorarch}/auto/ClearSilver/
  116. %{perl_vendorarch}/ClearSilver.pm
  117. %if %{with ruby}
  118. %files -n ruby-clearsilver
  119. %{ruby_vendorarchdir}/*.so
  120. %{ruby_vendorlibdir}/*.rb
  121. %endif
  122. %changelog
  123. * Wed Nov 02 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.10.5-14
  124. - built shared library.
  125. * Sat Nov 20 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.10.5-13
  126. - rebuilt with perl-5.34.0.
  127. - dropped python support.
  128. * Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.10.5-12
  129. - rebuilt with perl-5.26.
  130. - added BR:libxcrypt-devel.
  131. * Tue Dec 19 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.10.5-11
  132. - added Patch5 for gcc5.
  133. - disabled ruby stuff.
  134. * Sat Sep 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.5-10
  135. - rebuild with ruby-2.2.3
  136. - add Patch4 (clearsilver-ruby-2.2.patch) from fedora
  137. * Wed Dec 17 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.10.5-9
  138. - rebuilt with perl 5.16.3 and ruby 2.1.5
  139. * Sun Dec 08 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.10.5-8
  140. - rebuilt with ruby-2.0.0.353.
  141. * Thu Oct 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.5-7
  142. - rebuild with ruby-1.9.3
  143. - add patch3 to build with ruby-1.9
  144. - add patch2 for CVE-2011-4357
  145. * Sat Feb 25 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.10.5-6
  146. - rebuilt with python-2.7.
  147. * Sun May 15 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.10.5-5
  148. - rebuilt with perl-5.12.3 and python-2.6.
  149. * Mon Jun 22 2009 Shu KONNO <owa@bg.wakwak.com> 0.10.5-4
  150. - applied new versioning policy, spec in utf-8
  151. * Mon Jul 21 2008 Shu KONNO <owa@bg.wakwak.com> 0.10.5-3
  152. - rebuilt with python-2.5.2
  153. - added clearsilver-0.10.5-conf.patch
  154. * Tue Apr 29 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.10.5-2
  155. - rebuilt with perl-5.10.0.
  156. * Mon Apr 28 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.10.5-1
  157. - x86_64: make to skip testing.
  158. * Fri Nov 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.5-0vl4
  159. - add --disable-csharp for configure script
  160. * Tue Aug 28 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.10.5-0vl2
  161. - initial build for Vine Linux