x264-vl.spec 4.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164
  1. %define name x264
  2. %define version 0.0.0
  3. %define date 20100216
  4. %define time 2245
  5. %define release 13.%{date}%{?_dist_release}
  6. Summary: Library for encoding and decoding H264/AVC video streams
  7. Name: %{name}
  8. Version: %{version}
  9. Release: %{release}
  10. #Source: ftp://ftp.videolan.org/pub/videolan/x264/snapshots/%{name}-snapshot-%{date}-%{time}.tar.bz2
  11. Source: http://www.videolan.org/pub/videolan/x264/snapshots/%{name}-snapshot-%{date}-%{time}.tar.bz2
  12. Source1: %{name}.desktop
  13. # # don't remove config.h and don't re-run version.sh
  14. # #Patch0: x264-nover.patch
  15. # Patch0: x264-nover-20100216.patch
  16. # link with shared libx264
  17. Patch1: x264-shared.patch
  18. # don't strip if configured with --enable-debug
  19. Patch2: x264-nostrip.patch
  20. License: GPLv2+
  21. Group: System Environment/Libraries
  22. URL: http://www.videolan.org/developers/x264.html
  23. %ifarch x86_64 %{ix86}
  24. BuildRequires: yasm
  25. %endif
  26. # gpac-devel package provided by self-build-gpac
  27. # in self-build-%{name}.spec as PreReq.
  28. #BuildRequires: gpac-devel
  29. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  30. %description
  31. x264 is a free library for encoding H264/AVC video streams, written from
  32. scratch.
  33. %package devel
  34. Summary: Development files for the x264 library
  35. Group: Development/Libraries
  36. Requires: %{name} = %{version}-%{release}
  37. Requires: pkgconfig
  38. %description devel
  39. x264 is a free library for encoding H264/AVC video streams, written from
  40. scratch.
  41. This package contains header files, static library and API documentation
  42. for the x264.
  43. %prep
  44. %setup -q -n %{name}-snapshot-%{date}-%{time}
  45. #% patch0 -p1 -b .nover
  46. %patch1 -p1 -b .shared
  47. %patch2 -p1 -b .nostrip
  48. # AUTHORS file is in iso-8859-1
  49. iconv -f iso-8859-1 -t utf-8 -o AUTHORS.utf8 AUTHORS
  50. %__mv -f AUTHORS.utf8 AUTHORS
  51. %build
  52. ./configure \
  53. --host=%{_target_platform} \
  54. --prefix=%{_prefix} \
  55. --exec-prefix=%{_exec_prefix} \
  56. --bindir=%{_bindir} \
  57. --includedir=%{_includedir} \
  58. --libdir=%{_libdir} \
  59. --extra-cflags="$RPM_OPT_FLAGS" \
  60. --enable-mp4-output \
  61. %{?_with_visualize:--enable-visualize} \
  62. %ifnarch %{ix86}
  63. --disable-asm \
  64. %endif
  65. --enable-pthread \
  66. --enable-debug \
  67. --enable-shared \
  68. --enable-pic
  69. %{__make} %{?_smp_mflags}
  70. %install
  71. %{__rm} -rf %{buildroot}
  72. %{__make} DESTDIR=%{buildroot} install
  73. %clean
  74. %{__rm} -rf %{buildroot}
  75. %post -p /sbin/ldconfig
  76. %postun -p /sbin/ldconfig
  77. %files
  78. %defattr(644, root, root, 0755)
  79. %doc AUTHORS COPYING
  80. %attr(755,root,root) %{_bindir}/x264
  81. %{_libdir}/libx264.so.*
  82. %files devel
  83. %defattr(644, root, root, 0755)
  84. %doc doc/ratecontrol.txt doc/vui.txt
  85. %{_includedir}/x264.h
  86. %exclude %{_libdir}/libx264.a
  87. %{_libdir}/libx264.so
  88. %{_libdir}/pkgconfig/%{name}.pc
  89. %changelog
  90. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-13.20100216
  91. - change release to sync with self-build-x264
  92. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-12.20100216
  93. - updated source snapshot 20100216
  94. - applied to link x264 binary to the shared library from RPM Fusion development
  95. * Mon Sep 07 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-11.20090522
  96. - changed Source0: to http://www.videolan.org/pub/videolan/x264/snapshots
  97. * Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-10.20090522
  98. - change release to sync with self-build-x264
  99. * Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-9.20090522
  100. - 20090522 snapshot
  101. - updated x264-vine.patch
  102. * Fri Mar 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-8.20090110
  103. - corrected release number
  104. * Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-6.20090110
  105. - added configure options: --enable-mp4-output
  106. - added BuildRequires: gpac-devel
  107. * Sun Jan 25 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-5.20090110
  108. - change release to sync with self-build-x264
  109. * Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-4.20090110
  110. - 20090110 snapshot
  111. * Thu Nov 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-3.20081001
  112. - fixed License: GPLv2+
  113. - added BuildRequires: gettext
  114. - source updated
  115. - fixed x264-rpm.patch (merged x264-rpm.patch from RPM Fusion)
  116. and added x264-vine.patch
  117. #- changed version from 0.0.0-1.20080225 to 0.0.0-20081111.1
  118. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-2.20080225vl1
  119. - spec in utf8
  120. * Sun May 18 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.0.0-1.20080225
  121. - apply new versioning policy
  122. * Wed Feb 27 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-0.20080225vl1
  123. - initial build for Vine Linux 4.2
  124. * Sun Jan 20 2008 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 0.57-0.r721vlmp1
  125. - update to SVN r721
  126. * Sat Aug 4 2007 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 0.56-0.r667vlmp1
  127. - initial build for Vine Linux 4.1
  128. ### end of file