subversion-vl.spec 16 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482
  1. %define neon_version 0.25.5
  2. %define swig_version 1.3.29
  3. %define apache_dir /usr
  4. %define db_version 4.3.29
  5. %define swigdirs swig_pydir=%{python_sitearch}/libsvn swig_pydir_extra=%{python_sitearch}/svn
  6. # set to zero to avoid running test suite
  7. %define make_check 0
  8. Summary: Modern Version Control System
  9. Summary(ja): モダンなバージョン管理システム
  10. Name: subversion
  11. Version: 1.6.16
  12. Release: 2%{?_dist_release}
  13. License: ASL 1.1
  14. Group: Development/Tools
  15. URL: http://subversion.apache.org/
  16. Packager: iwai
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. SOURCE0: subversion-%{version}.tar.bz2
  20. SOURCE1: subversion.conf
  21. SOURCE2: httpd.davcheck.conf
  22. SOURCE3: filter-requires.sh
  23. Patch1: subversion-1.6.0-deplibs.patch
  24. Patch3: subversion-1.6.1-rpath.patch
  25. Patch6: subversion-1.5.0-pie.patch
  26. Patch10: subversion-1.5.7-update-neon-m4.patch
  27. Requires: db4 >= %{db_version}
  28. Requires: expat
  29. Requires: neon >= %{neon_version}
  30. BuildRequires: apache2-devel
  31. BuildRequires: apr-devel, apr-util-devel
  32. BuildRequires: autoconf >= 2.53
  33. BuildRequires: db4-devel >= %{db_version}
  34. BuildRequires: expat-devel
  35. BuildRequires: gdbm-devel
  36. BuildRequires: libtool >= 1.4.2
  37. BuildRequires: neon-devel >= %{neon_version}
  38. BuildRequires: openssl-devel
  39. BuildRequires: python
  40. BuildRequires: python-devel
  41. BuildRequires: swig >= %{swig_version}
  42. BuildRequires: texinfo
  43. BuildRequires: zlib-devel
  44. BuildRequires: openldap-devel
  45. BuildRequires: ruby >= 1.8.2
  46. BuildRequires: ruby-devel >= 1.8.2
  47. BuildRequires: perl >= 5.8.0
  48. BuildRequires: sqlite3-devel
  49. BuildRequires: krb5-devel
  50. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  51. %define __perl_requires %{SOURCE3}
  52. %description
  53. Subversion is a concurrent version control system which enables one
  54. or more users to collaborate in developing and maintaining a
  55. hierarchy of files and directories while keeping a history of all
  56. changes. Subversion only stores the differences between versions,
  57. instead of every complete file. Subversion is intended to be a
  58. compelling replacement for CVS.
  59. %package devel
  60. Group: Development/Libraries
  61. Summary: Development package for Subversion developers.
  62. Requires: subversion = %{version}-%{release}
  63. Requires: apr-devel, apr-util-devel
  64. %description devel
  65. The subversion-devel package includes the static libraries and include files
  66. for developers interacting with the subversion package.
  67. %package mod_dav_svn
  68. Group: System Environment/Daemons
  69. Summary: Apache server module for Subversion server.
  70. Requires: httpd >= %{apache_version}
  71. Requires: subversion = %{version}-%{release}
  72. %description mod_dav_svn
  73. The subversion-mod_dav_svn package adds the Subversion server Apache module to
  74. the Apache directories and configuration.
  75. %package tools
  76. Group: Development/Tools
  77. Summary: Tools for Subversion
  78. BuildRequires: perl >= 5.8.0
  79. Requires: perl >= 5.8.0
  80. Requires: subversion = %{version}-%{release}
  81. %description tools
  82. Tools for Subversion.
  83. %package perl
  84. Group: Development/Libraries
  85. Summary: Perl bindings to the Subversion libraries
  86. Requires: subversion = %{version}-%{release}
  87. Requires: perl >= 5.8.0
  88. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  89. %description perl
  90. This package includes the Perl bindings to the Subversion libraries.
  91. %package ruby
  92. Group: Development/Libraries
  93. Summary: Ruby bindings to the Subversion libraries
  94. Requires: subversion = %{version}-%{release}
  95. Requires: ruby >= 1.8.2
  96. %description ruby
  97. This package includes the Ruby bindings to the Subversion libraries.
  98. %package python
  99. Group: Development/Libraries
  100. Summary: Python bindings to the Subversion libraries
  101. Requires: subversion = %{version}-%{release}, python
  102. %description python
  103. This package includes the Python bindings to the Subversion libraries.
  104. %prep
  105. %setup -q
  106. %patch1 -p1 -b .deplibs
  107. %patch3 -p1 -b .rpath
  108. ## comment out: 1.6.9-1
  109. #%patch6 -p1 -b .pie
  110. ## comment out: 1.6.9-1
  111. #%patch10 -p1 -b .nola
  112. rm -rf neon apr apr-util db4
  113. %build
  114. ./autogen.sh
  115. # fix shebang lines, #111498
  116. perl -pi -e 's|/usr/bin/env perl -w|/usr/bin/perl -w|' tools/hook-scripts/*.pl.in
  117. # override weird -shrext from ruby
  118. export svn_cv_ruby_link="%{__cc} -shared"
  119. export svn_cv_ruby_sitedir_libsuffix=""
  120. export svn_cv_ruby_sitedir_archsuffix=""
  121. export CC=gcc CXX=g++ JAVA_HOME=%{jdk_path}
  122. export CPPFLAGS="-DSVN_NEON_0_26 -DSVN_NEON_0_25"
  123. %configure --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
  124. --with-swig --with-neon=%{_prefix} \
  125. --with-ruby-sitedir=%{rarchdir} \
  126. --with-apxs=%{_bindir}/apxs \
  127. --disable-mod-activation --disable-static --disable-neon-version-check
  128. # 1.3.0 tarball ships with generated swig sources
  129. make extraclean-swig-headers
  130. make %{?_smp_mflags} all
  131. make swig-py swig-py-lib %{swigdirs}
  132. make swig-pl swig-pl-lib swig-rb swig-rb-lib
  133. %install
  134. echo %{rarchdir}
  135. rm -rf $RPM_BUILD_ROOT
  136. make install \
  137. install-swig-py \
  138. install-swig-pl-lib \
  139. install-swig-rb \
  140. DESTDIR=$RPM_BUILD_ROOT %{swigdirs}
  141. make pure_vendor_install -C subversion/bindings/swig/perl/native \
  142. PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
  143. install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/subversion
  144. # Add subversion.conf configuration file into httpd/conf.d directory.
  145. install -m 755 -d $RPM_BUILD_ROOT/etc/apache2/conf.d
  146. install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/etc/apache2/conf.d
  147. # Set up tools package files.
  148. mkdir -p $RPM_BUILD_ROOT/usr/lib/subversion
  149. cp -r tools $RPM_BUILD_ROOT/usr/lib/subversion
  150. # Remove unpackaged files
  151. rm -rf $RPM_BUILD_ROOT%{_includedir}/subversion-*/*.txt \
  152. $RPM_BUILD_ROOT%{python_sitearch}/*/*.{a,la} \
  153. $RPM_BUILD_ROOT%{_libdir}/*.la
  154. # remove stuff produced with Perl modules
  155. find $RPM_BUILD_ROOT -type f \
  156. -a \( -name .packlist -o \( -name '*.bs' -a -empty \) \) \
  157. -print0 | xargs -0 rm -f
  158. # make Perl modules writable so they get stripped
  159. find $RPM_BUILD_ROOT%{_libdir}/perl5 -type f -perm 555 -print0 |
  160. xargs -0 chmod 755
  161. # unnecessary libraries for swig bindings
  162. rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig_*.{so,la,a}
  163. # Remove unnecessary ruby libraries
  164. rm -f $RPM_BUILD_ROOT%{rarchdir}/svn/ext/*.*a
  165. # Trim what goes in docdir
  166. rm -rf tools/*/*.in tools/test-scripts
  167. # Rename authz_svn INSTALL doc for docdir
  168. ln -f subversion/mod_authz_svn/INSTALL mod_authz_svn-INSTALL
  169. %clean
  170. rm -rf $RPM_BUILD_ROOT
  171. %post -p /sbin/ldconfig
  172. %postun -p /sbin/ldconfig
  173. %post tools -p /sbin/ldconfig
  174. %postun tools -p /sbin/ldconfig
  175. %files
  176. %defattr(-,root,root)
  177. %doc BUGS CHANGES COMMITTERS COPYING HACKING INSTALL README
  178. %doc subversion/LICENSE
  179. %{_bindir}/*
  180. %{_libdir}/libsvn_*.so.*
  181. %{_localedir}/*/*/subversion.mo
  182. %{_mandir}/man*/*
  183. %dir %{_sysconfdir}/subversion
  184. %exclude %{_mandir}/man*/*::*
  185. %exclude %{_libdir}/libsvn_swig_perl*.so.*
  186. %exclude %{_libdir}/libsvn_swig_py*.so.*
  187. %exclude %{_libdir}/libsvn_swig_ruby*.so.*
  188. %files devel
  189. %defattr(-,root,root)
  190. %{_includedir}/subversion-1
  191. %{_libdir}/libsvn*.so
  192. %exclude %{_libdir}/libsvn_swig_perl*.so.*
  193. %exclude %{_libdir}/libsvn_swig_py*.so.*
  194. %exclude %{_libdir}/libsvn_swig_ruby*.so.*
  195. %files mod_dav_svn
  196. %defattr(-,root,root)
  197. %config(noreplace) /etc/apache2/conf.d/subversion.conf
  198. %{apache_dir}/%{_lib}/apache2/modules/mod_*.*
  199. %files tools
  200. %defattr(-,root,root)
  201. %{_prefix}/lib/subversion/tools
  202. %files perl
  203. %defattr(-,root,root,-)
  204. %{perl_vendorarch}/auto/SVN
  205. %{perl_vendorarch}/SVN
  206. %{_libdir}/libsvn_swig_perl*
  207. %{_mandir}/man*/*::*
  208. %files ruby
  209. %defattr(-,root,root,-)
  210. %{_libdir}/libsvn_swig_ruby*
  211. %{rarchdir}/svn
  212. %files python
  213. %defattr(-,root,root,-)
  214. %{_libdir}/libsvn_swig_py*
  215. %{python_sitearch}/libsvn
  216. %{python_sitearch}/svn
  217. %changelog
  218. * Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.16-2
  219. - build with perl 5.12.3
  220. - add Requires: perl(:MODULE_COMPAT_...)
  221. * Sat Mar 5 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.16-1
  222. - new upstream release with security fix
  223. - add Vendor/Distri tags
  224. * Mon Nov 29 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.15-1
  225. - new upstream release
  226. * Tue Mar 2 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-2
  227. - fix <BTS:VineLinux:941>
  228. - using rpm macro: rarchdir
  229. - export svn_cv_ruby_sitedir_libsuffix and svn_cv_ruby_sitedir_archsuffix
  230. - using rpm macros: perl_vendorarch and python_sitearch
  231. - add BuildRequires: sqlite3-devel krb5-devel
  232. * Thu Feb 18 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-1
  233. - new upstream release
  234. - update URL
  235. - update deplibs patch (Patch1) from Fedora 1.6.9-2.fc13
  236. - update rpath patch (Patch3) from Fedora 1.6.9-2.fc13
  237. - stop applying pia patch (Patch6): sync Fedora 1.6.9-2.fc13
  238. - stop applying update-neon-m4 patch (Patch10): sync Fedora 1.6.9-2.fc13
  239. * Wed Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.7-1
  240. - new upstream release
  241. * Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.2-1
  242. - new upstream release
  243. * Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.6-2vl5
  244. - rebuilt with python-2.5.2
  245. * Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.6-1vl5
  246. - new upstream release
  247. - rebuild with neon-0.28.2
  248. - dropped old-Patch10 by adding --disable-neon-version-check to %%configure
  249. - added Patch6, 8, 9, 10 from Fedora Core
  250. * Thu Feb 21 2008 Lubomir Kundrak <lkundrak@redhat.com> 1.4.6-5
  251. - Correct install location of java stuff (#433295)
  252. * Wed Aug 8 2007 Joe Orton <jorton@redhat.com> 1.4.4-3
  253. - fix build with new glibc open()-as-macro
  254. - build all swig code in %%build, not %%install
  255. * Fri May 21 2004 Joe Orton <jorton@redhat.com> 1.0.3-2
  256. - build /usr/bin/* as PIEs
  257. * Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.3-0vl2
  258. - rebuild with expat-2.0.1
  259. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.3-0vl1
  260. - new upstream release
  261. - add Patch10 to build with neon.
  262. 1.3.2-0vl5 does not support neon..
  263. * Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl4
  264. - rebuild with new neon
  265. * Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.2-0vl3
  266. - rebuilt with new toolchain and db4-4.3.x
  267. * Sat Mar 31 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.2-0vl2
  268. - modified %%files section for lib64 architecture
  269. * Tue Aug 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl1
  270. - new upstream release
  271. - rebuild with new openldap-2.3.24
  272. * Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.1-0vl1
  273. - new upstream release
  274. - change Group to Develoment/Tools
  275. - build with apr-1.2.7/apr-util-1.2.7
  276. - require apr/apr-util instead of apache2-apr
  277. - build with swig-1.3.29
  278. - split {perl,python,ruby} related files to subpackage.
  279. * Tue Oct 18 2005 IWAI, Masaharu <iwai@alib.jp> 1.2.3-0vl1
  280. - new upstream release
  281. - add noreplace option for config file
  282. * Sun Jan 30 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl3
  283. - fix Requires and BuildPreReq.
  284. * Sun Jan 23 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl2
  285. - new upstream release.
  286. - add swig-runtime to 'BuildPreReq:'.
  287. - fix %%files.
  288. * Sun Oct 17 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.0.6-0vl1.1
  289. - require neon version 0.24.7 for ra_dav
  290. - add BuildPreReq: openldap-devel
  291. - replace BuildPreReq: httpd to BuildPreReq: apache2
  292. - replace tools Requires: perl(:MODULE_COMPAT_version) to perl >= 5.8.0
  293. * Wed Jul 21 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.6-0vl1
  294. - new upstream release
  295. * Tue Jun 22 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.5-0vl1
  296. - new upstream release
  297. * Fri Jun 4 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.4-0vl1
  298. - new upstream release
  299. - clean up specfile.
  300. * Tue Nov 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.32.1-0vl1
  301. - new upstream release
  302. - build with apache2-2.0.47
  303. * Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.20.0-0vl1
  304. - build Vine Linux
  305. * Sat Mar 01 2003 David Summers <david@summersoft.fay.ar.us> 0.18.1-5173
  306. - Enabled RA_DAV checking.
  307. Now requires httpd package to build because of RA_DAV tests.
  308. * Sat Jan 18 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4433
  309. - Created tools package to hold the tools.
  310. * Thu Jan 16 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4405
  311. - Now requires httpd >= 2.0.44-0.1 (APACHE_2_0_BRANCH) which contains the new
  312. version of APR/APR-UTILS as of 2003.01.15.
  313. - Added svnversion command.
  314. * Tue Dec 31 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4218
  315. - Create a svnadmin.static which is copied to svnadmin-version-release
  316. when the package is erased, so users can still dump/load their repositories
  317. even after they have upgraded the RPM package.
  318. * Sat Dec 14 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4128
  319. - SWIG now builds so we can use cvs2svn.
  320. * Fri Oct 04 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3280
  321. - Made cvs2svn conditional (at least until we can get it to build consistently
  322. and work).
  323. * Sat Sep 21 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3205
  324. - Added SWIG dependencies to add cvs2svn capabilities.
  325. * Fri Aug 16 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2984
  326. - Now requires neon-0.22.0.
  327. * Thu Aug 15 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2978
  328. - Took out loading mod_dav_svn from subversion.spec file and put it in
  329. subversion.conf file which goes into the apache conf directory.
  330. - Simplify what gets put into httpd.conf to only the include for the
  331. subversion.conf file.
  332. (Thanks to Scott Harrison <sharrison@users.sourceforge.net> for prompting
  333. me to do this).
  334. * Thu Aug 08 2002 David Summers <david@summersoft.fay.ar.us> 0.14.0-2919
  335. - Updated to APR/APR-UTIL 2002-08-08.
  336. * Tue Jun 25 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2332
  337. - Updated to APACHE/APR/APR-UTIL 2002-06-25.
  338. - Previous version had a few problems because of missing apache error/ files.
  339. * Sun Jun 23 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2318
  340. - Updated to apache-2.0.40-0.3.
  341. - Updated to subversion-0.13.1-2318.
  342. * Tue Jun 18 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2277
  343. - Updated for RedHat 7.3 (autoconf253).
  344. - Added a bunch of pre-requisites I didn't know were needed because I built a
  345. new machine that didn't have them already installed.
  346. - Fixed installation of man and info documentation pages.
  347. * Wed Mar 06 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1447
  348. - Back to apache-libapr* stuff, hopefully to stay.
  349. * Sun Feb 24 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1373
  350. - Fixed expat.patch to not have to make so many changes by writing a small
  351. shell script that changes libexpat to -lexpat.
  352. * Fri Feb 22 2002 Blair Zajac <blair@orcaware.com> 0.9.0-1364
  353. - Updated to neon-0.19.2.
  354. * Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1250
  355. - Back to using apr and apr-util separately from apache.
  356. * Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1232
  357. - Updated to APR and APR-UTIL 2002.02.11.
  358. - Updated to apache-2.0.32-0.2. (Requires apache-libapr and apache-libapr-util).
  359. - Took out a (now non-existant) documentation file.
  360. - Moved SPEC file changelog to after all package definitions.
  361. * Sun Feb 03 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1153
  362. - Updated to neon-0.18.5.
  363. - Broke up apache and apache-devel into apache-apr, apache-apr-devel,
  364. apache-apr-utils, and apache-apr-utils-devel.
  365. - Updated apache to APR and APR-UTILS to 2002.02.03 version.
  366. * Sat Feb 02 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1147
  367. - Now builds without the separate APR package as it is built into and
  368. "exported" from apache-2.0.31-0.3.
  369. * Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1132
  370. - Took out patches to install procedure now not required because of fixes
  371. in rev 1130.
  372. * Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1129
  373. - Added requirement for APR 0.2002.01.19 rev 2 where the /usr/bin/apr-config
  374. program was added.
  375. * Sun Oct 28 2001 David Summers <david@summersoft.fay.ar.us>
  376. - Release M5-r340: Added the subversion-server package.
  377. * Fri Oct 26 2001 David Summers <david@summersoft.fay.ar.us>
  378. - Release M5-r327: No longer need expat-lite. We can use the normal expat.
  379. * Thu Sep 27 2001 David Summers <david@summersoft.fay.ar.us>
  380. - Release M3-r117: Initial Version.