skrooge-vl.spec 6.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205
  1. Name: skrooge
  2. Summary: Personal finances manager
  3. Summary(ja): 個人向け財務管理ツール
  4. Version: 0.8.0
  5. Release: 1%{?_dist_release}
  6. Group: Applications/Productivity
  7. License: GPLv3+
  8. URL: http://skrooge.org
  9. Source0: http://skrooge.org/files/%{name}-%{version}.tar.bz2
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. BuildRequires: qca2-devel
  12. BuildRequires: libofx-devel
  13. BuildRequires: sqlite3-devel
  14. BuildRequires: kdelibs4-devel
  15. BuildRequires: gettext
  16. Requires: %{name}-libs = %{version}-%{release}
  17. %description
  18. %{name} is a personal finances manager,
  19. aiming at being simple and intuitive.
  20. It allows you to keep track of your expenses and incomes,
  21. categorize them, and build reports of them.
  22. %package libs
  23. Summary: Skrooge libraries
  24. Summary(ja): Skrooge ライブラリ
  25. Group: System Environment/Libraries
  26. #Requires: %{name} = %{version}-%{release}
  27. Requires: kdelibs4 >= 4.4.0
  28. %description libs
  29. %{name} libraries.
  30. %package devel
  31. Summary: Development files for %{name}
  32. Summary(ja): %{name} の開発用ファイル
  33. Group: Development/Libraries
  34. Requires: %{name}-libs = %{version}-%{release}
  35. %description devel
  36. The %{name}-devel package contains libraries for
  37. developing applications that use %{name}.
  38. %prep
  39. %setup -q
  40. ## to prevent spurious-executable-perm in -debuginfo
  41. chmod -x skgbasegui/skglineedit.h
  42. chmod -x skgbasegui/skglineedit.cpp
  43. chmod -x skgbasegui/skglineeditdesignerplugin.h
  44. chmod -x skgbasegui/skgtablewidgetdesignerplugin.h
  45. chmod -x skgbasegui/skglineeditdesignerplugin.cpp
  46. chmod -x skgbasegui/skgtablewidgetdesignerplugin.cpp
  47. %build
  48. mkdir -p %{_target_platform}
  49. pushd %{_target_platform}
  50. unset QTDIR || : ; . /etc/profile.d/qt4.sh
  51. ## the -DCMAKE is needed to prevent unused-direct-shlib-dependency in -libs
  52. ## cant be fixed upstream, see: https://bugs.kde.org/show_bug.cgi?id=209912
  53. %{cmake} \
  54. -Wno-dev \
  55. -DCMAKE_BUILD_TYPE=release \
  56. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  57. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  58. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  59. -DCMAKE_SHARED_LINKER_FLAGS="-Wl,--as-needed" \
  60. ..
  61. popd
  62. make %{?_smp_mflags} -C %{_target_platform}
  63. %install
  64. rm -rf %{buildroot}
  65. make install/fast -C %{_target_platform} DESTDIR=%{buildroot}
  66. %find_lang %{name} --with-kde
  67. # hack to support non-oxygen icon users (gnome), drop when/if skrooge
  68. # ever provides hicolor icons (too).
  69. mv %{buildroot}%{_datadir}/icons/oxygen %{buildroot}%{_datadir}/icons/hicolor
  70. %clean
  71. rm -rf %{buildroot}
  72. %check
  73. desktop-file-validate %{buildroot}%{_datadir}/applications/kde4/skrooge.desktop
  74. %post
  75. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  76. %postun
  77. if [ $1 -eq 0 ] ; then
  78. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  79. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  80. update-desktop-database -q &> /dev/null
  81. update-mime-database %{_datadir}/mime &> /dev/null
  82. fi
  83. %posttrans
  84. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  85. update-desktop-database -q &> /dev/null
  86. update-mime-database %{_datadir}/mime &> /dev/null
  87. %post libs -p /sbin/ldconfig
  88. %postun libs -p /sbin/ldconfig
  89. %files -f %{name}.lang
  90. %defattr(-,root,root,-)
  91. %doc AUTHORS CHANGELOG COPYING README TODO
  92. %{_bindir}/skrooge
  93. %{_datadir}/applications/kde4/skrooge.desktop
  94. %{_datadir}/config.kcfg/*.kcfg
  95. %{_datadir}/icons/hicolor/*/*/*
  96. %{_datadir}/kde4/apps/skrooge*/
  97. %{_datadir}/kde4/apps/skg*
  98. %{_datadir}/kde4/services/*.desktop
  99. %{_datadir}/kde4/servicetypes/skg-plugin.desktop
  100. %{_datadir}/mime/packages/x-skg.xml
  101. %{_datadir}/doc/HTML/*/skrooge/
  102. %files libs
  103. %defattr(-,root,root,-)
  104. %{_libdir}/kde4/plugins/designer/*.so.*
  105. %{_libdir}/kde4/*.so
  106. %{_libdir}/lib*.so.*
  107. %files devel
  108. %defattr(-,root,root,-)
  109. %{_libdir}/libskg*.so
  110. %{_libdir}/kde4/plugins/designer/libskg*.so
  111. %changelog
  112. * Sun Jan 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.0-1
  113. - Initial build for Vine Linux
  114. * Mon May 17 2010 Thomas Janssen <thomasj@fedoraproject.org> 0.7.1-1
  115. - skrooge 0.7.1 bugfix release
  116. * Mon Apr 26 2010 Thomas Janssen <thomasj@fedoraproject.org> 0.7.0-1
  117. - Skrooge 0.7.0
  118. * Wed Feb 10 2010 Thomas Janssen <thomasj@fedoraproject.org> 0.6.0-1
  119. - New upstream source 0.6.0
  120. * Thu Jan 28 2010 Rex Dieter <rdieter@fedoraproject.org> 0.5.5-2
  121. - use %%{_kde4_version}, don't rely on kde4-config --version parsing
  122. * Sun Dec 27 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.5-1
  123. - Update to new upstream release
  124. - Corrects a lot of bugs and problems. See the CHANGELOG for details.
  125. * Sun Nov 30 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.4-1
  126. - Update to new upstream version
  127. - Corrects a lot of bugs and problems. See the changelog for details.
  128. * Sun Nov 01 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.3-1
  129. - Updated to new upstream version
  130. - Readded a -DCMAKE workaround (please keep it for now)
  131. - Useing chmod -x to prevent spurious-executable-perm. Bug filed.
  132. * Wed Oct 14 2009 Rex Dieter <rdieter@fedoraproject.org> 0.5.2-2
  133. - (HTML) docs patch, use %%find_lang --with-kde
  134. - own %%{_kde4_appsdir}/skrooge*/ dirs
  135. - %%check: omit extraneous desktop-file-validate's
  136. * Thu Oct 08 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.2-1
  137. - Changed to final 0.5.2 version
  138. - Bugfixes, including a nasty bug where one thinks the data is gone
  139. - added HTML documentation
  140. - added localizations
  141. * Tue Sep 22 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.2-0.1.beta
  142. - Changed to new upstream Version 0.5.2_beta (lots of bugfixes)
  143. * Mon Sep 21 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.1-0.5.beta
  144. - Added -libs Requires libofx
  145. * Mon Sep 21 2009 Rex Dieter <rdieter@fedoraproject.org> 0.5.1-0.4.beta
  146. - misc cosmetics
  147. - mime scriptlets
  148. - move icons to hicolor
  149. - -libs: drop dup'd docs, add min kdelibs4 dep
  150. * Thu Sep 17 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.1-0.3.beta
  151. - Spec file corrections and Version correction
  152. * Wed Sep 16 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.1-beta2
  153. - cleaned up desktop files
  154. * Tue Sep 15 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.1-beta1
  155. - changed version to 0.5.1 beta with fixed rpmlint output
  156. * Sun Sep 13 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.0-2
  157. - Fixed the spec and rpmlintoutput debuginfo-without-source
  158. * Fri Sep 11 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.0-1
  159. - Initial Release 0.5.0