shotwell-vl.spec 5.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177
  1. Name: shotwell
  2. Version: 0.8.1
  3. Release: 1%{?_dist_release}
  4. Summary: A photo organizer for the GNOME desktop
  5. Summary(ja): GNOME デスクトップ向けの画像整理ソフト
  6. Group: Applications/Graphics
  7. # LGPLv2+ for the code
  8. # CC-BY-SA for some of the icons
  9. License: LGPLv2+ and CC-BY-SA
  10. URL: http://www.yorba.org/shotwell/
  11. Source0: http://www.yorba.org/download/shotwell/0.8/shotwell-%{version}.tar.bz2
  12. # svn co svn://svn.yorba.org/shotwell/branches/shotwell-0.4, make dist
  13. Patch0: workaround_desktop.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: GConf2-devel
  16. BuildRequires: LibRaw-devel
  17. BuildRequires: WebKit-gtk-devel
  18. BuildRequires: dbus-glib-devel
  19. BuildRequires: desktop-file-utils
  20. BuildRequires: gettext
  21. BuildRequires: gtk2-devel
  22. BuildRequires: gstreamer-devel
  23. BuildRequires: hal-devel
  24. BuildRequires: json-glib-devel
  25. BuildRequires: libexif-devel
  26. BuildRequires: libgee-devel
  27. BuildRequires: libgphoto2-devel
  28. BuildRequires: libgudev1-devel
  29. BuildRequires: libgexiv2-devel >= 0.2.0
  30. BuildRequires: libsoup-devel
  31. BuildRequires: libxml2-devel
  32. BuildRequires: sqlite3-devel
  33. BuildRequires: unique-devel
  34. BuildRequires: vala-devel >= 0.9.5
  35. %description
  36. Shotwell is a new open source photo organizer designed for the GNOME desktop
  37. environment. It allows you to import photos from your camera, view and edit
  38. them, and share them with others.
  39. %description -l ja
  40. Shotwell は GNOME デスクトップ環境用に設計された新しいオープンソースの
  41. 画像整理ソフトです。
  42. あなたのカメラから写真を取り込んだり、それらを表示・編集したり、
  43. 他の人々と共有するなどができます。
  44. %prep
  45. %setup -q -n %{name}-%{version}
  46. #%patch0 -p1
  47. %build
  48. ./configure --prefix=/usr --disable-schemas-install --assume-pkgs
  49. sed -i -e 's/\\n/\n/g' configure.mk
  50. sed -i -e 's/^CFLAGS=.*$/CFLAGS=%{optflags}/' Makefile
  51. sed -i -e 's|LIB_DIRS=.*$|LIB_DIRS=%{_libdir}|' libraw-config
  52. make %{?_smp_mflags}
  53. %install
  54. rm -rf $RPM_BUILD_ROOT
  55. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  56. export XDG_DISABLE_MAKEFILE_UPDATES=1
  57. make install DESTDIR=$RPM_BUILD_ROOT
  58. desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell.desktop
  59. desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell-viewer.desktop
  60. %find_lang %{name}
  61. %clean
  62. rm -rf $RPM_BUILD_ROOT
  63. %post
  64. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  65. update-desktop-database &> /dev/null || :
  66. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  67. gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
  68. %pre
  69. if [ "$1" -gt 1 ]; then
  70. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  71. gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
  72. fi
  73. %preun
  74. if [ "$1" -eq 0 ]; then
  75. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  76. gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
  77. fi
  78. %postun
  79. if [ $1 -eq 0 ] ; then
  80. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  81. gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
  82. fi
  83. update-desktop-database &> /dev/null || :
  84. %posttrans
  85. gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
  86. %files -f %{name}.lang
  87. %defattr(-,root,root,-)
  88. %doc README COPYING MAINTAINERS NEWS THANKS AUTHORS
  89. %{_sysconfdir}/gconf/schemas/shotwell.schemas
  90. %{_bindir}/shotwell
  91. %{_datadir}/gnome/help/
  92. %{_datadir}/shotwell
  93. %{_datadir}/applications/shotwell.desktop
  94. %{_datadir}/applications/shotwell-viewer.desktop
  95. %{_datadir}/icons/hicolor/*
  96. %changelog
  97. * Wed Jan 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-1
  98. - new upstream release
  99. - added BuildRequires: gstreamer-devel, json-glib-devel, libsoup-devel, libxml2-devel
  100. * Tue Sep 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-2
  101. - rebuilt with rpm-4.8.1 for pkg-config
  102. - fixed %%changelog in Tue Sep 14 2010
  103. * Tue Sep 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-1
  104. - new upstream release
  105. - changed source URL
  106. - added Patch0 to work around desktop file incorrect comment
  107. - changed BuildRequires: vala-devel >= 0.9.5
  108. * Fri Aug 27 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.1-1
  109. - new upstream release
  110. * Sat Aug 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.0-1
  111. - new upstream release
  112. - changed BuildRequires: libgexiv2-devel >= 0.2.0
  113. * Thu Jul 22 2010 Shu KONNO <owa@bg.wakwak.com> - 0.6.1-2
  114. - fixed LIB_DIRS in libraw-config (for lib64)
  115. * Wed Jul 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.1-1
  116. - new upstream release
  117. - added BuildRequires: LibRaw-devel, libgexiv2-devel
  118. * Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.2-1
  119. - new upstream release
  120. * Sat Mar 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.0-1
  121. - new upstream release
  122. - added BuildRequires: libgudev1-devel
  123. - applied new naming policy to spec
  124. * Wed Jan 20 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.3-1
  125. - new upstream release
  126. - proved Japanese description
  127. * Thu Jan 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.2-1
  128. - new upstrema release
  129. * Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.1-1
  130. - intial build for VineSeed
  131. * Fri Dec 18 2009 Matthias Clasen <mclasen@redhat.com> - 0.4.0-0.1.20091218svn
  132. * Thu Nov 12 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
  133. - Update to 0.3.2
  134. * Tue Nov 3 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.0-1
  135. - Version 0.3.0
  136. * Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.2.0-3
  137. - Rebuild against new libgee
  138. * Sun Aug 12 2009 Matthias Clasen <mclasen@redhat.com> - 0.2.0-2.fc12
  139. - Bring icon cache handling in sync with current guidelines
  140. * Sun Aug 9 2009 Matthias Clasen <mclasen@redhat.com> - 0.2.0-1.fc12
  141. - Initial packaging