tracker-miners-vl.spec 8.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279
  1. %bcond_with systemd
  2. %global with_enca 1
  3. %global with_libcue 1
  4. %global with_rss 0
  5. %global tracker_version 3.1.1
  6. %if %{with_rss}
  7. %global systemd_units tracker-extract-3.service tracker-miner-fs-3.service tracker-miner-fs-control-3.service tracker-miner-rss-3.service tracker-writeback-3.service
  8. %else
  9. %global systemd_units tracker-extract-3.service tracker-miner-fs-3.service tracker-miner-fs-control-3.service tracker-writeback-3.service
  10. %endif
  11. # Exclude private libraries from autogenerated provides and requires
  12. %global __provides_exclude_from ^%{_libdir}/tracker-miners-3.0/
  13. %global __requires_exclude ^(libtracker-extract\.so|libtracker-miner-3\.0\.so|libextract-.*\.so|libwriteback-.*\.so)
  14. Name: tracker-miners
  15. Version: 3.1.1
  16. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  17. Summary: Tracker miners and metadata extractors
  18. Group: system
  19. Vendor: Project Vine
  20. Distribution: Vine Linux
  21. # libtracker-extract is LGPLv2+; the miners are a mix of GPLv2+ and LGPLv2+ code
  22. License: GPLv2+ and LGPLv2+
  23. URL: https://wiki.gnome.org/Projects/Tracker
  24. %define shortver %(echo %{version} | sed -e 's/\\.[0-9]*$//')
  25. Source0: https://download.gnome.org/sources/%{name}/%{shortver}/%{name}-%{version}.tar.xz
  26. BuildRequires: asciidoc
  27. BuildRequires: gcc
  28. BuildRequires: giflib-devel
  29. BuildRequires: meson
  30. %if %{with systemd}
  31. BuildRequires: systemd
  32. %endif
  33. BuildRequires: pkgconfig(dbus-1)
  34. %if 0%{?with_enca}
  35. BuildRequires: pkgconfig(enca)
  36. %endif
  37. BuildRequires: pkgconfig(exempi-2.0)
  38. BuildRequires: flac-devel
  39. BuildRequires: pkgconfig(gexiv2)
  40. BuildRequires: pkgconfig(gstreamer-1.0)
  41. BuildRequires: pkgconfig(gstreamer-pbutils-1.0)
  42. BuildRequires: pkgconfig(gstreamer-tag-1.0)
  43. BuildRequires: pkgconfig(icu-i18n)
  44. BuildRequires: pkgconfig(icu-uc)
  45. %if 0%{?with_libcue}
  46. BuildRequires: pkgconfig(libcue)
  47. %endif
  48. BuildRequires: pkgconfig(libexif)
  49. %if 0%{?with_rss}
  50. BuildRequires: pkgconfig(libgrss)
  51. %endif
  52. BuildRequires: pkgconfig(libgsf-1)
  53. BuildRequires: pkgconfig(libgxps)
  54. #BuildRequires: pkgconfig(libiptcdata)
  55. BuildRequires: pkgconfig(libjpeg)
  56. BuildRequires: pkgconfig(libnm)
  57. #BuildRequires: pkgconfig(libosinfo-1.0)
  58. BuildRequires: pkgconfig(libpng)
  59. BuildRequires: pkgconfig(libseccomp)
  60. BuildRequires: pkgconfig(libtiff-4)
  61. BuildRequires: pkgconfig(libxml-2.0)
  62. BuildRequires: pkgconfig(poppler-glib)
  63. BuildRequires: pkgconfig(totem-plparser)
  64. BuildRequires: pkgconfig(tracker-sparql-3.0)
  65. BuildRequires: pkgconfig(upower-glib)
  66. BuildRequires: pkgconfig(vorbisfile)
  67. %if %{with systemd}
  68. %{?systemd_requires}
  69. %endif
  70. Requires(post,postun): desktop-file-utils
  71. Requires: tracker%{?_isa} >= %{tracker_version}
  72. # tracker-miners was split out from tracker in 1.99.2
  73. Obsoletes: tracker < 1.99.2
  74. Conflicts: tracker < 1.99.2
  75. %description
  76. Tracker is a powerful desktop-neutral first class object database,
  77. tag/metadata database and search tool.
  78. This package contains various miners and metadata extractors for tracker.
  79. %debug_package
  80. %prep
  81. %autosetup -p1
  82. %build
  83. # Disable the functional tests for now, they use python bytecodes.
  84. %meson \
  85. -Dtracker_core=system \
  86. -Dfunctional_tests=false \
  87. -Diptc=disabled \
  88. -Diso=disabled \
  89. %if ! 0%{?with_rss}
  90. -Dminer_rss=false \
  91. %endif
  92. %if %{with systemd}
  93. -Dsystemd_user_services=true \
  94. -Dsystemd_user_services_dir=%{_userunitdir} \
  95. %else
  96. -Dsystemd_user_services=false \
  97. %endif
  98. %{nil}
  99. %meson_build
  100. %install
  101. %meson_install
  102. %find_lang tracker3-miners
  103. %if %{with systemd}
  104. %post
  105. %systemd_user_post %{systemd_units}
  106. %endif
  107. %if %{with systemd}
  108. %preun
  109. %systemd_user_preun %{systemd_units}
  110. %endif
  111. %if %{with systemd}
  112. %postun
  113. %systemd_user_postun_with_restart %{systemd_units}
  114. %endif
  115. %files -f tracker3-miners.lang
  116. %license COPYING*
  117. %doc AUTHORS NEWS README.md
  118. %config(noreplace) %{_sysconfdir}/xdg/autostart/tracker-miner-fs-3.desktop
  119. %if 0%{?with_rss}
  120. %config(noreplace) %{_sysconfdir}/xdg/autostart/tracker-miner-rss-3.desktop
  121. %endif
  122. %{_libdir}/tracker-miners-3.0/
  123. %{_libexecdir}/tracker*
  124. %{_datadir}/dbus-1/interfaces/org.freedesktop.Tracker3.Miner.Files.Index.xml
  125. %{_datadir}/dbus-1/interfaces/org.freedesktop.Tracker3.Miner.xml
  126. %{_datadir}/dbus-1/services/org.freedesktop.Tracker*
  127. %{_datadir}/glib-2.0/schemas/*
  128. %{_datadir}/tracker3-miners/
  129. %{_mandir}/man1/tracker*.1*
  130. %if %{with systemd}
  131. %{_userunitdir}/tracker*.service
  132. %endif
  133. %changelog
  134. * Fri Apr 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.1-1
  135. - new upstream release.
  136. - built with icu69.
  137. * Mon Mar 29 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.0-1
  138. - new upstream release.
  139. * Fri Apr 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.3.3-2
  140. - rebuilt with icu-67.
  141. * Fri Mar 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.3.3-1
  142. - new upstream release.
  143. * Tue Oct 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.3.1
  144. - initial build for Vine Linux.
  145. - new upstream release.
  146. * Mon Sep 09 2019 Kalev Lember <klember@redhat.com> - 2.3.0-1
  147. - Update to 2.3.0
  148. * Fri Sep 06 2019 Nikola Forró <nforro@redhat.com> - 2.2.99.1-2
  149. - Rebuilt for exempi 2.5.1
  150. * Fri Sep 06 2019 Kalev Lember <klember@redhat.com> - 2.2.99.1-1
  151. - Update to 2.2.99.1
  152. * Mon Aug 12 2019 Kalev Lember <klember@redhat.com> - 2.2.99.0-1
  153. - Update to 2.2.99.0
  154. * Sat Jul 27 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.2-2
  155. - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
  156. * Fri May 03 2019 David King <amigadave@amigadave.com> - 2.2.2-1
  157. - Update to 2.2.2
  158. * Fri Mar 08 2019 Kalev Lember <klember@redhat.com> - 2.2.1-1
  159. - Update to 2.2.1
  160. * Thu Feb 21 2019 Kalev Lember <klember@redhat.com> - 2.2.0-3
  161. - Exclude private libraries from autogenerated provides and requires
  162. * Thu Feb 21 2019 Kalev Lember <klember@redhat.com> - 2.2.0-2
  163. - Fix the package to be installable again
  164. * Wed Feb 20 2019 Kalev Lember <klember@redhat.com> - 2.2.0-1
  165. - Update to 2.2.0
  166. - Switch to the meson build system
  167. * Sun Feb 03 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.5-4
  168. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  169. * Wed Jan 23 2019 Pete Walter <pwalter@fedoraproject.org> - 2.1.5-3
  170. - Rebuild for ICU 63
  171. * Mon Jan 21 2019 Kevin Fenzi <kevin@scrye.com> - 2.1.5-2
  172. - Rebuild to drop libiptcdata deps
  173. * Fri Sep 28 2018 Kalev Lember <klember@redhat.com> - 2.1.5-1
  174. - Update to 2.1.5
  175. * Wed Sep 05 2018 Kalev Lember <klember@redhat.com> - 2.1.4-2
  176. - Rebuilt with fixed vala
  177. * Tue Sep 04 2018 Kalev Lember <klember@redhat.com> - 2.1.4-1
  178. - Update to 2.1.4
  179. * Mon Sep 03 2018 Kalev Lember <klember@redhat.com> - 2.1.3-1
  180. - Update to 2.1.3
  181. * Sun Aug 19 2018 Kalev Lember <klember@redhat.com> - 2.1.1-1
  182. - Update to 2.1.1
  183. * Wed Jul 25 2018 Kalev Lember <klember@redhat.com> - 2.1.0-1
  184. - Update to 2.1.0
  185. * Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.5-3
  186. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  187. * Tue Jul 10 2018 Pete Walter <pwalter@fedoraproject.org> - 2.0.5-2
  188. - Rebuild for ICU 62
  189. * Tue Jun 26 2018 Kalev Lember <klember@redhat.com> - 2.0.5-1
  190. - Update to 2.0.5
  191. * Mon Apr 30 2018 Pete Walter <pwalter@fedoraproject.org> - 2.0.4-4
  192. - Rebuild for ICU 61.1
  193. * Sun Feb 11 2018 Sandro Mani <manisandro@gmail.com> - 2.0.4-3
  194. - Rebuild (giflib)
  195. * Thu Feb 08 2018 Kalev Lember <klember@redhat.com> - 2.0.4-2
  196. - Rebuild to really enable the RAW extractor
  197. * Wed Feb 07 2018 Kalev Lember <klember@redhat.com> - 2.0.4-1
  198. - Update to 2.0.4
  199. - Enable new gexiv2 based RAW extractor
  200. * Thu Nov 30 2017 Pete Walter <pwalter@fedoraproject.org> - 2.0.3-2
  201. - Rebuild for ICU 60.1
  202. * Tue Nov 21 2017 Kalev Lember <klember@redhat.com> - 2.0.3-1
  203. - Update to 2.0.3
  204. * Fri Oct 06 2017 Kalev Lember <klember@redhat.com> - 2.0.2-1
  205. - Update to 2.0.2
  206. * Tue Sep 19 2017 Kalev Lember <klember@redhat.com> - 2.0.0-3
  207. - Backport a fix for a crash when processing virtual elements (#1488707)
  208. * Fri Sep 15 2017 Kalev Lember <klember@redhat.com> - 2.0.0-2
  209. - Package review fixes (#1491725):
  210. - Pass --disable-mp3 to use the generic gstreamer extractor
  211. - Disable libstemmer support to match the previous behaviour
  212. - Fix removing .so symlinks for private libraries
  213. - Remove ldconfig rpm scripts as we don't install any shared libraries
  214. - Correct license tag and add comment explaining mixed source licensing
  215. * Thu Sep 14 2017 Kalev Lember <klember@redhat.com> - 2.0.0-1
  216. - Initial Fedora packaging