glib2-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: A library of handy utility functions.
  3. Name: glib2
  4. Version: 2.28.6
  5. Release: 1%{?_dist_release}
  6. License: LGPLv2+
  7. Group: System Environment/Libraries
  8. Source: http://ftp.gnome.org/pub/GNOME/sources/glib/2.28/glib-%{version}.tar.bz2
  9. Source2: glib2.sh
  10. Source3: glib2.csh
  11. BuildRoot: %{_tmppath}/glib-%{version}-root
  12. BuildRequires: pkgconfig >= 0.14
  13. BuildRequires: gamin-devel
  14. BuildRequires: gtk-doc
  15. BuildRequires: zlib-devel
  16. Obsoletes: glib-gtkbeta
  17. URL: http://www.gtk.org
  18. Vendor: Project Vine
  19. Distribution: Vine Linux
  20. Packager: Daisuke SUZUKI <daisuke@linux.or.jp>, Takemikaduchi
  21. %description
  22. GLib is the low-level core library that forms the basis
  23. for projects such as GTK+ and GNOME. It provides data structure
  24. handling for C, portability wrappers, and interfaces for such runtime
  25. functionality as an event loop, threads, dynamic loading, and an
  26. object system.
  27. This package provides version 2.28 of GLib.
  28. %package devel
  29. Summary: Development files for the GLib library
  30. Group: Development/Libraries
  31. Obsoletes: glib-gtkbeta-devel
  32. Requires: pkgconfig >= 0.14
  33. Requires: %{name} = %{version}
  34. Conflicts: glib-devel <= 1.2.8
  35. %description devel
  36. The glib-devel package includes the header files for
  37. version 2.28 of the GLib library.
  38. ## to build compat32 for x86_64 architecture support
  39. %package -n compat32-%{name}
  40. Summary: A library of handy utility functions.
  41. Group: System Environment/Libraries
  42. %description -n compat32-%{name}
  43. GLib is the low-level core library that forms the basis
  44. for projects such as GTK+ and GNOME. It provides data structure
  45. handling for C, portability wrappers, and interfaces for such runtime
  46. functionality as an event loop, threads, dynamic loading, and an
  47. object system.
  48. This package provides version 2.28 of GLib.
  49. %package -n compat32-%{name}-devel
  50. Summary: Development files for the GLib library
  51. Group: Development/Libraries
  52. Requires: pkgconfig >= 0.14
  53. Requires: compat32-%{name} = %{version}
  54. Conflicts: glib-devel <= 1.2.8
  55. %description -n compat32-%{name}-devel
  56. The glib-devel package includes the header files for
  57. version 2.28 of the GLib library.
  58. %prep
  59. %setup -q -n glib-%{version}
  60. %build
  61. %configure --disable-selinux --enable-static
  62. make %{?_smp_mflags}
  63. %install
  64. rm -rf $RPM_BUILD_ROOT
  65. mkdir -p $RPM_BUILD_ROOT%{_bindir}
  66. %makeinstall
  67. ## glib2.sh and glib2.csh
  68. ./mkinstalldirs $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
  69. install -m 755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
  70. install -m 755 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
  71. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  72. rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/lib*.{a,la}
  73. rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/*.cache
  74. %find_lang glib20
  75. %clean
  76. rm -rf $RPM_BUILD_ROOT
  77. %post -p /sbin/ldconfig
  78. %postun -p /sbin/ldconfig
  79. %post -n compat32-%{name} -p /sbin/ldconfig
  80. %postun -n compat32-%{name} -p /sbin/ldconfig
  81. %files -f glib20.lang
  82. %defattr(-, root, root)
  83. %doc AUTHORS COPYING ChangeLog NEWS README
  84. %{_bindir}/gdbus
  85. %{_bindir}/gio-querymodules
  86. %{_bindir}/glib-compile-schemas
  87. %{_bindir}/gsettings
  88. %{_libdir}/libglib-2.0.so.*
  89. %{_libdir}/libgthread-2.0.so.*
  90. %{_libdir}/libgmodule-2.0.so.*
  91. %{_libdir}/libgobject-2.0.so.*
  92. %{_libdir}/libgio-2.0.so.*
  93. %{_libdir}/gio/modules/lib*.so
  94. %{_sysconfdir}/profile.d/*
  95. %{_sysconfdir}/bash_completion.d/*
  96. %files devel
  97. %defattr(-, root, root)
  98. %{_bindir}/glib-genmarshal
  99. %{_bindir}/glib-gettextize
  100. %{_bindir}/glib-mkenums
  101. %{_bindir}/gobject-query
  102. %{_bindir}/gtester
  103. %{_bindir}/gtester-report
  104. %{_libdir}/lib*.so
  105. %{_libdir}/lib*.a
  106. %{_libdir}/glib-2.0
  107. %{_includedir}/*
  108. %{_datadir}/aclocal/*
  109. %{_libdir}/pkgconfig/*
  110. %{_datadir}/glib-2.0
  111. %doc %{_datadir}/gtk-doc/html/*
  112. %doc %{_mandir}/man1/*
  113. %{_datadir}/gdb/auto-load%{_libdir}/libglib-2.0.so.*-gdb.py*
  114. %{_datadir}/gdb/auto-load%{_libdir}/libgobject-2.0.so.*-gdb.py*
  115. %if %{build_compat32}
  116. %files -n compat32-%{name}
  117. %defattr(-, root, root)
  118. %{_libdir}/libglib-2.0.so.*
  119. %{_libdir}/libgthread-2.0.so.*
  120. %{_libdir}/libgmodule-2.0.so.*
  121. %{_libdir}/libgobject-2.0.so.*
  122. %{_libdir}/libgio-2.0.so.*
  123. %{_libdir}/gio/modules/lib*.so
  124. %files -n compat32-%{name}-devel
  125. %defattr(-, root, root)
  126. %{_libdir}/lib*.so
  127. %{_libdir}/lib*.a
  128. %{_libdir}/glib-2.0
  129. %{_libdir}/pkgconfig/*
  130. %endif
  131. %changelog
  132. * Fri Apr 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
  133. - new upstream release
  134. * Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.5-1
  135. - new upstream release
  136. * Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
  137. - new upstream release
  138. * Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
  139. - new upstream release
  140. * Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
  141. - new upstream release
  142. * Sat Feb 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
  143. - new upstream release
  144. * Sat Feb 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
  145. - new upstream release
  146. * Fri Dec 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-2
  147. - move the following files from glib2-devel to glib2 package
  148. (gdbus, gio-querymodules, glib-compile-schemas, gsettings)
  149. * Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-1
  150. - new upstream release
  151. * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.0-1
  152. - new upstream release
  153. - fix Source (add URL)
  154. - fix %files to add /etc/bash_completion.d files
  155. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.24.2-2
  156. - build with rpm-4.8.1-1 for pkg-config file
  157. * Sat Aug 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.2-1
  158. - new upstream release
  159. * Tue May 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.1-1
  160. - new upstream release
  161. * Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.0-1
  162. - new upstream release
  163. - add BuildRequires: zlib-devel
  164. * Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.5-1
  165. - new upstream release
  166. * Mon Jan 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.4-1
  167. - new upstream release
  168. * Thu Jan 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.3-1
  169. - new upstream release
  170. * Sun Oct 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
  171. - new upstream release
  172. * Thu Sep 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.0-1
  173. - new upstream release
  174. * Mon Jun 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.4-1
  175. - new upstream release
  176. * Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-1
  177. - new upstream release
  178. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-1
  179. - new upstream release
  180. * Sat Apr 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-1
  181. - new upstream release
  182. * Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.0-1
  183. - new upstream release
  184. * Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.4-1
  185. - new upstream release
  186. * Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.3-1
  187. - new upstream release
  188. * Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-1
  189. - new upstream release
  190. * Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-1
  191. - new upstream release
  192. * Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
  193. - new upstream release
  194. * Mon Jul 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.4-1
  195. - new upstream release
  196. * Sat May 10 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.16.3-2
  197. - updated %%if %%{build_compat32} case related statements
  198. * Wed Apr 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.3-1vl5
  199. - new upstream release
  200. - removed lib*.la files from devel package
  201. * Sun Apr 6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.2-1vl5
  202. - new upstream release
  203. * Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-1vl5
  204. - added %%{?_dist_release}
  205. - BuildRequires: gamin-devel
  206. * Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-0vl1
  207. - new upstream release
  208. * Thu Feb 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.6-0vl1
  209. - new upstream release
  210. * Wed Jan 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.5-0vl1
  211. - new upstream release
  212. * Wed Nov 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
  213. - new upstream release
  214. * Thu Oct 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
  215. - new upstream release
  216. - removed BuildRequires: automake17
  217. * Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-0vl1
  218. - new upstream release
  219. * Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.0-0vl1
  220. - new upstream release
  221. * Wed Jul 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.13-0vl1
  222. - new upstream release
  223. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl2
  224. - rebuild with new environment
  225. * Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl1
  226. - new upstream release
  227. * Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.11-0vl1
  228. - new upstream release
  229. * Mon Jan 08 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.7-0vl1
  230. - new upstream release
  231. * Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.6-0vl1
  232. - new upstream release
  233. * Thu Aug 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.3-0vl1
  234. - new upstream release
  235. * Wed Aug 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
  236. - new upstream release
  237. * Sat Aug 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
  238. - new upstream release
  239. * Mon Jun 26 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.3-0vl3
  240. - rebuild
  241. * Sun Jun 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl2
  242. - update glib2.{sh,csh}
  243. - add EUC-JP,CP932,UTF-8 to G_FILENAME_ENCODING
  244. * Fri Jun 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl1
  245. - new upstream release
  246. * Sat Apr 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
  247. - new upstream release
  248. * Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
  249. - new upstream release
  250. * Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
  251. - new upstream release
  252. * Mon Feb 27 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.6-0vl2
  253. - added compat32-* packages for x86_64 architecture support
  254. - chaged G_ATOMIC_X86_64 to I486 in config.h before making compat32
  255. * Sun Jan 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.6-0vl1
  256. - new upstream release
  257. * Thu Jan 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.5-0vl1
  258. - new upstream release
  259. * Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.4-0vl1
  260. - new upstream release
  261. * Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
  262. - new upstream release
  263. * Tue Sep 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl3
  264. - fixed typo in glib2.csh
  265. * Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
  266. - update glib2.{sh,csh} to use G_FILENAME_ENCODING instead of
  267. G_BROKEN_FILENAMES.
  268. * Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
  269. - new upstream release
  270. * Sat Aug 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
  271. - new upstream release
  272. * Sat Aug 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.7-0vl1
  273. - new upstream release
  274. * Fri Aug 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.6-0vl1
  275. - new upstream release
  276. * Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.4-0vl1
  277. - new upstream release
  278. * Sun Jul 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.5-0vl1
  279. - new upstream release
  280. - add *.la to build arts (should be fixed in arts?)
  281. * Sat Apr 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-0vl1
  282. - new upstream release
  283. * Fri Mar 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.3-0vl1
  284. - new upstream release
  285. * Sat Feb 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.2-0vl1
  286. - new upstream release
  287. * Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-0vl1
  288. - new upstream release
  289. * Sat Dec 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl1
  290. - new upstream release
  291. * Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl2
  292. - rebuilt
  293. * Mon Oct 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl1
  294. - new upstream release
  295. * Sat Aug 14 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.6-0vl1
  296. - new upstream release
  297. * Sun Aug 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.5-0vl1
  298. - new upstream release
  299. * Fri Jul 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4-0vl1
  300. - new upstream release
  301. * Sat Jun 5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
  302. - new upstream release
  303. * Sat May 1 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
  304. - new upstream release
  305. * Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
  306. - new upstream release
  307. * Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.2.3-0vl2
  308. - rebuild with new toolchain
  309. * Sun Aug 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3-0vl1
  310. - new upstream release
  311. * Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
  312. - new upstream release
  313. * Mon Feb 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
  314. - new upstream release
  315. * Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
  316. - new upstream release
  317. * Fri Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
  318. - new upstream release
  319. - build for Vine Linux
  320. * Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
  321. - install glib2.sh and glib2.csh to set G_BROKEN_FILENAMES
  322. - blow away unpackaged files in install
  323. * Thu Aug 8 2002 Owen Taylor <otaylor@redhat.com>
  324. - Version 2.0.6
  325. - Remove fixed-ltmain.sh; shouldn't be needed any more.
  326. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  327. - automated rebuild
  328. * Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
  329. - 2.0.4
  330. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  331. - automated rebuild
  332. * Wed Apr 24 2002 Havoc Pennington <hp@redhat.com>
  333. - rebuild in different environment
  334. * Mon Apr 15 2002 Owen Taylor <otaylor@redhat.com>
  335. - Fix missing .po files (#63336)
  336. * Wed Apr 3 2002 Alex Larsson <alexl@redhat.com>
  337. - Update to version 2.0.1
  338. * Fri Mar 8 2002 Owen Taylor <otaylor@redhat.com>
  339. - Version 2.0.0
  340. * Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
  341. - Update to 1.3.15
  342. * Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
  343. - Bump for rebuild
  344. * Mon Feb 18 2002 Alex Larsson <alexl@redhat.com>
  345. - Update to 1.3.14
  346. * Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
  347. - add horrible buildrequires hack
  348. * Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
  349. - 1.3.13.91 cvs snap
  350. * Mon Feb 11 2002 Matt Wilson <msw@redhat.com>
  351. - rebuild from CVS snapshot
  352. - use setup -q
  353. * Thu Jan 31 2002 Jeremy Katz <katzj@redhat.com>
  354. - rebuild
  355. * Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
  356. - 1.3.13
  357. * Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
  358. - attempting rebuild in rawhide
  359. * Wed Jan 2 2002 Havoc Pennington <hp@redhat.com>
  360. - remove 64-bit patch now upstream, 1.3.12.90
  361. * Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
  362. - add some missing files to file list, langify
  363. * Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
  364. - add temporary patch to fix GTypeFundamentals on 64-bit
  365. * Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
  366. - Version 1.3.11
  367. * Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
  368. - Version 1.3.10
  369. * Tue Sep 25 2001 Owen Taylor <otaylor@redhat.com>
  370. - Version 1.3.9
  371. * Wed Sep 19 2001 Owen Taylor <otaylor@redhat.com>
  372. - Version 1.3.8
  373. * Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
  374. - Make -devel package require main package (#45388)
  375. - Fix description and summary
  376. - Configure with --disable-gtk-doc
  377. * Wed Jun 20 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  378. - add some portability fixes needed at least on s390
  379. - copy config.{guess,sub} instead of calling libtoolize
  380. * Wed Jun 13 2001 Havoc Pennington <hp@redhat.com>
  381. - try a new glib tarball with Makefile changes to work around
  382. libtool linking to installed .la files
  383. - make -devel require pkgconfig
  384. * Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
  385. - either libtool or the bad libtool hacks caused link
  386. against glib-gobject 1.3.2, rebuild
  387. * Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
  388. - 1.3.6
  389. - bad libtool workarounds
  390. * Fri May 04 2001 Owen Taylor <otaylor@redhat.com>
  391. - 1.3.5, rename to glib2
  392. * Fri Nov 17 2000 Owen Taylor <otaylor@redhat.com>
  393. - Final 1.3.2
  394. * Mon Nov 13 2000 Owen Taylor <otaylor@redhat.com>
  395. - Version 1.3.2pre1
  396. - Remove pkgconfig
  397. * Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
  398. - Call 1.3.1b instead of snap... the snap* naming doesn't
  399. order correctly.
  400. * Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
  401. - new snapshot with fixed .pc files
  402. * Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
  403. - include .pc files in file list
  404. * Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
  405. - Include pkg-config
  406. - Upgrade to a glib CVS snapshot
  407. * Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
  408. - rebuild to cope with glibc locale binary incompatibility
  409. * Fri Jul 14 2000 Owen Taylor <otaylor@redhat.com>
  410. - Remove glib-config.1 manpage from build since
  411. it conflicts with glib-devel. When we go to
  412. glib glib1.2 setup, we should add it back
  413. * Fri Jul 07 2000 Owen Taylor <otaylor@redhat.com>
  414. - Version 1.3.1
  415. - Move back to standard %{prefix}
  416. * Thu Jun 8 2000 Owen Taylor <otaylor@redhat.com>
  417. - Rebuild in /opt/gtk-beta
  418. * Tue May 30 2000 Owen Taylor <otaylor@redhat.com>
  419. - New version (adds gobject)
  420. * Wed Apr 25 2000 Owen Taylor <otaylor@redhat.com>
  421. - Don't blow away /etc/ld.so.conf (sorry!)
  422. * Tue Apr 24 2000 Owen Taylor <otaylor@redhat.com>
  423. - Snapshot RPM for Pango testing
  424. * Fri Feb 04 2000 Owen Taylor <otaylor@redhat.com>
  425. - Added fixes from stable branch of CVS
  426. * Thu Oct 7 1999 Owen Taylor <otaylor@redhat.com>
  427. - version 1.2.6
  428. * Fri Sep 24 1999 Owen Taylor <otaylor@redhat.com>
  429. - version 1.2.5
  430. * Fri Sep 17 1999 Owen Taylor <otaylor@redhat.com>
  431. - version 1.2.4
  432. * Mon Jun 7 1999 Owen Taylor <otaylor@redhat.com>
  433. - version 1.2.3
  434. * Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
  435. - version 1.2.1
  436. * Fri Feb 26 1999 Michael Fulbright <drmike@redhat.com>
  437. - Version 1.2
  438. * Thu Feb 25 1999 Michael Fulbright <drmike@redhat.com>
  439. - version 1.2.0pre1
  440. * Tue Feb 23 1999 Cristian Gafton <gafton@redhat.com>
  441. - new description tags
  442. * Sun Feb 21 1999 Michael Fulbright <drmike@redhat.com>
  443. - removed libtoolize from %build
  444. * Thu Feb 11 1999 Michael Fulbright <drmike@redhat.com>
  445. - added libgthread to file list
  446. * Fri Feb 05 1999 Michael Fulbright <drmike@redhat.com>
  447. - version 1.1.15
  448. * Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
  449. - version 1.1.14
  450. * Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
  451. - version 1.1.13
  452. * Wed Jan 06 1999 Michael Fulbright <drmike@redhat.com>
  453. - version 1.1.12
  454. * Wed Dec 16 1998 Michael Fulbright <drmike@redhat.com>
  455. - updated in preparation for the GNOME freeze
  456. * Mon Apr 13 1998 Marc Ewing <marc@redhat.com>
  457. - Split out glib package